]> git.pld-linux.org Git - packages/ffcall.git/blob - ffcall.spec
- sparcv9 patch
[packages/ffcall.git] / ffcall.spec
1 %define         snap    20090629
2
3 Summary:        Libraries for building foreign function call interfaces
4 Summary(pl.UTF-8):      Biblioteki do tworzenia interfejsów wywołań obcych funkcji
5 Name:           ffcall
6 Version:        1.11
7 Release:        0.%{snap}.1
8 Epoch:          1
9 License:        GPL
10 Group:          Libraries
11 # cvs -d:pserver:anonymous@cvs.sv.gnu.org:/sources/libffcall co .
12 Source0:        %{name}-%{snap}.tar.bz2
13 # Source0-md5:  a5190885da8e701a012bb282bfb3c51b
14 Patch0:         %{name}-make-jN.patch
15 Patch1:         %{name}-sparcv9.patch
16 URL:            http://savannah.gnu.org/projects/libffcall
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This is a collection of four libraries which can be used to build
21 foreign function call interfaces in embedded interpreters.
22
23 The four packages are:
24 - avcall - calling C functions with variable arguments
25 - vacall - C functions accepting variable argument prototypes
26 - trampoline - closures as first-class C functions
27 - callback - closures with variable arguments as first-class C
28   functions (a reentrant combination of vacall and trampoline)
29
30 This version B includes some minor configuration changes so that files
31 are installed in the proper place. Also it compiles on cygwin and
32 mingw32.
33
34 %description -l pl.UTF-8
35 To jest zestaw czterech bibliotek, których można użyć do tworzenia
36 interfejsów wywołań obcych procedur we wbudowanych interpreterach.
37
38 Te cztery pakiety to:
39 - avcall - wywoływanie funkcji w C ze zmiennymi argumentami
40 - vacall - funkcje w C akceptujące prototypy ze zmiennymi argumentami
41 - trampoline - domknięcia jako funkcje C pierwszej klasy
42 - callback - domknięcia ze zmiennymi argumentami jako funkcje C
43   pierwszej klasy (zagnieżdżalna kombinacja vacall i trampoline)
44
45 Ta wersja B zawiera trochę małych zmian w konfiguracji, dzięki którym
46 pliki instalują się we właściwych miejscach. A także kompiluje się pod
47 cygwinem i mingw32.
48
49 %package devel
50 Summary:        Development files for ffcall libraries
51 Summary(pl.UTF-8):      Pliki dla programistów używających bibliotek ffcall
52 Group:          Development/Libraries
53 Requires:       %{name} = %{epoch}:%{version}-%{release}
54
55 %description devel
56 Development files for ffcall libraries: headers and static trampoline
57 and vacall libraries.
58
59 %description devel -l pl.UTF-8
60 Pliki dla programistów używających bibliotek ffcall: nagłówki i
61 statyczne biblioteki trampoline oraz vacall.
62
63 %package static
64 Summary:        Static versions of avcall and callback libraries
65 Summary(pl.UTF-8):      Statyczne wersje bibliotek avcall i callback
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
68
69 %description static
70 Static versions of avcall and callback libraries.
71
72 %description static -l pl.UTF-8
73 Statyczne wersje bibliotek avcall i callback.
74
75 %prep
76 %setup -q -n %{name}-%{snap}
77 %patch0 -p1
78 %patch1 -p1
79
80 %build
81 %configure \
82         --enable-shared
83
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT%{_mandir}
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 # don't need those since we have man pages
94 %{__rm} $RPM_BUILD_ROOT/usr/share/html/*.html
95
96 %clean
97 rm -fr $RPM_BUILD_ROOT
98
99 %post   -p /sbin/ldconfig
100 %postun -p /sbin/ldconfig
101
102 %files
103 %defattr(644,root,root,755)
104 %doc NEWS README
105 %attr(755,root,root) %{_libdir}/lib*.so.*.*
106
107 %files devel
108 %defattr(644,root,root,755)
109 %doc */*.html
110 %attr(755,root,root) %{_libdir}/lib*.so*
111 %{_libdir}/lib*.la
112 %{_libdir}/libtrampoline.a
113 %{_libdir}/libvacall.a
114 %{_includedir}/*
115 %{_mandir}/man?/*
116
117 %files static
118 %defattr(644,root,root,755)
119 %{_libdir}/libavcall.a
120 %{_libdir}/libcallback.a
This page took 0.055699 seconds and 3 git commands to generate.