]> git.pld-linux.org Git - packages/ffcall.git/blob - ffcall.spec
21181fba160889f8535250a25e5ca680f33bed29
[packages/ffcall.git] / ffcall.spec
1 %define         snap    20090629
2
3 Summary:        Libraries for building foreign function call interfaces
4 Summary(pl.UTF-8):      Biblioteki do tworzenia interfejsów wywołań obcych funkcji
5 Name:           ffcall
6 Version:        1.11
7 Release:        0.%{snap}.1
8 Epoch:          1
9 License:        GPL
10 Group:          Libraries
11 # cvs -d:pserver:anonymous@cvs.sv.gnu.org:/sources/libffcall co .
12 Source0:        %{name}-%{snap}.tar.bz2
13 # Source0-md5:  a5190885da8e701a012bb282bfb3c51b
14 Patch0:         %{name}-make-jN.patch
15 Patch1:         %{name}-sparcv9.patch
16 # https://savannah.gnu.org/bugs/index.php?22081
17 Patch2:         %{name}-sparc64.patch
18 URL:            http://savannah.gnu.org/projects/libffcall
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %undefine       __cxx
22
23 %description
24 This is a collection of four libraries which can be used to build
25 foreign function call interfaces in embedded interpreters.
26
27 The four packages are:
28 - avcall - calling C functions with variable arguments
29 - vacall - C functions accepting variable argument prototypes
30 - trampoline - closures as first-class C functions
31 - callback - closures with variable arguments as first-class C
32   functions (a reentrant combination of vacall and trampoline)
33
34 This version B includes some minor configuration changes so that files
35 are installed in the proper place. Also it compiles on cygwin and
36 mingw32.
37
38 %description -l pl.UTF-8
39 To jest zestaw czterech bibliotek, których można użyć do tworzenia
40 interfejsów wywołań obcych procedur we wbudowanych interpreterach.
41
42 Te cztery pakiety to:
43 - avcall - wywoływanie funkcji w C ze zmiennymi argumentami
44 - vacall - funkcje w C akceptujące prototypy ze zmiennymi argumentami
45 - trampoline - domknięcia jako funkcje C pierwszej klasy
46 - callback - domknięcia ze zmiennymi argumentami jako funkcje C
47   pierwszej klasy (zagnieżdżalna kombinacja vacall i trampoline)
48
49 Ta wersja B zawiera trochę małych zmian w konfiguracji, dzięki którym
50 pliki instalują się we właściwych miejscach. A także kompiluje się pod
51 cygwinem i mingw32.
52
53 %package devel
54 Summary:        Development files for ffcall libraries
55 Summary(pl.UTF-8):      Pliki dla programistów używających bibliotek ffcall
56 Group:          Development/Libraries
57 Requires:       %{name} = %{epoch}:%{version}-%{release}
58
59 %description devel
60 Development files for ffcall libraries: headers and static trampoline
61 and vacall libraries.
62
63 %description devel -l pl.UTF-8
64 Pliki dla programistów używających bibliotek ffcall: nagłówki i
65 statyczne biblioteki trampoline oraz vacall.
66
67 %package static
68 Summary:        Static versions of avcall and callback libraries
69 Summary(pl.UTF-8):      Statyczne wersje bibliotek avcall i callback
70 Group:          Development/Libraries
71 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
72
73 %description static
74 Static versions of avcall and callback libraries.
75
76 %description static -l pl.UTF-8
77 Statyczne wersje bibliotek avcall i callback.
78
79 %prep
80 %setup -q -n %{name}-%{snap}
81 %patch0 -p1
82 %patch1 -p1
83 %patch2 -p0
84
85 %build
86 %configure \
87         --enable-shared
88
89 %{__make}
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93 install -d $RPM_BUILD_ROOT%{_mandir}
94
95 %{__make} install \
96         DESTDIR=$RPM_BUILD_ROOT
97
98 # don't need those since we have man pages
99 %{__rm} $RPM_BUILD_ROOT%{_datadir}/html/*.html
100
101 %clean
102 rm -fr $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %files
108 %defattr(644,root,root,755)
109 %doc NEWS README
110 %attr(755,root,root) %{_libdir}/lib*.so.*.*
111
112 %files devel
113 %defattr(644,root,root,755)
114 %doc */*.html
115 %attr(755,root,root) %{_libdir}/lib*.so*
116 %{_libdir}/lib*.la
117 %{_libdir}/libtrampoline.a
118 %{_libdir}/libvacall.a
119 %{_includedir}/*
120 %{_mandir}/man?/*
121
122 %files static
123 %defattr(644,root,root,755)
124 %{_libdir}/libavcall.a
125 %{_libdir}/libcallback.a
This page took 0.07243 seconds and 3 git commands to generate.