]> git.pld-linux.org Git - packages/fedora-ds.git/blob - fedora-ds.spec
- tabs, cleanups
[packages/fedora-ds.git] / fedora-ds.spec
1 #
2 # http://directory.fedora.redhat.com/wiki/Building
3 #
4 Summary:        Fedora Directory Server
5 Summary(pl):    Fedora Directory Server - serwer us³ug katalogowych
6 Name:           fedora-ds
7 Version:        1.0.2
8 Release:        0.1
9 License:        GPL v2
10 Group:          Applications
11 Source0:        http://directory.fedora.redhat.com/sources/%{name}-%{version}.tar.gz
12 # Source0-md5:  d8bd5b68087229b4bb2e3867cb92ba85
13 Patch0:         %{name}-make.patch
14 Patch1:         %{name}-included.patch
15 Patch2:         http://directory.fedora.redhat.com/sources/ldapserver-gcc4.patch
16 URL:            http://directory.fedora.redhat.com/
17 BuildRequires:  apr-devel
18 BuildRequires:  db-devel >= 4.0
19 BuildRequires:  java-sun
20 BuildRequires:  libicu-devel
21 BuildRequires:  libtermcap-devel
22 BuildRequires:  ncurses-devel
23 BuildRequires:  nspr-devel >= 4.4.1
24 BuildRequires:  rpmbuild(macros) >= 1.228
25 #or BuildRequires:      ibm-java-sdk
26 #
27 #BuildRequires: Java/XML Components
28 # axis.jar, jaxrpc.jar, and saaj.jar - http://ws.apache.org/axis/index.html
29 # xercesImpl.jar and xml-apis.jar - http://xml.apache.org/xerces2-j/download.cgi
30 # activation.jar - http://java.sun.com/products/javabeans/glasgow/jaf.html
31 # axrpc-api.jar - http://java.sun.com/webservices/downloads/webservicespack.html
32 # crimson.jar - http://xml.apache.org/dist/crimson/
33 BuildRequires:  apache-devel
34 BuildRequires:  cyrus-sasl-devel
35 BuildRequires:  gdbm-devel >= 1.6
36 BuildRequires:  jakarta-ant >= 1.6.1
37 BuildRequires:  krb5-devel
38 #BuildRequires: mozilla-components: DBM (v1.61), NSS (v3.93), SVRCORE (v4.0), LDAPSDK (v5.16), and PerLDAP (*)
39 BuildRequires:  net-snmp-devel >= 5.2.1
40 BuildRequires:  nss-devel
41 BuildRequires:  perl-Mozilla-LDAP
42 Requires:       libicu >= 2.4
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 The Fedora Directory Server is a robust, scalable open-source server
47 designed to manage large directories of users and resources. It is
48 based on an open-systems server protocol called the Lightweight
49 Directory Access Protocol (LDAP). The Fedora Directory Server is a
50 world-class Directory Server implementation. Some of the more
51 interesting features that are included are:
52 - 4-Way Multi-Master Replication
53 - Scalability: thousands of operations per second, tens of thousands
54   of concurrent users, tens of millions of entries, hundreds of
55   gigabytes of data
56 - SSLv3, TLSv1, and SASL for secure authentication and transport
57 - Support for most LDAPv3 features, including many common controls and
58   extensions
59 - Schema update over LDAP
60 - Flexible in-tree Access Control Information (ACIs), updatable over
61   LDAP
62 - On-line configuration and management over LDAP
63 - Graphical console for all facets of user, group, and server
64   management
65
66 %description -l pl
67 Fedora Directory Server to potê¿ny, posiadaj±cy otwarte ¼ród³a,
68 skalowalny serwer zaprojektowany do zarz±dzania du¿ymi katalogami
69 u¿ytkowników i zasobów. Jest oparty na otwartym protokole serwerowym
70 LDAP (Lightweight Directory Access Protocol). Fedora Directory Server
71 to ¶wiatowej klasy implementacja serwera us³ug katalogowych. Bardziej
72 interesuj±ce cechy obejmuj±:
73 - 4-stronn± replikacjê multi-master
74 - skalowalno¶æ: tysi±ce operacji na sekund±, dziesi±tki tysiêcy
75   jednoczesnych u¿ytkowników, dziesi±tki milionów wpisów, setki
76   gigabajtów danych
77 - obs³ugê SSLv3, TLSv1 i SASL do bezpiecznego uwierzytelniania i
78   przesy³ania danych
79 - obs³ugê wiêkszo¶ci cech LDAPv3, w tym wielu popularnych opcji i
80   rozszerzeñ
81 - uaktualnianie schematu przez LDAP
82 - elastyczne informacje o prawach dostêpu w drzewie (ACI - Access
83   Control Information), uaktualniane przez LDAP
84 - konfiguracjê i zarz±dzanie w locie przez LDAP
85 - graficzn± konsolê dla wszystkich aspektów zarz±dzania u¿ytkownikami,
86   grupami i serwerem
87
88 %prep
89 %setup -q
90 %patch0 -p1
91 %patch1 -p1
92 #%patch2 -p1
93
94 %build
95 #%%configure
96 %{__make} \
97         NSPR_INCDIR=/usr/include/nspr \
98         SECURITY_INCDIR=/usr/include/openssl \
99         DBM_INCLUDE=/usr/include \
100         LDAP_INCLUDE=/usr/include/nss \
101         SASL_INCLUDE=/usr/include/sasl \
102         SVRCORE_INCLUDE=/usr/include \
103         MFLAGS="\
104                 USE_ADMINSERVER=1 \
105                 USE_CONSOLE=1 \
106                 USE_DSMLGW=1 \
107                 USE_ORGCHART=1 \
108                 USE_DSGW=1 \
109                 USE_JAVATOOLS=1 \
110                 USE_SETUPUTIL=1 \
111                 BUILD_RPM=0 \
112                 DEBUG=full \
113                 NOJAVA=0 \
114         "
115 #
116 #       BUILD_RPM=1 to make a RHEL/Fedora Core RPM package (default is a setuputil installable package).
117 #       DEBUG=full to build the debug version (default is optimized).
118 #       NOJAVA=1 to skip the Java code, including the console and DSML gateway.
119 #       USE_ADMINSERVER=1 - bundle the Admin Server (required to run Console/webapps)
120 #               USE_CONSOLE=1   - bundle the Administration Console (requires Java)
121 #               USE_DSMLGW=1     - build/bundle the DSMLv2 Gateway (requires Java)
122 #               USE_ORGCHART=1   - build/bundle the Org Chart webapp
123 #               USE_DSGW=1         - build/bundle the Phonebook/DS Gateway webapp
124 #               USE_JAVATOOLS=1  - build/bundle the Java command line tools
125 #               USE_SETUPUTIL=1  - build/bundle programs that use Setuputil
126 #
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
This page took 0.038166 seconds and 3 git commands to generate.