]> git.pld-linux.org Git - packages/fcgi.git/blob - fcgi.spec
- converted to UTF-8
[packages/fcgi.git] / fcgi.spec
1 Summary:        FastCGI development kit - shared libraries
2 Summary(pl.UTF-8):   Zestaw dla programistów FastCGI - biblioteki współdzielone
3 Name:           fcgi
4 Version:        2.4.0
5 Release:        2
6 License:        distributable
7 Group:          Libraries
8 Source0:        http://www.fastcgi.com/dist/%{name}-%{version}.tar.gz
9 # Source0-md5:  d15060a813b91383a9f3c66faf84867e
10 Patch0:         %{name}-no-libs.patch
11 Patch1:         %{name}-listen-backlog.patch
12 URL:            http://www.fastcgi.com/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libtool >= 2:1.4d-3
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _includedir     %{_prefix}/include/fastcgi
19
20 %description
21 FastCGI is an open extension to CGI that provides high performance for
22 all Internet applications without the penalties of Web server APIs.
23
24 FastCGI is designed to be layered on top of existing Web server APIs.
25 For instance, the mod_fastcgi Apache module adds FastCGI support to
26 the Apache server. FastCGI can also be used, with reduced
27 functionality and reduced performance, on any Web server that supports
28 CGI.
29
30 This FastCGI Developer's Kit is designed to make developing FastCGI
31 applications easy. The kit currently supports FastCGI applications
32 written in C/C++, Perl, Tcl, and Java.
33
34 This package contains only shared libraries used by programs developed
35 using FastCGI Developer's Kit and cgi-fcgi (bridge from CGI to
36 FastCGI).
37
38 %description -l pl.UTF-8
39 FastCGI to otwarte rozszerzenie CGI dające wysoką wydajność dla
40 wszystkich aplikacjach internetowych bez obciążania API serwera WWW.
41
42 FastCGI został zaprojektowany "na wierzchu" istniejących API serwerów.
43 Na przykład, moduł Apache mod_fastcgi dodaje obsługę FastCGI do serwera
44 Apache. FastCGI może być używany, ze zmniejszoną funkcjonalnością
45 i wydajnością, z dowolnym serwerem obsługującym CGI.
46
47 Zestaw Programisty FastCGI jest tak zaprojektowany, by uczynić łatwym
48 tworzenie aplikacji FastCGI. Aktualnie wspiera tworzenie aplikacji
49 FastCGI w C/C++, Perlu, Tcl i Javie.
50
51 Ten pakiet zawiera tylko biblioteki współdzielone używane przez programy
52 stworzone przy użyciu FastCGI developer's Kit oraz program cgi-fcgi
53 (bramkę pomiędzy CGI a FastCGI).
54
55 %package devel
56 Summary:        FastCGI development kit
57 Summary(pl.UTF-8):   Zestaw dla programistów FastCGI
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Obsoletes:      fastcgi-devkit
61
62 %description devel
63 This package contains FastCGI Developer's Kit, which is designed to
64 make developing FastCGI applications easy. The kit currently supports
65 FastCGI applications written in C/C++, Perl, Tcl, and Java.
66
67 %description devel -l pl.UTF-8
68 Ten pakiet zawiera Zestaw Programisty FastCGI, który jest tak
69 zaprojektowany, by uczynić łatwym tworzenie aplikacji FastCGI.
70 Aktualnie wspiera tworzenie aplikacji FastCGI w C/C++, Perlu, Tcl i
71 Javie.
72
73 %package static
74 Summary:        FastCGI static library
75 Summary(pl.UTF-8):   Statyczna biblioteka FastCGI
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 FastCGI static library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka FastCGI.
84
85 %prep
86 %setup -q
87 %patch0 -p1
88 %patch1 -p1
89
90 %build
91 # supplied libtool is broken (relink, C++)
92 %{__libtoolize}
93 %{__aclocal}
94 %{__autoconf}
95 %{__automake}
96
97 CPPFLAGS="-DLISTEN_BACKLOG=1024"
98 %configure \
99         --with-global \
100         --with-nodebug \
101         --with-noassert \
102         --with-notest
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 cp -a examples/{Makefile*,*.c} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc README LICENSE.TERMS doc/*.1
124 %attr(755,root,root) %{_bindir}/*
125 %attr(755,root,root) %{_libdir}/lib*.so.*.*
126
127 %files devel
128 %defattr(644,root,root,755)
129 %doc doc/*.htm* doc/*.gif doc/fastcgi-* doc/*.3
130 %attr(755,root,root) %{_libdir}/lib*.so
131 %{_libdir}/lib*.la
132 %{_includedir}
133 %{_examplesdir}/%{name}-%{version}
134
135 %files static
136 %defattr(644,root,root,755)
137 %{_libdir}/lib*.a
This page took 0.071743 seconds and 3 git commands to generate.