]> git.pld-linux.org Git - packages/fcft.git/blob - fcft.spec
up to 3.1.1
[packages/fcft.git] / fcft.spec
1 Summary:        A simple library for font loading and glyph rasterization
2 Name:           fcft
3 Version:        3.1.1
4 Release:        1
5 License:        MIT
6 Group:          Development/Libraries
7 Source0:        https://codeberg.org/dnkl/fcft/archive/%{version}.tar.gz
8 # Source0-md5:  db1b163271cc76eb62cf187bce4b7a4e
9 URL:            https://codeberg.org/dnkl/fcft
10 BuildRequires:  fontconfig-devel
11 BuildRequires:  freetype-devel >= 2.12.0
12 BuildRequires:  harfbuzz-devel
13 BuildRequires:  libutf8proc-devel
14 BuildRequires:  meson >= 0.58.0
15 BuildRequires:  ninja
16 BuildRequires:  pixman-devel
17 BuildRequires:  pkgconfig
18 BuildRequires:  rpmbuild(macros) >= 1.736
19 BuildRequires:  scdoc
20 BuildRequires:  tllist-devel >= 1.0.1
21 BuildRequires:  wayland-devel
22 BuildRequires:  wayland-protocols
23 Requires:       freetype >= 2.12.0
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 fcft is a small font loading and glyph rasterization library built
28 on-top of FontConfig, FreeType2 and pixman.
29
30 It can load and cache fonts from a fontconfig-formatted name string,
31 e.g. Monospace:size=12, optionally with user configured fallback
32 fonts.
33
34 After a font has been loaded, you can rasterize glyphs. When doing so,
35 the primary font is first considered. If it does not have the
36 requested glyph, the user configured fallback fonts (if any) are
37 considered. If none of the user configured fallback fonts has the
38 requested glyph, the FontConfig generated list of fallback fonts are
39 checked.
40
41 %package devel
42 Summary:        Header files for the fcft library
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       fontconfig-devel
46 Requires:       freetype-devel >= 2
47 Requires:       harfbuzz-devel
48 Requires:       libutf8proc-devel
49 Requires:       pixman-devel
50 Requires:       tllist-devel >= 1.0.1
51
52 %description devel
53 Header files for the fcft library.
54
55 %package static
56 Summary:        Static fcft library
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static fcft library.
62
63 %prep
64 %setup -q -n %{name}
65
66 %build
67 %meson build
68
69 %ninja_build -C build
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %ninja_install -C build
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %doc CHANGELOG.md README.md
85 %attr(755,root,root) %{_libdir}/libfcft.so.*.*
86 %attr(755,root,root) %ghost %{_libdir}/libfcft.so.4
87
88 %files devel
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_libdir}/libfcft.so
91 %dir %{_includedir}/fcft
92 %{_includedir}/fcft/fcft.h
93 %{_includedir}/fcft/stride.h
94 %{_pkgconfigdir}/fcft.pc
95 %{_mandir}/man3/fcft_*.3*
96
97 %files static
98 %defattr(644,root,root,755)
99 %{_libdir}/libfcft.a
This page took 0.044811 seconds and 4 git commands to generate.