]> git.pld-linux.org Git - packages/fcft.git/blob - fcft.spec
274b96b05457f27ee30f62c15a567006f0480357
[packages/fcft.git] / fcft.spec
1 Summary:        A simple library for font loading and glyph rasterization
2 Name:           fcft
3 Version:        3.0.1
4 Release:        1
5 License:        MIT
6 Group:          Development/Libraries
7 Source0:        https://codeberg.org/dnkl/fcft/archive/%{version}.tar.gz
8 # Source0-md5:  0e6edeb8bd86184b57cfeb3c74362126
9 URL:            https://codeberg.org/dnkl/fcft
10 BuildRequires:  fontconfig-devel
11 BuildRequires:  freetype-devel >= 2
12 BuildRequires:  harfbuzz-devel
13 BuildRequires:  libutf8proc-devel
14 BuildRequires:  meson >= 0.54.0
15 BuildRequires:  ninja
16 BuildRequires:  pixman-devel
17 BuildRequires:  pkgconfig
18 BuildRequires:  rpmbuild(macros) >= 1.736
19 BuildRequires:  scdoc
20 BuildRequires:  tllist-devel >= 1.0.1
21 BuildRequires:  wayland-devel
22 BuildRequires:  wayland-protocols
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 fcft is a small font loading and glyph rasterization library built
27 on-top of FontConfig, FreeType2 and pixman.
28
29 It can load and cache fonts from a fontconfig-formatted name string,
30 e.g. Monospace:size=12, optionally with user configured fallback
31 fonts.
32
33 After a font has been loaded, you can rasterize glyphs. When doing so,
34 the primary font is first considered. If it does not have the
35 requested glyph, the user configured fallback fonts (if any) are
36 considered. If none of the user configured fallback fonts has the
37 requested glyph, the FontConfig generated list of fallback fonts are
38 checked.
39
40 %package devel
41 Summary:        Header files for the fcft library
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       fontconfig-devel
45 Requires:       freetype-devel >= 2
46 Requires:       harfbuzz-devel
47 Requires:       libutf8proc-devel
48 Requires:       pixman-devel
49 Requires:       tllist-devel >= 1.0.1
50
51 %description devel
52 Header files for the fcft library.
53
54 %package static
55 Summary:        Static fcft library
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static fcft library.
61
62 %prep
63 %setup -q -n %{name}
64
65 %build
66 %meson build
67
68 %ninja_build -C build
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %ninja_install -C build
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %files
82 %defattr(644,root,root,755)
83 %doc CHANGELOG.md README.md
84 %attr(755,root,root) %{_libdir}/libfcft.so.*.*
85 %attr(755,root,root) %ghost %{_libdir}/libfcft.so.4
86
87 %files devel
88 %defattr(644,root,root,755)
89 %attr(755,root,root) %{_libdir}/libfcft.so
90 %dir %{_includedir}/fcft
91 %{_includedir}/fcft/fcft.h
92 %{_includedir}/fcft/stride.h
93 %{_pkgconfigdir}/fcft.pc
94 %{_mandir}/man3/fcft_*.3*
95
96 %files static
97 %defattr(644,root,root,755)
98 %{_libdir}/libfcft.a
This page took 0.067107 seconds and 2 git commands to generate.