]> git.pld-linux.org Git - packages/fann.git/blob - fann.spec
- fixes linking
[packages/fann.git] / fann.spec
1 Summary:        A fast artificial neural network library
2 Summary(pl.UTF-8):      Szybka biblioteka do tworzenia sztucznych sieci neuronowych
3 Name:           fann
4 Version:        2.0.0
5 Release:        1
6 License:        LGPL
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/fann/%{name}-%{version}.tar.bz2
9 # Source0-md5:  4224efa533265dcf39237667973d0e20
10 Source1:        http://dl.sourceforge.net/fann/%{name}_doc_complete_1.0.pdf
11 # Source1-md5:  8117a677afc79dfaa31de39ca84d82da
12 Patch0:         %{name}-python.patch
13 URL:            http://leenissen.dk/fann/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  libtool
17 BuildRequires:  python
18 BuildRequires:  python-devel >= 1:2.3
19 BuildRequires:  python-modules
20 BuildRequires:  sed >= 4.0
21 BuildRequires:  swig-python >= 1.3.25
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Fast Artificial Neural Network (FANN) Library is written in ANSI C.
26 The library implements multilayer feedforward ANNs, up to 150 times
27 faster than other libraries. FANN supports execution in fixed point,
28 for fast execution on systems like the iPAQ.
29
30 %description -l pl.UTF-8
31 FANN (Fast Artificial Neural Network - szybkie sztuczne sieci
32 neuronowe) to biblioteka napisana w ANSI C, implementująca
33 wielowarstwowe sztuczne sieci neuronowe, do 150 razy szybsza od innych
34 bibliotek. FANN obsługuje operacje stałoprzecinkowe w celu szybkiego
35 działania na systemach typu iPAQ.
36
37 %package devel
38 Summary:        Development libraries for FANN
39 Summary(pl.UTF-8):      Pliki nagłówkowe FANN
40 Group:          Development/Libraries
41 Requires:       %{name} = %{version}-%{release}
42
43 %description devel
44 This package is only needed if you intend to develop and/or compile
45 programs based on the FANN library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe FANN, potrzebne do tworzenia programów napisanych w
49 oparciu o bibliotekę FANN.
50
51 %package doc
52 Summary:        FANN documentation
53 Summary(pl.UTF-8):      Dokumentacja do FANN
54 Group:          Documentation
55
56 %description doc
57 Documentation for FANN.
58
59 %description doc -l pl.UTF-8
60 Dokumentacja do FANN.
61
62 %package static
63 Summary:        FANN static libraries
64 Summary(pl.UTF-8):      Biblioteki statyczne FANN
65 Group:          Development/Libraries
66 Requires:       %{name}-devel = %{version}-%{release}
67
68 %description static
69 FANN static libraries.
70  
71 %description static -l pl.UTF-8
72 Biblioteki statyczne FANN.
73
74 %package -n python-%{name}
75 Summary:        Python support for FANN
76 Summary(pl.UTF-8):      Moduł języka Python dla biblioteki FANN
77 Group:          Libraries/Python
78 Requires:       %{name} = %{version}-%{release}
79 %pyrequires_eq  python-libs
80
81 %description -n python-%{name}
82 Python support for FANN.
83
84 %description -n python-%{name} -l pl.UTF-8
85 Moduł języka Python dla biblioteki FANN.
86
87 %prep
88 %setup -q
89 cp %{SOURCE1} .
90 %patch0 -p1
91
92 %build
93 %{__libtoolize}
94 %{__aclocal}
95 %{__autoconf}
96 %{__automake}
97 %configure
98 %{__make}
99 cd python
100
101 CFLAGS="%{rpmcflags}" \
102 %{__make}
103 %py_comp .
104 %py_ocomp .
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 cd python
113 %{__make} install \
114         ROOT=$RPM_BUILD_ROOT
115
116 cd ..
117 install -d $RPM_BUILD_ROOT%{_examplesdir}/{python-,}%{name}-%{version}
118
119 install python/examples/*.py $RPM_BUILD_ROOT%{_examplesdir}/python-%{name}-%{version} 
120 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
121
122 rm -f $RPM_BUILD_ROOT%{py_sitedir}/pyfann/*.py
123
124 %clean
125 rm -rf $RPM_BUILD_ROOT
126
127 %post   -p /sbin/ldconfig
128 %postun -p /sbin/ldconfig
129
130 %files
131 %defattr(644,root,root,755)
132 %doc AUTHORS ChangeLog NEWS README TODO
133 %attr(755,root,root) %{_libdir}/lib*.so.*.*
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/lib*.so
138 %{_libdir}/lib*.la
139 %{_includedir}/*.h
140 %{_pkgconfigdir}/fann.pc
141 %{_examplesdir}/%{name}-%{version}
142
143 %files doc
144 %defattr(644,root,root,755)
145 %doc fann_doc_complete_1.0.pdf doc/*
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/lib*.a
150
151 %files -n python-%{name}
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{py_sitedir}/pyfann/*.so
154 %dir %{py_sitedir}/pyfann
155 %{py_sitedir}/pyfann/*.py[co]
156 %{_examplesdir}/python-%{name}-%{version}
This page took 0.094282 seconds and 3 git commands to generate.