]> git.pld-linux.org Git - packages/fakebo.git/blob - fakebo.spec
- Prereq: /sbin/chkconfig (rc-scripts does not require it)
[packages/fakebo.git] / fakebo.spec
1 Summary:        Fakes trojan servers and logs incoming requests
2 Summary(pl):    Program udaj±cy trojany i loguj±cy nadchodz±ce po³±czenia
3 Name:           fakebo
4 Version:        0.4.1
5 Release:        2
6 License:        GPL
7 Group:          Networking/Daemons
8 Group(de):      Netzwerkwesen/Server
9 Group(pl):      Sieciowe/Serwery
10 Source0:        ftp://ftp.linux.hr/pub/fakebo/%{name}-%{version}.tar.gz
11 Source1:        %{name}.init
12 URL:            http://cvs.linux.hr/fakebo/
13 BuildRequires:  autoconf
14 Prereq:         rc-scripts
15 Prereq:         /sbin/chkconfig
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 FakeBO fakes trojan server responses (Back Orifice, NetBus, etc.) and
20 logs every attempt to a logfile or stdout. It is able to send fake
21 pings and replies back to the client trying to access your system.
22
23 %description -l pl
24 FakeBO udaje odpowiedzi trojanów (Back Orifice, NetBus, itp.) i loguje
25 ka¿d± próbê do pliku z logiem lub na standardowe wyj¶cie. Jest on
26 zdolny do wysy³ania fa³szywych pingów i odpowiedzi z powrotem do
27 klienta próbuj±cego uzyskaæ dostêp do twojego systemu.
28
29 %prep
30 %setup -q
31
32 %build
33 autoconf
34 %configure
35 %{__make}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
40
41 %{__make} install DESTDIR=$RPM_BUILD_ROOT
42
43 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/fakebo
44
45 gzip -9nf HACKING AUTHORS TODO NEWS ChangeLog README custom.replies
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %post
51 /sbin/chkconfig --add fakebo
52 if [ -f /var/lock/subsys/fakebo ]; then
53         /etc/rc.d/init.d/fakebo restart 1>&2
54 else
55         echo "Run \"/etc/rc.d/init.d/fakebo start\" to start fakebo daemon."
56 fi
57
58
59 %postun
60 if [ "$1" = "0" ]; then
61         if [ -f /var/lock/subsys/fakebo ]; then
62                 /etc/rc.d/init.d/fakebo stop 1>&2
63         fi
64         /sbin/chkconfig --del fakebo
65 fi
66
67 %files
68 %defattr(644,root,root,755)
69 %doc *.gz
70 %attr(755,root,root) %{_bindir}/fakebo
71 %attr(754,root,root) /etc/rc.d/init.d/fakebo
72 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/fakebo.conf
73 %{_mandir}/man1/fakebo.1*
This page took 0.090197 seconds and 4 git commands to generate.