]> git.pld-linux.org Git - packages/f2c.git/blob - f2c.spec
- restored
[packages/f2c.git] / f2c.spec
1 Summary:        The f2c Fortran to C/C++ conversion program and libraries
2 Summary(pl.UTF-8):      Program f2c do tłumaczenia z Fortranu na C/C++ i biblioteki
3 Name:           f2c
4 Version:        20031027
5 Release:        1
6 License:        Distributable
7 Group:          Development/Languages/Fortran
8 Source0:        %{name}-%{version}.tar.bz2
9 # Source0-md5:  bcd2c9ba1307c9fc9f73027c3c4e3d4c
10 Patch0:         %{name}-20031027.patch
11 URL:            ftp://ftp.netlib.org/f2c/
12 BuildRequires:  rpmbuild(macros) >= 1.583
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %define         skip_post_check_so      libf2c.so.*
16
17 %description
18 f2c converts Fortran 77 source code to C or C++ source files. If no
19 Fortran files are named on the command line, f2c can read Fortran from
20 standard input and write C to standard output.
21
22 f2c can also be used (with the -P option) to generate ANSI C header
23 files for calling Fortran routines from C.
24
25 %description -l pl.UTF-8
26 f2c służy do tłumaczenia kodu źródłowego w Fortranie 77 na kod
27 dając w wyniku pliki z kodem źródłowym w C lub C++. Jeśli w wierszu
28 polecenia nie zostaną podane żadne pliki, f2c będzie oczekiwał kodu w
29 Fortranie na standardowym wejściu i pisał kod w C na standardowe
30 wyjście.
31
32 f2c może również służyć (z opcją -P) do generowania plików
33 nagłówkowych ANSI C w celu wywoływania procedur fortranowskich z C.
34
35 %prep
36 %setup -q
37 %patch0 -p1
38
39 %build
40 %ifarch alpha
41 MFLAG=-mieee
42 %endif
43
44 mkdir -p libf2c/PIC
45
46 cp -f libf2c/makefile.u libf2c/Makefile
47 cp -f src/makefile.u src/Makefile
48 %{__make} -C src f2c \
49         CC="%{__cc}" \
50         RPM_OPT_FLAGS="%{rpmcflags}" \
51         MFLAG="$MFLAG"
52 %{__make} -C libf2c \
53         CC="%{__cc}" \
54         RPM_OPT_FLAGS="%{rpmcflags} -fPIC" \
55         MFLAG="$MFLAG"
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir},%{_includedir}}
60
61 install libf2c/libf2c.a $RPM_BUILD_ROOT%{_libdir}
62 install f2c.h $RPM_BUILD_ROOT%{_includedir}
63 install src/f2c $RPM_BUILD_ROOT%{_bindir}
64 install fc $RPM_BUILD_ROOT%{_bindir}
65 install src/f2c.1t $RPM_BUILD_ROOT%{_mandir}/man1/f2c.1
66 install libf2c/libf2c.so.0.22 $RPM_BUILD_ROOT%{_libdir}
67 ln -sf libf2c.so.0.22 $RPM_BUILD_ROOT%{_libdir}/libf2c.so
68
69 rm -rf $RPM_BUILD_ROOT%{_prefix}/liblibf2c.so
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post   -p /sbin/ldconfig
75 %postun -p /sbin/ldconfig
76
77 %files
78 %defattr(644,root,root,755)
79 %doc f2c.ps README permission disclaimer changes src/Notice
80 %attr(755,root,root) %{_bindir}/*
81 %attr(755,root,root) %{_libdir}/libf2c.so.*.*
82 %attr(755,root,root) %{_libdir}/libf2c.so
83 %{_libdir}/libf2c.a
84 %{_includedir}/f2c.h
85 %{_mandir}/*/*
This page took 0.07742 seconds and 3 git commands to generate.