]> git.pld-linux.org Git - packages/expect.git/blob - expect.spec
- spec adapterized.
[packages/expect.git] / expect.spec
1 Summary:        tcl extension 
2 Summary(de):    tcl-Erweiterung 
3 Summary(fr):    Extension tcl 
4 Summary(pl):    Rozszerzenie TCL 
5 Summary(tr):    Programlar arasý etkileþimi mümkün kýlan tcl geniþletmesi
6 Name:           expect
7 Version:        5.28
8 Release:        3
9 License:        BSD
10 Group:          Development/Languages/Tcl
11 Group(pl):      Programowanie/Jêzyki/Tcl
12 Source0:        ftp://ftp.cme.nist.gov/pub/%{name}/%{name}.tar.gz
13 Icon:           tcl.gif
14 Patch0:         %{name}.patch
15 Patch1:         %{name}-mkpasswd.patch
16 Patch2:         %{name}-pty.patch
17 Patch3:         %{name}-strf.patch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Expect is a tool for automating interactive applications such as
22 telnet, ftp, passwd, fsck, rlogin, tip, etc. It makes it easy for a
23 script to control another program and interact with it.
24
25 %description -l pl
26 Expect to narzêdzie do automatyzacji interakcji z aplikacjami takimi
27 jak telnet, ftp, passwd, fsck, rlogin, tip itp. Expect pozwala w ³atwy
28 sposób przy pomocy skryptu kontrolowaæ inny program.
29
30 %description -l de
31 Expect ist ein Tool zur Automatisierung interaktiver Applikationen wie
32 telnet, ftp, passwd, fsck, rlogin, tip usw. Mit seiner Hilfe kann ein
33 Skript ein anderes Programm sehr leicht steuern oder damit
34 interagieren.
35
36 %description -l fr
37 expect est un un outil pour automatiser les applications interactives
38 comme telnet, ftp, passwd, fsck, rlogin, tip, etc. Il est alors facile
39 pour un script de contrôler un autre programme et d'interagir avec
40 lui.
41
42 %description -l tr
43 Expect telnet, ftp, passwd, fsck, rlogin, tip gibi etkileþimli
44 uygulamalarý otomatize etmeye yarayan bir araçtýr. Bir uygulamanýn bir
45 diðer uygulamayý denetlemesini kolaylaþtýrýr.
46
47 %package        devel
48 Summary:        tcl extension header files and development documentation
49 Summary(pl):    Pliki nag³ówkowe i dokumentacja do rozszerzenia jêzyka TCL
50 Group:          Development/Languages/Tcl
51 Group(pl):      Programowanie/Jêzyki/Tcl
52 Requires:       %{name} = %{version}
53
54 %description devel
55 Tcl extension language header files and develppment documentation.
56
57 %description -l pl devel
58 Pliki nag³ówkowe i dokumentacja do rozszerzenie jêzyka TCL.
59
60 %package        static
61 Summary:        tcl extension static library
62 Summary(pl):    Biblioteka statyczna rozszerzenia jêzyka TCL
63 Group:          Development/Languages/Tcl
64 Group(pl):      Programowanie/Jêzyki/Tcl
65 Requires:       %{name}-devel = %{version}
66
67 %description static
68 Tcl extension language static library.
69
70 %description -l pl static
71 Biblioteka statyczna rozszerzenia jêzyka TCL.
72
73 %prep
74 %setup  -q
75 %patch0 -p1
76 %patch1 -p2
77 %patch2 -p1
78 %patch3 -p1
79
80 %build
81 autoconf
82 CFLAGS="$RPM_OPT_FLAGS -w" \
83 ./configure     --enable-gcc \
84                 --enable-shared \
85 --prefix=%{_prefix} \
86                 --with-tclconfig=%{_libdir} \
87                 --with-tkconfig=/%{_libdir} \
88                 --with-tclinclude=%{_includedir} \
89                 --with-tkinclude=%{_includedir} \
90                 --mandir=%{_mandir} %{_target_platform}
91 make 
92 cd ..
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir} \
98 make \
99     prefix=$RPM_BUILD_ROOT%{_prefix} \
100     mandir=$RPM_BUILD_ROOT%{_mandir} \
101     install
102
103 for n in $RPM_BUILD_ROOT%{_bindir}/* ; do
104         if head -1 $n | grep '#!'; then
105                 cp -a $n $n.in
106                 sed "s|$RPM_BUILD_ROOT||" < $n.in > $n
107                 rm -f $n.in
108         fi
109 done
110
111 strip $RPM_BUILD_ROOT%{_bindir}/{expect,expectk}
112 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/*.so
113
114 ( cd $RPM_BUILD_ROOT%{_bindir}; mv -f rftp rftp-expect )
115
116 gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man[13]/* FAQ README ChangeLog
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files
125 %defattr(644,root,root,755)
126 %doc {FAQ,README,ChangeLog}.gz
127
128 %attr(755,root,root) %{_bindir}/*
129
130 %dir %{_libdir}/expect*
131 %attr(755,root,root) %{_libdir}/expect*/pkgIndex.tcl
132 %attr(755,root,root) %{_libdir}/libe*.so
133
134 %{_mandir}/man1/*
135
136 %files devel
137 %defattr(644,root,root,755)
138
139 %{_includedir}/*
140 %{_mandir}/man3/*
141
142 %files static
143 %defattr(644,root,root,755)
144
145 %{_libdir}/*.a
This page took 0.03744 seconds and 4 git commands to generate.