]> git.pld-linux.org Git - packages/expect.git/blob - expect.spec
- some fixes in %install.
[packages/expect.git] / expect.spec
1 Summary:     tcl extension to allow interaction between programs and scripts
2 Summary(de): tcl-Erweiterung zur Ermöglichung der Interaktion zwischen  Programmen und Skripts 
3 Summary(fr): Extension tcl permettant l'intéraction entre programmes et scripts"
4 Summary(tr): Programlar arasý etkileþimi mümkün kýlan tcl geniþletmesi
5 Name:        expect
6 Version:     5.26
7 Release:     1
8 Copyright:   BSD
9 Group:       Development/Languages/Tcl
10 Source:      ftp://ftp.cme.nist.gov/pub/expect/expect.tar.gz
11 Icon:        tcl.gif
12 Patch:       expect.patch
13 Buildroot:   /tmp/%{name}-%{version}-root
14
15 %description
16 Expect is a tool for automating interactive applications such as
17 telnet, ftp, passwd, fsck, rlogin, tip, etc. It makes it easy for a
18 script to control another program and interact with it.
19
20 %description -l de
21 Expect ist ein Tool zur Automatisierung interaktiver Applikationen 
22 wie telnet, ftp, passwd, fsck, rlogin, tip usw. Mit seiner Hilfe 
23 kann ein Skript ein anderes Programm sehr leicht steuern oder 
24 damit interagieren. 
25
26 %description -l fr
27 expect est un un outil pour automatiser les applications interactives
28 comme telnet, ftp, passwd, fsck, rlogin, tip, etc. Il est alors facile
29 pour un script de contrôler un autre programme et d'interagir avec lui.
30
31 %description -l tr
32 Expect telnet, ftp, passwd, fsck, rlogin, tip gibi etkileþimli uygulamalarý
33 otomatize etmeye yarayan bir araçtýr. Bir uygulamanýn bir diðer uygulamayý
34 denetlemesini kolaylaþtýrýr.
35
36 %package devel
37 Summary:     tcl extension header files and development documentation
38 Group:       Development/Languages/Tcl
39 Requires:    %{name} = %{version}
40
41 %description devel
42 Tcl extension language header files and develppment documentation.
43
44 %package static
45 Summary:     tcl extension static library
46 Group:       Development/Languages/Tcl
47 Requires:    %{name}-devel = %{version}
48
49 %description static
50 Tcl extension language static library.
51
52 %prep
53 %setup -q
54 %patch -p1
55
56 %build
57 # make the libraries reentrant
58 #RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
59
60 TCL_BIN_DIR=/usr/bin \
61 TCL_LIBRARY=/usr/lib \
62 CFLAGS="$RPM_OPT_FLAGS" \
63 ./configure     --enable-gcc \
64                 --enable-shared \
65                 --prefix=/usr \
66                 --with-tclconfig=/usr/lib
67 make
68 cd ..
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 #install -d $RPM_BUILD_ROOT/usr
73
74 LD_LIBRARY_PATH=$RPM_BUILD_ROOT/usr/lib \
75 make prefix=$RPM_BUILD_ROOT/usr install
76
77 for n in $RPM_BUILD_ROOT/usr/bin/* ; do
78         if head -1 $n | grep '#!'; then
79                 cp -a $n $n.in
80                 sed "s|$RPM_BUILD_ROOT||" < $n.in > $n
81                 rm -f $n.in
82         fi
83 done
84
85 strip $RPM_BUILD_ROOT/usr/{bin/*,lib/libe*.so} || :
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %files
94 %attr(755, root, root) /usr/bin/*
95 %dir /usr/lib/expect*
96 %attr(755, root, root) /usr/lib/expect*/pkgIndex.tcl
97 %attr(755, root, root) /usr/lib/libe*.so
98 %attr(644, root,  man) /usr/man/man1/*
99
100 %files devel
101 %attr(644, root, root) /usr/include/*
102 %attr(644, root,  man) /usr/man/man3/*
103
104 %files static
105 %attr(644, root, root) /usr/lib/lib*.a
106
107 %changelog
108 * Thu Sep  8 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
109   [5.26-1]
110 - expect is now in separated source package from orher tcl/tk stuff,
111 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
112 - added using %%{name} and %%{version} in Source,
113 - fixed using $RPM_OPT_FLAGS during compile (curren expect configure script
114   don't accept passing CFLAGS in enviroment variable),
115 - added striping shared libraries and othet binary,
116 - added devel and static subpackage,
117 - added package icon,
118 - added %attr and %defattr macros in %files (allow build package from
119   non-root account).
120
121 * Thu May 07 1998 Prospector System <bugs@redhat.com>
122 - translations modified for de, fr, tr
123
124 * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
125 - fixed expect binaries exec permissions
126
127 * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
128 - updated to Tix 4.1.0.006
129 - updated version numbers of tcl/tk to relflect includsion of p2
130
131 * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
132 - updated tcl/tk to patch level 2
133 - updated tclX to 8.0.2
134
135 * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
136 - fixed filelist for tix... replacing path to the expect binary in scripts
137   was leaving junk files around.
138
139 * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
140 - added patch to remove libieee test in configure.in for tcl and tk.
141   Shoudln't be needed anymore for glibc systems, but this isn't the "proper" 
142   solution for all systems
143 - fixed src urls
144
145 * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
146 - removed version numbers from descriptions
147
148 * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
149 - updated to tcl/tk 8.0 and related versions of packages
150
151 * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
152 - built against glibc
153 - fixed dangling tclx/tkx symlinks
This page took 0.04606 seconds and 4 git commands to generate.