]> git.pld-linux.org Git - packages/expect.git/blob - expect.spec
now builds with current env. (maybe that isnt nicest way..but that works)
[packages/expect.git] / expect.spec
1 Summary:        tcl extension 
2 Summary(de):    tcl-Erweiterung 
3 Summary(fr):    Extension tcl 
4 Summary(pl):    Rozszerzenie TCL 
5 Summary(tr):    Programlar arasý etkileþimi mümkün kýlan tcl geniþletmesi
6 Name:           expect
7 Version:        5.32.2
8 Release:        51
9 License:        BSD
10 Group:          Development/Languages/Tcl
11 Group(de):      Entwicklung/Sprachen/Tcl
12 Group(pl):      Programowanie/Jêzyki/Tcl
13 Source0:        ftp://ftp.scriptics.com/pub/tcl/expect/%{name}.%{version}.tar.gz
14 Patch0:         %{name}-pty.patch
15 Patch1:         %{name}-alpha.patch
16 Patch2:         %{name}-bug7869.patch
17 Patch3:         %{name}-fixcat.patch
18 Patch4:         %{name}-jbj.patch
19 Icon:           tcl.gif
20 URL:            http://expect.nist.gov/
21 BuildRequires:  glibc-static
22 BuildRequires:  tcl-devel >= 8.3.2
23 BuildRequires:  tk-devel >= 8.3.2
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Expect is a tool for automating interactive applications such as
28 telnet, ftp, passwd, fsck, rlogin, tip, etc. It makes it easy for a
29 script to control another program and interact with it.
30
31 %description -l pl
32 Expect to narzêdzie do automatyzacji interakcji z aplikacjami takimi
33 jak telnet, ftp, passwd, fsck, rlogin, tip itp. Expect pozwala w ³atwy
34 sposób przy pomocy skryptu kontrolowaæ inny program.
35
36 %description -l de
37 Expect ist ein Tool zur Automatisierung interaktiver Applikationen wie
38 telnet, ftp, passwd, fsck, rlogin, tip usw. Mit seiner Hilfe kann ein
39 Skript ein anderes Programm sehr leicht steuern oder damit
40 interagieren.
41
42 %description -l fr
43 expect est un un outil pour automatiser les applications interactives
44 comme telnet, ftp, passwd, fsck, rlogin, tip, etc. Il est alors facile
45 pour un script de contrôler un autre programme et d'interagir avec
46 lui.
47
48 %description -l tr
49 Expect telnet, ftp, passwd, fsck, rlogin, tip gibi etkileþimli
50 uygulamalarý otomatize etmeye yarayan bir araçtýr. Bir uygulamanýn bir
51 diðer uygulamayý denetlemesini kolaylaþtýrýr.
52
53 %package X11
54 Summary:        tk extension
55 Summary(pl):    rozszerzenie tk
56 Group:          Development/Languages/Tcl
57 Group(de):      Entwicklung/Sprachen/Tcl
58 Group(pl):      Programowanie/Jêzyki/Tcl
59 Requires:       %{name} = %{version}
60
61 %description X11
62 This package contains expectk, which is an Tk extension, just as
63 expect Tcl extension.
64
65 %description X11 -l pl
66 Ten pakiet zawiera expectk, który jest rozszerzeniem dla Tk takim jak
67 expect jest dla Tcl.
68
69 %package devel
70 Summary:        tcl extension header files and development documentation
71 Summary(pl):    Pliki nag³ówkowe i dokumentacja do rozszerzenia jêzyka TCL
72 Group:          Development/Languages/Tcl
73 Group(de):      Entwicklung/Sprachen/Tcl
74 Group(pl):      Programowanie/Jêzyki/Tcl
75 Requires:       %{name} = %{version}
76 Requires:       tcl-devel
77
78 %description devel
79 Tcl extension language header files and develppment documentation.
80
81 %description -l pl devel
82 Pliki nag³ówkowe i dokumentacja do rozszerzenie jêzyka TCL.
83
84 %package        static
85 Summary:        tcl extension static library
86 Summary(pl):    Biblioteka statyczna rozszerzenia jêzyka TCL
87 Group:          Development/Languages/Tcl
88 Group(de):      Entwicklung/Sprachen/Tcl
89 Group(pl):      Programowanie/Jêzyki/Tcl
90 Requires:       %{name}-devel = %{version}
91
92 %description static
93 Tcl extension language static library.
94
95 %description -l pl static
96 Biblioteka statyczna rozszerzenia jêzyka TCL.
97
98 %prep
99 %setup  -q -n %{name}5.32
100 %patch0 -p1
101 %patch1 -p1
102 %patch2 -p1
103 %patch3 -p1
104 %patch4 -p1
105
106 chmod +w configure
107
108 %build
109 %configure2_13 \
110         --enable-gcc \
111         --enable-shared \
112         --with-tclconfig=%{_libdir} \
113         --with-tkconfig=/%{_libdir} \
114         --with-tclinclude=%{_includedir} \
115         --with-tkinclude=%{_includedir}
116 %{__make} 
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 LD_LIBRARY_PATH=$RPM_BUILD_ROOT%{_libdir} \
122 %{__make} install \
123         INSTALL_ROOT=$RPM_BUILD_ROOT
124
125 ( cd $RPM_BUILD_ROOT%{_bindir}; mv -f rftp rftp-expect )
126
127 gzip -9nf FAQ README ChangeLog
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %files
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_bindir}/autoexpect
138 %attr(755,root,root) %{_bindir}/autopasswd
139 %attr(755,root,root) %{_bindir}/cryptdir
140 %attr(755,root,root) %{_bindir}/decryptdir
141 %attr(755,root,root) %{_bindir}/dislocate
142 %attr(755,root,root) %{_bindir}/expect
143 %attr(755,root,root) %{_bindir}/ftp-rfc
144 %attr(755,root,root) %{_bindir}/kibitz
145 %attr(755,root,root) %{_bindir}/lpunlock
146 %attr(755,root,root) %{_bindir}/mkpasswd
147 %attr(755,root,root) %{_bindir}/passmass
148 %attr(755,root,root) %{_bindir}/rftp-expect
149 %attr(755,root,root) %{_bindir}/rlogin-cwd
150 %attr(755,root,root) %{_bindir}/timed-read
151 %attr(755,root,root) %{_bindir}/timed-run
152 %attr(755,root,root) %{_bindir}/unbuffer
153 %attr(755,root,root) %{_bindir}/weather
154 %dir %{_libdir}/expect*
155 %attr(755,root,root) %{_libdir}/expect*/pkgIndex.tcl
156 %attr(755,root,root) %{_libdir}/libe*.so
157 %{_mandir}/man1/autoexpect.*
158 %{_mandir}/man1/cryptdir.*
159 %{_mandir}/man1/decryptdir.*
160 %{_mandir}/man1/dislocate.*
161 %{_mandir}/man1/expect.*
162 %{_mandir}/man1/kibitz.*
163 %{_mandir}/man1/mkpasswd.*
164 %{_mandir}/man1/passmass.*
165 %{_mandir}/man1/unbuffer.*
166
167 %files X11
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_bindir}/expectk
170 %attr(755,root,root) %{_bindir}/tknewsbiff
171 %attr(755,root,root) %{_bindir}/tkpasswd
172 %attr(755,root,root) %{_bindir}/xkibitz
173 %attr(755,root,root) %{_bindir}/xpstat
174 %{_mandir}/man1/expectk.*
175 %{_mandir}/man1/tknewsbiff.*
176 %{_mandir}/man1/xkibitz.*
177
178 %files devel
179 %defattr(644,root,root,755)
180 %doc *.gz
181 %{_includedir}/*
182 %{_mandir}/man3/*
183
184 %files static
185 %defattr(644,root,root,755)
186 %{_libdir}/*.a
This page took 0.050945 seconds and 4 git commands to generate.