]> git.pld-linux.org Git - packages/expect.git/blob - expect.spec
- removed using %attr(644,root,man) macros in %files.
[packages/expect.git] / expect.spec
1 Summary:     tcl extension to allow interaction between programs and scripts
2 Summary(de): tcl-Erweiterung zur Ermöglichung der Interaktion zwischen  Programmen und Skripts 
3 Summary(fr): Extension tcl permettant l'intéraction entre programmes et scripts"
4 Summary(pl): rozszerzenie tcl pozwalaj±ce na interakcjê miêdzy programami i skryptami
5 Summary(tr): Programlar arasý etkileþimi mümkün kýlan tcl geniþletmesi
6 Name:        expect
7 Version:     5.26
8 Release:     21
9 Copyright:   BSD
10 Group:       Development/Languages/Tcl
11 Source:      ftp://ftp.cme.nist.gov/pub/expect/expect.tar.gz
12 Icon:        %{name}.gif
13 Patch:       expect.patch
14 Buildroot:   /tmp/%{name}-%{version}-root
15
16 %description
17 Expect is a tool for automating interactive applications such as
18 telnet, ftp, passwd, fsck, rlogin, tip, etc. It makes it easy for a
19 script to control another program and interact with it.
20
21 %description -l pl
22 Expect to narzêdzie do automatyzacji interakcji z aplikacjami 
23 takimi jak telnet, ftp, passwd, fsck, rlogin, tip itp. Expect
24 pozwala w ³atwy sposób przy pomocy skryptu kontrolowaæ inny program.
25
26 %description -l de
27 Expect ist ein Tool zur Automatisierung interaktiver Applikationen 
28 wie telnet, ftp, passwd, fsck, rlogin, tip usw. Mit seiner Hilfe 
29 kann ein Skript ein anderes Programm sehr leicht steuern oder 
30 damit interagieren. 
31
32 %description -l fr
33 expect est un un outil pour automatiser les applications interactives
34 comme telnet, ftp, passwd, fsck, rlogin, tip, etc. Il est alors facile
35 pour un script de contrôler un autre programme et d'interagir avec lui.
36
37 %description -l tr
38 Expect telnet, ftp, passwd, fsck, rlogin, tip gibi etkileþimli uygulamalarý
39 otomatize etmeye yarayan bir araçtýr. Bir uygulamanýn bir diðer uygulamayý
40 denetlemesini kolaylaþtýrýr.
41
42 %package devel
43 Summary:     tcl extension header files and development documentation
44 Summary(pl): Pliki nag³ówkowe i dokumentacja developerska do rozszerzenia tcl
45 Group:       Development/Languages/Tcl
46 Requires:    %{name} = %{version}
47
48 %description devel
49 Tcl extension language header files and develppment documentation.
50
51 %description -l pl devel
52 Pliki nag³ówkowe i dokumentacja developersja do rozszerzenie jêzyka tcl.
53
54 %package static
55 Summary:     tcl extension static library
56 Summary(pl): Statyczna biblioteka rozszerzenia jêzyka tcl
57 Group:       Development/Languages/Tcl
58 Requires:    %{name}-devel = %{version}
59
60 %description static
61 Tcl extension language static library.
62
63 %description -l pl static
64 Statyczna biblioteka rozszerzenia jêzyka tcl.
65
66 %prep
67 %setup -q
68 %patch -p1
69
70 %build
71 # make the libraries reentrant
72 #RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
73
74 TCL_BIN_DIR=/usr/bin \
75 TCL_LIBRARY=/usr/lib \
76 CFLAGS="$RPM_OPT_FLAGS" \
77 ./configure     %{_target} \
78                 --enable-gcc \
79                 --enable-shared \
80                 --prefix=/usr \
81                 --with-tclconfig=/usr/lib
82 make
83 cd ..
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 #install -d $RPM_BUILD_ROOT/usr
88
89 LD_LIBRARY_PATH=$RPM_BUILD_ROOT/usr/lib \
90 make prefix=$RPM_BUILD_ROOT/usr install
91
92 for n in $RPM_BUILD_ROOT/usr/bin/* ; do
93         if head -1 $n | grep '#!'; then
94                 cp -a $n $n.in
95                 sed "s|$RPM_BUILD_ROOT||" < $n.in > $n
96                 rm -f $n.in
97         fi
98 done
99
100 strip $RPM_BUILD_ROOT/usr/{bin/*,lib/libe*.so} || :
101
102 %post   -p /sbin/ldconfig
103 %postun -p /sbin/ldconfig
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %attr(755, root, root) /usr/bin/*
110 %attr(755, root, root) %dir /usr/lib/expect*
111 %attr(755, root, root) /usr/lib/expect*/pkgIndex.tcl
112 %attr(755, root, root) /usr/lib/libe*.so
113 %{_mandir}/man1/*
114
115 %files devel
116 %attr(644, root, root) /usr/include/*
117 %{_mandir}/man3/*
118
119 %files static
120 %attr(644, root, root) /usr/lib/lib*.a
121
122 %changelog
123 * Sat Sep 26 1998 Arkadiusz Mi¶kiewicz <misiek@misiek.eu.org>
124   [5.26-2]
125 - added pl translation.
126
127 * Thu Sep  8 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
128   [5.26-1]
129 - expect is now in separated source package from orher tcl/tk stuff,
130 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
131 - added using %%{name} and %%{version} in Source,
132 - fixed using $RPM_OPT_FLAGS during compile (curren expect configure script
133   don't accept passing CFLAGS in enviroment variable),
134 - added stripping shared libraries and othet binary,
135 - added devel and static subpackage,
136 - added package icon,
137 - added %attr and %defattr macros in %files (allows build package from
138   non-root account).
139
140 * Thu May 07 1998 Prospector System <bugs@redhat.com>
141 - translations modified for de, fr, tr
142
143 * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
144 - fixed expect binaries exec permissions
145
146 * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
147 - updated to Tix 4.1.0.006
148 - updated version numbers of tcl/tk to relflect includsion of p2
149
150 * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
151 - updated tcl/tk to patch level 2
152 - updated tclX to 8.0.2
153
154 * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
155 - fixed filelist for tix... replacing path to the expect binary in scripts
156   was leaving junk files around.
157
158 * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
159 - added patch to remove libieee test in configure.in for tcl and tk.
160   Shoudln't be needed anymore for glibc systems, but this isn't the "proper" 
161   solution for all systems
162 - fixed src urls
163
164 * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
165 - removed version numbers from descriptions
166
167 * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
168 - updated to tcl/tk 8.0 and related versions of packages
169
170 * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
171 - built against glibc
172 - fixed dangling tclx/tkx symlinks
This page took 0.037102 seconds and 4 git commands to generate.