]> git.pld-linux.org Git - packages/exaile.git/blob - exaile.spec
- moving python files from libdir to datadir; rel. 2
[packages/exaile.git] / exaile.spec
1 #
2 # TODO: - separate plugins/*
3 #
4 Summary:        A powerful GTK+3 media player
5 Summary(pl.UTF-8):      Potężny odtwarzacz multimediów oparty na GTK+3
6 Name:           exaile
7 Version:        4.1.1
8 Release:        2
9 # GPL v2 in COPYING; GPL v1+ in license.txt; Artistic/Perl in lib/wmainfo.py
10 License:        GPL
11 Group:          X11/Applications/Multimedia
12 Source0:        https://github.com/exaile/exaile/releases/download/%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  e65089a19b038024a6b342db7eec06af
14 URL:            https://exaile.org/
15 BuildRequires:  gettext-tools
16 BuildRequires:  help2man
17 BuildRequires:  python3 >= 3.6
18 BuildRequires:  python3-pygobject3
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 2.000
21 Requires:       gstreamer
22 Requires:       gstreamer-plugins-good
23 Requires:       librsvg
24 Requires:       python3-bsddb3
25 Requires:       python3-dbus
26 Requires:       python3-feedparser
27 Requires:       python3-mutagen >= 1.10
28 Requires:       python3-pycairo
29 Requires:       python3-pygobject3
30 Recommends:     gstreamer-plugins-bad
31 Recommends:     gstreamer-plugins-ugly
32 Recommends:     python3-pillow
33 Recommends:     udisks2
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 Exaile is a media player aiming to be similar to KDE's AmaroK, but for
39 GTK+3. It incorporates many of the cool things from AmaroK (and other
40 media players).
41
42 Some of the features are:
43 - automatic fetching of album art
44 - handling of large libraries
45 - lyrics fetching
46 - artist/album information via the wikipedia
47 - last.fm support
48 - optional iPod support (assuming you have python-gpod installed)
49 - builtin shoutcast directory browser
50 - tabbed playlists
51 - blacklisting of tracks
52 - downloading of guitar tabs from fretplay.com
53 - submitting played tracks on the iPod to last.fm
54
55 %description -l pl.UTF-8
56 Exaile to odtwarzacz multimediów mający być podobny do AmaroKa, ale
57 dla GTK+3. Łączy wiele dobrych cech AmaroKa (i innych odtwarzaczy
58 multimediów).
59
60 Niektóre możliwości to:
61 - automatyczne pobieranie okładki albumu
62 - obsługa dużych bibliotek
63 - pobieranie tekstów utworów
64 - informacje o wykonawcy/albumie z wikipedii
65 - obsługa last.fm
66 - opcjonalna obsługa iPoda (przy zainstalowanym pakiecie python-gpod)
67 - wbudowana przeglądarka katalogów shoutcastów
68 - playlisty z zakładkami
69 - czarna lista ścieżek
70 - ściąganie tabulatur gitarowych z fretplay.com
71 - przesyłanie ścieżek odtworzonych na iPodzie do last.fm
72
73 %package -n bash-completion-%{name}
74 Summary:        Bash completion for exaile music player
75 Summary(pl.UTF-8):      Bashowe dopełnianie parametrów odtwarzacza muzyki exaile
76 Group:          Applications/Shells
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       bash-completion >= 2.0
79
80 %description -n bash-completion-%{name}
81 Bash completion for exaile.
82
83 %description -n bash-completion-%{name} -l pl.UTF-8
84 Bashowe dopełnianie parametrów odtwarzacza muzyki exaile.
85
86 %package -n fish-completion-%{name}
87 Summary:        Fish completion for exaile music player
88 Summary(pl.UTF-8):      Dopełnianie parametrów w fish dla odtwarzacza muzyki exaile
89 Group:          Applications/Shells
90 Requires:       %{name} = %{version}-%{release}
91 Requires:       fish
92
93 %description -n fish-completion-%{name}
94 Fish completion for exaile music player.
95
96 %description -n fish-completion-%{name} -l pl.UTF-8
97 Dopełnianie parametrów w fish dla odtwarzacza muzyki exaile.
98
99 %prep
100 %setup -q
101
102 # useless, there are bigger correspondent locales
103 %{__rm} po/frp.po
104
105 %build
106 %{__make} \
107         PREFIX=%{_prefix} \
108         LIBINSTALLDIR=/%{_datadir}
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         PREFIX=%{_prefix} \
115         DESTDIR=$RPM_BUILD_ROOT \
116         LIBINSTALLDIR=/%{_datadir}
117
118 # unsupported
119 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{ie,zh}
120
121 %find_lang %{name} --all-name
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files -f %{name}.lang
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_bindir}/%{name}
129 %dir %{_sysconfdir}/xdg/exaile
130 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/xdg/exaile/settings.ini
131 %dir %{_datadir}/%{name}
132 %{_datadir}/%{name}
133 %{_datadir}/appdata/exaile.appdata.xml
134 %{_datadir}/dbus-1/services/org.exaile.Exaile.service
135 %{_datadir}/%{name}/data
136 %{_desktopdir}/%{name}.desktop
137 %{_pixmapsdir}/%{name}.png
138 %{_mandir}/man1/exaile.1*
139 # maybe seperate subpackages for plugins?
140 %{_datadir}/%{name}/plugins
141
142 %files -n bash-completion-%{name}
143 %defattr(644,root,root,755)
144 %{bash_compdir}/%{name}
145
146 %files -n fish-completion-%{name}
147 %defattr(644,root,root,755)
148 %{fish_compdir}/%{name}.fish
This page took 0.372218 seconds and 3 git commands to generate.