]> git.pld-linux.org Git - packages/ewl.git/blob - ewl.spec
- rel 4
[packages/ewl.git] / ewl.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        Enlightenment Widget Library
6 Summary(pl.UTF-8):      Biblioteka widgetów Enlightenmenta (Enlightenment Widget Library)
7 Name:           ewl
8 Version:        0.5.1.008
9 Release:        4
10 License:        BSD
11 Group:          Libraries
12 Source0:        http://enlightenment.freedesktop.org/files/%{name}-%{version}.tar.gz
13 # Source0-md5:  d660de3d11b0b3219634c6736fe975fd
14 URL:            http://enlightenment.org/p.php?p=about/libs/ewl
15 BuildRequires:  autoconf
16 BuildRequires:  automake >= 1.4
17 # ecore-file ecore-txt
18 BuildRequires:  ecore-devel >= 0.9.9.038
19 BuildRequires:  edje >= 0.5.0.038
20 BuildRequires:  edje-devel >= 0.5.0.038
21 BuildRequires:  efreet-devel >= 0.0.3
22 BuildRequires:  emotion-devel >= 0.0.1
23 BuildRequires:  epsilon-devel >= 0.3.0.008
24 BuildRequires:  evas-devel >= 0.9.9.038
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig
27 BuildRequires:  xorg-lib-libX11-devel
28 Requires:       %{name}-libs = %{version}-%{release}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %undefine       __cxx
32
33 %description
34 EWL is a widget library which uses the E Foundation Libraries (EFL).
35
36 %description -l pl.UTF-8
37 EWL to biblioteka widgetów używająca EFL (E Foundation Libraries -
38 podstawowych bibliotek Englightenmenta).
39
40 %package libs
41 Summary:        EWL library
42 Summary(pl.UTF-8):      Biblioteka EWL
43 Group:          Libraries
44 Requires:       ecore-file >= 0.9.9.038
45 Requires:       ecore-txt >= 0.9.9.038
46 Requires:       edje-libs >= 0.5.0.038
47 Requires:       efreet >= 0.0.3
48 Requires:       emotion >= 0.0.1
49 Requires:       epsilon-libs >= 0.3.0.008
50 Requires:       evas >= 0.9.9.038
51
52 %description libs
53 EWL library.
54
55 %description libs -l pl.UTF-8
56 Biblioteka EWL.
57
58 %package devel
59 Summary:        EWL header files and test programs
60 Summary(pl.UTF-8):      Pliki nagłówkowe i programy testowe dla biblioteki EWL
61 Group:          Development/Libraries
62 Requires:       %{name}-libs = %{version}-%{release}
63 # ecore-file ecore-txt
64 Requires:       ecore-devel >= 0.9.9.038
65 Requires:       edje-devel >= 0.5.0.038
66 Requires:       efreet-devel >= 0.0.3
67 Requires:       emotion-devel >= 0.0.1
68 Requires:       epsilon-devel >= 0.3.0.008
69 Requires:       evas-devel >= 0.9.9.038
70
71 %description devel
72 EWL header files and test programs.
73
74 %description devel -l pl.UTF-8
75 Pliki nagłówkowe i programy testowe dla biblioteki EWL.
76
77 %package static
78 Summary:        Static EWL library
79 Summary(pl.UTF-8):      Statyczna biblioteka EWL
80 Group:          Development/Libraries
81 Requires:       %{name}-devel = %{version}-%{release}
82
83 %description static
84 Static EWL library.
85
86 %description static -l pl.UTF-8
87 Statyczna biblioteka EWL.
88
89 %prep
90 %setup -q
91
92 %build
93 %configure \
94         %{!?with_static_libs:--disable-static}
95 %{__make}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*/*.{la,a}
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   libs -p /sbin/ldconfig
109 %postun libs -p /sbin/ldconfig
110
111 %files
112 %defattr(644,root,root,755)
113 %doc AUTHORS COPYING NEWS README TODO
114 %attr(755,root,root) %{_bindir}/ewl_config
115 %attr(755,root,root) %{_bindir}/ewl_test
116 %attr(755,root,root) %{_bindir}/ewl_embed_test
117 %attr(755,root,root) %{_bindir}/ewl_simple_test
118 %dir %{_sysconfdir}/ewl
119 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/ewl/ewl.cfg
120 %dir %{_libdir}/%{name}/tests
121 %attr(755,root,root) %{_libdir}/%{name}/tests/ewl_*.so
122 %{_datadir}/%{name}
123
124 %files libs
125 %defattr(644,root,root,755)
126 %attr(755,root,root) %{_libdir}/libewl.so.*.*.*
127 %dir %{_libdir}/%{name}
128 %dir %{_libdir}/%{name}/engines
129 # missing -avoid-version
130 %attr(755,root,root) %{_libdir}/%{name}/engines/*.so*
131 %dir %{_libdir}/%{name}/plugins
132 %attr(755,root,root) %{_libdir}/%{name}/plugins/ewl_io_manager_*.so
133
134 %files devel
135 %defattr(644,root,root,755)
136 %attr(755,root,root) %{_bindir}/ewl-config
137 %attr(755,root,root) %{_libdir}/libewl.so
138 %{_libdir}/libewl.la
139 %dir %{_includedir}/ewl
140 %{_includedir}/ewl/Ewl.h
141 %{_includedir}/ewl/Ewl_Test.h
142 %{_includedir}/ewl/ewl_*.h
143 %{_pkgconfigdir}/ewl.pc
144 %{_aclocaldir}/ewl.m4
145
146 %if %{with static_libs}
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libewl.a
150 %endif
This page took 0.068943 seconds and 4 git commands to generate.