]> git.pld-linux.org Git - packages/evolution.git/blob - evolution.spec
- updated to 1.5.92.1
[packages/evolution.git] / evolution.spec
1 #
2 # todo:
3 # - splitting mail, addressbook and calendar:
4 #   - etspec?
5 #   - ui?
6 #   - dependencies, i.e.: mail should require addressbook?
7 #
8 # Conditionals:
9 %bcond_without  ldap            # build without ldap support
10 %bcond_without  kerberos5       # build without kerberos5 support
11
12 %define         mver            1.5
13 %define         subver  92.1
14
15 Summary:        The GNOME2 Email/Calendar/Addressbook Suite
16 Summary(pl):    Klient poczty dla GNOME2/Kalendarz/Ksi±¿ka Adresowa
17 Summary(pt_BR): Cliente de email integrado com calendário e catálogo de endereços
18 Summary(zh_CN): Evolution - GNOME2¸öÈ˺͹¤×÷×éÐÅÏ¢¹ÜÀí¹¤¾ß(°üÀ¨µç×ÓÓʼþ£¬ÈÕÀúºÍµØÖ·±¡)
19 Name:           evolution
20 Version:        %{mver}.%{subver}
21 Release:        1
22 License:        GPL
23 Group:          Applications/Mail
24 Source0:        http://ftp.gnome.org/pub/gnome/sources/evolution/%{mver}/%{name}-%{version}.tar.bz2
25 # Source0-md5:  4e83d43dbecc60d2ce88c961183b29e7
26 Source1:        %{name}-e-pilot-settings.c
27 Source2:        %{name}-e-pilot-settings.h
28 Patch0:         %{name}-locale-names.patch
29 Patch1:         %{name}-nolibs.patch
30 Patch2:         %{name}-gnome-icon-theme.patch
31 Patch3:         %{name}-GG-IM.patch
32 Patch4:         %{name}-desktop.patch
33 Patch5:         %{name}-libcom_err_include.patch
34 URL:            http://www.ximian.com/products/ximian_evolution/
35 BuildRequires:  GConf2-devel >= 2.6.2
36 BuildRequires:  ORBit2-devel >= 1:2.10.3
37 BuildRequires:  autoconf
38 BuildRequires:  automake
39 BuildRequires:  bison
40 BuildRequires:  evolution-data-server-devel >= 0.0.97
41 BuildRequires:  flex
42 BuildRequires:  freetype-devel >= 2.0.5
43 BuildRequires:  gal-devel >= 1:2.1.13
44 BuildRequires:  gettext-devel
45 BuildRequires:  gnome-common
46 BuildRequires:  gnome-pilot-devel >= 2.0.0
47 BuildRequires:  gnome-vfs2-devel >= 2.6.1.1
48 BuildRequires:  gtk-doc >= 1.1
49 BuildRequires:  gtkhtml-devel >= 3.1.19
50 %{?with_kerberos5:BuildRequires:        heimdal-devel}
51 BuildRequires:  intltool >= 0.30
52 BuildRequires:  libglade2-devel >= 1:2.4.0
53 BuildRequires:  libgnomeprintui-devel >= 2.6.1
54 BuildRequires:  libgnomeui-devel >= 2.6.1.1
55 BuildRequires:  libsoup-devel >= 2.1.12
56 BuildRequires:  libtool
57 BuildRequires:  libxml2
58 BuildRequires:  nspr-devel
59 BuildRequires:  nss-devel
60 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.0}
61 #BuildRequires: openssl-devel >= 0.9.7d
62 BuildRequires:  pilot-link-devel >= 0.11.4
63 BuildRequires:  pkgconfig
64 BuildRequires:  psmisc
65 BuildRequires:  python
66 BuildRequires:  scrollkeeper >= 0.1.4
67 BuildRequires:  which
68 Requires(post,postun):  /sbin/ldconfig
69 Requires(post,postun):  /usr/bin/scrollkeeper-update
70 Requires(post):         GConf2
71 Requires:       %{name}-component = %{version}-%{release}
72 Requires:       GConf2 >= 2.6.2
73 Requires:       bonobo-activation
74 Requires:       evolution-data-server >= 0.0.97
75 Requires:       gal >= 1:2.1.13
76 Requires:       gtkhtml >= 3.1.19
77 Requires:       libglade2 >= 1:2.4.0
78 Requires:       psmisc
79 Requires:       scrollkeeper >= 0.1.4
80 Obsoletes:      evolution2
81 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
82
83 %description
84 Evolution is the GNOME2 mailer, calendar, contact manager and
85 communications tool. The tools which make up Evolution will be tightly
86 integrated with one another and act as a seamless personal
87 information-management tool.
88
89 %description -l pl
90 Evolution to program pocztowy GNOME2, kalendarz, ksi±¿ka adresowa i
91 narzêdzie komunikacyjne.
92
93 %description -l pt_BR
94 Evolution é um cliente de email para o GNOME2 com calendário e outras
95 ferramentas interessantes.
96
97 %package devel
98 Summary:        Header files for evolution
99 Summary(pl):    Pliki nag³ówkowe i dokumentacja
100 Summary(pt_BR): Bibliotecas e arquivos de inclusão para desenvolvimento
101 Summary(zh_CN): Evolution×é¼þ¿ª·¢¿â
102 Group:          Development/Libraries
103 Requires:       %{name} = %{version}-%{release}
104 Requires:       cyrus-sasl-devel
105 Requires:       freetype-devel
106 Requires:       gal-devel >= 1:2.1.13
107 Requires:       gnome-vfs2-devel >= 2.6.1.1
108 Requires:       gtkhtml-devel >= 3.1.19
109 Requires:       libglade2-devel >= 1:2.4.0
110 Requires:       libgnomeprintui-devel >= 2.6.1
111 Requires:       libgnomeui-devel >= 2.6.1.1
112 Requires:       libsoup-devel >= 2.1.12
113 Requires:       nspr-devel
114 Requires:       nss-devel
115 %{?with_ldap:Requires:  openldap-devel >= 2.0.0}
116 #Requires:      openssl-devel >= 0.9.7c
117 Obsoletes:      evolution2-devel
118
119 %description devel
120 This package contains the files necessary to develop applications
121 using Evolution's libraries.
122
123 %description devel -l pl
124 Pakiet zawiera pliki potrzebne do rozwoju aplikacji u¿ywaj±cych
125 bibliotek programu Evolution.
126
127 %description devel -l pt_BR
128 Este pacote contém os arquivos necessários para desenvolvimento de
129 aplicações utilizando as bibliotecas do Evolution.
130
131 %package static
132 Summary:        Static libraries for evolution
133 Summary(pl):    Biblioteki statyczne dla evolution
134 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento
135 Group:          Development/Libraries
136 Requires:       %{name}-devel = %{version}-%{release}
137 Obsoletes:      evolution2-static
138
139 %description static
140 This package contains static libraries for Evolution.
141
142 %description static -l pl
143 Pakiet zawiera statyczne biblioteki Evolution.
144
145 %description static -l pt_BR
146 Este pacote contém as bibliotecas estáticas para desenvolvimento de
147 aplicações.
148
149 %package mail
150 Summary:        Evolution mail component
151 Summary(pl):    Modu³ pocztowy Evolution
152 Group:          X11/Applications
153 # mail composer requires addressbook component
154 Requires:       %{name}-addressbook = %{version}-%{release}
155 Requires(post,postun):  /sbin/ldconfig
156 Requires(post):         GConf2
157 Provides:       %{name}-component = %{version}-%{release}
158
159 %description mail
160 Evolution mail.
161
162 %description mail -l pl
163 Modu³ pocztowy Evolution.
164
165 %package addressbook
166 Summary:        Evolution addressbook component
167 Summary(pl):    Modu³ ksi±¿ki adresowej Evolution
168 Group:          X11/Applications
169 Requires:       %{name} = %{version}-%{release}
170 Requires(post): /sbin/ldconfig
171 Requires(post): GConf2
172 Provides:       %{name}-component = %{version}-%{release}
173
174 %description addressbook
175 Evolution addressbook.
176
177 %description addressbook -l pl
178 Ksi±¿ka adresowa Evolution.
179
180 %package calendar
181 Summary:        Evolution calendar and todo component
182 Summary(pl):    Modu³ kalendarza i listy zadañ Evolution
183 Group:          X11/Applications
184 Requires:       %{name} = %{version}-%{release}
185 Requires(post): /sbin/ldconfig
186 Requires(post): GConf2
187 Provides:       %{name}-component = %{version}-%{release}
188
189 %description calendar
190 Evolution calendar and todo component.
191
192 %description calendar -l pl
193 Kalendarz i lista zadañ Evolution.
194
195 %package pilot
196 Summary:        Evolution conduits for gnome-pilot
197 Summary(pl):    Dodatki do wymiany danych z gnome-pilot
198 Group:          X11/Applications
199 Requires:       %{name} = %{version}-%{release}
200 Obsoletes:      evolution2-pilot
201
202 %description pilot
203 This package contains conduits needed by gnome-pilot to synchronize
204 your Palm with Evolution.
205
206 %description pilot -l pl
207 Ten pakiet zawiera dodatki do synchronizacji danych Evolution z
208 Palmem.
209
210 %prep
211 %setup -q
212 %patch0 -p1
213 %patch1 -p1
214 %patch2 -p1
215 %patch3 -p1
216 %patch4 -p1
217 %{?with_kerberos5:%patch5 -p1}
218
219 mv po/{no,nb}.po
220
221 install %{SOURCE1} widgets/misc/e-pilot-settings.c
222 install %{SOURCE2} widgets/misc/e-pilot-settings.h
223
224 %build
225 glib-gettextize --copy --force
226 intltoolize --copy --force
227 %{__libtoolize}
228 %{__aclocal} -I %{_aclocaldir}/gnome2-macros
229 %{__autoheader}
230 %{__autoconf}
231 %{__automake}
232 %configure \
233         --enable-gtk-doc \
234         --enable-pilot-conduits=yes \
235         %{?with_ldap:--with-openldap=yes} \
236         %{!?with_ldap:--with-openldap=no} \
237         %{?with_kerberos5:--with-krb5=%{_prefix}} \
238         %{!?with_kerberos5:--with-krb5=no} \
239         --without-static-ldap \
240         --enable-nntp=yes \
241         --enable-file-locking=fcntl \
242         --enable-dot-locking=no \
243         --with-nspr-includes="%{_includedir}/nspr" \
244         --with-nss-includes="%{_includedir}/nss" \
245         --with-nspr-libs="%{_libdir}" \
246         --with-nss-libs="%{_libdir}" \
247         --enable-ipv6=yes \
248         --with-html-dir=%{_gtkdocdir} \
249         --with-kde-applnk-path=no \
250         --disable-schemas-install \
251         --enable-nss=yes \
252         --enable-smime=yes \
253         --enable-static
254
255 # hack to rebuild *.c and *.h from *.idl (check if needed with new versions)
256 # (required if you use ORBit2-devel 2.7.2)
257 find -name \*.idl -exec touch {} \;
258
259 %{__make} \
260         GTKHTML_DATADIR=%{_datadir}/idl
261
262 %install
263 rm -rf $RPM_BUILD_ROOT
264
265 %{__make} install \
266         DESTDIR=$RPM_BUILD_ROOT \
267         KDE_APPLNK_DIR=%{_applnkdir}/Network/Mail \
268         omf_dest_dir=%{_omf_dest_dir}/%{name} \
269         GTKHTML_DATADIR=%{_datadir}/idl \
270         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
271
272 # strip doesn't pass these files and they aren't necessary, so remove them
273 # probably this should be done differently, but I have no idea
274 rm -f $RPM_BUILD_ROOT%{_libdir}/evolution/%{mver}/*/*.a
275 rm -f $RPM_BUILD_ROOT%{_libdir}/evolution/%{mver}/libemiscwidgets.a
276 rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-pilot/*/*.{a,la}
277
278 %find_lang %{name} --all-name --with-gnome
279
280 %clean
281 rm -rf $RPM_BUILD_ROOT
282
283 %post
284 /sbin/ldconfig
285 /usr/bin/scrollkeeper-update
286 %gconf_schema_install
287
288 %postun
289 /sbin/ldconfig
290 /usr/bin/scrollkeeper-update
291
292 %post mail
293 /sbin/ldconfig
294 %gconf_schema_install
295
296 %postun mail
297 /sbin/ldconfig
298
299 %post addressbook
300 /sbin/ldconfig
301 %gconf_schema_install
302
303 %postun addressbook -p /sbin/ldconfig
304
305 %post calendar
306 /sbin/ldconfig
307 %gconf_schema_install
308
309 %postun calendar -p /sbin/ldconfig
310
311 %files -f evolution.lang
312 %defattr(644,root,root,755)
313 %doc AUTHORS ChangeLog NEWS* README
314 %attr(755,root,root) %{_bindir}/*
315 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeconduit.so.*
316 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libemiscwidgets.so.*
317 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeselectnames.so.*
318 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeshell.so.*
319 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeutil.so.*
320 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-a11y.so.*
321 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-importer.so.*
322 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-widgets-a11y.so.*
323 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-alarm-notify
324 %attr(755,root,root) %{_libdir}/evolution/%{mver}/killev
325 # addressbook requires it:
326 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libcamel*.so.*
327 %dir %{_libdir}/evolution
328 %dir %{_libdir}/evolution/%{mver}
329 %dir %{_libdir}/evolution/%{mver}/components
330 %{_libdir}/bonobo/servers/GNOME_Evolution_Shell_1.5.server
331 %dir %{_datadir}/idl/evolution-%{mver}
332 %dir %{_datadir}/evolution
333 %dir %{_datadir}/evolution/%{mver}
334 %dir %{_datadir}/evolution/%{mver}/views
335 %{_datadir}/evolution/%{mver}/*.xml
336 %dir %{_datadir}/evolution/%{mver}/default
337 %dir %{_datadir}/evolution/%{mver}/default/C
338 %{_datadir}/evolution/%{mver}/errors
339 %{_datadir}/evolution/%{mver}/etspec
340 %{_datadir}/evolution/%{mver}/glade
341 %{_datadir}/evolution/%{mver}/help
342 %{_datadir}/evolution/%{mver}/images
343 %{_datadir}/evolution/%{mver}/ui
344 %{_datadir}/mime-info/*
345 %{_datadir}/idl/evolution-%{mver}/Evolution-Component.idl
346 %{_datadir}/idl/evolution-%{mver}/Evolution-ConfigControl.idl
347 %{_datadir}/idl/evolution-%{mver}/Evolution-Offline.idl
348 %{_datadir}/idl/evolution-%{mver}/Evolution-Shell.idl
349 %{_datadir}/idl/evolution-%{mver}/Evolution-Wizard.idl
350 %{_datadir}/idl/evolution-%{mver}/Evolution-common.idl
351 %{_datadir}/idl/evolution-%{mver}/Evolution.idl
352 %{_datadir}/idl/evolution-%{mver}/GNOME_Evolution_Importer.idl
353 %{_desktopdir}/*
354 %{_pixmapsdir}/*
355 %{_sysconfdir}/gconf/schemas/apps_evolution_shell-1.5.schemas
356 %{_omf_dest_dir}/%{name}
357
358 %files devel
359 %defattr(644,root,root,755)
360 %attr(755,root,root) %{_libdir}/evolution/%{mver}/*.so
361 %{_libdir}/evolution/%{mver}/*.la
362 %{_libdir}/evolution/*/*/*.la
363 %{_includedir}/*
364 %{_pkgconfigdir}/*
365
366 %files static
367 %defattr(644,root,root,755)
368 %{_libdir}/evolution/%{mver}/*.a
369
370 %files mail
371 %defattr(644,root,root,755)
372 %dir %{_libdir}/evolution/%{mver}/camel*
373 %dir %{_libdir}/evolution/%{mver}/evolution-calendar-importers
374 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-mail-importers.so*
375 %attr(755,root,root) %{_libdir}/evolution/%{mver}/camel/*
376 %attr(755,root,root) %{_libdir}/evolution/%{mver}/components/libevolution-mail.so
377 %attr(755,root,root) %{_libdir}/evolution/%{mver}/camel-providers/*.so
378 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-calendar-importers/*.so
379 %{_libdir}/bonobo/servers/GNOME_Evolution_Mail_1.5.server
380 %{_libdir}/bonobo/servers/GNOME_Evolution_Mail_Importers_1.5.server
381 %{_libdir}/evolution/%{mver}/camel-providers/*.urls
382 %{_datadir}/evolution/%{mver}/views/mail*
383 %{_datadir}/evolution/%{mver}/default/C/mail
384 %{_datadir}/idl/evolution-%{mver}/Composer.idl
385 %{_datadir}/idl/evolution-%{mver}/Evolution-Composer.idl
386 %{_sysconfdir}/gconf/schemas/evolution-mail-1.5.schemas
387
388 %files addressbook
389 %defattr(644,root,root,755)
390 %dir %{_libdir}/evolution/%{mver}/evolution-addressbook-importers
391 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-addressbook-clean
392 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-addressbook-export
393 %attr(755,root,root) %{_libdir}/evolution/%{mver}/csv2vcard
394 %attr(755,root,root) %{_libdir}/evolution/%{mver}/components/libevolution-addressbook.so
395 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-addressbook-a11y.so.*
396 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-addressbook-importers/lib*.so
397 %{_libdir}/bonobo/servers/GNOME_Evolution_Addressbook*
398 %{_datadir}/evolution/%{mver}/views/addressbook*
399 %{_datadir}/evolution/%{mver}/ecps
400 %{_datadir}/idl/evolution-%{mver}/Evolution-Addressbook-SelectNames.idl
401 %{_sysconfdir}/gconf/schemas/apps_evolution_addressbook-1.5.schemas
402
403 %files calendar
404 %defattr(644,root,root,755)
405 %attr(755,root,root) %{_libdir}/evolution/%{mver}/components/libevolution-calendar.so
406 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-calendar-a11y.so.*
407 %{_libdir}/bonobo/servers/GNOME_Evolution_Calendar*
408 %{_datadir}/evolution/%{mver}/views/calendar*
409 %{_datadir}/evolution/%{mver}/views/tasks*
410 %{_datadir}/idl/evolution-%{mver}/evolution-calendar.idl
411 %{_sysconfdir}/gconf/schemas/apps_evolution_calendar-1.5.schemas
412
413 %files pilot
414 %defattr(644,root,root,755)
415 %attr(755,root,root) %{_libdir}/evolution/%{mver}/conduits/*
416 %{_datadir}/gnome-pilot/conduits/*
This page took 0.089985 seconds and 4 git commands to generate.