]> git.pld-linux.org Git - packages/evolution.git/blob - evolution.spec
- cosmetics
[packages/evolution.git] / evolution.spec
1 #
2 # todo:
3 # - splitting mail, addressbook and calendar:
4 #   - etspec?
5 #   - ui?
6 #   - dependencies, i.e.: mail should require addressbook?
7 #
8 # Conditionals:
9 %bcond_without  ldap            # build without ldap support
10 %bcond_without  kerberos5       # build without kerberos5 support
11
12 %define         mver            1.5
13 %define         subver  93
14
15 Summary:        The GNOME2 Email/Calendar/Addressbook Suite
16 Summary(pl):    Klient poczty dla GNOME2/Kalendarz/Ksi±¿ka Adresowa
17 Summary(pt_BR): Cliente de email integrado com calendário e catálogo de endereços
18 Summary(zh_CN): Evolution - GNOME2¸öÈ˺͹¤×÷×éÐÅÏ¢¹ÜÀí¹¤¾ß(°üÀ¨µç×ÓÓʼþ£¬ÈÕÀúºÍµØÖ·±¡)
19 Name:           evolution
20 Version:        %{mver}.%{subver}
21 Release:        1
22 License:        GPL
23 Group:          Applications/Mail
24 Source0:        http://ftp.gnome.org/pub/gnome/sources/evolution/%{mver}/%{name}-%{version}.tar.bz2
25 # Source0-md5:  a01dc293bca189461f6cbd61b0a5a0ee
26 Patch0:         %{name}-locale-names.patch
27 Patch1:         %{name}-nolibs.patch
28 Patch2:         %{name}-gnome-icon-theme.patch
29 Patch3:         %{name}-GG-IM.patch
30 Patch4:         %{name}-desktop.patch
31 URL:            http://www.ximian.com/products/ximian_evolution/
32 BuildRequires:  GConf2-devel >= 2.6.2
33 BuildRequires:  ORBit2-devel >= 1:2.10.3
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 BuildRequires:  bison
37 BuildRequires:  evolution-data-server-devel >= 0.0.98
38 BuildRequires:  flex
39 BuildRequires:  freetype-devel >= 2.0.5
40 BuildRequires:  gal-devel >= 1:2.1.14
41 BuildRequires:  gettext-devel
42 BuildRequires:  gnome-common
43 BuildRequires:  gnome-pilot-devel >= 2.0.0
44 BuildRequires:  gnome-vfs2-devel >= 2.6.1.1
45 BuildRequires:  gtk-doc >= 1.1
46 BuildRequires:  gtkhtml-devel >= 3.1.20
47 %{?with_kerberos5:BuildRequires:        heimdal-devel}
48 BuildRequires:  intltool >= 0.30
49 BuildRequires:  libglade2-devel >= 1:2.4.0
50 BuildRequires:  libgnomeprintui-devel >= 2.6.1
51 BuildRequires:  libgnomeui-devel >= 2.6.1.1
52 BuildRequires:  libsoup-devel >= 2.1.13
53 BuildRequires:  libtool
54 BuildRequires:  libxml2
55 BuildRequires:  nspr-devel
56 BuildRequires:  nss-devel
57 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.0}
58 #BuildRequires: openssl-devel >= 0.9.7d
59 BuildRequires:  pilot-link-devel >= 0.11.4
60 BuildRequires:  pkgconfig
61 BuildRequires:  psmisc
62 BuildRequires:  python
63 BuildRequires:  scrollkeeper >= 0.1.4
64 BuildRequires:  which
65 Requires(post,postun):  /sbin/ldconfig
66 Requires(post,postun):  /usr/bin/scrollkeeper-update
67 Requires(post):         GConf2
68 Requires:       %{name}-component = %{version}-%{release}
69 Requires:       GConf2 >= 2.6.2
70 Requires:       bonobo-activation
71 Requires:       evolution-data-server >= 0.0.98
72 Requires:       gal >= 1:2.1.14
73 Requires:       gtkhtml >= 3.1.20
74 Requires:       libglade2 >= 1:2.4.0
75 Requires:       psmisc
76 Requires:       scrollkeeper >= 0.1.4
77 Obsoletes:      evolution2
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 Evolution is the GNOME2 mailer, calendar, contact manager and
82 communications tool. The tools which make up Evolution will be tightly
83 integrated with one another and act as a seamless personal
84 information-management tool.
85
86 %description -l pl
87 Evolution to program pocztowy GNOME2, kalendarz, ksi±¿ka adresowa i
88 narzêdzie komunikacyjne.
89
90 %description -l pt_BR
91 Evolution é um cliente de email para o GNOME2 com calendário e outras
92 ferramentas interessantes.
93
94 %package devel
95 Summary:        Header files for evolution
96 Summary(pl):    Pliki nag³ówkowe i dokumentacja
97 Summary(pt_BR): Bibliotecas e arquivos de inclusão para desenvolvimento
98 Summary(zh_CN): Evolution×é¼þ¿ª·¢¿â
99 Group:          Development/Libraries
100 Requires:       %{name} = %{version}-%{release}
101 Requires:       cyrus-sasl-devel
102 Requires:       freetype-devel
103 Requires:       gal-devel >= 1:2.1.14
104 Requires:       gnome-vfs2-devel >= 2.6.1.1
105 Requires:       gtkhtml-devel >= 3.1.20
106 Requires:       libglade2-devel >= 1:2.4.0
107 Requires:       libgnomeprintui-devel >= 2.6.1
108 Requires:       libgnomeui-devel >= 2.6.1.1
109 Requires:       libsoup-devel >= 2.1.13
110 Requires:       nspr-devel
111 Requires:       nss-devel
112 %{?with_ldap:Requires:  openldap-devel >= 2.0.0}
113 #Requires:      openssl-devel >= 0.9.7c
114 Obsoletes:      evolution2-devel
115
116 %description devel
117 This package contains the files necessary to develop applications
118 using Evolution's libraries.
119
120 %description devel -l pl
121 Pakiet zawiera pliki potrzebne do rozwoju aplikacji u¿ywaj±cych
122 bibliotek programu Evolution.
123
124 %description devel -l pt_BR
125 Este pacote contém os arquivos necessários para desenvolvimento de
126 aplicações utilizando as bibliotecas do Evolution.
127
128 %package static
129 Summary:        Static libraries for evolution
130 Summary(pl):    Biblioteki statyczne dla evolution
131 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento
132 Group:          Development/Libraries
133 Requires:       %{name}-devel = %{version}-%{release}
134 Obsoletes:      evolution2-static
135
136 %description static
137 This package contains static libraries for Evolution.
138
139 %description static -l pl
140 Pakiet zawiera statyczne biblioteki Evolution.
141
142 %description static -l pt_BR
143 Este pacote contém as bibliotecas estáticas para desenvolvimento de
144 aplicações.
145
146 %package mail
147 Summary:        Evolution mail component
148 Summary(pl):    Modu³ pocztowy Evolution
149 Group:          X11/Applications
150 # mail composer requires addressbook component
151 Requires:       %{name}-addressbook = %{version}-%{release}
152 Requires(post,postun):  /sbin/ldconfig
153 Requires(post):         GConf2
154 Provides:       %{name}-component = %{version}-%{release}
155
156 %description mail
157 Evolution mail.
158
159 %description mail -l pl
160 Modu³ pocztowy Evolution.
161
162 %package addressbook
163 Summary:        Evolution addressbook component
164 Summary(pl):    Modu³ ksi±¿ki adresowej Evolution
165 Group:          X11/Applications
166 Requires:       %{name} = %{version}-%{release}
167 Requires(post): /sbin/ldconfig
168 Requires(post): GConf2
169 Provides:       %{name}-component = %{version}-%{release}
170
171 %description addressbook
172 Evolution addressbook.
173
174 %description addressbook -l pl
175 Ksi±¿ka adresowa Evolution.
176
177 %package calendar
178 Summary:        Evolution calendar and todo component
179 Summary(pl):    Modu³ kalendarza i listy zadañ Evolution
180 Group:          X11/Applications
181 Requires:       %{name} = %{version}-%{release}
182 Requires(post): /sbin/ldconfig
183 Requires(post): GConf2
184 Provides:       %{name}-component = %{version}-%{release}
185
186 %description calendar
187 Evolution calendar and todo component.
188
189 %description calendar -l pl
190 Kalendarz i lista zadañ Evolution.
191
192 %package pilot
193 Summary:        Evolution conduits for gnome-pilot
194 Summary(pl):    Dodatki do wymiany danych z gnome-pilot
195 Group:          X11/Applications
196 Requires:       %{name} = %{version}-%{release}
197 Obsoletes:      evolution2-pilot
198
199 %description pilot
200 This package contains conduits needed by gnome-pilot to synchronize
201 your Palm with Evolution.
202
203 %description pilot -l pl
204 Ten pakiet zawiera dodatki do synchronizacji danych Evolution z
205 Palmem.
206
207 %prep
208 %setup -q
209 %patch0 -p1
210 %patch1 -p1
211 %patch2 -p1
212 %patch3 -p1
213 %patch4 -p1
214
215 mv po/{no,nb}.po
216
217 %build
218 glib-gettextize --copy --force
219 intltoolize --copy --force
220 %{__libtoolize}
221 %{__aclocal} -I %{_aclocaldir}/gnome2-macros
222 %{__autoheader}
223 %{__autoconf}
224 %{__automake}
225 %configure \
226         --enable-gtk-doc \
227         --enable-pilot-conduits=yes \
228         %{?with_ldap:--with-openldap=yes} \
229         %{!?with_ldap:--with-openldap=no} \
230         %{?with_kerberos5:--with-krb5=%{_prefix}} \
231         %{!?with_kerberos5:--with-krb5=no} \
232         --without-static-ldap \
233         --enable-nntp=yes \
234         --enable-file-locking=fcntl \
235         --enable-dot-locking=no \
236         --with-nspr-includes="%{_includedir}/nspr" \
237         --with-nss-includes="%{_includedir}/nss" \
238         --with-nspr-libs="%{_libdir}" \
239         --with-nss-libs="%{_libdir}" \
240         --enable-ipv6=yes \
241         --with-html-dir=%{_gtkdocdir} \
242         --with-kde-applnk-path=no \
243         --disable-schemas-install \
244         --enable-nss=yes \
245         --enable-smime=yes \
246         --enable-static \
247         --enable-file-chooser
248
249 # hack to rebuild *.c and *.h from *.idl (check if needed with new versions)
250 # (required if you use ORBit2-devel 2.7.2)
251 find -name \*.idl -exec touch {} \;
252
253 %{__make} \
254         GTKHTML_DATADIR=%{_datadir}/idl
255
256 %install
257 rm -rf $RPM_BUILD_ROOT
258
259 %{__make} install \
260         DESTDIR=$RPM_BUILD_ROOT \
261         KDE_APPLNK_DIR=%{_applnkdir}/Network/Mail \
262         omf_dest_dir=%{_omf_dest_dir}/%{name} \
263         GTKHTML_DATADIR=%{_datadir}/idl \
264         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
265
266 # strip doesn't pass these files and they aren't necessary, so remove them
267 # probably this should be done differently, but I have no idea
268 rm -f $RPM_BUILD_ROOT%{_libdir}/evolution/%{mver}/*/*.a
269 rm -f $RPM_BUILD_ROOT%{_libdir}/evolution/%{mver}/libemiscwidgets.a
270 rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-pilot/*/*.{a,la}
271
272 %find_lang %{name} --all-name --with-gnome
273
274 %clean
275 rm -rf $RPM_BUILD_ROOT
276
277 %post
278 /sbin/ldconfig
279 /usr/bin/scrollkeeper-update
280 %gconf_schema_install
281
282 %postun
283 /sbin/ldconfig
284 /usr/bin/scrollkeeper-update
285
286 %post mail
287 /sbin/ldconfig
288 %gconf_schema_install
289
290 %postun mail
291 /sbin/ldconfig
292
293 %post addressbook
294 /sbin/ldconfig
295 %gconf_schema_install
296
297 %postun addressbook -p /sbin/ldconfig
298
299 %post calendar
300 /sbin/ldconfig
301 %gconf_schema_install
302
303 %postun calendar -p /sbin/ldconfig
304
305 %files -f evolution.lang
306 %defattr(644,root,root,755)
307 %doc AUTHORS ChangeLog NEWS* README
308 %attr(755,root,root) %{_bindir}/*
309 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeconduit.so.*
310 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libemiscwidgets.so.*
311 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeselectnames.so.*
312 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeshell.so.*
313 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeutil.so.*
314 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-a11y.so.*
315 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-importer.so.*
316 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-widgets-a11y.so.*
317 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-alarm-notify
318 %attr(755,root,root) %{_libdir}/evolution/%{mver}/killev
319 # addressbook requires it:
320 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libcamel*.so.*
321 %dir %{_libdir}/evolution
322 %dir %{_libdir}/evolution/%{mver}
323 %dir %{_libdir}/evolution/%{mver}/components
324 %{_libdir}/bonobo/servers/GNOME_Evolution_Shell_1.5.server
325 %dir %{_datadir}/idl/evolution-%{mver}
326 %dir %{_datadir}/evolution
327 %dir %{_datadir}/evolution/%{mver}
328 %dir %{_datadir}/evolution/%{mver}/views
329 %{_datadir}/evolution/%{mver}/*.xml
330 %dir %{_datadir}/evolution/%{mver}/default
331 %dir %{_datadir}/evolution/%{mver}/default/C
332 %{_datadir}/evolution/%{mver}/errors
333 %{_datadir}/evolution/%{mver}/etspec
334 %{_datadir}/evolution/%{mver}/glade
335 %{_datadir}/evolution/%{mver}/help
336 %{_datadir}/evolution/%{mver}/images
337 %{_datadir}/evolution/%{mver}/ui
338 %{_datadir}/mime-info/*
339 %{_datadir}/idl/evolution-%{mver}/Evolution-Component.idl
340 %{_datadir}/idl/evolution-%{mver}/Evolution-ConfigControl.idl
341 %{_datadir}/idl/evolution-%{mver}/Evolution-Offline.idl
342 %{_datadir}/idl/evolution-%{mver}/Evolution-Shell.idl
343 %{_datadir}/idl/evolution-%{mver}/Evolution-Wizard.idl
344 %{_datadir}/idl/evolution-%{mver}/Evolution-common.idl
345 %{_datadir}/idl/evolution-%{mver}/Evolution.idl
346 %{_datadir}/idl/evolution-%{mver}/GNOME_Evolution_Importer.idl
347 %{_desktopdir}/*
348 %{_pixmapsdir}/*
349 %{_sysconfdir}/gconf/schemas/apps_evolution_shell-1.5.schemas
350 %{_omf_dest_dir}/%{name}
351
352 %files devel
353 %defattr(644,root,root,755)
354 %attr(755,root,root) %{_libdir}/evolution/%{mver}/*.so
355 %{_libdir}/evolution/%{mver}/*.la
356 %{_libdir}/evolution/*/*/*.la
357 %{_includedir}/*
358 %{_pkgconfigdir}/*
359
360 %files static
361 %defattr(644,root,root,755)
362 %{_libdir}/evolution/%{mver}/*.a
363
364 %files mail
365 %defattr(644,root,root,755)
366 %dir %{_libdir}/evolution/%{mver}/camel*
367 %dir %{_libdir}/evolution/%{mver}/evolution-calendar-importers
368 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-mail-importers.so*
369 %attr(755,root,root) %{_libdir}/evolution/%{mver}/camel/*
370 %attr(755,root,root) %{_libdir}/evolution/%{mver}/components/libevolution-mail.so
371 %attr(755,root,root) %{_libdir}/evolution/%{mver}/camel-providers/*.so
372 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-calendar-importers/*.so
373 %{_libdir}/bonobo/servers/GNOME_Evolution_Mail_1.5.server
374 %{_libdir}/bonobo/servers/GNOME_Evolution_Mail_Importers_1.5.server
375 %{_libdir}/evolution/%{mver}/camel-providers/*.urls
376 %{_datadir}/evolution/%{mver}/views/mail*
377 %{_datadir}/evolution/%{mver}/default/C/mail
378 %{_datadir}/idl/evolution-%{mver}/Composer.idl
379 %{_datadir}/idl/evolution-%{mver}/Evolution-Composer.idl
380 %{_sysconfdir}/gconf/schemas/evolution-mail-1.5.schemas
381
382 %files addressbook
383 %defattr(644,root,root,755)
384 %dir %{_libdir}/evolution/%{mver}/evolution-addressbook-importers
385 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-addressbook-clean
386 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-addressbook-export
387 %attr(755,root,root) %{_libdir}/evolution/%{mver}/csv2vcard
388 %attr(755,root,root) %{_libdir}/evolution/%{mver}/components/libevolution-addressbook.so
389 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-addressbook-a11y.so.*
390 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-addressbook-importers/lib*.so
391 %{_libdir}/bonobo/servers/GNOME_Evolution_Addressbook*
392 %{_datadir}/evolution/%{mver}/views/addressbook*
393 %{_datadir}/evolution/%{mver}/ecps
394 %{_datadir}/idl/evolution-%{mver}/Evolution-Addressbook-SelectNames.idl
395 %{_sysconfdir}/gconf/schemas/apps_evolution_addressbook-1.5.schemas
396
397 %files calendar
398 %defattr(644,root,root,755)
399 %attr(755,root,root) %{_libdir}/evolution/%{mver}/components/libevolution-calendar.so
400 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-calendar-a11y.so.*
401 %{_libdir}/bonobo/servers/GNOME_Evolution_Calendar*
402 %{_datadir}/evolution/%{mver}/views/calendar*
403 %{_datadir}/evolution/%{mver}/views/tasks*
404 %{_datadir}/idl/evolution-%{mver}/evolution-calendar.idl
405 %{_sysconfdir}/gconf/schemas/apps_evolution_calendar-1.5.schemas
406
407 %files pilot
408 %defattr(644,root,root,755)
409 %attr(755,root,root) %{_libdir}/evolution/%{mver}/conduits/*
410 %{_datadir}/gnome-pilot/conduits/*
This page took 0.063544 seconds and 4 git commands to generate.