]> git.pld-linux.org Git - packages/evolution.git/blob - evolution.spec
- up to version 1.5.8, removed obsoleted gcc34 patch
[packages/evolution.git] / evolution.spec
1 #
2 # todo:
3 # - splitting mail, addressbook and calendar:
4 #   - etspec?
5 #   - ui?
6 #   - dependencies, i.e.: mail should require addressbook?
7 #
8 # Conditionals:
9 %bcond_without ldap     # build without ldap support
10
11 %define         mver            1.5
12 %define         subver  8
13
14 Summary:        The GNOME2 Email/Calendar/Addressbook Suite
15 Summary(pl):    Klient poczty dla GNOME2/Kalendarz/Ksi±¿ka Adresowa
16 Summary(pt_BR): Cliente de email integrado com calendário e catálogo de endereços
17 Summary(zh_CN): Evolution - GNOME2¸öÈ˺͹¤×÷×éÐÅÏ¢¹ÜÀí¹¤¾ß(°üÀ¨µç×ÓÓʼþ£¬ÈÕÀúºÍµØÖ·±¡)
18 Name:           evolution
19 Version:        %{mver}.%{subver}
20 Release:        1
21 License:        GPL
22 Group:          Applications/Mail
23 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/%{mver}/%{name}-%{version}.tar.bz2
24 # Source0-md5:  a09ca19c5d2bbe332c2bd493b1e9328b
25 Patch0:         %{name}-locale-names.patch
26 Patch1:         %{name}-nolibs.patch
27 Patch2:         %{name}-schemas.patch
28 URL:            http://www.ximian.com/products/ximian_evolution/
29 BuildRequires:  GConf2-devel >= 2.6.1
30 BuildRequires:  ORBit2-devel >= 1:2.10.2
31 BuildRequires:  autoconf
32 BuildRequires:  automake
33 BuildRequires:  bison
34 BuildRequires:  evolution-data-server-devel >= 0.0.93
35 BuildRequires:  flex
36 BuildRequires:  freetype-devel >= 2.0.5
37 BuildRequires:  gal-devel >= 1:2.1.9
38 BuildRequires:  gettext-devel
39 BuildRequires:  gnome-common
40 BuildRequires:  gnome-pilot-devel >= 2.0.0
41 BuildRequires:  gnome-vfs2-devel >= 2.6.1.1
42 BuildRequires:  gtk-doc >= 1.1
43 BuildRequires:  gtkhtml-devel >= 3.1.14
44 BuildRequires:  intltool >= 0.30
45 BuildRequires:  libglade2-devel >= 1:2.4.0
46 BuildRequires:  libgnomeprintui-devel >= 2.6.1
47 BuildRequires:  libgnomeui-devel >= 2.6.1.1
48 BuildRequires:  libsoup-devel >= 2.1.10
49 BuildRequires:  libtool
50 BuildRequires:  libxml2
51 BuildRequires:  nspr-devel
52 BuildRequires:  nss-devel
53 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.0}
54 #BuildRequires: openssl-devel >= 0.9.7d
55 BuildRequires:  pilot-link-devel >= 0.11.4
56 BuildRequires:  pkgconfig
57 BuildRequires:  psmisc
58 BuildRequires:  python
59 BuildRequires:  scrollkeeper >= 0.1.4
60 BuildRequires:  which
61 Requires(post,postun):  /sbin/ldconfig
62 Requires(post,postun):  /usr/bin/scrollkeeper-update
63 Requires(post):         GConf2
64 Requires:       %{name}-component = %{version}-%{release}
65 Requires:       GConf2 >= 2.6.1
66 Requires:       bonobo-activation
67 Requires:       evolution-data-server >= 0.0.93
68 Requires:       gal >= 1:2.1.9
69 Requires:       gtkhtml >= 3.1.14
70 Requires:       libglade2 >= 1:2.4.0
71 Requires:       psmisc
72 Requires:       scrollkeeper >= 0.1.4
73 Obsoletes:      evolution2
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %description
77 Evolution is the GNOME2 mailer, calendar, contact manager and
78 communications tool. The tools which make up Evolution will be tightly
79 integrated with one another and act as a seamless personal
80 information-management tool.
81
82 %description -l pl
83 Evolution to program pocztowy GNOME2, kalendarz, ksi±¿ka adresowa i
84 narzêdzie komunikacyjne.
85
86 %description -l pt_BR
87 Evolution é um cliente de email para o GNOME2 com calendário e outras
88 ferramentas interessantes.
89
90 %package devel
91 Summary:        Header files for evolution
92 Summary(pl):    Pliki nag³ówkowe i dokumentacja
93 Summary(pt_BR): Bibliotecas e arquivos de inclusão para desenvolvimento
94 Summary(zh_CN): Evolution×é¼þ¿ª·¢¿â
95 Group:          Development/Libraries
96 Requires:       %{name} = %{version}-%{release}
97 Requires:       cyrus-sasl-devel
98 Requires:       freetype-devel
99 Requires:       gal-devel >= 1:2.1.9
100 Requires:       gnome-vfs2-devel >= 2.6.1.1
101 Requires:       gtkhtml-devel >= 3.1.14
102 Requires:       libglade2-devel >= 1:2.4.0
103 Requires:       libgnomeprintui-devel >= 2.6.1
104 Requires:       libgnomeui-devel >= 2.6.1.1
105 Requires:       libsoup-devel >= 2.1.10
106 Requires:       nspr-devel
107 Requires:       nss-devel
108 %{?with_ldap:Requires:  openldap-devel >= 2.0.0}
109 #Requires:      openssl-devel >= 0.9.7c
110 Obsoletes:      evolution2-devel
111
112 %description devel
113 This package contains the files necessary to develop applications
114 using Evolution's libraries.
115
116 %description devel -l pl
117 Pakiet zawiera pliki potrzebne do rozwoju aplikacji u¿ywaj±cych
118 bibliotek programu Evolution.
119
120 %description devel -l pt_BR
121 Este pacote contém os arquivos necessários para desenvolvimento de
122 aplicações utilizando as bibliotecas do Evolution.
123
124 %package static
125 Summary:        Static libraries for evolution
126 Summary(pl):    Biblioteki statyczne dla evolution
127 Summary(pt_BR): Bibliotecas estáticas para desenvolvimento
128 Group:          Development/Libraries
129 Requires:       %{name}-devel = %{version}-%{release}
130 Obsoletes:      evolution2-static
131
132 %description static
133 This package contains static libraries for Evolution.
134
135 %description static -l pl
136 Pakiet zawiera statyczne biblioteki Evolution.
137
138 %description static -l pt_BR
139 Este pacote contém as bibliotecas estáticas para desenvolvimento de
140 aplicações.
141
142 %package mail
143 Summary:        Evolution mail component
144 Summary(pl):    Modu³ pocztowy Evolution
145 Group:          X11/Applications
146 # mail composer requires addressbook component
147 Requires:       %{name}-addressbook = %{version}-%{release}
148 Requires(post,postun):  /sbin/ldconfig
149 Requires(post):         GConf2
150 Provides:       %{name}-component = %{version}-%{release}
151
152 %description mail
153 Evolution mail.
154
155 %description mail -l pl
156 Modu³ pocztowy Evolution.
157
158 %package addressbook
159 Summary:        Evolution addressbook component
160 Summary(pl):    Modu³ ksi±¿ki adresowej Evolution
161 Group:          X11/Applications
162 Requires:       %{name} = %{version}-%{release}
163 Requires(post): /sbin/ldconfig
164 Requires(post):         GConf2
165 Provides:       %{name}-component = %{version}-%{release}
166
167 %description addressbook
168 Evolution addressbook.
169
170 %description addressbook -l pl
171 Ksi±¿ka adresowa Evolution.
172
173 %package calendar
174 Summary:        Evolution calendar and todo component
175 Summary(pl):    Modu³ kalendarza i listy zadañ Evolution
176 Group:          X11/Applications
177 Requires:       %{name} = %{version}-%{release}
178 Requires(post): /sbin/ldconfig
179 Requires(post):         GConf2
180 Provides:       %{name}-component = %{version}-%{release}
181
182 %description calendar
183 Evolution calendar and todo component.
184
185 %description calendar -l pl
186 Kalendarz i lista zadañ Evolution.
187
188 %package pilot
189 Summary:        Evolution conduits for gnome-pilot
190 Summary(pl):    Dodatki do wymiany danych z gnome-pilot
191 Group:          X11/Applications
192 Requires:       %{name} = %{version}-%{release}
193 Obsoletes:      evolution2-pilot
194
195 %description pilot
196 This package contains conduits needed by gnome-pilot to synchronize
197 your Palm with Evolution.
198
199 %description pilot -l pl
200 Ten pakiet zawiera dodatki do synchronizacji danych Evolution z
201 Palmem.
202
203 %prep
204 %setup -q
205 %patch0 -p1
206 %patch1 -p1
207 %patch2 -p1
208
209 mv po/{no,nb}.po
210
211 %build
212 glib-gettextize --copy --force
213 intltoolize --copy --force
214 %{__libtoolize}
215 %{__aclocal} -I %{_aclocaldir}/gnome2-macros
216 %{__autoheader}
217 %{__autoconf}
218 %{__automake}
219 %configure \
220         --enable-gtk-doc \
221         --enable-pilot-conduits=yes \
222         %{?with_ldap:--with-openldap=yes} \
223         %{!?with_ldap:--with-openldap=no} \
224         --without-static-ldap \
225         --enable-nntp=yes \
226         --enable-file-locking=fcntl \
227         --enable-dot-locking=no \
228         --with-nspr-includes="%{_includedir}/nspr" \
229         --with-nss-includes="%{_includedir}/nss" \
230         --with-nspr-libs="%{_libdir}" \
231         --with-nss-libs="%{_libdir}" \
232         --enable-ipv6=yes \
233         --with-html-dir=%{_gtkdocdir} \
234         --with-kde-applnk-path=no \
235         --disable-schemas-install \
236         --enable-nss=yes \
237         --enable-smime=yes \
238         --enable-static
239
240 # hack to rebuild *.c and *.h from *.idl (check if needed with new versions)
241 # (required if you use ORBit2-devel 2.7.2)
242 find -name \*.idl -exec touch {} \;
243
244 %{__make} \
245         GTKHTML_DATADIR=%{_datadir}/idl
246
247 %install
248 rm -rf $RPM_BUILD_ROOT
249
250 %{__make} install \
251         DESTDIR=$RPM_BUILD_ROOT \
252         KDE_APPLNK_DIR=%{_applnkdir}/Network/Mail \
253         omf_dest_dir=%{_omf_dest_dir}/%{name} \
254         GTKHTML_DATADIR=%{_datadir}/idl \
255         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
256
257 # strip doesn't pass these files and they aren't necessary, so remove them
258 # probably this should be done differently, but I have no idea
259 rm -f $RPM_BUILD_ROOT%{_libdir}/evolution/%{mver}/*/*.a
260 rm -f $RPM_BUILD_ROOT%{_libdir}/evolution/%{mver}/libemiscwidgets.a
261 rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-pilot/*/*.{a,la}
262
263 %find_lang %{name} --all-name --with-gnome
264
265 %clean
266 rm -rf $RPM_BUILD_ROOT
267
268 %post
269 /sbin/ldconfig
270 /usr/bin/scrollkeeper-update
271 %gconf_schema_install
272
273 %postun
274 /sbin/ldconfig
275 /usr/bin/scrollkeeper-update
276
277 %post mail
278 /sbin/ldconfig
279 %gconf_schema_install
280
281 %postun mail
282 /sbin/ldconfig
283
284 %post addressbook
285 /sbin/ldconfig
286 %gconf_schema_install
287
288 %postun addressbook -p /sbin/ldconfig
289
290 %post calendar
291 /sbin/ldconfig
292 %gconf_schema_install
293
294 %postun calendar -p /sbin/ldconfig
295
296 %files -f evolution.lang
297 %defattr(644,root,root,755)
298 %doc AUTHORS ChangeLog NEWS* README
299 %attr(755,root,root) %{_bindir}/*
300 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeconduit.so.*
301 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libemiscwidgets.so.*
302 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeselectnames.so.*
303 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeshell.so.*
304 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libeutil.so.*
305 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-a11y.so.*
306 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-importer.so.*
307 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-widgets-a11y.so.*
308 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-alarm-notify
309 %attr(755,root,root) %{_libdir}/evolution/%{mver}/killev
310 # addressbook requires it:
311 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libcamel*.so.*
312 %dir %{_libdir}/evolution
313 %dir %{_libdir}/evolution/%{mver}
314 %dir %{_libdir}/evolution/%{mver}/components
315 %{_libdir}/bonobo/servers/GNOME_Evolution_Shell_1.5.server
316 %dir %{_datadir}/idl/evolution-%{mver}
317 %dir %{_datadir}/evolution
318 %dir %{_datadir}/evolution/%{mver}
319 %dir %{_datadir}/evolution/%{mver}/views
320 %{_datadir}/evolution/%{mver}/*.xml
321 %dir %{_datadir}/evolution/%{mver}/default
322 %dir %{_datadir}/evolution/%{mver}/default/C
323 %{_datadir}/evolution/%{mver}/errors
324 %{_datadir}/evolution/%{mver}/etspec
325 %{_datadir}/evolution/%{mver}/glade
326 %{_datadir}/evolution/%{mver}/help
327 %{_datadir}/evolution/%{mver}/images
328 %{_datadir}/evolution/%{mver}/ui
329 %{_datadir}/mime-info/*
330 %{_datadir}/idl/evolution-%{mver}/Evolution-Component.idl
331 %{_datadir}/idl/evolution-%{mver}/Evolution-ConfigControl.idl
332 %{_datadir}/idl/evolution-%{mver}/Evolution-Offline.idl
333 %{_datadir}/idl/evolution-%{mver}/Evolution-Shell.idl
334 %{_datadir}/idl/evolution-%{mver}/Evolution-Wizard.idl
335 %{_datadir}/idl/evolution-%{mver}/Evolution-common.idl
336 %{_datadir}/idl/evolution-%{mver}/Evolution.idl
337 %{_datadir}/idl/evolution-%{mver}/GNOME_Evolution_Importer.idl
338 %{_desktopdir}/*
339 %{_pixmapsdir}/*
340 %{_sysconfdir}/gconf/schemas/apps_evolution_shell-1.5.schemas
341 %{_omf_dest_dir}/%{name}
342
343 %files devel
344 %defattr(644,root,root,755)
345 %attr(755,root,root) %{_libdir}/evolution/%{mver}/*.so
346 %{_libdir}/evolution/%{mver}/*.la
347 %{_libdir}/evolution/*/*/*.la
348 %{_includedir}/*
349 %{_pkgconfigdir}/*
350
351 %files static
352 %defattr(644,root,root,755)
353 %{_libdir}/evolution/%{mver}/*.a
354
355 %files mail
356 %defattr(644,root,root,755)
357 %dir %{_libdir}/evolution/%{mver}/camel*
358 %dir %{_libdir}/evolution/%{mver}/evolution-calendar-importers
359 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-mail-importers.so*
360 %attr(755,root,root) %{_libdir}/evolution/%{mver}/camel/*
361 %attr(755,root,root) %{_libdir}/evolution/%{mver}/components/libevolution-mail.so
362 %attr(755,root,root) %{_libdir}/evolution/%{mver}/camel-providers/*.so
363 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-calendar-importers/*.so
364 %{_libdir}/bonobo/servers/GNOME_Evolution_Mail_1.5.server
365 %{_libdir}/bonobo/servers/GNOME_Evolution_Mail_Importers_1.5.server
366 %{_libdir}/evolution/%{mver}/camel-providers/*.urls
367 %{_datadir}/evolution/%{mver}/views/mail*
368 %{_datadir}/evolution/%{mver}/default/C/mail
369 %{_datadir}/idl/evolution-%{mver}/Composer.idl
370 %{_datadir}/idl/evolution-%{mver}/Evolution-Composer.idl
371 %{_sysconfdir}/gconf/schemas/evolution-mail-1.5.schemas
372
373 %files addressbook
374 %defattr(644,root,root,755)
375 %dir %{_libdir}/evolution/%{mver}/evolution-addressbook-importers
376 %attr(755,root,root) %{_libdir}/evolution/%{mver}/components/libevolution-addressbook.so
377 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-addressbook-a11y.so.*
378 %attr(755,root,root) %{_libdir}/evolution/%{mver}/evolution-addressbook-importers/lib*.so
379 %{_libdir}/bonobo/servers/GNOME_Evolution_Addressbook*
380 %{_datadir}/evolution/%{mver}/views/addressbook*
381 %{_datadir}/evolution/%{mver}/ecps
382 %{_datadir}/idl/evolution-%{mver}/Evolution-Addressbook-SelectNames.idl
383 %{_sysconfdir}/gconf/schemas/apps_evolution_addressbook-1.5.schemas
384
385 %files calendar
386 %defattr(644,root,root,755)
387 %attr(755,root,root) %{_libdir}/evolution/%{mver}/components/libevolution-calendar.so
388 %attr(755,root,root) %{_libdir}/evolution/%{mver}/libevolution-calendar-a11y.so.*
389 %{_libdir}/bonobo/servers/GNOME_Evolution_Calendar*
390 %{_datadir}/evolution/%{mver}/views/calendar*
391 %{_datadir}/evolution/%{mver}/views/tasks*
392 %{_datadir}/idl/evolution-%{mver}/evolution-calendar.idl
393 %{_sysconfdir}/gconf/schemas/apps_evolution_calendar-1.5.schemas
394
395 %files pilot
396 %defattr(644,root,root,755)
397 %attr(755,root,root) %{_libdir}/evolution/%{mver}/conduits/*
398 %{_datadir}/gnome-pilot/conduits/*
This page took 0.065475 seconds and 4 git commands to generate.