]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
fce005acb3b829d1b553362e97919adf9dd14a25
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             0.16
6 %define         subver  262
7 %define         githash 4b3453d
8 %define         php_min_version 5.3.3
9 %include        /usr/lib/rpm/macros.php
10 Summary:        Eventum Issue / Bug tracking system
11 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
12 Name:           eventum
13 Version:        3.0.0
14 Release:        1.%{subver}.%{rel}
15 License:        GPL v2
16 Group:          Applications/WWW
17 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}-%{subver}/%{name}-%{version}-%{subver}.tar.gz
18 Source0:        %{name}-%{version}-%{subver}-g%{githash}.tar.gz
19 # Source0-md5:  d571072508b7254ed26dd21e5878ed6c
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}-mail-queue.cron
22 Source3:        %{name}-mail-download.cron
23 Source4:        %{name}-reminder.cron
24 Source5:        %{name}-monitor.cron
25 Source6:        %{name}-cvs.php
26 Source7:        %{name}-irc.php
27 Source8:        %{name}-irc.init
28 Source9:        %{name}-irc.sysconfig
29 Source10:       sphinx.crontab
30 Source13:       %{name}-router-postfix.sh
31 Source14:       %{name}.logrotate
32 Source15:       %{name}-lighttpd.conf
33 Source16:       http://www.isocra.com/images/updown2.gif
34 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
35 Source17:       %{name}.tmpfiles
36 #Patch0:                %{name}-lf.patch
37 Patch2:         %{name}-order.patch
38 #Patch3:                group-users.patch
39 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
40 # packaging patches that probably never go upstream
41 Patch100:       %{name}-paths.patch
42 Patch101:       %{name}-cvs-config.patch
43 Patch105:       %{name}-bot-reconnect.patch
44 Patch107:       %{name}-gettext.patch
45 # some tests
46 Patch200:       %{name}-fixed-nav.patch
47 URL:            http://eventum.mysql.org/
48 BuildRequires:  /usr/bin/php
49 BuildRequires:  gettext-devel
50 BuildRequires:  php(core) >= %{php_min_version}
51 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
52 BuildRequires:  rpmbuild(macros) >= 1.654
53 BuildRequires:  sed >= 4.0
54 Requires:       %{name}-base = %{version}-%{release}
55 Requires:       php(core) >= %{php_min_version}
56 Requires:       php(filter)
57 Requires:       php(gd)
58 Requires:       php(iconv)
59 Requires:       php(imap)
60 Requires:       php(json)
61 Requires:       php(mbstring)
62 Requires:       php(mysql)
63 Requires:       php(pcre)
64 Requires:       php(session)
65 Requires:       php-Smarty >= 3.1
66 Requires:       php-Smarty-plugin-gettext
67 Requires:       php-pear-DB
68 Requires:       php-pear-Date
69 Requires:       php-pear-Mail
70 Requires:       php-pear-Mail_Mime
71 Requires:       php-pear-Mail_mimeDecode
72 Requires:       php-pear-Math_Stats
73 Requires:       php-pear-Net_DIME
74 Requires:       php-pear-Net_SMTP
75 Requires:       php-pear-Net_Socket
76 Requires:       php-pear-Net_URL
77 Requires:       php-pear-Net_UserAgent_Detect
78 Requires:       php-pear-PEAR-core
79 Requires:       php-pear-Text_Diff
80 Requires:       php-pear-XML_RPC
81 Requires:       webapps
82 Requires:       webserver(access)
83 Requires:       webserver(alias)
84 Requires:       webserver(indexfile)
85 Requires:       webserver(php) >= 4.2.0
86 Suggests:       localedb
87 Suggests:       php-pear-Net_LDAP2
88 Conflicts:      logrotate < 3.8.0
89 BuildArch:      noarch
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
93
94 # exclude optional php dependencies
95 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
96
97 %define         _noautoreq      %{_noautophp}
98
99 %define         _libdir         %{_prefix}/lib/%{name}
100 %define         _appdir         %{_datadir}/%{name}
101 %define         _smartydir      %{php_data_dir}/Smarty
102 %define         _webapps        /etc/webapps
103 %define         _webapp         %{name}
104 %define         _webappdir      %{_webapps}/%{_webapp}
105 %define         _sysconfdir     /etc/%{name}
106
107 %description
108 Eventum is a user-friendly and flexible issue tracking system that can
109 be used by a support department to track incoming technical support
110 requests, or by a software development team to quickly organize tasks
111 and bugs. Eventum is used by the MySQL AB Technical Support team, and
112 has allowed us to dramatically improve our response times.
113
114 %description -l pl.UTF-8
115 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
116 może być używany przez dział obsługi do śledzenia przychodzących żądań
117 obsługi technicznej albo przez zespół tworzący oprogramowanie do
118 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
119 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
120 reakcji.
121
122 %package base
123 Summary:        Eventum base package
124 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
125 Group:          Applications/WWW
126 Requires(postun):       /usr/sbin/groupdel
127 Requires(postun):       /usr/sbin/userdel
128 Requires(pre):  /bin/id
129 Requires(pre):  /usr/bin/getgid
130 Requires(pre):  /usr/sbin/groupadd
131 Requires(pre):  /usr/sbin/useradd
132 Provides:       group(eventum)
133 Provides:       user(eventum)
134
135 %description base
136 This package contains base directory structure for Eventum.
137
138 %description base -l pl.UTF-8
139 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
140
141 %package setup
142 Summary:        Eventum setup package
143 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
144 Group:          Applications/WWW
145 Requires:       %{name} = %{version}-%{release}
146
147 %description setup
148 Install this package to configure initial Eventum installation. You
149 should uninstall this package when you're done, as it considered
150 insecure to keep the setup files in place.
151
152 %description setup -l pl.UTF-8
153 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
154 pierwszej instalacji. Potem należy go odinstalować, jako że
155 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
156
157 %package mail-queue
158 Summary:        Eventum mail queue process
159 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
160 Group:          Applications/WWW
161 Requires:       %{name} = %{version}-%{release}
162 Requires:       crondaemon
163
164 %description mail-queue
165 Beginning with the first release of Eventum, emails are not directly
166 sent out from the various scripts, but rather added to a mail queue
167 table that is processed by a cron job. If an email cannot be sent, it
168 will be marked as such in the mail queue log, and the cron job script
169 will re-try to send it again the next time it runs.
170
171 This package contains the cron job.
172
173 %description mail-queue -l pl.UTF-8
174 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
175 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
176 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
177 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
178 następnym razem.
179
180 Ten pakiet zawiera zadanie dla crona.
181
182 %package mail-download
183 Summary:        Eventum email download
184 Summary(pl.UTF-8):      Ściąganie poczty Eventum
185 Group:          Applications/WWW
186 Requires:       %{name} = %{version}-%{release}
187 Requires:       crondaemon
188
189 %description mail-download
190 In order for Eventum's email integration feature to work, you need to
191 setup a cron job to run the script every so often.
192
193 This package contains the cron job.
194
195 %description mail-download -l pl.UTF-8
196 Aby integracja poczty elektronicznej w Eventum działała, trzeba
197 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
198 często.
199
200 Ten pakiet zawiera zadanie dla crona.
201
202 %package reminder
203 Summary:        Eventum Reminder System
204 Summary(pl.UTF-8):      System przypominania dla Eventum
205 Group:          Applications/WWW
206 Requires:       %{name} = %{version}-%{release}
207 Requires:       crondaemon
208
209 %description reminder
210 The reminder system was designed with the objective as serving as a
211 safe net for issues that need attention. Depending on what
212 configuration you create, you may have several reminders (or alerts)
213 be sent out whenever an issue needs attention, for whatever parameter
214 you may deem necessary.
215
216 This package contains the cron job.
217
218 %description reminder -l pl.UTF-8
219 System przypominania został zaprojektowany tak, aby służył jako
220 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
221 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
222 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
223 uważać za potrzebny.
224
225 Ten pakiet zawiera zadanie dla crona.
226
227 %package monitor
228 Summary:        Eventum Heartbeat Monitor
229 Summary(pl.UTF-8):      Monitor życia dla Eventum
230 Group:          Applications/WWW
231 Requires:       %{name} = %{version}-%{release}
232 Requires:       crondaemon
233 Requires:       php(posix)
234
235 %description monitor
236 The heartbeat monitor is a feature designed for the administrator that
237 wants to be alerted whenever a common problem in Eventum is detected,
238 like the database server not being available anymore, or maybe when
239 the recommended permissions for certain configuration files are
240 changed.
241
242 Please note that before running the heartbeat monitor, you may need to
243 customize some of the checks to be appropriate for your own system,
244 particularly the permission and file checks on
245 Monitor::checkConfiguration().
246
247 This package contains the cron job.
248
249 %description monitor -l pl.UTF-8
250 Monitor życia to funkcjonalność zaprojektowana dla administratora
251 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
252 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
253 do plików konfiguracyjnych.
254
255 Należy zauważyć, że przed uruchomieniem tego monitora może być
256 konieczne dostosowanie niektórych testów do systemu, w szczególności
257 testów uprawnień i plików w Monitor::checkConfiguration().
258
259 Ten pakiet zawiera zadanie dla crona.
260
261 %package route-drafts
262 Summary:        Eventum Draft Routing
263 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
264 Group:          Applications/WWW
265 Requires:       %{name} = %{version}-%{release}
266 Requires:       eventum(router)
267
268 %description route-drafts
269 The draft routing feature is used to automatically associate a thread
270 of drafts into an Eventum issue. By setting up Postfix to deliver
271 emails sent to a specific address (usually draft-<number>@<domain>) to
272 the above script, users are able to send drafts written in their mail
273 client to be stored in Eventum. These drafts will NOT broadcasted to
274 the notification list.
275
276 %description route-drafts -l pl.UTF-8
277 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
278 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
279 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
280 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
281 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
282 na listę powiadomień.
283
284 %package route-emails
285 Summary:        Eventum Email Routing
286 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
287 Group:          Applications/WWW
288 Requires:       %{name} = %{version}-%{release}
289 Requires:       eventum(router)
290
291 %description route-emails
292 The email routing feature is used to automatically associate a thread
293 of emails into an Eventum issue. By setting up Postfix to deliver
294 emails sent to a specific address (usually issue-<number>@<domain>) to
295 the above script, users are able to use their email clients to reply
296 to emails coming from Eventum, and those replies will be automatically
297 associated with the issue and broadcasted to the entire notification
298 list.
299
300 %description route-emails -l pl.UTF-8
301 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
302 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
303 aby dostarczał listy wysyłane na pewien adres (zwykle
304 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
305 używać klientów pocztowych do odpowiadania na listy przychodzące z
306 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
307 rozprowadzane do całej listy ogłoszeniowej.
308
309 %package route-notes
310 Summary:        Eventum Note Routing
311 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
312 Group:          Applications/WWW
313 Requires:       %{name} = %{version}-%{release}
314 Requires:       eventum(router)
315
316 %description route-notes
317 The note routing feature is used to automatically associate a thread
318 of notes into an Eventum issue. By setting up Postfix to deliver
319 emails sent to a specific address (usually note-<number>@<domain>) to
320 the above script, users are able to use their email clients to reply
321 to internal notes coming from Eventum, and those replies will be
322 automatically associated with the issue and broadcasted to the
323 notification list staff members.
324
325 %description route-notes -l pl.UTF-8
326 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
327 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
328 dostarczał listy wysyłane na pewien adres (zwykle
329 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
330 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
331 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
332 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
333
334 %package router-postfix
335 Summary:        Eventum Mail Routing - Postfix
336 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
337 Group:          Applications/Mail
338 Requires:       %{name} = %{version}-%{release}
339 Requires:       postfix
340 Provides:       eventum(router)
341 Obsoletes:      eventum(router)
342
343 %description router-postfix
344 This package provides way of routing notes and emails back to Eventum
345 via Postfix.
346
347 The Postfix configuration instructions you can find from
348 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
349
350 %description router-postfix -l pl.UTF-8
351 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
352 przez Postfiksa.
353
354 Opis konfiguracji Postfiksa można znaleźć pod adresem
355 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
356
357 %package irc
358 Summary:        Eventum IRC Notification Bot
359 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
360 Group:          Applications/WWW
361 Requires(post,preun):   /sbin/chkconfig
362 Requires:       %{name} = %{version}-%{release}
363 Requires:       php(sockets)
364 Requires:       php-pear-Net_SmartIRC
365 Requires:       rc-scripts >= 0.4.0.18
366
367 %description irc
368 The IRC notification bot is a nice feature for remote teams that want
369 to handle issues and want to have a quick and easy way to get simple
370 notifications. Right now the bot notifies of the following actions:
371 - New Issues
372 - Blocked emails
373 - Issues that got their assignment list changed
374
375 NOTE: You will need to manually edit the bot.php script to set your
376 appropriate preferences, like IRC server and channel that the bot
377 should join.
378
379 %description irc -l pl.UTF-8
380 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
381 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
382 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
383 następujących zdarzeniach:
384 - nowych sprawach
385 - zablokowanych listach
386 - sprawach, dla których zmieniła się lista powiązań
387
388 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
389 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
390
391 %package cli
392 Summary:        Eventum command-line interface
393 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
394 Group:          Applications/WWW
395 Requires:       %{name}-base = %{version}-%{release}
396 Requires:       php(core) >= %{php_min_version}
397 Requires:       php(phar)
398 Requires:       php-pear-XML_RPC
399
400 %description cli
401 The Eventum command-line interface allows you to access most of the
402 features of the web interface straight from your command shell.
403
404 %description cli -l pl.UTF-8
405 Interfejs linii poleceń Eventum pozwala na dostęp do większości
406 funkcji interfejsu WWW prosto z linii poleceń powłoki.
407
408 %package scm
409 Summary:        Eventum SCM integration
410 Summary(pl.UTF-8):      Integracja SCM dla Eventum
411 Group:          Applications/WWW
412 Requires:       php(core) >= %{php_min_version}
413 Requires:       php(json)
414 Requires:       php(pcre)
415 Requires:       php(spl)
416 Suggests:       cvs
417 Suggests:       git-core
418 Suggests:       php(openssl)
419 Suggests:       subversion
420
421 %description scm
422 This feature allows your software development teams to integrate your
423 Source Control Management system with your Issue Tracking System.
424
425 The integration is implemented in such a way that it will be forward
426 compatible with pretty much any SCM system, such as CVS.
427
428 For installation see
429 </eventum/help.php?topic=scm_integration_installation>.
430
431 %description scm -l pl.UTF-8
432 Ten pakiet pozwala zespołom programistów na integrację systemu
433 zarządzania źródłami (SCM - Source Control Management) z systemem
434 śledzenia spraw.
435
436 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
437 prawie każdym systemem SCM, jak np. CVS.
438
439 Szczegóły na temat instalacji można przeczytać pod
440 </eventum/help.php?topic=scm_integration_installation>.
441
442 %package sphinx
443 Summary:        Eventum Sphinx Search
444 Group:          Applications/WWW
445 Requires:       %{name} = %{version}-%{release}
446 Requires:       crondaemon
447 Requires:       sphinx
448
449 %description sphinx
450 Sphinx search integration for Eventum.
451
452 This package contains the cron job.
453
454 %prep
455 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
456
457 mv docs/examples .
458
459 # GPL v2
460 rm docs/COPYING
461
462 # bug fixes / features
463 #%patch0 -p1
464 %{?with_order:%patch2 -p1}
465 #%patch3 -p0
466 #%patch4 -p1
467
468 %{?with_order:cp -p %{SOURCE16} htdocs/images}
469
470 #%patch200 -p1
471
472 # produce default sphinx config
473 # must be run before paths.patch
474 %if 0
475 cat <<'EOF' > config/config.php
476 <?php
477 define('APP_SQL_DBTYPE', 'mysql');
478 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
479 define('APP_SQL_DBPORT', 3306);
480 define('APP_SQL_DBNAME', 'eventum');
481 define('APP_SQL_DBUSER', 'mysql');
482 define('APP_SQL_DBPASS', '');
483 define('APP_TABLE_PREFIX', 'eventum_');
484 EOF
485 php config/sphinx.conf.php > config/sphinx.conf
486 rm -f config/config.php
487 %endif
488
489 # packaging
490 %patch100 -p1
491 %patch101 -p1
492 %patch105 -p1
493 %patch107 -p1
494
495 %{__sed} -i -e "
496 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
497 " upgrade/{*/,}*.php
498
499 # remove backups from patching as we use globs to package files to buildroot
500 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
501
502 %build
503 %{__make} -C localization
504
505 %install
506 rm -rf $RPM_BUILD_ROOT
507 install -d \
508         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
509         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
510         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
511         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
512         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
513         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
514         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
515
516 %{__make} install-eventum install-cli install-irc install-scm install-localization \
517         sysconfdir=%{_webappdir} \
518         localedir=%{_localedir} \
519         DESTDIR=$RPM_BUILD_ROOT
520
521 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
522 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
523
524 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
525
526 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
527
528 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
529 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
530 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
531 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
532
533 install -d $RPM_BUILD_ROOT/etc/sphinx
534 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
535 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
536
537 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
538 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
539 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
540 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
541 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
542
543 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
544
545 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
546 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
547
548 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
549
550 # postfix router
551 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
552
553 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
554
555 %find_lang %{name}
556
557 # scm
558 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
559
560 %clean
561 rm -rf $RPM_BUILD_ROOT
562
563 %pre
564 %addusertogroup http %{name}
565
566 %post
567 # greate empty ghost files
568 for a in cli.log errors.log irc_bot.log login_attempts.log; do
569         if [ ! -f /var/log/%{name}/$a ]; then
570                 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
571         fi
572 done
573
574 # run database update if configured
575 test -s %{_webappdir}/config.php && \
576 %{_appdir}/upgrade/update-database.php || :
577
578 # nuke Smarty templates cache after upgrade
579 rm -f /var/cache/eventum/*.php
580
581 # Restart webserver on upgrade to get .mo translations reloaded.
582 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
583 %php_webserver_restart
584
585 %preun
586 if [ "$1" = "0" ]; then
587         # nuke cache
588         rm -f /var/cache/eventum/*.php 2>/dev/null || :
589 fi
590
591 %pre base
592 %groupadd -P %{name}-base -g 146 %{name}
593 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
594
595 %postun base
596 if [ "$1" = "0" ]; then
597         %userremove %{name}
598         %groupremove %{name}
599 fi
600
601 %post setup
602 chmod 660 %{_webappdir}/{config,private_key}.php
603 chown root:http %{_webappdir}/{config,private_key}.php
604
605 %postun setup
606 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
607         chmod 640 %{_webappdir}/{config,private_key}.php
608         chown root:http %{_webappdir}/{config,private_key}.php
609 fi
610
611 %post irc
612 /sbin/chkconfig --add eventum-irc
613 %service eventum-irc restart "Eventum IRC Bot"
614
615 %preun irc
616 if [ "$1" = 0 ]; then
617         %service eventum-irc stop
618         /sbin/chkconfig --del eventum-irc
619 fi
620
621 %triggerin -- apache1 < 1.3.37-3, apache1-base
622 %webapp_register apache %{_webapp}
623
624 %triggerun -- apache1 < 1.3.37-3, apache1-base
625 %webapp_unregister apache %{_webapp}
626
627 %triggerin -- apache < 2.2.0, apache-base
628 %webapp_register httpd %{_webapp}
629
630 %triggerun -- apache < 2.2.0, apache-base
631 %webapp_unregister httpd %{_webapp}
632
633 %triggerin -- lighttpd
634 %webapp_register lighttpd %{_webapp}
635
636 %triggerun -- lighttpd
637 %webapp_unregister lighttpd %{_webapp}
638
639 %triggerpostun -- %{name} < 3.0.0-0.2
640 for f in /etc/cron.d/eventum-*; do
641         # crontabs moved to bin
642         %{__sed} -i -e '
643                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
644                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
645                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
646                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
647         ' $f
648 done
649
650 %files -f %{name}.lang
651 %defattr(644,root,root,755)
652 %doc docs/*
653 %attr(751,root,root) %dir %{_webappdir}
654 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
655 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
656 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
657 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
658 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
659 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
660 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
661
662 %dir %attr(731,root,http) /var/log/%{name}
663 %attr(620,root,http) %ghost /var/log/%{name}/*
664 %dir %attr(750,root,root) /var/log/archive/%{name}
665 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
666
667 %dir %{_appdir}/bin
668 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
669
670 %{_appdir}/autoload.php
671 %{_appdir}/init.php
672 %dir %{_appdir}/htdocs
673 %{_appdir}/htdocs/*.php
674 %{_appdir}/htdocs/*.ico
675 %{_appdir}/htdocs/ajax
676 %{_appdir}/htdocs/css
677 %{_appdir}/htdocs/customer
678 %{_appdir}/htdocs/images
679 %{_appdir}/htdocs/js
680 %{_appdir}/htdocs/manage
681 %{_appdir}/htdocs/misc
682 %{_appdir}/htdocs/reports
683 %{_appdir}/htdocs/rpc
684 %{_appdir}/htdocs/components
685 %{_appdir}/templates
686
687 %dir %{_appdir}/upgrade
688 %{_appdir}/upgrade/flush_compiled_templates.php
689 %{_appdir}/upgrade/*.sql
690 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
691 %attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
692 %attr(755,root,root) %{_appdir}/upgrade/ldap_update_users.php
693 %attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
694 %{_appdir}/upgrade/patches
695
696 %dir %{_appdir}/lib
697 %{_appdir}/lib/eventum
698 %exclude %{_appdir}/lib/eventum/class.monitor.php
699
700 %{_appdir}/vendor
701
702 %{_examplesdir}/%{name}-%{version}
703
704 %{systemdtmpfilesdir}/%{name}.conf
705 %dir %attr(730,root,http) /var/run/%{name}
706 %dir %attr(730,root,http) /var/cache/%{name}
707
708 %files base
709 %defattr(644,root,root,755)
710 %attr(751,root,root) %dir %{_sysconfdir}
711 %dir %{_libdir}
712 %dir %{_appdir}
713 %dir /var/lib/%{name}
714 # saved mail copies
715 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
716 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
717 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
718
719 %files setup
720 %defattr(644,root,root,755)
721 %{_appdir}/htdocs/setup
722
723 %files mail-queue
724 %defattr(644,root,root,755)
725 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
726 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
727
728 %files mail-download
729 %defattr(644,root,root,755)
730 %attr(755,root,root) %{_appdir}/bin/download_emails.php
731 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
732
733 %files reminder
734 %defattr(644,root,root,755)
735 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
736 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
737
738 %files monitor
739 %defattr(644,root,root,755)
740 %{_appdir}/lib/eventum/class.monitor.php
741 %attr(755,root,root) %{_appdir}/bin/monitor.php
742 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
743
744 %files route-drafts
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{_appdir}/bin/route_drafts.php
747
748 %files route-emails
749 %defattr(644,root,root,755)
750 %attr(755,root,root) %{_appdir}/bin/route_emails.php
751
752 %files route-notes
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_appdir}/bin/route_notes.php
755
756 %files router-postfix
757 %defattr(644,root,root,755)
758 %attr(755,root,root) %{_libdir}/router-postfix
759
760 %files irc
761 %defattr(644,root,root,755)
762 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
763 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
764 %attr(755,root,root) %{_sbindir}/%{name}-irc-bot
765 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
766
767 %files cli
768 %defattr(644,root,root,755)
769 %doc cli/eventumrc
770 %attr(755,root,root) %{_bindir}/%{name}
771
772 %files scm
773 %defattr(644,root,root,755)
774 %attr(751,root,root) %dir %{_sysconfdir}
775 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
776 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
777 %attr(755,root,root) %{_sbindir}/eventum-git-hook
778 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
779 %attr(755,root,root) %{_sbindir}/helpers.php
780
781 %files sphinx
782 %defattr(644,root,root,755)
783 %{_webappdir}/sphinx.conf.php
784 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
785 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.091696 seconds and 3 git commands to generate.