]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
e68944f1e9ec8fd042731ffa13baa6c6e6eb989b
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 #
9 # Conditional build:
10 %bcond_without  order   # with experimental order patch
11
12 %define         php_min_version 5.1.2
13 #define         subver  RC3
14 %define         rel             4
15 %include        /usr/lib/rpm/macros.php
16 Summary:        Eventum Issue / Bug tracking system
17 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
18 Name:           eventum
19 Version:        2.3.3
20 Release:        %{rel}
21 #Release:       %{rel}.bzr%{subver}
22 License:        GPL v2
23 Group:          Applications/WWW
24 Source0:        http://launchpad.net/eventum/trunk/%{version}/+download/%{name}-%{version}.tar.gz
25 # Source0-md5:  e1a5097d191468061865065678665f0e
26 #Source0:       %{name}-%{version}-dev-r%{subver}.tar.gz
27 #Source0:       %{name}-%{version}%{subver}.tar.gz
28 Source1:        %{name}-apache.conf
29 Source2:        %{name}-mail-queue.cron
30 Source3:        %{name}-mail-download.cron
31 Source4:        %{name}-reminder.cron
32 Source5:        %{name}-monitor.cron
33 Source6:        %{name}-cvs.php
34 Source7:        %{name}-irc.php
35 Source8:        %{name}-irc.init
36 Source9:        %{name}-irc.sysconfig
37 Source10:       sphinx.crontab
38 Source13:       %{name}-router-postfix.sh
39 Source14:       %{name}.logrotate
40 Source15:       %{name}-lighttpd.conf
41 Source16:       http://www.isocra.com/images/updown2.gif
42 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
43 Source17:       %{name}.tmpfiles
44 Source18:       %{name}-httpd.conf
45 Patch0:         %{name}-lf.patch
46 Patch2:         %{name}-order.patch
47 Patch3:         group-users.patch
48 # packaging patches that probably never go upstream
49 Patch100:       %{name}-paths.patch
50 Patch101:       %{name}-cvs-config.patch
51 Patch105:       %{name}-bot-reconnect.patch
52 Patch107:       %{name}-gettext.patch
53 # some tests
54 Patch200:       %{name}-fixed-nav.patch
55 URL:            http://eventum.mysql.org/
56 BuildRequires:  /usr/bin/php
57 BuildRequires:  gettext-devel
58 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
59 BuildRequires:  rpmbuild(macros) >= 1.654
60 BuildRequires:  sed >= 4.0
61 Requires:       %{name}-base = %{version}-%{release}
62 Requires:       Smarty >= 2.6.10-4
63 Requires:       php(core) >= %{php_min_version}
64 Requires:       php(filter)
65 Requires:       php(gd)
66 Requires:       php(iconv)
67 Requires:       php(imap)
68 Requires:       php(json)
69 Requires:       php(mbstring)
70 Requires:       php(mysql)
71 Requires:       php(pcre)
72 Requires:       php(session)
73 Requires:       php-pear-DB
74 Requires:       php-pear-Date
75 Requires:       php-pear-Mail
76 Requires:       php-pear-Mail_Mime
77 Requires:       php-pear-Mail_mimeDecode
78 Requires:       php-pear-Math_Stats
79 Requires:       php-pear-Net_DIME
80 Requires:       php-pear-Net_SMTP
81 Requires:       php-pear-Net_Socket
82 Requires:       php-pear-Net_URL
83 Requires:       php-pear-Net_UserAgent_Detect
84 Requires:       php-pear-PEAR-core
85 Requires:       php-pear-Text_Diff
86 Requires:       php-pear-XML_RPC
87 Requires:       smarty-gettext
88 Requires:       webapps
89 Requires:       webserver(access)
90 Requires:       webserver(alias)
91 Requires:       webserver(indexfile)
92 Requires:       webserver(php) >= 4.2.0
93 Suggests:       localedb
94 Suggests:       php-pear-Net_LDAP2
95 Conflicts:      apache-base < 2.4.0-1
96 Conflicts:      logrotate < 3.8.0
97 BuildArch:      noarch
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define         _noautoreq_pear ../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* jpgraph_dir.php .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.php
101
102 # exclude optional php dependencies
103 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
104
105 %define         _noautoreq      %{_noautophp}
106
107 %define         _libdir         %{_prefix}/lib/%{name}
108 %define         _appdir         %{_datadir}/%{name}
109 %define         _smartydir      %{php_data_dir}/Smarty
110 %define         _webapps        /etc/webapps
111 %define         _webapp         %{name}
112 %define         _webappdir      %{_webapps}/%{_webapp}
113 %define         _sysconfdir     /etc/%{name}
114
115 %description
116 Eventum is a user-friendly and flexible issue tracking system that can
117 be used by a support department to track incoming technical support
118 requests, or by a software development team to quickly organize tasks
119 and bugs. Eventum is used by the MySQL AB Technical Support team, and
120 has allowed us to dramatically improve our response times.
121
122 %description -l pl.UTF-8
123 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
124 może być używany przez dział obsługi do śledzenia przychodzących żądań
125 obsługi technicznej albo przez zespół tworzący oprogramowanie do
126 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
127 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
128 reakcji.
129
130 %package base
131 Summary:        Eventum base package
132 Summary(pl.UTF-8):      Podstawowy pakiet Eventum
133 Group:          Applications/WWW
134 Requires(postun):       /usr/sbin/groupdel
135 Requires(postun):       /usr/sbin/userdel
136 Requires(pre):  /bin/id
137 Requires(pre):  /usr/bin/getgid
138 Requires(pre):  /usr/sbin/groupadd
139 Requires(pre):  /usr/sbin/useradd
140 Provides:       group(eventum)
141 Provides:       user(eventum)
142
143 %description base
144 This package contains base directory structure for Eventum.
145
146 %description base -l pl.UTF-8
147 Ten pakiet zawiera podstawową strukturę katalogów dla Eventum.
148
149 %package setup
150 Summary:        Eventum setup package
151 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
152 Group:          Applications/WWW
153 Requires:       %{name} = %{version}-%{release}
154
155 %description setup
156 Install this package to configure initial Eventum installation. You
157 should uninstall this package when you're done, as it considered
158 insecure to keep the setup files in place.
159
160 %description setup -l pl.UTF-8
161 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
162 pierwszej instalacji. Potem należy go odinstalować, jako że
163 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
164
165 %package mail-queue
166 Summary:        Eventum mail queue process
167 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
168 Group:          Applications/WWW
169 Requires:       %{name} = %{version}-%{release}
170 Requires:       crondaemon
171
172 %description mail-queue
173 Beginning with the first release of Eventum, emails are not directly
174 sent out from the various scripts, but rather added to a mail queue
175 table that is processed by a cron job. If an email cannot be sent, it
176 will be marked as such in the mail queue log, and the cron job script
177 will re-try to send it again the next time it runs.
178
179 This package contains the cron job.
180
181 %description mail-queue -l pl.UTF-8
182 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
183 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
184 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
185 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
186 następnym razem.
187
188 Ten pakiet zawiera zadanie dla crona.
189
190 %package mail-download
191 Summary:        Eventum email download
192 Summary(pl.UTF-8):      Ściąganie poczty Eventum
193 Group:          Applications/WWW
194 Requires:       %{name} = %{version}-%{release}
195 Requires:       crondaemon
196
197 %description mail-download
198 In order for Eventum's email integration feature to work, you need to
199 setup a cron job to run the script every so often.
200
201 This package contains the cron job.
202
203 %description mail-download -l pl.UTF-8
204 Aby integracja poczty elektronicznej w Eventum działała, trzeba
205 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
206 często.
207
208 Ten pakiet zawiera zadanie dla crona.
209
210 %package reminder
211 Summary:        Eventum Reminder System
212 Summary(pl.UTF-8):      System przypominania dla Eventum
213 Group:          Applications/WWW
214 Requires:       %{name} = %{version}-%{release}
215 Requires:       crondaemon
216
217 %description reminder
218 The reminder system was designed with the objective as serving as a
219 safe net for issues that need attention. Depending on what
220 configuration you create, you may have several reminders (or alerts)
221 be sent out whenever an issue needs attention, for whatever parameter
222 you may deem necessary.
223
224 This package contains the cron job.
225
226 %description reminder -l pl.UTF-8
227 System przypominania został zaprojektowany tak, aby służył jako
228 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
229 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
230 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
231 uważać za potrzebny.
232
233 Ten pakiet zawiera zadanie dla crona.
234
235 %package monitor
236 Summary:        Eventum Heartbeat Monitor
237 Summary(pl.UTF-8):      Monitor życia dla Eventum
238 Group:          Applications/WWW
239 Requires:       %{name} = %{version}-%{release}
240 Requires:       crondaemon
241 Requires:       php(posix)
242
243 %description monitor
244 The heartbeat monitor is a feature designed for the administrator that
245 wants to be alerted whenever a common problem in Eventum is detected,
246 like the database server not being available anymore, or maybe when
247 the recommended permissions for certain configuration files are
248 changed.
249
250 Please note that before running the heartbeat monitor, you may need to
251 customize some of the checks to be appropriate for your own system,
252 particularly the permission and file checks on
253 Monitor::checkConfiguration().
254
255 This package contains the cron job.
256
257 %description monitor -l pl.UTF-8
258 Monitor życia to funkcjonalność zaprojektowana dla administratora
259 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
260 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
261 do plików konfiguracyjnych.
262
263 Należy zauważyć, że przed uruchomieniem tego monitora może być
264 konieczne dostosowanie niektórych testów do systemu, w szczególności
265 testów uprawnień i plików w Monitor::checkConfiguration().
266
267 Ten pakiet zawiera zadanie dla crona.
268
269 %package route-drafts
270 Summary:        Eventum Draft Routing
271 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
272 Group:          Applications/WWW
273 Requires:       %{name} = %{version}-%{release}
274 Requires:       eventum(router)
275
276 %description route-drafts
277 The draft routing feature is used to automatically associate a thread
278 of drafts into an Eventum issue. By setting up Postfix to deliver
279 emails sent to a specific address (usually draft-<number>@<domain>) to
280 the above script, users are able to send drafts written in their mail
281 client to be stored in Eventum. These drafts will NOT broadcasted to
282 the notification list.
283
284 %description route-drafts -l pl.UTF-8
285 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
286 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
287 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
288 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
289 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
290 na listę powiadomień.
291
292 %package route-emails
293 Summary:        Eventum Email Routing
294 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
295 Group:          Applications/WWW
296 Requires:       %{name} = %{version}-%{release}
297 Requires:       eventum(router)
298
299 %description route-emails
300 The email routing feature is used to automatically associate a thread
301 of emails into an Eventum issue. By setting up Postfix to deliver
302 emails sent to a specific address (usually issue-<number>@<domain>) to
303 the above script, users are able to use their email clients to reply
304 to emails coming from Eventum, and those replies will be automatically
305 associated with the issue and broadcasted to the entire notification
306 list.
307
308 %description route-emails -l pl.UTF-8
309 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
310 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
311 aby dostarczał listy wysyłane na pewien adres (zwykle
312 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
313 używać klientów pocztowych do odpowiadania na listy przychodzące z
314 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
315 rozprowadzane do całej listy ogłoszeniowej.
316
317 %package route-notes
318 Summary:        Eventum Note Routing
319 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
320 Group:          Applications/WWW
321 Requires:       %{name} = %{version}-%{release}
322 Requires:       eventum(router)
323
324 %description route-notes
325 The note routing feature is used to automatically associate a thread
326 of notes into an Eventum issue. By setting up Postfix to deliver
327 emails sent to a specific address (usually note-<number>@<domain>) to
328 the above script, users are able to use their email clients to reply
329 to internal notes coming from Eventum, and those replies will be
330 automatically associated with the issue and broadcasted to the
331 notification list staff members.
332
333 %description route-notes -l pl.UTF-8
334 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
335 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
336 dostarczał listy wysyłane na pewien adres (zwykle
337 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
338 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
339 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
340 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
341
342 %package router-postfix
343 Summary:        Eventum Mail Routing - Postfix
344 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
345 Group:          Applications/Mail
346 Requires:       %{name} = %{version}-%{release}
347 Requires:       postfix
348 Provides:       eventum(router)
349 Obsoletes:      eventum(router)
350
351 %description router-postfix
352 This package provides way of routing notes and emails back to Eventum
353 via Postfix.
354
355 The Postfix configuration instructions you can find from
356 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
357
358 %description router-postfix -l pl.UTF-8
359 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
360 przez Postfiksa.
361
362 Opis konfiguracji Postfiksa można znaleźć pod adresem
363 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
364
365 %package irc
366 Summary:        Eventum IRC Notification Bot
367 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
368 Group:          Applications/WWW
369 Requires(post,preun):   /sbin/chkconfig
370 Requires:       %{name} = %{version}-%{release}
371 Requires:       php(sockets)
372 Requires:       php-pear-Net_SmartIRC
373 Requires:       rc-scripts >= 0.4.0.18
374
375 %description irc
376 The IRC notification bot is a nice feature for remote teams that want
377 to handle issues and want to have a quick and easy way to get simple
378 notifications. Right now the bot notifies of the following actions:
379 - New Issues
380 - Blocked emails
381 - Issues that got their assignment list changed
382
383 NOTE: You will need to manually edit the bot.php script to set your
384 appropriate preferences, like IRC server and channel that the bot
385 should join.
386
387 %description irc -l pl.UTF-8
388 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
389 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
390 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
391 następujących zdarzeniach:
392 - nowych sprawach
393 - zablokowanych listach
394 - sprawach, dla których zmieniła się lista powiązań
395
396 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
397 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
398
399 %package cli
400 Summary:        Eventum command-line interface
401 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
402 Group:          Applications/WWW
403 Requires:       %{name}-base = %{version}-%{release}
404 Requires:       php(core) >= %{php_min_version}
405 Requires:       php-cli
406 Requires:       php-pear-XML_RPC
407
408 %description cli
409 The Eventum command-line interface allows you to access most of the
410 features of the web interface straight from your command shell.
411
412 %description cli -l pl.UTF-8
413 Interfejs linii poleceń Eventum pozwala na dostęp do większości
414 funkcji interfejsu WWW prosto z linii poleceń powłoki.
415
416 %package scm
417 Summary:        Eventum SCM integration
418 Summary(pl.UTF-8):      Integracja SCM dla Eventum
419 Group:          Applications/WWW
420 Requires:       %{name}-base = %{version}-%{release}
421 Requires:       php(core) >= %{php_min_version}
422 Requires:       php(pcre)
423 Requires:       php-cli
424
425 %description scm
426 This feature allows your software development teams to integrate your
427 Source Control Management system with your Issue Tracking System.
428
429 The integration is implemented in such a way that it will be forward
430 compatible with pretty much any SCM system, such as CVS.
431
432 For installation see
433 </eventum/help.php?topic=scm_integration_installation>.
434
435 %description scm -l pl.UTF-8
436 Ten pakiet pozwala zespołom programistów na integrację systemu
437 zarządzania źródłami (SCM - Source Control Management) z systemem
438 śledzenia spraw.
439
440 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
441 prawie każdym systemem SCM, jak np. CVS.
442
443 Szczegóły na temat instalacji można przeczytać pod
444 </eventum/help.php?topic=scm_integration_installation>.
445
446 %package sphinx
447 Summary:        Eventum Sphinx Search
448 Group:          Applications/WWW
449 Requires:       %{name} = %{version}-%{release}
450 Requires:       crondaemon
451 Requires:       sphinx
452
453 %description sphinx
454 Sphinx search integration for Eventum.
455
456 This package contains the cron job.
457
458 %prep
459 %setup -q
460
461 # GPL v2
462 rm docs/COPYING
463
464 rm -r upgrade/*v1.[123]* # too old to support in PLD Linux
465 rm -r upgrade/v{1.,2.0,2.1_}* # no longer supported in PLD Linux
466 rm upgrade/flush_compiled_templates.php
467 rm -r upgrade/{*/,}index.html # not needed in PLD Linux
468
469 # bug fixes / features
470 %patch0 -p1
471 %{?with_order:%patch2 -p1}
472 %patch3 -p0
473
474 cp -p %{SOURCE16} htdocs/images
475
476 #%patch200 -p1
477
478 # produce default sphinx config
479 # must be run before paths.patch
480 cat <<'EOF' > config/config.php
481 <?php
482 define('APP_SQL_DBTYPE', 'mysql');
483 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
484 define('APP_SQL_DBPORT', 3306);
485 define('APP_SQL_DBNAME', 'eventum');
486 define('APP_SQL_DBUSER', 'mysql');
487 define('APP_SQL_DBPASS', '');
488 define('APP_TABLE_PREFIX', 'eventum_');
489 EOF
490 php config/sphinx.conf.php > config/sphinx.conf
491 rm -f config/config.php
492
493 # packaging
494 %patch100 -p1
495 %patch101 -p1
496 %patch105 -p1
497 %patch107 -p1
498
499 %{__sed} -i -e "
500 s;define('CONFIG_PATH'.*');define('CONFIG_PATH', '%{_webappdir}');
501 " upgrade/{*/,}*.php
502
503 # remove backups from patching as we use globs to package files to buildroot
504 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
505
506 %build
507 %{__make} -C localization
508
509 %install
510 rm -rf $RPM_BUILD_ROOT
511 install -d \
512         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
513         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
514         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
515         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
516         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
517         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
518         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
519
520 %{__make} install-eventum install-cli install-irc install-scm install-jpgraph install-localization \
521         sysconfdir=%{_webappdir} \
522         DESTDIR=$RPM_BUILD_ROOT
523
524 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
525
526 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
527 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
528 cp -p %{SOURCE18} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
529 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
530
531 install -d $RPM_BUILD_ROOT/etc/sphinx
532 cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
533 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
534
535 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
536 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
537 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
538 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
539 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
540
541 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
542
543 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
544 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
545
546 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
547
548 # postfix router
549 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
550
551 install %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
552
553 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
554
555 %find_lang %{name}
556
557 # scm
558 install -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
559
560 # old compat
561 ln -s %{_sbindir}/eventum-cvs-hook $RPM_BUILD_ROOT%{_libdir}/process_cvs_commits
562 ln -s %{_sbindir}/eventum-svn-hook $RPM_BUILD_ROOT%{_libdir}/process_svn_commits
563
564 # skip pear for cli
565 rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
566 cp -a cli/lib/eventum $RPM_BUILD_ROOT%{_datadir}/%{name}/cli
567
568 %clean
569 rm -rf $RPM_BUILD_ROOT
570
571 %pre
572 %addusertogroup http %{name}
573
574 %post
575 # greate empty ghost files
576 for a in cli.log errors.log irc_bot.log login_attempts.log; do
577         if [ ! -f /var/log/%{name}/$a ]; then
578                 install -m 0620 -o root -g eventum /dev/null /var/log/%{name}/$a
579         fi
580 done
581
582 # run database update if configured
583 test -s %{_webappdir}/config.php && \
584 %{_appdir}/upgrade/update-database.php || :
585
586 # nuke Smarty templates cache after upgrade
587 rm -f /var/cache/eventum/*.php
588
589 # Restart webserver on upgrade to get .mo translations reloaded.
590 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
591 %php_webserver_restart
592
593 %preun
594 if [ "$1" = "0" ]; then
595         # nuke cache
596         rm -f /var/cache/eventum/*.php 2>/dev/null || :
597 fi
598
599 %pre base
600 %groupadd -P %{name}-base -g 146 %{name}
601 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
602
603 %postun base
604 if [ "$1" = "0" ]; then
605         %userremove %{name}
606         %groupremove %{name}
607 fi
608
609 %post setup
610 chmod 660 %{_webappdir}/{config,private_key}.php
611 chown root:http %{_webappdir}/{config,private_key}.php
612
613 %postun setup
614 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
615         chmod 640 %{_webappdir}/{config,private_key}.php
616         chown root:http %{_webappdir}/{config,private_key}.php
617 fi
618
619 %post irc
620 /sbin/chkconfig --add eventum-irc
621 %service eventum-irc restart "Eventum IRC Bot"
622
623 %preun irc
624 if [ "$1" = 0 ]; then
625         %service eventum-irc stop
626         /sbin/chkconfig --del eventum-irc
627 fi
628
629 %triggerin -- apache1 < 1.3.37-3, apache1-base
630 %webapp_register apache %{_webapp}
631
632 %triggerun -- apache1 < 1.3.37-3, apache1-base
633 %webapp_unregister apache %{_webapp}
634
635 %triggerin -- apache-base
636 %webapp_register httpd %{_webapp}
637
638 %triggerun -- apache-base
639 %webapp_unregister httpd %{_webapp}
640
641 %triggerin -- lighttpd
642 %webapp_register lighttpd %{_webapp}
643
644 %triggerun -- lighttpd
645 %webapp_unregister lighttpd %{_webapp}
646
647 %triggerpostun -- %{name} < 2.2-2.57
648 # switching eventum->http user
649 chgrp http %{_webappdir}/config.php
650 chgrp http %{_webappdir}/private_key.php
651 chgrp http %{_webappdir}/setup.php
652 chgrp http /var/log/%{name}/*
653 # update crontab user
654 for a in /etc/cron.d/eventum-*; do
655         [ -f "$a" ] || continue
656         awk '!/#/ && NR > 6 && $6 =="eventum" {sub("eventum", "http", $6)}{print}'  $a > $a.rpmtmp && cat $a.rpmtmp > $a
657         rm -f $a.rpmtmp
658
659         # crontabs moved to crons subdir
660         %{__sed} -i -e '
661                 s,/usr/share/eventum/process_mail_queue.php,/usr/share/eventum/crons/process_mail_queue.php,
662                 s,/usr/share/eventum/download_emails.php,/usr/share/eventum/crons/download_emails.php,
663                 s,/usr/share/eventum/check_reminders.php,/usr/share/eventum/crons/check_reminders.php,
664                 s,/usr/share/eventum/monitor.php,/usr/share/eventum/crons/monitor.php,
665         ' $a
666 done
667
668 %files -f %{name}.lang
669 %defattr(644,root,root,755)
670 %doc docs/* htdocs/setup/schema.sql
671 %attr(751,root,root) %dir %{_webappdir}
672 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
673 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
674 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
675 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
676 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
677 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
678 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
679
680 %dir %attr(731,root,http) /var/log/%{name}
681 %attr(620,root,http) %ghost /var/log/%{name}/*
682 %dir %attr(750,root,root) /var/log/archive/%{name}
683 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
684
685 %dir %{_appdir}/crons
686 %{_appdir}/init.php
687 %dir %{_appdir}/htdocs
688 %{_appdir}/htdocs/*.php
689 %{_appdir}/htdocs/*.ico
690 %{_appdir}/htdocs/css
691 %{_appdir}/htdocs/customer
692 %{_appdir}/htdocs/images
693 %{_appdir}/htdocs/js
694 %{_appdir}/htdocs/manage
695 %{_appdir}/htdocs/reports
696 %{_appdir}/htdocs/rpc
697 %{_appdir}/htdocs/misc
698 %if %{with order}
699 %{_appdir}/htdocs/ajax
700 %endif
701 %{_appdir}/templates
702
703 %dir %{_appdir}/upgrade
704 %{_appdir}/upgrade/init.php
705 %attr(755,root,root) %{_appdir}/upgrade/update-database.php
706 %attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
707 %dir %{_appdir}/upgrade/v*
708 %attr(755,root,root) %{_appdir}/upgrade/v*/*.php
709 %{_appdir}/upgrade/patches
710
711 %dir %{_appdir}/lib
712 %{_appdir}/lib/eventum
713 %{_appdir}/lib/jpgraph
714 %exclude %{_appdir}/lib/eventum/class.monitor.php
715 %{systemdtmpfilesdir}/%{name}.conf
716 %dir %attr(730,root,http) /var/run/%{name}
717 %dir %attr(730,root,http) /var/cache/%{name}
718
719 %files base
720 %defattr(644,root,root,755)
721 %attr(751,root,root) %dir %{_sysconfdir}
722 %dir %{_libdir}
723 %dir %{_appdir}
724 %dir /var/lib/%{name}
725 # saved mail copies
726 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
727 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
728 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
729
730 %files setup
731 %defattr(644,root,root,755)
732 %{_appdir}/htdocs/setup
733
734 %files mail-queue
735 %defattr(644,root,root,755)
736 %attr(755,root,root) %{_appdir}/crons/process_mail_queue.php
737 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
738
739 %files mail-download
740 %defattr(644,root,root,755)
741 %attr(755,root,root) %{_appdir}/crons/download_emails.php
742 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
743
744 %files reminder
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{_appdir}/crons/check_reminders.php
747 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
748
749 %files monitor
750 %defattr(644,root,root,755)
751 %{_appdir}/lib/eventum/class.monitor.php
752 %attr(755,root,root) %{_appdir}/crons/monitor.php
753 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
754
755 %files route-drafts
756 %defattr(644,root,root,755)
757 %attr(755,root,root) %{_appdir}/route_drafts.php
758
759 %files route-emails
760 %defattr(644,root,root,755)
761 %attr(755,root,root) %{_appdir}/route_emails.php
762
763 %files route-notes
764 %defattr(644,root,root,755)
765 %attr(755,root,root) %{_appdir}/route_notes.php
766
767 %files router-postfix
768 %defattr(644,root,root,755)
769 %attr(755,root,root) %{_libdir}/router-postfix
770
771 %files irc
772 %defattr(644,root,root,755)
773 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
774 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
775 %attr(755,root,root) %{_sbindir}/%{name}-irc-bot
776 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
777
778 %files cli
779 %defattr(644,root,root,755)
780 %doc cli/eventumrc
781 %attr(755,root,root) %{_bindir}/%{name}
782 %{_appdir}/cli
783
784 %files scm
785 %defattr(644,root,root,755)
786 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
787 %attr(755,root,root) %{_libdir}/process_cvs_commits
788 %attr(755,root,root) %{_libdir}/process_svn_commits
789 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
790 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
791
792 %files sphinx
793 %defattr(644,root,root,755)
794 %{_webappdir}/sphinx.conf.php
795 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
796 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.106982 seconds and 3 git commands to generate.