]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
e64fe72ac99e4f214d9befec8fb40ad843a0feff
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
9 #
10 # Conditional build:
11 %bcond_with     qmail   # build the router-qmail subpackage
12 %bcond_with     order_patch     # with custom issue order patch
13
14 #define _snap   20060330
15 #define _rc             RC3
16 %define _rel    2.25
17
18 %include        /usr/lib/rpm/macros.php
19 Summary:        Eventum Issue / Bug tracking system
20 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
21 Name:           eventum
22 Version:        1.7.1
23 Release:        %{?_snap:0.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
24 License:        GPL
25 Group:          Applications/WWW
26 #Source0:       http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{_snap}.tar.gz
27 Source0:        http://mysql.dataphone.se/Downloads/eventum/%{name}-%{version}.tar.gz
28 # Source0-md5:  e1845de39b4d9bd30ddec9c26031a7d5
29 Source1:        %{name}-apache.conf
30 Source2:        %{name}-mail-queue.cron
31 Source3:        %{name}-mail-download.cron
32 Source4:        %{name}-reminder.cron
33 Source5:        %{name}-monitor.cron
34 Source6:        %{name}-cvs.php
35 Source7:        %{name}-irc.php
36 Source8:        %{name}-irc.init
37 Source9:        %{name}-irc.sysconfig
38 Source10:       %{name}-config.php
39 Source11:       %{name}-router-qmail.sh
40 Source12:       %{name}-config-setup.php
41 Source13:       %{name}-upgrade.sh
42 Source14:       %{name}-router-postfix.sh
43 Source15:       %{name}.logrotate
44 Patch0:         %{name}-lf.patch
45 Patch1:         %{name}-perms.patch
46 Patch2:         %{name}-cli-wr-separated.patch
47 Patch3:         %{name}-scm-parse-response.patch
48 Patch4:         %{name}-double-decode.patch
49 Patch5:         %{name}-route-mem.patch
50 Patch6:         %{name}-scm-pluscharisbad.patch
51 Patch7:         %{name}-scm-updates.patch
52 Patch8:         %{name}-close-signature.patch
53 Patch9:         %{name}-list-sorting.patch
54 Patch10:        %{name}-workflow-handlenewnote-note_id.patch
55 Patch11:        %{name}-order4b.patch
56 Patch12:        %{name}-cli-errorcheck.patch
57 Patch13:        %{name}-combined.patch
58 Patch14:        %{name}-xml-inline.patch
59 Patch15:        %{name}-timetracking-advanced-logic.patch
60 Patch16:        %{name}-timedisplay.patch
61 Patch17:        %{name}-bug-17267.patch
62 Patch18:        %{name}-compact-issue-display.patch
63 Patch19:        %{name}-fixed-nav.patch
64 # packaging patches that probably never go upstream
65 Patch100:       %{name}-paths.patch
66 Patch101:       %{name}-cvs-config.patch
67 Patch102:       %{name}-irc-mem.patch
68 Patch103:       %{name}-irc-config.patch
69 Patch104:       %{name}-PEAR.patch
70 Patch105:       %{name}-httpclient-clientside.patch
71 Patch106:       %{name}-bot-reconnect.patch
72 Patch107:       %{name}-private-key.patch
73 URL:            http://dev.mysql.com/downloads/other/eventum/
74 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
75 BuildRequires:  rpmbuild(macros) >= 1.268
76 BuildRequires:  sed >= 4.0
77 Requires(triggerpostun):        /usr/bin/php
78 Requires(triggerpostun):        sed >= 4.0
79 Requires:       %{name}-base = %{version}-%{release}
80 Requires:       Smarty >= 2.6.10-4
81 Requires:       apache(mod_dir)
82 Requires:       php >= 3:4.2.0
83 Requires:       php-gd
84 Requires:       php-imap
85 Requires:       php-mysql
86 Requires:       php-pcre
87 Requires:       php-pear-Benchmark
88 Requires:       php-pear-DB
89 Requires:       php-pear-Date
90 Requires:       php-pear-HTTP_Request
91 Requires:       php-pear-Mail
92 Requires:       php-pear-Mail_Mime
93 Requires:       php-pear-Math_Stats
94 Requires:       php-pear-Net_DIME
95 Requires:       php-pear-Net_SMTP
96 Requires:       php-pear-Net_Socket
97 Requires:       php-pear-Net_URL
98 Requires:       php-pear-Net_UserAgent_Detect
99 Requires:       php-pear-PEAR-core
100 Requires:       php-pear-Text_Diff
101 Requires:       php-pear-XML_RPC
102 Requires:       php-session
103 Requires:       webapps
104 BuildArch:      noarch
105 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
108
109 %define         _libdir         %{_prefix}/lib/%{name}
110 %define         _appdir         %{_datadir}/%{name}
111 %define         _smartyplugindir        %{_appdir}/include/smarty
112 %define         _smartydir      /usr/share/php/Smarty
113 %define         _webapps        /etc/webapps
114 %define         _webapp         %{name}
115 %define         _webappdir      %{_webapps}/%{_webapp}
116 %define         _sysconfdir     /etc/%{name}
117
118 %description
119 Eventum is a user-friendly and flexible issue tracking system that can
120 be used by a support department to track incoming technical support
121 requests, or by a software development team to quickly organize tasks
122 and bugs. Eventum is used by the MySQL AB Technical Support team, and
123 has allowed us to dramatically improve our response times.
124
125 %description -l pl
126 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
127 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
128 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
129 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
130 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
131 reakcji.
132
133 %package base
134 Summary:        Eventum base package
135 Summary(pl):    Podstawowy pakiet Eventum
136 Group:          Applications/WWW
137 Requires(postun):       /usr/sbin/groupdel
138 Requires(postun):       /usr/sbin/userdel
139 Requires(pre):  /bin/id
140 Requires(pre):  /usr/bin/getgid
141 Requires(pre):  /usr/sbin/groupadd
142 Requires(pre):  /usr/sbin/useradd
143 Provides:       group(eventum)
144 Provides:       user(eventum)
145
146 %description base
147 This package contains base directory structure for Eventum.
148
149 %description base -l pl
150 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
151
152 %package setup
153 Summary:        Eventum setup package
154 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
155 Group:          Applications/WWW
156 Requires:       %{name} = %{version}-%{release}
157
158 %description setup
159 Install this package to configure initial Eventum installation. You
160 should uninstall this package when you're done, as it considered
161 insecure to keep the setup files in place.
162
163 %description setup -l pl
164 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
165 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
166 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
167
168 %package mail-queue
169 Summary:        Eventum mail queue process
170 Summary(pl):    Przetwarzanie kolejki poczty Eventum
171 Group:          Applications/WWW
172 Requires:       %{name} = %{version}-%{release}
173 Requires:       crondaemon
174
175 %description mail-queue
176 Beginning with the first release of Eventum, emails are not directly
177 sent out from the various scripts, but rather added to a mail queue
178 table that is processed by a cron job. If an email cannot be sent, it
179 will be marked as such in the mail queue log, and the cron job script
180 will re-try to send it again the next time it runs.
181
182 This package contains the cron job.
183
184 %description mail-queue -l pl
185 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
186 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
187 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
188 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
189 nastêpnym razem.
190
191 Ten pakiet zawiera zadanie dla crona.
192
193 %package mail-download
194 Summary:        Eventum email download
195 Summary(pl):    ¦ci±ganie poczty Eventum
196 Group:          Applications/WWW
197 Requires:       %{name} = %{version}-%{release}
198 Requires:       crondaemon
199
200 %description mail-download
201 In order for Eventum's email integration feature to work, you need to
202 setup a cron job to run the script every so often.
203
204 This package contains the cron job.
205
206 %description mail-download -l pl
207 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
208 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
209 czêsto.
210
211 Ten pakiet zawiera zadanie dla crona.
212
213 %package reminder
214 Summary:        Eventum Reminder System
215 Summary(pl):    System przypominania dla Eventum
216 Group:          Applications/WWW
217 Requires:       %{name} = %{version}-%{release}
218 Requires:       crondaemon
219
220 %description reminder
221 The reminder system was designed with the objective as serving as a
222 safe net for issues that need attention. Depending on what
223 configuration you create, you may have several reminders (or alerts)
224 be sent out whenever an issue needs attention, for whatever parameter
225 you may deem necessary.
226
227 This package contains the cron job.
228
229 %description reminder -l pl
230 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
231 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
232 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
233 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
234 uwa¿aæ za potrzebny.
235
236 Ten pakiet zawiera zadanie dla crona.
237
238 %package monitor
239 Summary:        Eventum Heartbeat Monitor
240 Summary(pl):    Monitor ¿ycia dla Eventum
241 Group:          Applications/WWW
242 Requires:       %{name} = %{version}-%{release}
243 Requires:       crondaemon
244 Requires:       php-posix
245
246 %description monitor
247 The heartbeat monitor is a feature designed for the administrator that
248 wants to be alerted whenever a common problem in Eventum is detected,
249 like the database server not being available anymore, or maybe when
250 the recommended permissions for certain configuration files are
251 changed.
252
253 Please note that before running the heartbeat monitor, you may need to
254 customize some of the checks to be appropriate for your own system,
255 particularly the permission and file checks on
256 Monitor::checkConfiguration().
257
258 This package contains the cron job.
259
260 %description monitor -l pl
261 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
262 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
263 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
264 do plików konfiguracyjnych.
265
266 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
267 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
268 testów uprawnieñ i plików w Monitor::checkConfiguration().
269
270 Ten pakiet zawiera zadanie dla crona.
271
272 %package route-drafts
273 Summary:        Eventum Draft Routing
274 Summary(pl):    Przekazywanie szkiców dla Eventum
275 Group:          Applications/WWW
276 Requires:       %{name} = %{version}-%{release}
277 Requires:       eventum(router)
278
279 %description route-drafts
280 The draft routing feature is used to automatically associate a thread
281 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
282 to deliver emails sent to a specific address (usually
283 draft-<number>@<domain>) to the above script, users are able to send
284 drafts written in their mail client to be stored in Eventum. These
285 drafts will NOT broadcasted to the notification list.
286
287 %description route-drafts -l pl
288 Przekazywanie szkiców s³u¿y do automatycznego wi±zania w±tku szkiców z
289 problemem w Eventum. Ustawiaj±c qmaila (czy nawet Postfiksa), aby
290 dostarcza³ pocztê wys³an± na podany adres (zwykle
291 draft-<liczba>@<domena>) do tego skryptu umo¿liwia siê u¿ytkownikom
292 wysy³anie szkiców napisanych w ich kliencie pocztowym do zapisania w
293 Eventum. Szkice te NIE bêd± wysy³ane na listê powiadomieñ.
294
295 %package route-emails
296 Summary:        Eventum Email Routing
297 Summary(pl):    Przekazywanie poczty dla Eventum
298 Group:          Applications/WWW
299 Requires:       %{name} = %{version}-%{release}
300 Requires:       eventum(router)
301
302 %description route-emails
303 The email routing feature is used to automatically associate a thread
304 of emails into an Eventum issue. By setting up qmail (or even postfix)
305 to deliver emails sent to a specific address (usually
306 issue-<number>@<domain>) to the above script, users are able to use
307 their email clients to reply to emails coming from Eventum, and those
308 replies will be automatically associated with the issue and
309 broadcasted to the entire notification list.
310
311 %description route-emails -l pl
312 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
313 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
314 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
315 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
316 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
317 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
318 rozprowadzane do ca³ej listy og³oszeniowej.
319
320 %package route-notes
321 Summary:        Eventum Note Routing
322 Summary(pl):    Przekazywanie notatek dla Eventum
323 Group:          Applications/WWW
324 Requires:       %{name} = %{version}-%{release}
325 Requires:       eventum(router)
326
327 %description route-notes
328 The note routing feature is used to automatically associate a thread
329 of notes into an Eventum issue. By setting up qmail (or even postfix)
330 to deliver emails sent to a specific address (usually
331 note-<number>@<domain>) to the above script, users are able to use
332 their email clients to reply to internal notes coming from Eventum,
333 and those replies will be automatically associated with the issue and
334 broadcasted to the notification list staff members.
335
336 %description route-notes -l pl
337 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
338 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
339 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
340 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
341 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
342 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
343 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
344
345 %package router-qmail
346 Summary:        Eventum Mail Routing - qmail
347 Summary(pl):    Przekazywanie poczty Eventum - qmail
348 Group:          Applications/Mail
349 # loose dep is intentional. qmail subpackage isn't built on PLD
350 # builders and there really nothing changes.
351 Requires:       %{name} >= %{version}-%{release}
352 Requires:       qmail >= 1.03
353 Provides:       eventum(router)
354 Obsoletes:      eventum(router)
355
356 %description router-qmail
357 This package provides way of routing notes and emails back to Eventum
358 via qmail.
359
360 %description router-qmail -l pl
361 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
362 przez qmaila.
363
364 %package router-postfix
365 Summary:        Eventum Mail Routing - Postfix
366 Summary(pl):    Przekazywanie poczty Eventum - Postfix
367 Group:          Applications/Mail
368 Requires:       %{name} = %{version}-%{release}
369 Requires:       postfix
370 Provides:       eventum(router)
371 Obsoletes:      eventum(router)
372
373 %description router-postfix
374 This package provides way of routing notes and emails back to Eventum
375 via Postfix.
376
377 The Postfix configuration instructions you can find from
378 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
379
380 %description router-postfix -l pl
381 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
382 przez Postfiksa.
383
384 Opis konfiguracji Postfiksa mo¿na znale¼æ pod adresem
385 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
386
387 %package irc
388 Summary:        Eventum IRC Notification Bot
389 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
390 Group:          Applications/WWW
391 Requires(post,preun):   /sbin/chkconfig
392 Requires(triggerpostun):        sed >= 4.0
393 Requires:       %{name} = %{version}-%{release}
394 Requires:       php-pear-Net_SmartIRC
395 Requires:       php-sockets
396 Requires:       rc-scripts >= 0.4.0.18
397
398 %description irc
399 The IRC notification bot is a nice feature for remote teams that want
400 to handle issues and want to have a quick and easy way to get simple
401 notifications. Right now the bot notifies of the following actions:
402 - New Issues
403 - Blocked emails
404 - Issues that got their assignment list changed
405
406 NOTE: You will need to manually edit the bot.php script to set your
407 appropriate preferences, like IRC server and channel that the bot
408 should join.
409
410 %description irc -l pl
411 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
412 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
413 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
414 nastêpuj±cych zdarzeniach:
415 - nowych sprawach
416 - zablokowanych listach
417 - sprawach, dla których zmieni³a siê lista powi±zañ
418
419 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
420 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
421
422 %package cli
423 Summary:        Eventum command-line interface
424 Summary(pl):    Interfejs linii poleceñ dla Eventum
425 Group:          Applications/WWW
426 Requires:       %{name}-base = %{version}-%{release}
427 Requires:       php-cli
428 Requires:       php-common >= 3:4.1.0
429 Requires:       php-pear-XML_RPC
430
431 %description cli
432 The Eventum command-line interface allows you to access most of the
433 features of the web interface straight from your command shell.
434
435 %description cli -l pl
436 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
437 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
438
439 %package scm
440 Summary:        Eventum SCM integration
441 Summary(pl):    Integracja SCM dla Eventum
442 Group:          Applications/WWW
443 Requires:       %{name}-base = %{version}-%{release}
444 Requires:       php-cli
445 Requires:       php-common >= 3:4.1.0
446 Requires:       php-pcre
447
448 %description scm
449 This feature allows your software development teams to integrate your
450 Source Control Management system with your Issue Tracking System.
451
452 The integration is implemented in such a way that it will be forward
453 compatible with pretty much any SCM system, such as CVS.
454
455 For installation see
456 </eventum/help.php?topic=scm_integration_installation>.
457
458 %description scm -l pl
459 Ten pakiet pozwala zespo³om programistów na integracjê systemu
460 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
461 ¶ledzenia spraw.
462
463 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
464 prawie ka¿dym systemem SCM, jak np. CVS.
465
466 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
467 </eventum/help.php?topic=scm_integration_installation>.
468
469 %prep
470 %setup -q %{?_snap:-n %{name}-%{_snap}}
471 # undos the source
472 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
473
474 rm -f setup.conf.php # not to be installed by *.php glob
475 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
476 rm -f misc/upgrade/flush_compiled_templates.php
477 rm -rf misc/upgrade/*/upgrade_config.php # not needed in PLD Linux
478
479 # sample, not used in eventum
480 rm -f rpc/xmlrpc_client.php
481
482 # bug fixes.
483 %patch0 -p1
484 %patch1 -p1
485 %patch2 -p1
486 %patch3 -p1
487 %patch4 -p1
488 %patch5 -p1
489 %patch6 -p1
490 %patch7 -p1
491 %patch8 -p1
492 %patch9 -p1
493 %patch10 -p1
494 %{?with_order_patch:%patch11 -p1}
495 %patch12 -p1
496 %patch13 -p1
497 %patch14 -p1
498 %patch15 -p1
499 %patch16 -p1
500 %patch17 -p1
501 %patch18 -p1
502 %patch19 -p1
503
504 # packaging
505 %patch100 -p1
506 %patch101 -p1
507 %patch102 -p1
508 %patch103 -p1
509 %patch104 -p1
510 %patch105 -p1
511 %patch106 -p1
512 %patch107 -p1
513
514 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
515 sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
516 sed -e '1i#!%{_bindir}/php' misc/irc/bot.php > %{name}-bot
517 mv misc/cli/eventumrc_example eventumrc
518 sed -i -e '1i#!%{_bindir}/php' misc/*.php
519 chmod +x misc/*.php
520 mv include/private_key.php private_key.php.in
521
522 # replace in remaining scripts config.inc.php to system one
523 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
524         s,include_once(".*config.inc.php"),include_once("%{_webappdir}/core.php"),
525 '
526
527 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
528         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_webappdir}/private_key.php"),
529 '
530
531 # remove backups from patching as we use globs to package files to buildroot
532 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
533
534 %install
535 rm -rf $RPM_BUILD_ROOT
536 install -d \
537         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
538         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
539         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
540         $RPM_BUILD_ROOT/var/log/{archiv/,}%{name} \
541         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
542         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
543
544 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
545 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
546 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
547 cp -a templates $RPM_BUILD_ROOT%{_appdir}
548 cp -a include/{customer,custom_field,jpgraph,workflow} $RPM_BUILD_ROOT%{_appdir}/include
549 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
550 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
551 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
552
553 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
554 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
555 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
556
557 # cli
558 install -d $RPM_BUILD_ROOT%{_appdir}/cli
559 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
560 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
561 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
562 install %{name}-bot $RPM_BUILD_ROOT%{_sbindir}
563
564 # scm
565 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
566 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
567
568 # private key
569 cp -a private_key.php.in $RPM_BUILD_ROOT%{_webappdir}/private_key.php
570
571 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
572 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
573 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
574 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
575 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
576 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
577 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
578 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
579 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
580
581 sed -e '
582 s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}}%{?_rc:-%{_rc}},
583 s,%%{PHP_PEAR_DIR}%%,%{php_pear_dir},
584 s,%%{APP_PATH}%%,%{_appdir},
585 s,%%{SMARTY_DIR}%%,%{_smartydir},
586 s,%%{SYSCONFDIR}%%,%{_webappdir},
587 ' %{SOURCE10} > $RPM_BUILD_ROOT%{_webappdir}/core.php
588
589 # config
590 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
591 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_webappdir}/config}.php
592
593 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
594 # These plugins are not in Smarty package (Smarty-2.6.2-3)
595 cp -a \
596         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
597         include/Smarty/plugins/modifier.highlight_quoted.php \
598         $RPM_BUILD_ROOT%{_smartyplugindir}
599
600 # qmail router
601 %if %{with qmail}
602 d=$RPM_BUILD_ROOT/var/lib/%{name}
603 echo 'root' > $d/.qmail
604 echo 'root' > $d/.qmail-default
605 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
606 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
607 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
608 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
609 %endif
610 # postfix router
611 install %{SOURCE14} $RPM_BUILD_ROOT%{_libdir}/router-postfix
612
613 install -D %{SOURCE15} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
614
615 %clean
616 rm -rf $RPM_BUILD_ROOT
617
618 %pre
619 %addusertogroup http %{name}
620
621 %post
622 # check if the package is configured.
623 if grep -q 'header("Location: setup/")' %{_webappdir}/config.php; then
624 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
625 %banner %{name} -e <<EOF
626
627 You haven't yet configured Eventum!
628 Please open in browser <http://localhost/eventum/>
629 If you need access from elsewhere, you need to edit
630 %{_webappdir}/apache.conf and restart apache.
631
632 IMPORTANT: When You have configured Eventum, please uninstall the
633 setup package, so that %{name}-setup is able to secure your Eventum
634 installation.
635
636 EOF
637 #' vim syntax hack
638 else
639 %banner %{name} -e <<EOF
640
641 You haven't yet configured Eventum!
642
643 To setup eventum, please install %{name}-setup and open in browser
644 <http://localhost/eventum/>.
645 If you need access from elsewhere, you need to edit
646 %{_webappdir}/apache.conf and restart apache.
647
648 IMPORTANT: When You have configured Eventum, please uninstall the
649 setup package, so that %{name}-setup is able to secure your Eventum
650 installation.
651
652 EOF
653 #' vim syntax hack
654 fi
655
656 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
657 %banner %{name} -e <<EOF
658
659 You have default private key installed!
660
661 Install %{name}-setup and open up http://yourserver/eventum/setup/
662 -- that will help you setup initial config.
663
664 when have configured Eventum, please uninstall the setup package,
665 so that %{name}-setup is able to secure your Eventum installation.
666
667 EOF
668         elif [ -d %{_appdir}/setup ]; then
669 %banner %{name} -e <<EOF
670
671 If you have have configured Eventum, please uninstall the setup package,
672 so that %{name}-setup is able to secure your Eventum installation.
673
674 EOF
675 fi
676
677 # nuke Smarty templates cache after upgrade
678 rm -f /var/cache/eventum/*.php
679
680 %preun
681 if [ "$1" = "0" ]; then
682         # nuke cache
683         rm -f /var/cache/eventum/*.php 2>/dev/null || :
684 fi
685
686 %pre base
687 %groupadd -P %{name}-base -g 146 %{name}
688 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
689
690 %postun base
691 if [ "$1" = "0" ]; then
692         %userremove %{name}
693         %groupremove %{name}
694 fi
695
696 %post router-qmail
697 CF=/etc/qmail/control/virtualdomains
698 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
699         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
700         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
701         umask 022
702         echo "#${FQDN}:%{name}" >> $CF
703
704 %banner %{name}-qmail -e <<EOF
705
706 Added "#${FQDN}:%{name}" to $CF,
707 Please verify that it is correct and restart qmail:
708 # service qmail reload
709
710 Consult qmail-send(8) for more information on virtualdomains.
711
712 EOF
713 fi
714
715 %preun router-qmail
716 if [ "$1" = "0" ]; then
717         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
718 fi
719
720 %post setup
721 chmod 660 %{_webappdir}/{config,private_key}.php
722 chown root:eventum %{_webappdir}/{config,private_key}.php
723
724 %postun setup
725 if [ "$1" = "0" ]; then
726         chmod 640 %{_webappdir}/{config,private_key}.php
727         chown root:eventum %{_webappdir}/{config,private_key}.php
728 fi
729
730 %post irc
731 /sbin/chkconfig --add eventum-irc
732 %service eventum-irc restart "Eventum IRC Bot"
733
734 %preun irc
735 if [ "$1" = 0 ]; then
736         %service eventum-irc stop
737         /sbin/chkconfig --del eventum-irc
738 fi
739
740 %triggerin -- apache1
741 %webapp_register apache %{_webapp}
742
743 %triggerun -- apache1
744 %webapp_unregister apache %{_webapp}
745
746 %triggerin -- apache < 2.2.0, apache-base
747 %webapp_register httpd %{_webapp}
748
749 %triggerun -- apache < 2.2.0, apache-base
750 %webapp_unregister httpd %{_webapp}
751
752 # FIXME
753 # only one upgrade trigger is called if you're upgrading over two
754 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
755 # use common trigger (the highest version and rpmvercmp from poldek?)
756 %triggerpostun -- eventum < 1.5.1-0.257
757 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
758 database_changes.php Perform database changes
759 EOF
760
761 %triggerpostun -- eventum < 1.5.2-0.289
762 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
763 database_changes.php Perform database changes
764 set_priority_ranks.php Fix the ranking of priority values
765 EOF
766
767 %triggerpostun -- eventum < 1.5.3-0.291
768 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
769 database_changes.php Perform database changes
770 EOF
771
772 %triggerpostun -- eventum < 1.5.4-1.12
773 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
774 database_changes.php Perform database changes
775 EOF
776
777 %triggerpostun -- eventum < 1.6.0-RC2.6
778 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
779 database_changes.php Perform database changes
780 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
781 EOF
782
783 %triggerpostun -- eventum < 1.6.1-0.2
784 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
785 database_changes.php Perform database changes
786 EOF
787
788 %triggerpostun irc -- eventum-irc < 1.6.1-3.14
789 sed -i -e '
790 s,\$irc_host,$irc_server_hostname,
791 s,\$irc_port,$irc_server_port,
792 s,\$irc_nick,$nickname,
793 s,\$irc_realname,$realname,
794 s,\$irc_username,$username,
795 s,\$irc_password,$password,
796 ' /etc/eventum/irc.php
797
798 %triggerpostun -- eventum < 1.7.0-2.0.48
799 # migrate from apache-config macros
800 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
801         if [ -d /etc/apache/webapps.d ]; then
802                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
803                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
804         fi
805
806         if [ -d /etc/httpd/webapps.d ]; then
807                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
808                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
809         fi
810 fi
811
812 if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
813         /usr/sbin/webapp register apache %{_webapp}
814         rm -f /etc/apache/conf.d/99_%{_webapp}.conf
815         %service -q apache reload
816 fi
817 if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
818         /usr/sbin/webapp register httpd %{_webapp}
819         rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
820         %service -q httpd reload
821 fi
822
823 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
824 database_changes.php Perform database changes
825 set_root_message_ids.php Set iss_root_message_id
826 EOF
827
828 # regular configs
829 for i in apache.conf config.php private_key.php setup.php; do
830         if [ -f /etc/eventum/$i.rpmsave ]; then
831                 mv -f %{_webappdir}/$i{,.rpmnew}
832                 mv -f /etc/eventum/$i.rpmsave %{_webappdir}/$i
833         fi
834 done
835
836 %triggerpostun cli -- %{name}-cli < 1.7.0-3.4
837 if [ -f %{_webappdir}/cli.php.rpmsave ]; then
838         mv -f %{_sysconfdir}/cli.php{,.rpmnew}
839         mv -f %{_webappdir}/cli.php.rpmsave %{_sysconfdir}/cli.php
840 fi
841
842 %triggerpostun irc -- %{name}-irc < 1.7.0-3.4
843 if [ -f %{_webappdir}/irc.php.rpmsave ]; then
844         mv -f %{_sysconfdir}/irc.php{,.rpmnew}
845         mv -f %{_webappdir}/irc.php.rpmsave %{_sysconfdir}/irc.php
846 fi
847
848 %files
849 %defattr(644,root,root,755)
850 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
851 %doc docs/* setup/schema.sql
852 %attr(751,root,root) %dir %{_webappdir}
853 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
854 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
855 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
856 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
857 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
858 %attr(640,root,eventum) %config %verify(not mtime) %{_webappdir}/core.php
859
860 %dir %attr(731,root,eventum) /var/log/%{name}
861 %attr(620,root,eventum) %ghost /var/log/%{name}/*
862 %dir %attr(750,root,root) /var/log/archiv/%{name}
863 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
864
865 %dir %{_appdir}/htdocs
866 %{_appdir}/htdocs/*.php
867 %{_appdir}/htdocs/*.ico
868 %{_appdir}/htdocs/css
869 %{_appdir}/htdocs/customer
870 %{_appdir}/htdocs/images
871 %{_appdir}/htdocs/js
872 %{_appdir}/htdocs/manage
873 %{_appdir}/htdocs/reports
874 %{_appdir}/htdocs/rpc
875 %{_appdir}/htdocs/misc
876 %{_appdir}/templates
877 %dir %{_appdir}/upgrade
878 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
879 %{_appdir}/upgrade/[!u]*
880 %{_smartyplugindir}
881
882 %dir %{_appdir}/include
883 %{_appdir}/include/customer
884 %{_appdir}/include/custom_field
885 %{_appdir}/include/jpgraph
886 %{_appdir}/include/workflow
887 %{_appdir}/include/class.[!m]*.php
888 %{_appdir}/include/class.mail.php
889 %{_appdir}/include/class.mail_queue.php
890 %{_appdir}/include/class.mime_helper.php
891 %{_appdir}/include/class.misc.php
892 %{_appdir}/include/db_access.php
893
894 %dir %attr(730,root,eventum) /var/run/%{name}
895 %dir %attr(730,root,eventum) /var/cache/%{name}
896
897 %files base
898 %defattr(644,root,root,755)
899 %attr(751,root,root) %dir %{_sysconfdir}
900 %dir %{_libdir}
901 %dir %{_appdir}
902 # qmail will ignore user, if it's home directory is not owned
903 %attr(750,eventum,eventum) %dir /var/lib/%{name}
904 # saved mail copies
905 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
906 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
907 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
908
909 %files setup
910 %defattr(644,root,root,755)
911 %{_appdir}/htdocs/setup
912
913 %files mail-queue
914 %defattr(644,root,root,755)
915 %attr(755,root,root) %{_appdir}/process_mail_queue.php
916 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
917
918 %files mail-download
919 %defattr(644,root,root,755)
920 %attr(755,root,root) %{_appdir}/download_emails.php
921 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
922
923 %files reminder
924 %defattr(644,root,root,755)
925 %attr(755,root,root) %{_appdir}/check_reminders.php
926 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
927
928 %files monitor
929 %defattr(644,root,root,755)
930 %{_appdir}/include/class.monitor.php
931 %attr(755,root,root) %{_appdir}/monitor.php
932 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
933
934 %files route-drafts
935 %defattr(644,root,root,755)
936 %attr(755,root,root) %{_appdir}/route_drafts.php
937
938 %files route-emails
939 %defattr(644,root,root,755)
940 %attr(755,root,root) %{_appdir}/route_emails.php
941
942 %files route-notes
943 %defattr(644,root,root,755)
944 %attr(755,root,root) %{_appdir}/route_notes.php
945
946 %if %{with qmail}
947 %files router-qmail
948 %defattr(644,root,root,755)
949 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
950 %attr(755,root,root) %{_libdir}/router-qmail
951 %endif
952
953 %files router-postfix
954 %defattr(644,root,root,755)
955 %attr(755,root,root) %{_libdir}/router-postfix
956
957 %files irc
958 %defattr(644,root,root,755)
959 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
960 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
961 %attr(755,root,root) %{_sbindir}/%{name}-bot
962 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
963
964 %files cli
965 %defattr(644,root,root,755)
966 %doc eventumrc
967 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
968 %attr(755,root,root) %{_bindir}/%{name}
969 %{_appdir}/cli
970
971 %files scm
972 %defattr(644,root,root,755)
973 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
974 %attr(755,root,root) %{_libdir}/scm
This page took 0.096191 seconds and 2 git commands to generate.