]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
be3344d567605b1c6cb40bfc797df526203b82e1
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - discard bundled packages (from INSTALL):
3 #  - JpGraph 1.5.3 (last GPL version)
4 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
5 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
6 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
7 #  - A few other small javascript libraries
8 # - 64bit platforms beware? http://bugs.php.net/bug.php?id=30215 (it's actually Smarty related problem)
9 #
10 # Conditional build:
11 %bcond_with     qmail   # build the router-qmail subpackage
12 %bcond_with     order_patch     # with custom issue order patch
13
14 #define _snap   20060330
15 #define _rc             RC3
16 %define _rel    1.6
17
18 %include        /usr/lib/rpm/macros.php
19 Summary:        Eventum Issue / Bug tracking system
20 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
21 Name:           eventum
22 Version:        1.7.1
23 Release:        %{?_snap:0.%{_snap}.}%{?_rc:%{_rc}.}%{_rel}
24 License:        GPL
25 Group:          Applications/WWW
26 #Source0:       http://downloads.mysql.com/snapshots/eventum/%{name}-nightly-%{_snap}.tar.gz
27 Source0:        http://mysql.dataphone.se/Downloads/eventum/%{name}-%{version}.tar.gz
28 # Source0-md5:  e1845de39b4d9bd30ddec9c26031a7d5
29 Source1:        %{name}-apache.conf
30 Source2:        %{name}-mail-queue.cron
31 Source3:        %{name}-mail-download.cron
32 Source4:        %{name}-reminder.cron
33 Source5:        %{name}-monitor.cron
34 Source6:        %{name}-cvs.php
35 Source7:        %{name}-irc.php
36 Source8:        %{name}-irc.init
37 Source9:        %{name}-irc.sysconfig
38 Source10:       %{name}-config.php
39 Source11:       %{name}-router-qmail.sh
40 Source12:       %{name}-config-setup.php
41 Source13:       %{name}-upgrade.sh
42 Source14:       %{name}-router-postfix.sh
43 Patch0:         %{name}-lf.patch
44 Patch1:         %{name}-perms.patch
45 Patch2:         %{name}-cli-wr-separated.patch
46 Patch3:         %{name}-scm-parse-response.patch
47 Patch4:         %{name}-double-decode.patch
48 Patch5:         %{name}-route-mem.patch
49 Patch6:         %{name}-scm-pluscharisbad.patch
50 Patch7:         %{name}-scm-updates.patch
51 Patch8:         %{name}-close-signature.patch
52 Patch9:         %{name}-list-sorting.patch
53 Patch10:        %{name}-workflow-handlenewnote-note_id.patch
54 Patch11:        %{name}-order4b.patch
55 Patch100:       %{name}-paths.patch
56 Patch101:       %{name}-cvs-config.patch
57 Patch102:       %{name}-irc-mem.patch
58 Patch103:       %{name}-irc-config.patch
59 Patch104:       %{name}-PEAR.patch
60 Patch105:       %{name}-httpclient-clientside.patch
61 Patch106:       %{name}-bot-reconnect.patch
62 Patch107:       %{name}-private-key.patch
63 URL:            http://dev.mysql.com/downloads/other/eventum/
64 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
65 BuildRequires:  rpmbuild(macros) >= 1.268
66 BuildRequires:  sed >= 4.0
67 Requires(triggerpostun):        /usr/bin/php
68 Requires(triggerpostun):        sed >= 4.0
69 Requires:       %{name}-base = %{version}-%{release}
70 Requires:       Smarty >= 2.6.10-4
71 Requires:       apache(mod_dir)
72 Requires:       php >= 3:4.2.0
73 Requires:       php-gd
74 Requires:       php-imap
75 Requires:       php-mysql
76 Requires:       php-pcre
77 Requires:       php-pear-Benchmark
78 Requires:       php-pear-DB
79 Requires:       php-pear-Date
80 Requires:       php-pear-HTTP_Request
81 Requires:       php-pear-Mail
82 Requires:       php-pear-Mail_Mime
83 Requires:       php-pear-Math_Stats
84 Requires:       php-pear-Net_DIME
85 Requires:       php-pear-Net_SMTP
86 Requires:       php-pear-Net_Socket
87 Requires:       php-pear-Net_URL
88 Requires:       php-pear-Net_UserAgent_Detect
89 Requires:       php-pear-PEAR-core
90 Requires:       php-pear-Text_Diff
91 Requires:       php-pear-XML_RPC
92 Requires:       php-session
93 Requires:       webapps
94 BuildArch:      noarch
95 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
96
97 %define         _noautoreq      'pear(/etc/webapps/.*)' 'pear(jpgraph_dir.php)' 'pear(.*Smarty.class.php)'
98
99 %define         _libdir         %{_prefix}/lib/%{name}
100 %define         _appdir         %{_datadir}/%{name}
101 %define         _smartyplugindir        %{_appdir}/include/smarty
102 %define         _smartydir      /usr/share/php/Smarty
103 %define         _webapps        /etc/webapps
104 %define         _webapp         %{name}
105 %define         _webappdir      %{_webapps}/%{_webapp}
106 %define         _sysconfdir     /etc/%{name}
107
108 %description
109 Eventum is a user-friendly and flexible issue tracking system that can
110 be used by a support department to track incoming technical support
111 requests, or by a software development team to quickly organize tasks
112 and bugs. Eventum is used by the MySQL AB Technical Support team, and
113 has allowed us to dramatically improve our response times.
114
115 %description -l pl
116 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
117 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
118 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
119 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
120 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
121 reakcji.
122
123 %package base
124 Summary:        Eventum base package
125 Summary(pl):    Podstawowy pakiet Eventum
126 Group:          Applications/WWW
127 Requires(postun):       /usr/sbin/groupdel
128 Requires(postun):       /usr/sbin/userdel
129 Requires(pre):  /bin/id
130 Requires(pre):  /usr/bin/getgid
131 Requires(pre):  /usr/sbin/groupadd
132 Requires(pre):  /usr/sbin/useradd
133 Provides:       group(eventum)
134 Provides:       user(eventum)
135
136 %description base
137 This package contains base directory structure for Eventum.
138
139 %description base -l pl
140 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
141
142 %package setup
143 Summary:        Eventum setup package
144 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
145 Group:          Applications/WWW
146 Requires:       %{name} = %{version}-%{release}
147
148 %description setup
149 Install this package to configure initial Eventum installation. You
150 should uninstall this package when you're done, as it considered
151 insecure to keep the setup files in place.
152
153 %description setup -l pl
154 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
155 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
156 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
157
158 %package mail-queue
159 Summary:        Eventum mail queue process
160 Summary(pl):    Przetwarzanie kolejki poczty Eventum
161 Group:          Applications/WWW
162 Requires:       %{name} = %{version}-%{release}
163 Requires:       crondaemon
164
165 %description mail-queue
166 Beginning with the first release of Eventum, emails are not directly
167 sent out from the various scripts, but rather added to a mail queue
168 table that is processed by a cron job. If an email cannot be sent, it
169 will be marked as such in the mail queue log, and the cron job script
170 will re-try to send it again the next time it runs.
171
172 This package contains the cron job.
173
174 %description mail-queue -l pl
175 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
176 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
177 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
178 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
179 nastêpnym razem.
180
181 Ten pakiet zawiera zadanie dla crona.
182
183 %package mail-download
184 Summary:        Eventum email download
185 Summary(pl):    ¦ci±ganie poczty Eventum
186 Group:          Applications/WWW
187 Requires:       %{name} = %{version}-%{release}
188 Requires:       crondaemon
189
190 %description mail-download
191 In order for Eventum's email integration feature to work, you need to
192 setup a cron job to run the script every so often.
193
194 This package contains the cron job.
195
196 %description mail-download -l pl
197 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
198 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
199 czêsto.
200
201 Ten pakiet zawiera zadanie dla crona.
202
203 %package reminder
204 Summary:        Eventum Reminder System
205 Summary(pl):    System przypominania dla Eventum
206 Group:          Applications/WWW
207 Requires:       %{name} = %{version}-%{release}
208 Requires:       crondaemon
209
210 %description reminder
211 The reminder system was designed with the objective as serving as a
212 safe net for issues that need attention. Depending on what
213 configuration you create, you may have several reminders (or alerts)
214 be sent out whenever an issue needs attention, for whatever parameter
215 you may deem necessary.
216
217 This package contains the cron job.
218
219 %description reminder -l pl
220 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
221 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
222 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
223 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
224 uwa¿aæ za potrzebny.
225
226 Ten pakiet zawiera zadanie dla crona.
227
228 %package monitor
229 Summary:        Eventum Heartbeat Monitor
230 Summary(pl):    Monitor ¿ycia dla Eventum
231 Group:          Applications/WWW
232 Requires:       %{name} = %{version}-%{release}
233 Requires:       crondaemon
234 Requires:       php-posix
235
236 %description monitor
237 The heartbeat monitor is a feature designed for the administrator that
238 wants to be alerted whenever a common problem in Eventum is detected,
239 like the database server not being available anymore, or maybe when
240 the recommended permissions for certain configuration files are
241 changed.
242
243 Please note that before running the heartbeat monitor, you may need to
244 customize some of the checks to be appropriate for your own system,
245 particularly the permission and file checks on
246 Monitor::checkConfiguration().
247
248 This package contains the cron job.
249
250 %description monitor -l pl
251 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
252 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
253 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
254 do plików konfiguracyjnych.
255
256 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
257 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
258 testów uprawnieñ i plików w Monitor::checkConfiguration().
259
260 Ten pakiet zawiera zadanie dla crona.
261
262 %package route-drafts
263 Summary:        Eventum Draft Routing
264 Summary(pl):    Przekazywanie szkiców dla Eventum
265 Group:          Applications/WWW
266 Requires:       %{name} = %{version}-%{release}
267 Requires:       eventum(router)
268
269 %description route-drafts
270 The draft routing feature is used to automatically associate a thread
271 of drafts into an Eventum issue. By setting up qmail (or even Postfix)
272 to deliver emails sent to a specific address (usually
273 draft-<number>@<domain>) to the above script, users are able to send
274 drafts written in their mail client to be stored in Eventum. These
275 drafts will NOT broadcasted to the notification list.
276
277 %description route-drafts -l pl
278 Przekazywanie szkiców s³u¿y do automatycznego wi±zania w±tku szkiców z
279 problemem w Eventum. Ustawiaj±c qmaila (czy nawet Postfiksa), aby
280 dostarcza³ pocztê wys³an± na podany adres (zwykle
281 draft-<liczba>@<domena>) do tego skryptu umo¿liwia siê u¿ytkownikom
282 wysy³anie szkiców napisanych w ich kliencie pocztowym do zapisania w
283 Eventum. Szkice te NIE bêd± wysy³ane na listê powiadomieñ.
284
285 %package route-emails
286 Summary:        Eventum Email Routing
287 Summary(pl):    Przekazywanie poczty dla Eventum
288 Group:          Applications/WWW
289 Requires:       %{name} = %{version}-%{release}
290 Requires:       eventum(router)
291
292 %description route-emails
293 The email routing feature is used to automatically associate a thread
294 of emails into an Eventum issue. By setting up qmail (or even postfix)
295 to deliver emails sent to a specific address (usually
296 issue-<number>@<domain>) to the above script, users are able to use
297 their email clients to reply to emails coming from Eventum, and those
298 replies will be automatically associated with the issue and
299 broadcasted to the entire notification list.
300
301 %description route-emails -l pl
302 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
303 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
304 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
305 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
306 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
307 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
308 rozprowadzane do ca³ej listy og³oszeniowej.
309
310 %package route-notes
311 Summary:        Eventum Note Routing
312 Summary(pl):    Przekazywanie notatek dla Eventum
313 Group:          Applications/WWW
314 Requires:       %{name} = %{version}-%{release}
315 Requires:       eventum(router)
316
317 %description route-notes
318 The note routing feature is used to automatically associate a thread
319 of notes into an Eventum issue. By setting up qmail (or even postfix)
320 to deliver emails sent to a specific address (usually
321 note-<number>@<domain>) to the above script, users are able to use
322 their email clients to reply to internal notes coming from Eventum,
323 and those replies will be automatically associated with the issue and
324 broadcasted to the notification list staff members.
325
326 %description route-notes -l pl
327 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
328 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
329 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
330 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
331 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
332 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
333 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
334
335 %package router-qmail
336 Summary:        Eventum Mail Routing - qmail
337 Summary(pl):    Przekazywanie poczty Eventum - qmail
338 Group:          Applications/Mail
339 # loose dep is intentional. qmail subpackage isn't built on PLD
340 # builders and there really nothing changes.
341 Requires:       %{name} >= %{version}-%{release}
342 Requires:       qmail >= 1.03
343 Provides:       eventum(router)
344 Obsoletes:      eventum(router)
345
346 %description router-qmail
347 This package provides way of routing notes and emails back to Eventum
348 via qmail.
349
350 %description router-qmail -l pl
351 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
352 przez qmaila.
353
354 %package router-postfix
355 Summary:        Eventum Mail Routing - Postfix
356 Summary(pl):    Przekazywanie poczty Eventum - Postfix
357 Group:          Applications/Mail
358 Requires:       %{name} = %{version}-%{release}
359 Requires:       postfix
360 Provides:       eventum(router)
361 Obsoletes:      eventum(router)
362
363 %description router-postfix
364 This package provides way of routing notes and emails back to Eventum
365 via Postfix.
366
367 The Postfix configuration instructions you can find from
368 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
369
370 %description router-postfix -l pl
371 Ten pakiet udostêpnia metodê przekazywania notatek i listów do Eventum
372 przez Postfiksa.
373
374 Opis konfiguracji Postfiksa mo¿na znale¼æ pod adresem
375 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
376
377 %package irc
378 Summary:        Eventum IRC Notification Bot
379 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
380 Group:          Applications/WWW
381 Requires(triggerpostun):        sed >= 4.0
382 Requires:       %{name} = %{version}-%{release}
383 Requires:       php-pear-Net_SmartIRC
384 Requires:       php-sockets
385 Requires:       rc-scripts >= 0.4.0.18
386
387 %description irc
388 The IRC notification bot is a nice feature for remote teams that want
389 to handle issues and want to have a quick and easy way to get simple
390 notifications. Right now the bot notifies of the following actions:
391 - New Issues
392 - Blocked emails
393 - Issues that got their assignment list changed
394
395 NOTE: You will need to manually edit the bot.php script to set your
396 appropriate preferences, like IRC server and channel that the bot
397 should join.
398
399 %description irc -l pl
400 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
401 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
402 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
403 nastêpuj±cych zdarzeniach:
404 - nowych sprawach
405 - zablokowanych listach
406 - sprawach, dla których zmieni³a siê lista powi±zañ
407
408 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
409 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
410
411 %package cli
412 Summary:        Eventum command-line interface
413 Summary(pl):    Interfejs linii poleceñ dla Eventum
414 Group:          Applications/WWW
415 Requires:       %{name}-base = %{version}-%{release}
416 Requires:       php-cli
417 Requires:       php-common >= 3:4.1.0
418 Requires:       php-pear-XML_RPC
419
420 %description cli
421 The Eventum command-line interface allows you to access most of the
422 features of the web interface straight from your command shell.
423
424 %description cli -l pl
425 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
426 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
427
428 %package scm
429 Summary:        Eventum SCM integration
430 Summary(pl):    Integracja SCM dla Eventum
431 Group:          Applications/WWW
432 Requires:       %{name}-base = %{version}-%{release}
433 Requires:       php-cli
434 Requires:       php-common >= 3:4.1.0
435 Requires:       php-pcre
436
437 %description scm
438 This feature allows your software development teams to integrate your
439 Source Control Management system with your Issue Tracking System.
440
441 The integration is implemented in such a way that it will be forward
442 compatible with pretty much any SCM system, such as CVS.
443
444 For installation see
445 </eventum/help.php?topic=scm_integration_installation>.
446
447 %description scm -l pl
448 Ten pakiet pozwala zespo³om programistów na integracjê systemu
449 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
450 ¶ledzenia spraw.
451
452 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
453 prawie ka¿dym systemem SCM, jak np. CVS.
454
455 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
456 </eventum/help.php?topic=scm_integration_installation>.
457
458 %prep
459 %setup -q %{?_snap:-n %{name}-%{_snap}}
460 # undos the source
461 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
462
463 rm -f setup.conf.php # not to be installed by *.php glob
464 rm -rf misc/upgrade/*v1.[123]* # too old to support in PLD Linux
465 rm -f misc/upgrade/flush_compiled_templates.php
466 rm -rf misc/upgrade/*/upgrade_config.php # not needed in PLD Linux
467
468 # sample, not used in eventum
469 rm -f rpc/xmlrpc_client.php
470
471 # bug fixes.
472 %patch0 -p1
473 %patch1 -p1
474 %patch2 -p1
475 %patch3 -p1
476 %patch4 -p1
477 %patch5 -p1
478 %patch6 -p1
479 %patch7 -p1
480 %patch8 -p1
481 %patch9 -p1
482 %patch10 -p1
483 %{?with_order_patch:%patch11 -p1}
484
485 # packaging
486 %patch100 -p1
487 %patch101 -p1
488 %patch102 -p1
489 %patch103 -p1
490 %patch104 -p1
491 %patch105 -p1
492 %patch106 -p1
493 %patch107 -p1
494
495 sed -e '1s,#!.*/bin/php -q,#!%{_bindir}/php,' misc/cli/eventum > %{name}-cli
496 sed -e '1i#!%{_bindir}/php' misc/scm/process_cvs_commits.php > %{name}-scm
497 sed -e '1i#!%{_bindir}/php' misc/irc/bot.php > %{name}-bot
498 mv misc/cli/eventumrc_example eventumrc
499 sed -i -e '1i#!%{_bindir}/php' misc/*.php
500 chmod +x misc/*.php
501 mv include/private_key.php private_key.php.in
502
503 # replace in remaining scripts config.inc.php to system one
504 grep -rl 'include_once(".*config.inc.php")' . | xargs sed -i -e '
505         s,include_once(".*config.inc.php"),include_once("%{_webappdir}/core.php"),
506 '
507
508 grep -rl 'APP_INC_PATH..*"private_key.php"' . | xargs sed -i -e '
509         s,include_once(APP_INC_PATH.*"private_key.php"),include_once("%{_webappdir}/private_key.php"),
510 '
511
512 # remove backups from patching as we use globs to package files to buildroot
513 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
514
515 %install
516 rm -rf $RPM_BUILD_ROOT
517 install -d \
518         $RPM_BUILD_ROOT{%{_webappdir},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
519         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,sysconfig} \
520         $RPM_BUILD_ROOT/var/{run,log,cache,lib}/%{name} \
521         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
522         $RPM_BUILD_ROOT%{_appdir}/{include,htdocs/misc,upgrade} \
523
524 cp -a *.php css customer images js manage reports rpc setup $RPM_BUILD_ROOT%{_appdir}/htdocs
525 cp -a misc/*.html $RPM_BUILD_ROOT%{_appdir}/htdocs/misc
526 cp -a misc/*.php $RPM_BUILD_ROOT%{_appdir}
527 cp -a templates $RPM_BUILD_ROOT%{_appdir}
528 cp -a include/{customer,custom_field,jpgraph,workflow} $RPM_BUILD_ROOT%{_appdir}/include
529 cp -a include/*.php $RPM_BUILD_ROOT%{_appdir}/include
530 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
531 cp -a misc/upgrade $RPM_BUILD_ROOT%{_appdir}
532
533 cp -a favicon.ico $RPM_BUILD_ROOT%{_appdir}/htdocs/favicon.ico
534 install %{SOURCE12} $RPM_BUILD_ROOT%{_appdir}/htdocs/setup/config.inc.php
535 install %{SOURCE13} $RPM_BUILD_ROOT%{_appdir}/upgrade/upgrade.sh
536
537 # cli
538 install -d $RPM_BUILD_ROOT%{_appdir}/cli
539 cp -a misc/cli/include/class.{misc,command_line}.php $RPM_BUILD_ROOT%{_appdir}/cli
540 cp -a misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
541 install %{name}-cli $RPM_BUILD_ROOT%{_bindir}/%{name}
542 install %{name}-bot $RPM_BUILD_ROOT%{_sbindir}
543
544 # scm
545 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
546 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
547
548 # private key
549 cp -a private_key.php.in $RPM_BUILD_ROOT%{_webappdir}/private_key.php
550
551 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
552 install %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
553 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
554 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
555 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
556 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
557 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
558 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
559 install %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
560
561 sed -e '
562 s,%%{APP_VERSION}%%,%{version}%{?_snap:-%{_snap}}%{?_rc:-%{_rc}},
563 s,%%{PHP_PEAR_DIR}%%,%{php_pear_dir},
564 s,%%{APP_PATH}%%,%{_appdir},
565 s,%%{SMARTY_DIR}%%,%{_smartydir},
566 s,%%{SYSCONFDIR}%%,%{_webappdir},
567 ' %{SOURCE10} > $RPM_BUILD_ROOT%{_webappdir}/core.php
568
569 # config
570 > $RPM_BUILD_ROOT%{_webappdir}/setup.php
571 mv $RPM_BUILD_ROOT{%{_appdir}/htdocs/config.inc,%{_webappdir}/config}.php
572
573 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
574 # These plugins are not in Smarty package (Smarty-2.6.2-3)
575 cp -a \
576         include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php \
577         include/Smarty/plugins/modifier.highlight_quoted.php \
578         $RPM_BUILD_ROOT%{_smartyplugindir}
579
580 # qmail router
581 %if %{with qmail}
582 d=$RPM_BUILD_ROOT/var/lib/%{name}
583 echo 'root' > $d/.qmail
584 echo 'root' > $d/.qmail-default
585 echo '| %{_libdir}/router-qmail drafts' > $d/.qmail-draft-default
586 echo '| %{_libdir}/router-qmail emails 1' > $d/.qmail-issue-default
587 echo '| %{_libdir}/router-qmail notes' > $d/.qmail-note-default
588 install %{SOURCE11} $RPM_BUILD_ROOT%{_libdir}/router-qmail
589 %endif
590 # postfix router
591 install %{SOURCE14} $RPM_BUILD_ROOT%{_libdir}/router-postfix
592
593 %clean
594 rm -rf $RPM_BUILD_ROOT
595
596 %pre
597 %addusertogroup http %{name}
598
599 %post
600 # check if the package is configured.
601 if grep -q 'header("Location: setup/")' %{_webappdir}/config.php; then
602 if [ -f %{_appdir}/htdocs/setup/index.php ]; then
603 %banner %{name} -e <<EOF
604
605 You haven't yet configured Eventum!
606 Please open in browser <http://localhost/eventum/>
607 If you need access from elsewhere, you need to edit
608 %{_webappdir}/apache.conf and restart apache.
609
610 IMPORTANT: When You have configured Eventum, please uninstall the
611 setup package, so that %{name}-setup is able to secure your Eventum
612 installation.
613
614 EOF
615 #' vim syntax hack
616 else
617 %banner %{name} -e <<EOF
618
619 You haven't yet configured Eventum!
620
621 To setup eventum, please install %{name}-setup and open in browser
622 <http://localhost/eventum/>.
623 If you need access from elsewhere, you need to edit
624 %{_webappdir}/apache.conf and restart apache.
625
626 IMPORTANT: When You have configured Eventum, please uninstall the
627 setup package, so that %{name}-setup is able to secure your Eventum
628 installation.
629
630 EOF
631 #' vim syntax hack
632 fi
633
634 elif grep -q 'DEFAULTPRIVATEKEY' %{_webappdir}/private_key.php; then
635 %banner %{name} -e <<EOF
636
637 You have default private key installed!
638
639 Install %{name}-setup and open up http://yourserver/eventum/setup/
640 -- that will help you setup initial config.
641
642 when have configured Eventum, please uninstall the setup package,
643 so that %{name}-setup is able to secure your Eventum installation.
644
645 EOF
646         elif [ -d %{_appdir}/setup ]; then
647 %banner %{name} -e <<EOF
648
649 If you have have configured Eventum, please uninstall the setup package,
650 so that %{name}-setup is able to secure your Eventum installation.
651
652 EOF
653 fi
654
655 # nuke Smarty templates cache after upgrade
656 rm -f /var/cache/eventum/*.php
657
658 %preun
659 if [ "$1" = "0" ]; then
660         # nuke cache
661         rm -f /var/cache/eventum/*.php 2>/dev/null || :
662 fi
663
664 %pre base
665 %groupadd -P %{name}-base -g 146 %{name}
666 %useradd -P %{name}-base -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
667
668 %postun base
669 if [ "$1" = "0" ]; then
670         %userremove %{name}
671         %groupremove %{name}
672 fi
673
674 %post router-qmail
675 CF=/etc/qmail/control/virtualdomains
676 if ! grep -q ':%{name}\b' $CF 2>/dev/null; then
677         FQDN=$(awk -F'"' '/define/ && $2 ~ /APP_HOSTNAME/ {print $4}' %{_webappdir}/config.php 2>/dev/null)
678         [ "$FQDN" ] || FQDN=$(hostname -f 2>/dev/null || echo localhost)
679         umask 022
680         echo "#${FQDN}:%{name}" >> $CF
681
682 %banner %{name}-qmail -e <<EOF
683
684 Added "#${FQDN}:%{name}" to $CF,
685 Please verify that it is correct and restart qmail:
686 # service qmail reload
687
688 Consult qmail-send(8) for more information on virtualdomains.
689
690 EOF
691 fi
692
693 %preun router-qmail
694 if [ "$1" = "0" ]; then
695         sed -i -e '/:%{name}\b/d' /etc/qmail/control/virtualdomains
696 fi
697
698 %post setup
699 chmod 660 %{_webappdir}/{config,private_key}.php
700 chown root:eventum %{_webappdir}/{config,private_key}.php
701
702 %postun setup
703 if [ "$1" = "0" ]; then
704         chmod 640 %{_webappdir}/{config,private_key}.php
705         chown root:eventum %{_webappdir}/{config,private_key}.php
706 fi
707
708 %post irc
709 /sbin/chkconfig --add eventum-irc
710 %service eventum-irc restart "Eventum IRC Bot"
711
712 %triggerin -- apache1
713 %webapp_register apache %{_webapp}
714
715 %triggerun -- apache1
716 %webapp_unregister apache %{_webapp}
717
718 %triggerin -- apache < 2.2.0, apache-base
719 %webapp_register httpd %{_webapp}
720
721 %triggerun -- apache < 2.2.0, apache-base
722 %webapp_unregister httpd %{_webapp}
723
724 # FIXME
725 # only one upgrade trigger is called if you're upgrading over two
726 # versions, say 1.5 to 1.5.3, only 1.5.3 trigger is called.
727 # use common trigger (the highest version and rpmvercmp from poldek?)
728 %triggerpostun -- eventum < 1.5.1-0.257
729 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5_to_v1.5.1 <<EOF
730 database_changes.php Perform database changes
731 EOF
732
733 %triggerpostun -- eventum < 1.5.2-0.289
734 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.1_to_v1.5.2 <<EOF
735 database_changes.php Perform database changes
736 set_priority_ranks.php Fix the ranking of priority values
737 EOF
738
739 %triggerpostun -- eventum < 1.5.3-0.291
740 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.2_to_v1.5.3 <<EOF
741 database_changes.php Perform database changes
742 EOF
743
744 %triggerpostun -- eventum < 1.5.4-1.12
745 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.3_to_v1.5.4 <<EOF
746 database_changes.php Perform database changes
747 EOF
748
749 %triggerpostun -- eventum < 1.6.0-RC2.6
750 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.5.5_to_v1.6.0 <<EOF
751 database_changes.php Perform database changes
752 upgrade_saved_searches.php Upgrade existing custom filters (saved searches)
753 EOF
754
755 %triggerpostun -- eventum < 1.6.1-0.2
756 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.0_to_v1.6.1 <<EOF
757 database_changes.php Perform database changes
758 EOF
759
760 %triggerpostun irc -- eventum-irc < 1.6.1-3.14
761 sed -i -e '
762 s,\$irc_host,$irc_server_hostname,
763 s,\$irc_port,$irc_server_port,
764 s,\$irc_nick,$nickname,
765 s,\$irc_realname,$realname,
766 s,\$irc_username,$username,
767 s,\$irc_password,$password,
768 ' /etc/eventum/irc.php
769
770 %triggerpostun -- eventum < 1.7.0-2.0.48
771 # migrate from apache-config macros
772 if [ -f /etc/%{name}/apache.conf.rpmsave ]; then
773         if [ -d /etc/apache/webapps.d ]; then
774                 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
775                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
776         fi
777
778         if [ -d /etc/httpd/webapps.d ]; then
779                 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
780                 cp -f /etc/%{name}/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
781         fi
782 fi
783
784 if [ -L /etc/apache/conf.d/99_%{_webapp}.conf ]; then
785         /usr/sbin/webapp register apache %{_webapp}
786         rm -f /etc/apache/conf.d/99_%{_webapp}.conf
787         %service -q apache reload
788 fi
789 if [ -L /etc/httpd/httpd.conf/99_%{_webapp}.conf ]; then
790         /usr/sbin/webapp register httpd %{_webapp}
791         rm -f /etc/httpd/httpd.conf/99_%{_webapp}.conf
792         %service -q httpd reload
793 fi
794
795 %{_appdir}/upgrade/upgrade.sh %{_appdir}/upgrade/v1.6.1_to_v1.7.0 <<EOF
796 database_changes.php Perform database changes
797 set_root_message_ids.php Set iss_root_message_id
798 EOF
799
800 # regular configs
801 for i in apache.conf config.php private_key.php setup.php; do
802         if [ -f /etc/eventum/$i.rpmsave ]; then
803                 mv -f %{_webappdir}/$i{,.rpmnew}
804                 mv -f /etc/eventum/$i.rpmsave %{_webappdir}/$i
805         fi
806 done
807
808 %triggerpostun cli -- %{name}-cli < 1.7.0-3.4
809 if [ -f %{_webappdir}/cli.php.rpmsave ]; then
810         mv -f %{_sysconfdir}/cli.php{,.rpmnew}
811         mv -f %{_webappdir}/cli.php.rpmsave %{_sysconfdir}/cli.php
812 fi
813
814 %triggerpostun irc -- %{name}-irc < 1.7.0-3.4
815 if [ -f %{_webappdir}/irc.php.rpmsave ]; then
816         mv -f %{_sysconfdir}/irc.php{,.rpmnew}
817         mv -f %{_webappdir}/irc.php.rpmsave %{_sysconfdir}/irc.php
818 fi
819
820 %files
821 %defattr(644,root,root,755)
822 %doc ChangeLog FAQ INSTALL README UPGRADE CONTRIB
823 %doc docs/* setup/schema.sql
824 %attr(751,root,root) %dir %{_webappdir}
825 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
826 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
827 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
828 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
829 %attr(660,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
830 %attr(640,root,eventum) %config %verify(not mtime) %{_webappdir}/core.php
831
832 %dir %attr(731,root,eventum) /var/log/%{name}
833 %attr(620,root,eventum) %ghost /var/log/%{name}/*
834
835 %dir %{_appdir}/htdocs
836 %{_appdir}/htdocs/*.php
837 %{_appdir}/htdocs/*.ico
838 %{_appdir}/htdocs/css
839 %{_appdir}/htdocs/customer
840 %{_appdir}/htdocs/images
841 %{_appdir}/htdocs/js
842 %{_appdir}/htdocs/manage
843 %{_appdir}/htdocs/reports
844 %{_appdir}/htdocs/rpc
845 %{_appdir}/htdocs/misc
846 %{_appdir}/templates
847 %dir %{_appdir}/upgrade
848 %attr(755,root,root) %{_appdir}/upgrade/upgrade.sh
849 %{_appdir}/upgrade/[!u]*
850 %{_smartyplugindir}
851
852 %dir %{_appdir}/include
853 %{_appdir}/include/customer
854 %{_appdir}/include/custom_field
855 %{_appdir}/include/jpgraph
856 %{_appdir}/include/workflow
857 %{_appdir}/include/class.[!m]*.php
858 %{_appdir}/include/class.mail.php
859 %{_appdir}/include/class.mail_queue.php
860 %{_appdir}/include/class.mime_helper.php
861 %{_appdir}/include/class.misc.php
862 %{_appdir}/include/db_access.php
863
864 %dir %attr(730,root,eventum) /var/run/%{name}
865 %dir %attr(730,root,eventum) /var/cache/%{name}
866
867 %files base
868 %defattr(644,root,root,755)
869 %attr(751,root,root) %dir %{_sysconfdir}
870 %dir %{_libdir}
871 %dir %{_appdir}
872 # qmail will ignore user, if it's home directory is not owned
873 %attr(750,eventum,eventum) %dir /var/lib/%{name}
874 # saved mail copies
875 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_emails
876 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_drafts
877 %attr(770,root,eventum) %dir /var/lib/%{name}/routed_notes
878
879 %files setup
880 %defattr(644,root,root,755)
881 %{_appdir}/htdocs/setup
882
883 %files mail-queue
884 %defattr(644,root,root,755)
885 %attr(755,root,root) %{_appdir}/process_mail_queue.php
886 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
887
888 %files mail-download
889 %defattr(644,root,root,755)
890 %attr(755,root,root) %{_appdir}/download_emails.php
891 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
892
893 %files reminder
894 %defattr(644,root,root,755)
895 %attr(755,root,root) %{_appdir}/check_reminders.php
896 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
897
898 %files monitor
899 %defattr(644,root,root,755)
900 %{_appdir}/include/class.monitor.php
901 %attr(755,root,root) %{_appdir}/monitor.php
902 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
903
904 %files route-drafts
905 %defattr(644,root,root,755)
906 %attr(755,root,root) %{_appdir}/route_drafts.php
907
908 %files route-emails
909 %defattr(644,root,root,755)
910 %attr(755,root,root) %{_appdir}/route_emails.php
911
912 %files route-notes
913 %defattr(644,root,root,755)
914 %attr(755,root,root) %{_appdir}/route_notes.php
915
916 %if %{with qmail}
917 %files router-qmail
918 %defattr(644,root,root,755)
919 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{name}/.qmail*
920 %attr(755,root,root) %{_libdir}/router-qmail
921 %endif
922
923 %files router-postfix
924 %defattr(644,root,root,755)
925 %attr(755,root,root) %{_libdir}/router-postfix
926
927 %files irc
928 %defattr(644,root,root,755)
929 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
930 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
931 %attr(755,root,root) %{_sbindir}/%{name}-bot
932 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
933
934 %files cli
935 %defattr(644,root,root,755)
936 %doc eventumrc
937 %attr(644,root,root) %config %verify(not md5 mtime size) %{_sysconfdir}/cli.php
938 %attr(755,root,root) %{_bindir}/%{name}
939 %{_appdir}/cli
940
941 %files scm
942 %defattr(644,root,root,755)
943 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
944 %attr(755,root,root) %{_libdir}/scm
This page took 0.095484 seconds and 2 git commands to generate.