]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
a29b49c12608d94fc94413e90aa36adaececda97
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1.3
6 %define         subver  327
7 %define         githash 34e5417
8 %define         php_min_version 5.3.7
9 %include        /usr/lib/rpm/macros.php
10 Summary:        Eventum Issue / Bug tracking system
11 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
12 Name:           eventum
13 Version:        3.0.6
14 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
15 License:        GPL v2
16 Group:          Applications/WWW
17 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.gz
18 Source0:        %{name}-%{version}-%{subver}-g%{githash}.tar.gz
19 # Source0-md5:  7df9693ab6f2912a959a738c9ac89482
20 Source1:        %{name}-apache.conf
21 Source2:        %{name}-mail-queue.cron
22 Source3:        %{name}-mail-download.cron
23 Source4:        %{name}-reminder.cron
24 Source5:        %{name}-monitor.cron
25 Source6:        %{name}-cvs.php
26 Source8:        %{name}-irc.init
27 Source9:        %{name}-irc.sysconfig
28 Source10:       sphinx.crontab
29 Source13:       %{name}-router-postfix.sh
30 Source14:       %{name}.logrotate
31 Source15:       %{name}-lighttpd.conf
32 Source16:       http://www.isocra.com/images/updown2.gif
33 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
34 Source17:       %{name}.tmpfiles
35 Patch2:         %{name}-order.patch
36 #Patch3:                group-users.patch
37 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
38 # packaging patches that probably never go upstream
39 Patch100:       %{name}-paths.patch
40 Patch101:       %{name}-cvs-config.patch
41 Patch107:       %{name}-gettext.patch
42 Patch108:       autoload.patch
43 # some tests
44 Patch200:       %{name}-fixed-nav.patch
45 URL:            http://eventum.mysql.org/
46 BuildRequires:  /usr/bin/php
47 BuildRequires:  gettext-devel
48 BuildRequires:  php(core) >= %{php_min_version}
49 BuildRequires:  rpm-php-pearprov >= 4.0.2-98
50 BuildRequires:  rpmbuild(macros) >= 1.654
51 BuildRequires:  sed >= 4.0
52 Requires(postun):       /usr/sbin/groupdel
53 Requires(postun):       /usr/sbin/userdel
54 Requires(pre):  /bin/id
55 Requires(pre):  /usr/bin/getgid
56 Requires(pre):  /usr/sbin/groupadd
57 Requires(pre):  /usr/sbin/useradd
58 Requires:       fonts-TTF-RedHat-liberation
59 Requires:       php(core) >= %{php_min_version}
60 Requires:       php(filter)
61 Requires:       php(iconv)
62 Requires:       php(imap)
63 Requires:       php(json)
64 Requires:       php(mbstring)
65 Requires:       php(mysqli)
66 Requires:       php(pcre)
67 Requires:       php(session)
68 Requires:       php-Smarty >= 3.1
69 Requires:       php-Smarty-plugin-gettext
70 Requires:       php-ZendFramework-Config >= 2.4
71 Requires:       php-monolog >= 1.17.2
72 Requires:       php-pear-DB
73 Requires:       php-pear-Mail
74 Requires:       php-pear-Mail_Mime
75 Requires:       php-pear-Mail_mimeDecode
76 Requires:       php-pear-Math_Stats
77 Requires:       php-pear-Net_DIME
78 Requires:       php-pear-Net_SMTP
79 Requires:       php-pear-Net_Socket
80 Requires:       php-pear-Net_URL
81 Requires:       php-pear-Net_UserAgent_Detect
82 Requires:       php-pear-PEAR-core
83 Requires:       php-pear-Text_Diff
84 Requires:       php-pear-XML_RPC
85 Requires:       php-psr-Log >= 1.0.0-2
86 Requires:       php-symfony2-HttpFoundation >= 2.7.7
87 Requires:       phplot >= 5.8.0
88 Requires:       webapps
89 Requires:       webserver(access)
90 Requires:       webserver(alias)
91 Requires:       webserver(indexfile)
92 Requires:       webserver(php) >= 4.2.0
93 Suggests:       localedb
94 Suggests:       php-pear-Net_LDAP2
95 Suggests:       webserver(setenv)
96 Provides:       group(eventum)
97 Provides:       user(eventum)
98 Obsoletes:      eventum-base < 3.0.3-1.305
99 Conflicts:      logrotate < 3.8.0
100 BuildArch:      noarch
101 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103 %define         _noautoreq_pear ../init.php ../../init.php init.php /usr/share/eventum/init.php /etc/webapps/.* %{_appdir}/.* .*Smarty.class.php Services/JSON.php class.date_helper.php sphinxapi.php Net/LDAP2.* Auth/SASL.* Util.php smarty_internal.*
104
105 # exclude optional php dependencies
106 %define         _noautophp      php-gnupg php-hash php-pecl-http php-tk
107
108 %define         _noautoreq      %{_noautophp}
109
110 %define         _libdir         %{_prefix}/lib/%{name}
111 %define         _appdir         %{_datadir}/%{name}
112 %define         _smartydir      %{php_data_dir}/Smarty
113 %define         _webapps        /etc/webapps
114 %define         _webapp         %{name}
115 %define         _webappdir      %{_webapps}/%{_webapp}
116 %define         _sysconfdir     /etc/%{name}
117
118 %description
119 Eventum is a user-friendly and flexible issue tracking system that can
120 be used by a support department to track incoming technical support
121 requests, or by a software development team to quickly organize tasks
122 and bugs. Eventum is used by the MySQL AB Technical Support team, and
123 has allowed us to dramatically improve our response times.
124
125 %description -l pl.UTF-8
126 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
127 może być używany przez dział obsługi do śledzenia przychodzących żądań
128 obsługi technicznej albo przez zespół tworzący oprogramowanie do
129 szybkiej organizacji zadań i błędów. Eventum jest używany przez zespół
130 Technical Support MySQL AB i umożliwił im znacząco poprawić czasy
131 reakcji.
132
133 %package setup
134 Summary:        Eventum setup package
135 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
136 Group:          Applications/WWW
137 Requires:       %{name} = %{version}-%{release}
138
139 %description setup
140 Install this package to configure initial Eventum installation. You
141 should uninstall this package when you're done, as it considered
142 insecure to keep the setup files in place.
143
144 %description setup -l pl.UTF-8
145 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
146 pierwszej instalacji. Potem należy go odinstalować, jako że
147 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
148
149 %package doc
150 Summary:        Eventum documentation and Wiki
151 Group:          Documentation
152
153 %description doc
154 Eventum documentation and copy of Wiki.
155
156 %package mail-queue
157 Summary:        Eventum mail queue process
158 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
159 Group:          Applications/WWW
160 Requires:       %{name} = %{version}-%{release}
161 Requires:       crondaemon
162
163 %description mail-queue
164 Beginning with the first release of Eventum, emails are not directly
165 sent out from the various scripts, but rather added to a mail queue
166 table that is processed by a cron job. If an email cannot be sent, it
167 will be marked as such in the mail queue log, and the cron job script
168 will re-try to send it again the next time it runs.
169
170 This package contains the cron job.
171
172 %description mail-queue -l pl.UTF-8
173 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
174 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
175 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
176 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
177 następnym razem.
178
179 Ten pakiet zawiera zadanie dla crona.
180
181 %package mail-download
182 Summary:        Eventum email download
183 Summary(pl.UTF-8):      Ściąganie poczty Eventum
184 Group:          Applications/WWW
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       crondaemon
187
188 %description mail-download
189 In order for Eventum's email integration feature to work, you need to
190 setup a cron job to run the script every so often.
191
192 This package contains the cron job.
193
194 %description mail-download -l pl.UTF-8
195 Aby integracja poczty elektronicznej w Eventum działała, trzeba
196 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
197 często.
198
199 Ten pakiet zawiera zadanie dla crona.
200
201 %package reminder
202 Summary:        Eventum Reminder System
203 Summary(pl.UTF-8):      System przypominania dla Eventum
204 Group:          Applications/WWW
205 Requires:       %{name} = %{version}-%{release}
206 Requires:       crondaemon
207
208 %description reminder
209 The reminder system was designed with the objective as serving as a
210 safe net for issues that need attention. Depending on what
211 configuration you create, you may have several reminders (or alerts)
212 be sent out whenever an issue needs attention, for whatever parameter
213 you may deem necessary.
214
215 This package contains the cron job.
216
217 %description reminder -l pl.UTF-8
218 System przypominania został zaprojektowany tak, aby służył jako
219 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
220 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
221 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
222 uważać za potrzebny.
223
224 Ten pakiet zawiera zadanie dla crona.
225
226 %package monitor
227 Summary:        Eventum Heartbeat Monitor
228 Summary(pl.UTF-8):      Monitor życia dla Eventum
229 Group:          Applications/WWW
230 Requires:       %{name} = %{version}-%{release}
231 Requires:       crondaemon
232 Requires:       php(posix)
233
234 %description monitor
235 The heartbeat monitor is a feature designed for the administrator that
236 wants to be alerted whenever a common problem in Eventum is detected,
237 like the database server not being available anymore, or maybe when
238 the recommended permissions for certain configuration files are
239 changed.
240
241 Please note that before running the heartbeat monitor, you may need to
242 customize some of the checks to be appropriate for your own system,
243 particularly the permission and file checks on
244 Monitor::checkConfiguration().
245
246 This package contains the cron job.
247
248 %description monitor -l pl.UTF-8
249 Monitor życia to funkcjonalność zaprojektowana dla administratora
250 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
251 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
252 do plików konfiguracyjnych.
253
254 Należy zauważyć, że przed uruchomieniem tego monitora może być
255 konieczne dostosowanie niektórych testów do systemu, w szczególności
256 testów uprawnień i plików w Monitor::checkConfiguration().
257
258 Ten pakiet zawiera zadanie dla crona.
259
260 %package route-drafts
261 Summary:        Eventum Draft Routing
262 Summary(pl.UTF-8):      Przekazywanie szkiców dla Eventum
263 Group:          Applications/WWW
264 Requires:       %{name} = %{version}-%{release}
265 Requires:       eventum(router)
266
267 %description route-drafts
268 The draft routing feature is used to automatically associate a thread
269 of drafts into an Eventum issue. By setting up Postfix to deliver
270 emails sent to a specific address (usually draft-<number>@<domain>) to
271 the above script, users are able to send drafts written in their mail
272 client to be stored in Eventum. These drafts will NOT broadcasted to
273 the notification list.
274
275 %description route-drafts -l pl.UTF-8
276 Przekazywanie szkiców służy do automatycznego wiązania wątku szkiców z
277 problemem w Eventum. Ustawiając Postfiksa, aby dostarczał pocztę
278 wysłaną na podany adres (zwykle draft-<liczba>@<domena>) do tego
279 skryptu umożliwia się użytkownikom wysyłanie szkiców napisanych w ich
280 kliencie pocztowym do zapisania w Eventum. Szkice te NIE będą wysyłane
281 na listę powiadomień.
282
283 %package route-emails
284 Summary:        Eventum Email Routing
285 Summary(pl.UTF-8):      Przekazywanie poczty dla Eventum
286 Group:          Applications/WWW
287 Requires:       %{name} = %{version}-%{release}
288 Requires:       eventum(router)
289
290 %description route-emails
291 The email routing feature is used to automatically associate a thread
292 of emails into an Eventum issue. By setting up Postfix to deliver
293 emails sent to a specific address (usually issue-<number>@<domain>) to
294 the above script, users are able to use their email clients to reply
295 to emails coming from Eventum, and those replies will be automatically
296 associated with the issue and broadcasted to the entire notification
297 list.
298
299 %description route-emails -l pl.UTF-8
300 Funkcjonalność przekazywania poczty służy do automatycznego wiązania
301 wątku listów ze sprawą w Eventum. Po ustawieniu czy nawet Postfiksa,
302 aby dostarczał listy wysyłane na pewien adres (zwykle
303 issue-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
304 używać klientów pocztowych do odpowiadania na listy przychodzące z
305 Eventum, a odpowiedzi te będą automatycznie wiązane ze sprawą i
306 rozprowadzane do całej listy ogłoszeniowej.
307
308 %package route-notes
309 Summary:        Eventum Note Routing
310 Summary(pl.UTF-8):      Przekazywanie notatek dla Eventum
311 Group:          Applications/WWW
312 Requires:       %{name} = %{version}-%{release}
313 Requires:       eventum(router)
314
315 %description route-notes
316 The note routing feature is used to automatically associate a thread
317 of notes into an Eventum issue. By setting up Postfix to deliver
318 emails sent to a specific address (usually note-<number>@<domain>) to
319 the above script, users are able to use their email clients to reply
320 to internal notes coming from Eventum, and those replies will be
321 automatically associated with the issue and broadcasted to the
322 notification list staff members.
323
324 %description route-notes -l pl.UTF-8
325 Funkcjonalność przekazywania notatek służy do automatycznego wiązania
326 wątku notatek ze sprawą w Eventum. Po ustawieniu Postfiksa, aby
327 dostarczał listy wysyłane na pewien adres (zwykle
328 note-<numer>@<domena>) na powyższy skrypt, użytkownicy będą mogli
329 używać klientów pocztowych do odpowiadania na wewnętrzne notatki
330 pochodzące od Eventu, a odpowiedzi te będą automatycznie wiązane ze
331 sprawą i rozprowadzane do członków personelu listy ogłoszeniowej.
332
333 %package router-postfix
334 Summary:        Eventum Mail Routing - Postfix
335 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
336 Group:          Applications/Mail
337 Requires:       %{name} = %{version}-%{release}
338 Requires:       postfix
339 Provides:       eventum(router)
340 Obsoletes:      eventum(router)
341
342 %description router-postfix
343 This package provides way of routing notes and emails back to Eventum
344 via Postfix.
345
346 The Postfix configuration instructions you can find from
347 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
348
349 %description router-postfix -l pl.UTF-8
350 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
351 przez Postfiksa.
352
353 Opis konfiguracji Postfiksa można znaleźć pod adresem
354 <http://eventum.mysql.org/wiki/index.php/Setting_up_email_routing_with_postfix>.
355
356 %package irc
357 Summary:        Eventum IRC Notification Bot
358 Summary(pl.UTF-8):      IRC-owy bot powiadamiający dla Eventum
359 Group:          Applications/WWW
360 Requires(post,preun):   /sbin/chkconfig
361 Requires:       %{name} = %{version}-%{release}
362 Requires:       php(pcntl)
363 Requires:       php(sockets)
364 Requires:       php-pear-Net_SmartIRC >= 1.1.9
365 Requires:       rc-scripts >= 0.4.0.18
366
367 %description irc
368 The IRC notification bot is a nice feature for remote teams that want
369 to handle issues and want to have a quick and easy way to get simple
370 notifications. Right now the bot notifies of the following actions:
371 - New Issues
372 - Blocked emails
373 - Issues that got their assignment list changed
374
375 NOTE: You will need to manually edit the bot.php script to set your
376 appropriate preferences, like IRC server and channel that the bot
377 should join.
378
379 %description irc -l pl.UTF-8
380 IRC-owy bot powiadamiający to miła funkcjonalność dla zdalnych
381 zespołów chcących obsługiwać sprawy i mieć szybki i łatwy sposób na
382 uzyskiwanie prostych powiadomień. Aktualnie bot powiadamia o
383 następujących zdarzeniach:
384 - nowych sprawach
385 - zablokowanych listach
386 - sprawach, dla których zmieniła się lista powiązań
387
388 UWAGA: w celu wprowadzenia własnych ustawień, takich jak serwer IRC i
389 kanał używany przez bota, trzeba ręcznie zmodyfikować skrypt bot.php .
390
391 %package cli
392 Summary:        Eventum command-line interface
393 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
394 Group:          Applications/WWW
395 Requires:       php(core) >= %{php_min_version}
396 Requires:       php(phar)
397 Requires:       php-pear-XML_RPC
398
399 %description cli
400 The Eventum command-line interface allows you to access most of the
401 features of the web interface straight from your command shell.
402
403 %description cli -l pl.UTF-8
404 Interfejs linii poleceń Eventum pozwala na dostęp do większości
405 funkcji interfejsu WWW prosto z linii poleceń powłoki.
406
407 %package scm
408 Summary:        Eventum SCM integration
409 Summary(pl.UTF-8):      Integracja SCM dla Eventum
410 Group:          Applications/WWW
411 Requires:       php(core) >= %{php_min_version}
412 Requires:       php(json)
413 Requires:       php(pcre)
414 Requires:       php(spl)
415 Suggests:       cvs
416 Suggests:       git-core
417 Suggests:       php(openssl)
418 Suggests:       subversion
419
420 %description scm
421 This feature allows your software development teams to integrate your
422 Source Control Management system with your Issue Tracking System.
423
424 The integration is implemented in such a way that it will be forward
425 compatible with pretty much any SCM system, such as CVS.
426
427 For installation see
428 </eventum/help.php?topic=scm_integration_installation>.
429
430 %description scm -l pl.UTF-8
431 Ten pakiet pozwala zespołom programistów na integrację systemu
432 zarządzania źródłami (SCM - Source Control Management) z systemem
433 śledzenia spraw.
434
435 Integracja jest zaimplementowana tak, aby być kompatybilna w przód z
436 prawie każdym systemem SCM, jak np. CVS.
437
438 Szczegóły na temat instalacji można przeczytać pod
439 </eventum/help.php?topic=scm_integration_installation>.
440
441 %package sphinx
442 Summary:        Eventum Sphinx Search
443 Group:          Applications/WWW
444 Requires:       %{name} = %{version}-%{release}
445 Requires:       crondaemon
446 Requires:       sphinx
447
448 %description sphinx
449 Sphinx search integration for Eventum.
450
451 This package contains the cron job.
452
453 %prep
454 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
455
456 mv docs/examples .
457
458 # bug fixes / features
459 %{?with_order:%patch2 -p1}
460 #%patch3 -p0
461 #%patch4 -p1
462
463 %{?with_order:cp -p %{SOURCE16} htdocs/images}
464
465 #%patch200 -p1
466
467 # produce default sphinx config
468 # must be run before paths.patch
469 %if 0
470 cat <<'EOF' > config/config.php
471 <?php
472 define('APP_SQL_DBTYPE', 'mysql');
473 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
474 define('APP_SQL_DBPORT', 3306);
475 define('APP_SQL_DBNAME', 'eventum');
476 define('APP_SQL_DBUSER', 'mysql');
477 define('APP_SQL_DBPASS', '');
478 define('APP_TABLE_PREFIX', 'eventum_');
479 EOF
480 php config/sphinx.conf.php > config/sphinx.conf
481 rm config/config.php
482 %endif
483
484 # packaging
485 %patch100 -p1
486 %patch101 -p1
487 %patch107 -p1
488 %patch108 -p1
489
490 rm htdocs/.htaccess.dist
491
492 # cleanup vendor. keep only needed libraries.
493 # (the rest are packaged with system packages)
494 mv vendor vendor.dist
495 vendor() {
496         local path dir
497         for path; do
498                 dir=$(dirname $path)
499                 test -d vendor/$dir || mkdir -p vendor/$dir
500                 mv vendor.dist/$path vendor/$path
501         done
502 }
503 vendor autoload.php
504 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
505 vendor composer/ClassLoader.php
506 vendor ircmaxell/{password-compat,random-lib,security-lib}
507
508 # remove backups from patching as we use globs to package files to buildroot
509 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
510
511 %build
512 %{__make} -C localization
513
514 %install
515 rm -rf $RPM_BUILD_ROOT
516 install -d \
517         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
518         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
519         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
520         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
521         $RPM_BUILD_ROOT/var/lib/%{name}/routed_{emails,drafts,notes} \
522         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
523
524 %{__make} install-eventum install-cli install-scm install-localization \
525         sysconfdir=%{_webappdir} \
526         localedir=%{_localedir} \
527         DESTDIR=$RPM_BUILD_ROOT
528
529 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
530
531 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
532
533 # unsupported locale
534 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
535
536 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
537 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
538
539 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
540
541 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
542 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
543 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
544 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
545
546 install -d $RPM_BUILD_ROOT/etc/sphinx
547 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
548 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
549
550 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
551 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
552 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
553 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
554 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
555
556 cp -p config/irc_config.dist.php $RPM_BUILD_ROOT%{_webappdir}/irc_config.php
557
558 install -p %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
559 cp -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/eventum-irc
560
561 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
562
563 # postfix router
564 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
565
566 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
567
568 %find_lang %{name}
569
570 # scm
571 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/scm.php
572
573 %clean
574 rm -rf $RPM_BUILD_ROOT
575
576 %pre
577 %groupadd -g 146 %{name}
578 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
579 %addusertogroup http %{name}
580
581 %post
582 # create empty ghost files
583 # these permissions ensure the logs are write only
584 for a in \
585         errors.log login_attempts.log \
586         cli.log \
587         irc_bot_error.log irc_bot_smartirc.log \
588 ; do
589         test -f /var/log/%{name}/$a && continue
590         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
591 done
592
593 # run database update if configured
594 test -s %{_webappdir}/config.php && \
595 %{_appdir}/bin/upgrade.php || :
596
597 # nuke Smarty templates cache after upgrade
598 rm -f /var/cache/eventum/*.php
599
600 # Restart webserver on upgrade to get .mo translations reloaded.
601 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
602 %php_webserver_restart
603
604 %preun
605 if [ "$1" = "0" ]; then
606         # nuke cache
607         rm -f /var/cache/eventum/*.php 2>/dev/null || :
608 fi
609
610 %postun
611 if [ "$1" = "0" ]; then
612         %userremove %{name}
613         %groupremove %{name}
614 fi
615
616 %post setup
617 chmod 660 %{_webappdir}/{config,private_key}.php
618 chown root:http %{_webappdir}/{config,private_key}.php
619
620 %postun setup
621 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
622         chmod 640 %{_webappdir}/{config,private_key}.php
623         chown root:http %{_webappdir}/{config,private_key}.php
624 fi
625
626 %post irc
627 /sbin/chkconfig --add eventum-irc
628 %service eventum-irc restart "Eventum IRC Bot"
629
630 %preun irc
631 if [ "$1" = 0 ]; then
632         %service eventum-irc stop
633         /sbin/chkconfig --del eventum-irc
634 fi
635
636 %triggerin -- apache1 < 1.3.37-3, apache1-base
637 %webapp_register apache %{_webapp}
638
639 %triggerun -- apache1 < 1.3.37-3, apache1-base
640 %webapp_unregister apache %{_webapp}
641
642 %triggerin -- apache < 2.2.0, apache-base
643 %webapp_register httpd %{_webapp}
644
645 %triggerun -- apache < 2.2.0, apache-base
646 %webapp_unregister httpd %{_webapp}
647
648 %triggerin -- lighttpd
649 %webapp_register lighttpd %{_webapp}
650
651 %triggerun -- lighttpd
652 %webapp_unregister lighttpd %{_webapp}
653
654 %triggerpostun -- %{name} < 3.0.0-0.2
655 for f in /etc/cron.d/eventum-*; do
656         # crontabs moved to bin
657         %{__sed} -i -e '
658                 s,/usr/share/eventum/crons/process_mail_queue.php,%{_appdir}/bin/process_mail_queue.php,
659                 s,/usr/share/eventum/crons/download_emails.php,%{_appdir}/bin/download_emails.php,
660                 s,/usr/share/eventum/crons/check_reminders.php,%{_appdir}/bin/check_reminders.php,
661                 s,/usr/share/eventum/crons/monitor.php,%{_appdir}/bin/monitor.php,
662         ' $f
663 done
664
665 %files -f %{name}.lang
666 %defattr(644,root,root,755)
667 %attr(751,root,root) %dir %{_webappdir}
668 %attr(751,root,root) %dir %{_webappdir}/custom_field
669 %attr(751,root,root) %dir %{_webappdir}/templates
670 %attr(751,root,root) %dir %{_webappdir}/workflow
671 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
672 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
673 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
674 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
675 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
676 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
677 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
678
679 %dir %attr(711,root,http) /var/log/%{name}
680 %attr(620,root,http) %ghost /var/log/%{name}/*
681 %dir %attr(750,root,root) /var/log/archive/%{name}
682 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
683
684 %dir %{_appdir}
685 %{_appdir}/config
686
687 %dir %{_appdir}/bin
688 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
689 %attr(755,root,root) %{_appdir}/bin/upgrade.php
690
691 %{_appdir}/autoload.php
692 %{_appdir}/init.php
693 %dir %{_appdir}/htdocs
694 %{_appdir}/htdocs/*.php
695 %{_appdir}/htdocs/*.ico
696 %{_appdir}/htdocs/ajax
697 %{_appdir}/htdocs/css
698 %{_appdir}/htdocs/customer
699 %{_appdir}/htdocs/images
700 %{_appdir}/htdocs/js
701 %{_appdir}/htdocs/manage
702 %{_appdir}/htdocs/reports
703 %{_appdir}/htdocs/rpc
704 %{_appdir}/htdocs/components
705 %{_appdir}/templates
706
707 %dir %{_appdir}/upgrade
708 %{_appdir}/upgrade/flush_compiled_templates.php
709 %{_appdir}/upgrade/*.sql
710 %attr(755,root,root) %{_appdir}/upgrade/ldap_import.php
711 %attr(755,root,root) %{_appdir}/upgrade/ldap_update_users.php
712 %attr(755,root,root) %{_appdir}/upgrade/scm_trac_import.php
713 %{_appdir}/upgrade/patches
714
715 %{_appdir}/vendor
716
717 %dir %{_appdir}/lib
718 %{_appdir}/lib/eventum
719 %exclude %{_appdir}/lib/eventum/class.monitor.php
720
721 %dir %{_libdir}
722
723 %{systemdtmpfilesdir}/%{name}.conf
724
725 %dir /var/lib/%{name}
726 %dir %attr(730,root,http) /var/run/%{name}
727 %dir %attr(730,root,http) /var/cache/%{name}
728
729 # saved mail copies
730 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
731 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
732 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
733
734 %files setup
735 %defattr(644,root,root,755)
736 %{_appdir}/htdocs/setup
737
738 %files doc
739 %defattr(644,root,root,755)
740 %doc docs/*
741 %{_examplesdir}/%{name}-%{version}
742
743 %files mail-queue
744 %defattr(644,root,root,755)
745 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
746 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
747 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
748
749 %files mail-download
750 %defattr(644,root,root,755)
751 %attr(755,root,root) %{_appdir}/bin/download_emails.php
752 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
753
754 %files reminder
755 %defattr(644,root,root,755)
756 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
757 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
758
759 %files monitor
760 %defattr(644,root,root,755)
761 %{_appdir}/lib/eventum/class.monitor.php
762 %attr(755,root,root) %{_appdir}/bin/monitor.php
763 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
764
765 %files route-drafts
766 %defattr(644,root,root,755)
767 %attr(755,root,root) %{_appdir}/bin/route_drafts.php
768
769 %files route-emails
770 %defattr(644,root,root,755)
771 %attr(755,root,root) %{_appdir}/bin/route_emails.php
772
773 %files route-notes
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{_appdir}/bin/route_notes.php
776
777 %files router-postfix
778 %defattr(644,root,root,755)
779 %attr(755,root,root) %{_libdir}/router-postfix
780
781 %files irc
782 %defattr(644,root,root,755)
783 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/irc_config.php
784 %attr(640,root,eventum) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/eventum-irc
785 %attr(755,root,root) %{_appdir}/bin/irc-bot.php
786 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
787
788 %files cli
789 %defattr(644,root,root,755)
790 %doc cli/eventumrc
791 %attr(755,root,root) %{_bindir}/%{name}
792
793 %files scm
794 %defattr(644,root,root,755)
795 %attr(751,root,root) %dir %{_sysconfdir}
796 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/scm.php
797 %attr(755,root,root) %{_sbindir}/eventum-cvs-hook
798 %attr(755,root,root) %{_sbindir}/eventum-git-hook
799 %attr(755,root,root) %{_sbindir}/eventum-svn-hook
800 %attr(755,root,root) %{_sbindir}/helpers.php
801
802 %files sphinx
803 %defattr(644,root,root,755)
804 %{_webappdir}/sphinx.conf.php
805 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
806 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.094396 seconds and 3 git commands to generate.