]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
9dd9755858c8f3ef0d81a9b4e66fad03b3ad8c6f
[packages/eventum.git] / eventum.spec
1 #
2 # Conditional build:
3 %bcond_with     order   # with experimental order patch
4
5 %define         rel             1
6 %define         subver  67
7 %define         githash 26f3e1f3
8 %define         php_min_version 5.6.0
9 Summary:        Eventum Issue / Bug tracking system
10 Summary(pl.UTF-8):      Eventum - system śledzenia spraw/błędów
11 Name:           eventum
12 Version:        3.5.6
13 Release:        %{?subver:1.%{subver}.%{?githash:g%{githash}.}}%{rel}
14 License:        GPL v2+
15 Group:          Applications/WWW
16 #Source0:       https://github.com/eventum/eventum/releases/download/v%{version}/%{name}-%{version}.tar.xz
17 Source0:        https://github.com/eventum/eventum/releases/download/snapshot/%{name}-%{version}-%{subver}-g%{githash}.tar.xz
18 # Source0-md5:  85dfe8f431b58010ad7af20fd43bba57
19 Source1:        %{name}-apache.conf
20 Source2:        %{name}-mail-queue.cron
21 Source3:        %{name}-mail-download.cron
22 Source4:        %{name}-reminder.cron
23 Source5:        %{name}-monitor.cron
24 Source10:       sphinx.crontab
25 Source13:       %{name}-router-postfix.sh
26 Source14:       %{name}.logrotate
27 Source15:       %{name}-lighttpd.conf
28 Source16:       http://www.isocra.com/images/updown2.gif
29 # Source16-md5: deb6eeb2552ba757d3a949ed10c4107d
30 Source17:       %{name}.tmpfiles
31 Patch2:         %{name}-order.patch
32 #Patch3:                group-users.patch
33 #Patch4:                https://github.com/glensc/eventum/compare/cf_escape.patch
34 # packaging patches that probably never go upstream
35 Patch100:       %{name}-paths.patch
36 Patch107:       %{name}-gettext.patch
37 Patch108:       autoload.patch
38 # some tests
39 Patch200:       %{name}-fixed-nav.patch
40 URL:            https://wiki.github.com/eventum/eventum/
41 BuildRequires:  gettext-tools
42 BuildRequires:  rpmbuild(macros) >= 1.654
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  xz
46 Requires(post): sudo
47 Requires(postun):       /usr/sbin/groupdel
48 Requires(postun):       /usr/sbin/userdel
49 Requires(pre):  /bin/id
50 Requires(pre):  /usr/bin/getgid
51 Requires(pre):  /usr/sbin/groupadd
52 Requires(pre):  /usr/sbin/useradd
53 Requires:       fonts-TTF-RedHat-liberation
54 Requires:       php(core) >= %{php_min_version}
55 Requires:       php(filter)
56 Requires:       php(iconv)
57 Requires:       php(imap)
58 Requires:       php(json)
59 Requires:       php(mbstring)
60 Requires:       php(pcre)
61 Requires:       php(pdo_mysql)
62 Requires:       php(session)
63 Requires:       php-Smarty >= 3.1
64 Requires:       php-Smarty-plugin-gettext
65 Requires:       php-ZendFramework-Config >= 2.4
66 Requires:       php-ZendFramework-Loader >= 2.4
67 Requires:       php-ZendFramework-Mail >= 2.4.13-2
68 Requires:       php-ZendFramework-Mime >= 2.4
69 Requires:       php-ZendFramework-ServiceManager >= 2.4
70 Requires:       php-ZendFramework-Validator >= 2.4
71 Requires:       php-monolog >= 1.17.2
72 Requires:       php-pear-Math_Stats
73 Requires:       php-pear-Net_SMTP
74 Requires:       php-pear-Net_Socket
75 Requires:       php-pear-Net_URL
76 Requires:       php-pear-PEAR-core
77 Requires:       php-pear-Text_Diff
78 Requires:       php-psr-Log >= 1.0.0-2
79 Requires:       phplot >= 5.8.0
80 Requires:       webapps
81 Requires:       webserver(access)
82 Requires:       webserver(alias)
83 Requires:       webserver(indexfile)
84 Requires:       webserver(php) >= 4.2.0
85 Suggests:       localedb
86 Suggests:       php(mcrypt)
87 Suggests:       php(openssl)
88 Suggests:       php-pear-Net_POP3
89 Suggests:       webserver(setenv)
90 Provides:       group(eventum)
91 Provides:       user(eventum)
92 Obsoletes:      eventum-base < 3.0.3-1.305
93 Obsoletes:      eventum-route-drafts < 3.0.8-1.1
94 Obsoletes:      eventum-route-emails < 3.0.8-1.1
95 Obsoletes:      eventum-route-notes < 3.0.8-1.1
96 Conflicts:      logrotate < 3.8.0
97 BuildArch:      noarch
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %define         _libdir         %{_prefix}/lib/%{name}
101 %define         _appdir         %{_datadir}/%{name}
102 %define         _smartydir      %{php_data_dir}/Smarty
103 %define         _webapps        /etc/webapps
104 %define         _webapp         %{name}
105 %define         _webappdir      %{_webapps}/%{_webapp}
106 %define         _sysconfdir     /etc/%{name}
107
108 %description
109 Eventum is a user-friendly and flexible issue tracking system that can
110 be used by a support department to track incoming technical support
111 requests, or by a software development team to quickly organize tasks
112 and bugs.
113
114 %description -l pl.UTF-8
115 Eventum to przyjazny dla użytkownika system śledzenia spraw, który
116 może być używany przez dział obsługi do śledzenia przychodzących żądań
117 obsługi technicznej albo przez zespół tworzący oprogramowanie do
118 szybkiej organizacji zadań i błędów.
119
120 %package setup
121 Summary:        Eventum setup package
122 Summary(pl.UTF-8):      Pakiet do wstępnej konfiguracji Eventum
123 Group:          Applications/WWW
124 Requires:       %{name} = %{version}-%{release}
125
126 %description setup
127 Install this package to configure initial Eventum installation. You
128 should uninstall this package when you're done, as it considered
129 insecure to keep the setup files in place.
130
131 %description setup -l pl.UTF-8
132 Ten pakiet należy zainstalować w celu wstępnej konfiguracji Eventum po
133 pierwszej instalacji. Potem należy go odinstalować, jako że
134 pozostawienie plików instalacyjnych mogłoby być niebezpieczne.
135
136 %package doc
137 Summary:        Eventum documentation and Wiki
138 Group:          Documentation
139
140 %description doc
141 Eventum documentation and copy of Wiki.
142
143 %package mail-queue
144 Summary:        Eventum mail queue process
145 Summary(pl.UTF-8):      Przetwarzanie kolejki poczty Eventum
146 Group:          Applications/WWW
147 Requires:       %{name} = %{version}-%{release}
148 Requires:       crondaemon
149
150 %description mail-queue
151 Beginning with the first release of Eventum, emails are not directly
152 sent out from the various scripts, but rather added to a mail queue
153 table that is processed by a cron job. If an email cannot be sent, it
154 will be marked as such in the mail queue log, and the cron job script
155 will re-try to send it again the next time it runs.
156
157 This package contains the cron job.
158
159 %description mail-queue -l pl.UTF-8
160 Od pierwszego wydania Eventum poczta nie jest wysyłana bezpośrednio z
161 różnych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
162 Jeśli poczta nie może być wysłana, będzie odpowiednio oznaczona w logu
163 kolejki poczty, a skrypt z crona będzie próbował wysłać ją ponownie
164 następnym razem.
165
166 Ten pakiet zawiera zadanie dla crona.
167
168 %package mail-download
169 Summary:        Eventum email download
170 Summary(pl.UTF-8):      Ściąganie poczty Eventum
171 Group:          Applications/WWW
172 Requires:       %{name} = %{version}-%{release}
173 Requires:       crondaemon
174
175 %description mail-download
176 In order for Eventum's email integration feature to work, you need to
177 setup a cron job to run the script every so often.
178
179 This package contains the cron job.
180
181 %description mail-download -l pl.UTF-8
182 Aby integracja poczty elektronicznej w Eventum działała, trzeba
183 ustawić zadanie crona, aby uruchamiał odpowiedni skrypt wystarczająco
184 często.
185
186 Ten pakiet zawiera zadanie dla crona.
187
188 %package reminder
189 Summary:        Eventum Reminder System
190 Summary(pl.UTF-8):      System przypominania dla Eventum
191 Group:          Applications/WWW
192 Requires:       %{name} = %{version}-%{release}
193 Requires:       crondaemon
194
195 %description reminder
196 The reminder system was designed with the objective as serving as a
197 safe net for issues that need attention. Depending on what
198 configuration you create, you may have several reminders (or alerts)
199 be sent out whenever an issue needs attention, for whatever parameter
200 you may deem necessary.
201
202 This package contains the cron job.
203
204 %description reminder -l pl.UTF-8
205 System przypominania został zaprojektowany tak, aby służył jako
206 bezpieczna sieć dla spraw wymagających uwagi. W zależności od
207 konfiguracji można ustawić różne przypominajki (lub alarmy) wysyłane
208 przy każdej sprawie wymagającej uwagi lub przy parametrze, który można
209 uważać za potrzebny.
210
211 Ten pakiet zawiera zadanie dla crona.
212
213 %package monitor
214 Summary:        Eventum Heartbeat Monitor
215 Summary(pl.UTF-8):      Monitor życia dla Eventum
216 Group:          Applications/WWW
217 Requires:       %{name} = %{version}-%{release}
218 Requires:       crondaemon
219 Requires:       php(posix)
220
221 %description monitor
222 The heartbeat monitor is a feature designed for the administrator that
223 wants to be alerted whenever a common problem in Eventum is detected,
224 like the database server not being available anymore, or maybe when
225 the recommended permissions for certain configuration files are
226 changed.
227
228 Please note that before running the heartbeat monitor, you may need to
229 customize some of the checks to be appropriate for your own system,
230 particularly the permission and file checks on
231 Monitor::checkConfiguration().
232
233 This package contains the cron job.
234
235 %description monitor -l pl.UTF-8
236 Monitor życia to funkcjonalność zaprojektowana dla administratora
237 chcącego być alarmowanym przy każdym wykryciu popularnego problemu z
238 Eventum, jak nie działanie serwera bazy danych albo zmiana uprawnień
239 do plików konfiguracyjnych.
240
241 Należy zauważyć, że przed uruchomieniem tego monitora może być
242 konieczne dostosowanie niektórych testów do systemu, w szczególności
243 testów uprawnień i plików w Monitor::checkConfiguration().
244
245 Ten pakiet zawiera zadanie dla crona.
246
247 %package router-postfix
248 Summary:        Eventum Mail Routing - Postfix
249 Summary(pl.UTF-8):      Przekazywanie poczty Eventum - Postfix
250 Group:          Applications/Mail
251 Requires:       %{name} = %{version}-%{release}
252 Requires:       postfix
253 Provides:       eventum(router)
254 Obsoletes:      eventum(router)
255
256 %description router-postfix
257 This package provides way of routing notes and emails back to Eventum
258 via Postfix.
259
260 The Postfix configuration instructions you can find from
261 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
262
263 %description router-postfix -l pl.UTF-8
264 Ten pakiet udostępnia metodę przekazywania notatek i listów do Eventum
265 przez Postfiksa.
266
267 Opis konfiguracji Postfiksa można znaleźć pod adresem
268 <https://github.com/eventum/eventum/wiki/System-Admin:-Setting-up-email-routing-with-postfix>
269
270 %package cli
271 Summary:        Eventum command-line interface
272 Summary(pl.UTF-8):      Interfejs linii poleceń dla Eventum
273 Group:          Applications/WWW
274 Requires:       php(core) >= %{php_min_version}
275 Requires:       php(phar)
276
277 %description cli
278 The Eventum command-line interface allows you to access most of the
279 features of the web interface straight from your command shell.
280
281 %description cli -l pl.UTF-8
282 Interfejs linii poleceń Eventum pozwala na dostęp do większości
283 funkcji interfejsu WWW prosto z linii poleceń powłoki.
284
285 %package sphinx
286 Summary:        Eventum Sphinx Search
287 Group:          Applications/WWW
288 Requires:       %{name} = %{version}-%{release}
289 Requires:       crondaemon
290 Requires:       sphinx
291
292 %description sphinx
293 Sphinx search integration for Eventum.
294
295 This package contains the cron job.
296
297 %prep
298 %setup -q -n %{name}-%{version}%{?githash:-%{subver}-g%{githash}}
299
300 mv docs/examples .
301
302 # bug fixes / features
303 %{?with_order:%patch2 -p1}
304 #%patch3 -p0
305 #%patch4 -p1
306 %{?with_order:cp -p %{SOURCE16} htdocs/images}
307 #%patch200 -p1
308
309 # produce default sphinx config
310 # must be run before paths.patch
311 %if 0
312 cat <<'EOF' > config/config.php
313 <?php
314 define('APP_SQL_DBTYPE', 'mysql');
315 define('APP_SQL_DBHOST', 'localhost:/var/lib/mysql/mysql.sock');
316 define('APP_SQL_DBPORT', 3306);
317 define('APP_SQL_DBNAME', 'eventum');
318 define('APP_SQL_DBUSER', 'mysql');
319 define('APP_SQL_DBPASS', '');
320 define('APP_TABLE_PREFIX', 'eventum_');
321 EOF
322 php config/sphinx.conf.php > config/sphinx.conf
323 rm config/config.php
324 %endif
325
326 # packaging
327 %patch100 -p1
328 %patch107 -p1
329 %patch108 -p1
330
331 rm htdocs/.htaccess.dist
332 rm config/config.dist.php
333
334 # cleanup vendor. keep only needed libraries.
335 # (the rest are packaged with system packages)
336 mv vendor vendor.dist
337 vendor() {
338         local path dir
339         for path; do
340                 dir=$(dirname $path)
341                 test -d vendor/$dir || mkdir -p vendor/$dir
342                 mv vendor.dist/$path vendor/$path
343         done
344 }
345 vendor autoload.php
346 vendor composer/autoload_{classmap,files,namespaces,real,psr4}.php
347 vendor composer/ClassLoader.php
348 vendor ircmaxell/{random-lib,security-lib}
349 vendor defuse/php-encryption
350 vendor willdurand/email-reply-parser
351 vendor theorchard/monolog-cascade
352 vendor malkusch/lock
353 vendor phpxmlrpc/phpxmlrpc
354 vendor robmorgan/phinx
355 vendor mnapoli/silly
356 vendor psr/container
357 vendor phlib/flysystem-pdo
358 vendor league/flysystem
359 vendor php-di/invoker
360 vendor symfony/config
361 vendor symfony/console
362 vendor symfony/contracts
363 vendor symfony/event-dispatcher
364 vendor symfony/filesystem
365 vendor symfony/http-foundation
366 vendor symfony/options-resolver
367 vendor symfony/serializer
368 vendor symfony/yaml
369 vendor symfony/ldap
370 vendor symfony/security-core
371 vendor symfony/security-csrf
372 vendor glen/filename-normalizer
373 vendor doctrine/annotations
374 vendor doctrine/cache
375 vendor doctrine/collections
376 vendor doctrine/common
377 vendor doctrine/dbal
378 vendor doctrine/inflector
379 vendor doctrine/instantiator
380 vendor doctrine/lexer
381 vendor doctrine/orm
382 vendor cebe/markdown
383 vendor enrise/urihelper
384 vendor cakephp/core
385 vendor cakephp/collection
386 vendor cakephp/utility
387 vendor cakephp/datasource
388 vendor cakephp/database
389 vendor cakephp/log
390 vendor cakephp/cache
391 vendor doctrine/persistence
392 vendor doctrine/reflection
393 vendor doctrine/event-manager
394
395 # remove backups from patching as we use globs to package files to buildroot
396 find '(' -name '*~' -o -name '*.orig' ')' | xargs -r rm -v
397
398 %build
399 %{__make} -C localization
400
401 %install
402 rm -rf $RPM_BUILD_ROOT
403 install -d \
404         $RPM_BUILD_ROOT{%{_webappdir}/{custom_field,templates,workflow},%{_sysconfdir},%{_bindir},%{_sbindir},%{_libdir}} \
405         $RPM_BUILD_ROOT/etc/{rc.d/init.d,cron.d,logrotate.d,sysconfig} \
406         $RPM_BUILD_ROOT/var/{run,cache,lib}/%{name} \
407         $RPM_BUILD_ROOT/var/log/{archive/,}%{name} \
408         $RPM_BUILD_ROOT/var/lib/%{name}/{routed_{emails,drafts,notes},storage} \
409         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
410
411 %{__make} install-eventum install-cli install-localization \
412         sysconfdir=%{_webappdir} \
413         localedir=%{_localedir} \
414         DESTDIR=$RPM_BUILD_ROOT
415
416 ln -s %{_webappdir} $RPM_BUILD_ROOT%{_appdir}/config
417
418 cp -a vendor $RPM_BUILD_ROOT%{_appdir}
419
420 # unsupported locale
421 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ht
422
423 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
424 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
425
426 %{?with_order:cp -a htdocs/ajax $RPM_BUILD_ROOT%{_appdir}/htdocs}
427
428 touch $RPM_BUILD_ROOT%{_webappdir}/htpasswd
429 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/apache.conf
430 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_webappdir}/httpd.conf
431 cp -p %{SOURCE15} $RPM_BUILD_ROOT%{_webappdir}/lighttpd.conf
432
433 install -d $RPM_BUILD_ROOT/etc/sphinx
434 #cp -p config/sphinx.conf $RPM_BUILD_ROOT/etc/sphinx/%{name}.conf
435 cp -p config/sphinx.conf.php $RPM_BUILD_ROOT%{_webappdir}
436
437 cp -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
438 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
439 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
440 cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
441 cp -p %{SOURCE10} $RPM_BUILD_ROOT/etc/cron.d/%{name}-sphinx
442
443 cp -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
444
445 # postfix router
446 install -p %{SOURCE13} $RPM_BUILD_ROOT%{_libdir}/router-postfix
447
448 cp -p %{SOURCE17} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
449
450 %find_lang %{name}
451
452 %clean
453 rm -rf $RPM_BUILD_ROOT
454
455 %pre
456 %groupadd -g 146 %{name}
457 %useradd -u 146 -d /var/lib/%{name} -g %{name} -c "Eventum User" %{name}
458 %addusertogroup http %{name}
459
460 %post
461 # create empty ghost files
462 # these permissions ensure the logs are write only
463 for a in \
464         errors.log login_attempts.log \
465         eventum.log \
466         auth.log cli.log \
467 ; do
468         test -f /var/log/%{name}/$a && continue
469         install -m 0620 -o root -g http /dev/null /var/log/%{name}/$a
470 done
471
472 # run database update if configured
473 test -s %{_webappdir}/config.php && \
474 sudo -H -u http -- %{_appdir}/bin/upgrade.php || :
475
476 # nuke Smarty templates cache after upgrade
477 rm -f /var/cache/eventum/*.php
478
479 # Restart webserver on upgrade to get .mo translations reloaded.
480 # actually php engines "php-fcgi" and "php-fpm" needed only, apache is restarted anyway via webapp trigger.
481 %php_webserver_restart
482
483 %preun
484 if [ "$1" = "0" ]; then
485         # nuke cache
486         rm -f /var/cache/eventum/*.php 2>/dev/null || :
487 fi
488
489 %postun
490 if [ "$1" = "0" ]; then
491         %userremove %{name}
492         %groupremove %{name}
493 fi
494
495 %post setup
496 chmod 660 %{_webappdir}/{config,private_key,secret_key}.php
497 chown root:http %{_webappdir}/{config,private_key,secret_key}.php
498
499 %postun setup
500 if [ "$1" = "0" ] && [ -f %{_webappdir}/config.php ]; then
501         chmod 640 %{_webappdir}/{config,private_key,secret_key}.php
502         chown root:http %{_webappdir}/{config,private_key,secret_key}.php
503 fi
504
505 %triggerin -- apache1 < 1.3.37-3, apache1-base
506 %webapp_register apache %{_webapp}
507
508 %triggerun -- apache1 < 1.3.37-3, apache1-base
509 %webapp_unregister apache %{_webapp}
510
511 %triggerin -- apache < 2.2.0, apache-base
512 %webapp_register httpd %{_webapp}
513
514 %triggerun -- apache < 2.2.0, apache-base
515 %webapp_unregister httpd %{_webapp}
516
517 %triggerin -- lighttpd
518 %webapp_register lighttpd %{_webapp}
519
520 %triggerun -- lighttpd
521 %webapp_unregister lighttpd %{_webapp}
522
523 %files -f %{name}.lang
524 %defattr(644,root,root,755)
525 %attr(771,root,http) %dir %{_webappdir}
526 %attr(751,root,http) %dir %{_webappdir}/crm
527 %attr(751,root,http) %dir %{_webappdir}/custom_field
528 %attr(751,root,http) %dir %{_webappdir}/partner
529 %attr(751,root,http) %dir %{_webappdir}/templates
530 %attr(751,root,http) %dir %{_webappdir}/workflow
531 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/apache.conf
532 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/httpd.conf
533 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/lighttpd.conf
534 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/config.php
535 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/private_key.php
536 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/secret_key.php
537 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/setup.php
538 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webappdir}/htpasswd
539
540 %dir %attr(731,root,http) /var/log/%{name}
541 %attr(620,root,http) %ghost /var/log/%{name}/*
542 %dir %attr(750,root,root) /var/log/archive/%{name}
543 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
544
545 %dir %{_appdir}
546 %{_appdir}/config
547
548 %dir %{_appdir}/bin
549 %attr(755,root,root) %{_appdir}/bin/extension.php
550 %attr(755,root,root) %{_appdir}/bin/ldapsync.php
551 %attr(755,root,root) %{_appdir}/bin/migrate_storage_adapter.php
552 %attr(755,root,root) %{_appdir}/bin/process_all_emails.php
553 %attr(755,root,root) %{_appdir}/bin/upgrade.php
554
555 %{_appdir}/autoload.php
556 %{_appdir}/globals.php
557 %{_appdir}/init.php
558 %{_appdir}/phinx.php
559 %dir %{_appdir}/htdocs
560 %{_appdir}/htdocs/*.php
561 %{_appdir}/htdocs/*.ico
562 %{_appdir}/htdocs/ajax
563 %{_appdir}/htdocs/css
564 %{_appdir}/htdocs/customer
565 %{_appdir}/htdocs/images
566 %{_appdir}/htdocs/js
567 %{_appdir}/htdocs/manage
568 %{_appdir}/htdocs/reports
569 %{_appdir}/htdocs/rpc
570 %{_appdir}/htdocs/components
571 %{_appdir}/templates
572
573 %dir %{_appdir}/db
574 %dir %{_appdir}/db/migrations
575 %{_appdir}/db/migrations/*.php
576
577 %{_appdir}/res
578 %{_appdir}/src
579 %{_appdir}/vendor
580 %dir %{_appdir}/lib
581 %{_appdir}/lib/eventum
582 %exclude %{_appdir}/src/Console/Command/MailDownloadCommand.php
583 %exclude %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
584 %exclude %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
585 %exclude %{_appdir}/src/Console/Command/MonitorCommand.php
586 %exclude %{_appdir}/src/Console/Command/ReminderCheckCommand.php
587
588 %dir %{_libdir}
589
590 %{systemdtmpfilesdir}/%{name}.conf
591
592 %dir /var/lib/%{name}
593 %dir %attr(730,root,http) /var/run/%{name}
594 %dir %attr(730,root,http) /var/cache/%{name}
595
596 # saved mail copies
597 %attr(770,root,http) %dir /var/lib/%{name}/routed_emails
598 %attr(770,root,http) %dir /var/lib/%{name}/routed_drafts
599 %attr(770,root,http) %dir /var/lib/%{name}/routed_notes
600 # attachment storage
601 %attr(770,root,http) %dir /var/lib/%{name}/storage
602
603 %files setup
604 %defattr(644,root,root,755)
605 %{_appdir}/htdocs/setup
606
607 %files doc
608 %defattr(644,root,root,755)
609 %doc docs/*
610 %{_examplesdir}/%{name}-%{version}
611
612 %files mail-queue
613 %defattr(644,root,root,755)
614 %{_appdir}/src/Console/Command/MailQueueProcessCommand.php
615 %{_appdir}/src/Console/Command/MailQueueTruncateCommand.php
616 %attr(755,root,root) %{_appdir}/bin/process_mail_queue.php
617 %attr(755,root,root) %{_appdir}/bin/truncate_mail_queue.php
618 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
619
620 %files mail-download
621 %defattr(644,root,root,755)
622 %{_appdir}/src/Console/Command/MailDownloadCommand.php
623 %attr(755,root,root) %{_appdir}/bin/download_emails.php
624 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
625
626 %files reminder
627 %defattr(644,root,root,755)
628 %{_appdir}/src/Console/Command/ReminderCheckCommand.php
629 %attr(755,root,root) %{_appdir}/bin/check_reminders.php
630 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
631
632 %files monitor
633 %defattr(644,root,root,755)
634 %{_appdir}/src/Console/Command/MonitorCommand.php
635 %attr(755,root,root) %{_appdir}/bin/monitor.php
636 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
637
638 %files router-postfix
639 %defattr(644,root,root,755)
640 %attr(755,root,root) %{_libdir}/router-postfix
641
642 %files cli
643 %defattr(644,root,root,755)
644 %doc cli/eventumrc
645 %attr(755,root,root) %{_bindir}/%{name}
646
647 %files sphinx
648 %defattr(644,root,root,755)
649 %{_webappdir}/sphinx.conf.php
650 #%attr(750,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/sphinx/%{name}.conf
651 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-sphinx
This page took 0.065499 seconds and 3 git commands to generate.