]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
83b741e44ce962f98f859bc61538183e45175e1e
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - system pear is incompatible, at least pear DB class seems broke Eventum
3 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
4 # - discard bundled packages (from INSTALL):
5 #  - JpGraph 1.5.3 (last GPL version)
6 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
7 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
8 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
9 #  - A few other small javascript libraries
10 # - create eventum-router-qmail, eventum-router-postfix for -route-mails and -route-notes
11 # - need start-stop-daemon (from dpkg for now)
12 # - use eventum user for irc bot?
13
14 %bcond_with     pear    # build with system PEAR packages (or use bundled ones)
15
16 # snapshot: DATE
17 #define _snap 20050215
18
19 %if 0%{?_snap}
20 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
21 %else
22 %define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
23 %endif
24
25 %define _rel 1.142
26
27 Summary:        Eventum Issue - a bug tracking system
28 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
29 Name:           eventum
30 Version:        1.4
31 Release:        %{?_snap:0.%{_snap}.}%{_rel}
32 License:        GPL
33 Group:          Applications/WWW
34 Source0:        %{_source}
35 # Source0-md5:  361c1355e46a6bbfa54e420964ec92cf
36 Source1:        %{name}-apache.conf
37 Source2:        %{name}-mail-queue.cron
38 Source3:        %{name}-mail-download.cron
39 Source4:        %{name}-reminder.cron
40 Source5:        %{name}-monitor.cron
41 Source6:        %{name}-cvs.php
42 Source7:        %{name}-irc.php
43 Source8:        %{name}-irc.init
44 Patch0:         %{name}-paths.patch
45 Patch1:         %{name}-scm-encode.patch
46 Patch2:         %{name}-cvs-config.patch
47 Patch3:         %{name}-irc-config.patch
48 Patch4:         %{name}-PEAR.patch
49 Patch10:                %{name}-clock-status.patch
50 Patch11:                %{name}-scm_checkin_associated.patch
51 Patch12:                %{name}-mail-queue.tpl.patch
52 Patch13:                %{name}-maildecode.patch
53 Patch14:                %{name}-send-typo.patch
54 Patch15:                %{name}-fixes.patch
55 Patch16:                %{name}-rss-charset.patch
56 Patch17:                %{name}-scm-silence-add.patch
57 URL:            http://dev.mysql.com/downloads/other/eventum/index.html
58 BuildRequires:  rpmbuild(macros) >= 1.177
59 BuildRequires:  sed >= 4.0
60 Requires:       php >= 4.1.0
61 Requires:       php-gd
62 Requires:       php-imap
63 Requires:       php-mysql
64 Requires:       php-pcre
65 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
66 %if %{with pear}
67 Requires:       Smarty >= 2.6.2
68 Requires:       php-pear-Benchmark
69 Requires:       php-pear-DB
70 Requires:       php-pear-Date
71 Requires:       php-pear-HTTP_Request
72 Requires:       php-pear-Mail
73 Requires:       php-pear-Math_Stats
74 Requires:       php-pear-Net_DIME
75 Requires:       php-pear-Net_POP3
76 Requires:       php-pear-Net_SMTP
77 Requires:       php-pear-Net_SmartIRC
78 Requires:       php-pear-Net_Socket
79 Requires:       php-pear-Net_URL
80 Requires:       php-pear-Net_UserAgent_Detect
81 Requires:       php-pear-PEAR
82 Requires:       php-pear-Text_Diff
83 Requires:       php-pear-XML_RPC
84 %endif
85 Requires:       apache-mod_dir
86 # conflict with non-confdir apache
87 Conflicts:      apache1 < 1.3.33-1.1
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 %define         _sysconfdir     /etc/%{name}
91 %define         _appdir %{_datadir}/%{name}
92 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
93
94 %define         _apache1dir     /etc/apache
95 %define         _apache2dir     /etc/httpd
96
97 %description
98 Eventum is a user-friendly and flexible issue tracking system that can
99 be used by a support department to track incoming technical support
100 requests, or by a software development team to quickly organize tasks
101 and bugs. Eventum is used by the MySQL AB Technical Support team, and
102 has allowed us to dramatically improve our response times.
103
104 %description -l pl
105 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
106 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
107 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
108 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
109 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
110 reakcji.
111
112 %package base
113 Summary:        Eventum base package
114 Summary(pl):    Podstawowy pakiet Eventum
115 Group:          Applications/WWW
116
117 %description base
118 This package contains base directory structure for Eventum.
119
120 %description base -l pl
121 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
122
123 %package setup
124 Summary:        Eventum setup package
125 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
126 Group:          Applications/WWW
127 PreReq:         %{name} = %{epoch}:%{version}-%{release}
128
129 %description setup
130 Install this package to configure initial Eventum installation. You
131 should uninstall this package when you're done, as it considered
132 insecure to keep the setup files in place.
133
134 %description setup -l pl
135 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
136 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
137 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
138
139 %package mail-queue
140 Summary:        Eventum mail queue process
141 Summary(pl):    Przetwarzanie kolejki poczty Eventum
142 Group:          Applications/WWW
143 Requires:       %{name} = %{epoch}:%{version}-%{release}
144 Requires:       crondaemon
145 Requires:       php4 >= 4.1.0
146
147 %description mail-queue
148 Beginning with the first release of Eventum, emails are not directly
149 sent out from the various scripts, but rather added to a mail queue
150 table that is processed by a cron job. If an email cannot be sent, it
151 will be marked as such in the mail queue log, and the cron job script
152 will re-try to send it again the next time it runs.
153
154 This package contains the cron job.
155
156 %description mail-queue -l pl
157 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
158 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
159 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
160 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
161 nastêpnym razem.
162
163 Ten pakiet zawiera zadanie dla crona.
164
165 %package mail-download
166 Summary:        Eventum email download
167 Summary(pl):    ¦ci±ganie poczty Eventum
168 Group:          Applications/WWW
169 Requires:       %{name} = %{epoch}:%{version}-%{release}
170 Requires:       crondaemon
171 Requires:       php4 >= 4.1.0
172
173 %description mail-download
174 In order for Eventum's email integration feature to work, you need to
175 setup a cron job to run the script every so often.
176
177 This package contains the cron job.
178
179 %description mail-download -l pl
180 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
181 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
182 czêsto.
183
184 Ten pakiet zawiera zadanie dla crona.
185
186 %package reminder
187 Summary:        Eventum Reminder System
188 Summary(pl):    System przypominania dla Eventum
189 Group:          Applications/WWW
190 Requires:       %{name} = %{epoch}:%{version}-%{release}
191 Requires:       php4 >= 4.1.0
192 Requires:       crondaemon
193
194 %description reminder
195 The reminder system was designed with the objective as serving as a
196 safe net for issues that need attention. Depending on what
197 configuration you create, you may have several reminders (or alerts)
198 be sent out whenever an issue needs attention, for whatever parameter
199 you may deem necessary.
200
201 This package contains the cron job.
202
203 %description reminder -l pl
204 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
205 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
206 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
207 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
208 uwa¿aæ za potrzebny.
209
210 Ten pakiet zawiera zadanie dla crona.
211
212 %package monitor
213 Summary:        Eventum Heartbeat Monitor
214 Summary(pl):    Monitor ¿ycia dla Eventum
215 Group:          Applications/WWW
216 Requires:       %{name} = %{epoch}:%{version}-%{release}
217 Requires:       php4 >= 4.1.0
218 Requires:       crondaemon
219
220 %description monitor
221 The heartbeat monitor is a feature designed for the administrator that
222 wants to be alerted whenever a common problem in Eventum is detected,
223 like the database server not being available anymore, or maybe when
224 the recommended permissions for certain configuration files are
225 changed.
226
227 Please note that before running the heartbeat monitor, you may need to
228 customize some of the checks to be appropriate for your own system,
229 particularly the permission and file checks on
230 Monitor::checkConfiguration().
231
232 This package contains the cron job.
233
234 %description monitor -l pl
235 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
236 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
237 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
238 do plików konfiguracyjnych.
239
240 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
241 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
242 testów uprawnieñ i plików w Monitor::checkConfiguration().
243
244 Ten pakiet zawiera zadanie dla crona.
245
246 %package route-emails
247 Summary:        Eventum Email Routing
248 Summary(pl):    Przekazywanie poczty dla Eventum
249 Group:          Applications/WWW
250 Requires:       %{name} = %{epoch}:%{version}-%{release}
251 Requires:       php4 >= 4.1.0
252 #Requires:      eventum-router
253
254 %description route-emails
255 The email routing feature is used to automatically associate a thread
256 of emails into an Eventum issue. By setting up qmail (or even postfix)
257 to deliver emails sent to a specific address (usually
258 issue-<number>@<domain>) to the above script, users are able to use
259 their email clients to reply to emails coming from Eventum, and those
260 replies will be automatically associated with the issue and
261 broadcasted to the entire notification list.
262
263 %description route-emails -l pl
264 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
265 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
266 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
267 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
268 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
269 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
270 rozprowadzane do ca³ej listy og³oszeniowej.
271
272 %package route-notes
273 Summary:        Eventum Note Routing
274 Summary(pl):    Przekazywanie notatek dla Eventum
275 Group:          Applications/WWW
276 Requires:       %{name} = %{epoch}:%{version}-%{release}
277 Requires:       php4 >= 4.1.0
278 #Requires:      eventum-router
279
280 %description route-notes
281 The note routing feature is used to automatically associate a thread
282 of notes into an Eventum issue. By setting up qmail (or even postfix)
283 to deliver emails sent to a specific address (usually
284 note-<number>@<domain>) to the above script, users are able to use
285 their email clients to reply to internal notes coming from Eventum,
286 and those replies will be automatically associated with the issue and
287 broadcasted to the notification list staff members.
288
289 %description route-notes -l pl
290 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
291 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
292 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
293 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
294 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
295 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
296 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
297
298 %package irc
299 Summary:        Eventum IRC Notification Bot
300 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
301 Group:          Applications/WWW
302 Requires:       %{name} = %{epoch}:%{version}-%{release}
303 Requires:       php >= 4.1.0
304 Requires:       php-sockets
305 # FIXME just need start-stop-daemon
306 Requires:       dpkg
307
308 %description irc
309 The IRC notification bot is a nice feature for remote teams that want
310 to handle issues and want to have a quick and easy way to get simple
311 notifications. Right now the bot notifies of the following actions:
312 - New Issues
313 - Blocked emails
314 - Issues that got their assignment list changed
315
316 NOTE: You will need to manually edit the bot.php script to set your
317 appropriate preferences, like IRC server and channel that the bot
318 should join.
319
320 %description irc -l pl
321 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
322 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
323 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
324 nastêpuj±cych zdarzeniach:
325 - nowych sprawach
326 - zablokowanych listach
327 - sprawach, dla których zmieni³a siê lista powi±zañ
328
329 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
330 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
331
332 %package cli
333 Summary:        Eventum command-line interface
334 Summary(pl):    Interfejs linii poleceñ dla Eventum
335 Group:          Applications/WWW
336 Requires:       %{name} = %{epoch}:%{version}-%{release}
337 Requires:       php4 >= 4.1.0
338 Requires:       php4-cli
339 Requires:       php4-curl
340 Requires:       php4-xml
341 Requires:       php-pear-XML_RPC
342
343 %description cli
344 The Eventum command-line interface allows you to access most of the
345 features of the web interface straight from your command shell.
346
347 %description cli -l pl
348 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
349 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
350
351 %package scm
352 Summary:        Eventum SCM integration
353 Summary(pl):    Integracja SCM dla Eventum
354 Group:          Applications/WWW
355 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
356 Requires:       php4 >= 4.1.0
357
358 %description scm
359 This feature allows your software development teams to integrate your
360 Source Control Management system with your Issue Tracking System.
361
362 The integration is implemented in such a way that it will be forward
363 compatible with pretty much any SCM system, such as CVS.
364
365 For installation see
366 /eventum/help.php?topic=scm_integration_installation .
367
368 %description scm -l pl
369 Ten pakiet pozwala zespo³om programistów na integracjê systemu
370 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
371 ¶ledzenia spraw.
372
373 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
374 prawie ka¿dym systemem SCM, jak np. CVS.
375
376 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
377 /eventum/help.php?topic=scm_integration_installation .
378
379 %prep
380 %setup -q %{?_snap:-n %{name}-%{_snap}}
381 # undos the source
382 find . -type f -print0 | xargs -0 sed -i -e 's,
383 $,,'
384
385 # packaging
386 %patch0 -p1 -b .paths
387 %patch1 -p1
388 %patch2 -p1
389 %patch3 -p1
390 %{?with_pear:%patch4 -p1 -b .PEAR}
391
392 # bug fixes. do not apply if building snap
393 %if %{undefined snap}
394 %patch10 -p1
395 %patch11 -p1
396 %patch12 -p1
397 %patch13 -p1
398 %patch14 -p1
399 %patch15 -p1
400 %patch16 -p1
401 %patch17 -p1
402 %endif
403
404 rm -f */*~ */*/*~
405
406 %install
407 rm -rf $RPM_BUILD_ROOT
408 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_appdir}} \
409         $RPM_BUILD_ROOT{/etc/{rc.d/init.d,cron.d},/var/log/%{name}} \
410         $RPM_BUILD_ROOT{/var/run/eventum,/var/cache/eventum}
411
412 cp -a *.php {css,customer,images,include,js} \
413         {manage,misc,reports,rpc,setup,templates} $RPM_BUILD_ROOT%{_appdir}
414 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
415
416 > $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
417
418 sed -i -e 's,/usr/local/bin/php,/usr/bin/php4,' $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum
419 echo '#!/usr/bin/php4 -q' > %{name}-scm
420 cat $RPM_BUILD_ROOT%{_appdir}/misc/scm/process_cvs_commits.php >> %{name}-scm
421
422 # change private key, so we can easily grep
423 sed -i -e '
424 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
425 ' $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
426
427 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
428 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
429 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
430 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
431 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
432 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
433 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
434 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
435
436 # in conf
437 mv $RPM_BUILD_ROOT%{_appdir}/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/config.php
438 mv $RPM_BUILD_ROOT%{_appdir}/setup.conf.php $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
439 mv $RPM_BUILD_ROOT%{_appdir}/include/private_key.php $RPM_BUILD_ROOT%{_sysconfdir}
440 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
441 ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
442 ln -s %{_sysconfdir}/setup.php $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
443 ln -s %{_sysconfdir}/private_key.php $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
444
445 # in doc
446 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/upgrade
447 # sample, not used in eventum
448 rm -rf $RPM_BUILD_ROOT%{_appdir}/rpc/xmlrpc_client.php
449
450 # in bindir
451 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum $RPM_BUILD_ROOT%{_bindir}
452 rm -f $RPM_BUILD_ROOT%{_appdir}/misc/{cli/eventumrc_example,scm/process_cvs_commits.php}
453 cp misc/cli/eventumrc_example eventumrc
454 install %{name}-scm $RPM_BUILD_ROOT%{_bindir}/%{name}-scm
455
456 %if %{with pear}
457 # provided by PEAR
458 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/cli/include/pear
459 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
460
461 # use system Smarty
462 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
463 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
464 # These plugins are not in Smarty package (Smarty-2.6.2-3)
465 cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php $RPM_BUILD_ROOT%{_smartyplugindir}
466 %endif
467
468 %clean
469 rm -rf $RPM_BUILD_ROOT
470
471 %post
472 # apache1
473 if [ -d %{_apache1dir}/conf.d ]; then
474         ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
475         if [ -f /var/lock/subsys/apache ]; then
476                 /etc/rc.d/init.d/apache restart 1>&2
477         fi
478 fi
479 # apache2
480 if [ -d %{_apache2dir}/httpd.conf ]; then
481         ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
482         if [ -f /var/lock/subsys/httpd ]; then
483                 /etc/rc.d/init.d/httpd restart 1>&2
484         fi
485 fi
486
487 # check if the package is configured.
488 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
489 %banner %{name} -e <<EOF
490
491 You haven't yet configured Eventum!
492
493 Install %{name}-setup and open up http://yourserver/eventum/
494 -- that will help you setup initial config.
495
496 when have configured Eventum, please uninstall the setup package,
497 so that %{name}-setup is able to secure your Eventum installation.
498
499 EOF
500 #' vim stupidity.
501
502 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
503 %banner %{name} -e <<EOF
504
505 You have default private key installed!
506
507 Install %{name}-setup and open up http://yourserver/eventum/setup/
508 -- that will help you setup initial config.
509
510 when have configured Eventum, please uninstall the setup package,
511 so that %{name}-setup is able to secure your Eventum installation.
512
513 EOF
514         elif [ -d %{_appdir}/setup ]; then
515 %banner %{name} -e <<EOF
516
517 If you have have configured Eventum, please uninstall the setup package,
518 so that %{name}-setup is able to secure your Eventum installation.
519
520 EOF
521 fi
522
523
524 %preun
525 if [ "$1" = "0" ]; then
526         # apache1
527         if [ -f %{_apache1dir}/apache.conf ]; then
528                 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
529                 if [ -f /var/lock/subsys/apache ]; then
530                         /etc/rc.d/init.d/apache restart 1>&2
531                 fi
532         fi
533         # apache2
534         if [ -d %{_apache2dir}/httpd.conf ]; then
535                 rm -f %{_apache2dir}/httpd.conf/99_%{name}.conf
536                 if [ -f /var/lock/subsys/httpd ]; then
537                         /etc/rc.d/init.d/httpd restart 1>&2
538                 fi
539         fi
540 fi
541
542 %post setup
543 chmod 660 %{_sysconfdir}/{config,private_key}.php
544 chown root:http %{_sysconfdir}/{config,private_key}.php
545
546 %postun setup
547 if [ "$1" = "0" ]; then
548         chmod 640 %{_sysconfdir}/{config,private_key}.php
549         chown root:http %{_sysconfdir}/{config,private_key}.php
550 fi
551
552 %files
553 %defattr(644,root,root,755)
554 %doc ChangeLog FAQ INSTALL README UPGRADE misc/upgrade docs/* rpc/xmlrpc_client.php
555 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
556 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
557 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
558 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
559
560 %dir %{_appdir}
561 %dir %{_appdir}/misc
562
563 %dir %attr(731,root,http) /var/log/%{name}
564 %attr(620,root,http) %ghost /var/log/%{name}/*
565
566 %{_appdir}/*.php
567 %{_appdir}/css
568 %{_appdir}/customer
569 %{_appdir}/images
570 %{_appdir}/js
571 %{_appdir}/manage
572 %{_appdir}/reports
573 %{_appdir}/rpc
574 %{_appdir}/templates
575
576 %if %{with pear}
577 %{_smartyplugindir}/*
578 %else
579 %{_appdir}/include/pear
580 %{_appdir}/include/Smarty
581 %endif
582
583 %dir %{_appdir}/include
584 %{_appdir}/include/customer
585 %{_appdir}/include/jpgraph
586 %{_appdir}/include/workflow
587 %{_appdir}/include/*.php
588
589 %dir %attr(730,root,http) /var/run/%{name}
590 %dir %attr(730,root,http) /var/cache/%{name}
591
592 %{_appdir}/misc/blank.html
593
594 %files base
595 %defattr(644,root,root,755)
596 %attr(751,root,root) %dir %{_sysconfdir}
597
598 %files setup
599 %defattr(644,root,root,755)
600 %{_appdir}/setup
601
602 %files mail-queue
603 %defattr(644,root,root,755)
604 %{_appdir}/misc/process_mail_queue.php
605 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
606
607 %files mail-download
608 %defattr(644,root,root,755)
609 %{_appdir}/misc/download_emails.php
610 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
611
612 %files reminder
613 %defattr(644,root,root,755)
614 %{_appdir}/misc/check_reminders.php
615 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
616
617 %files monitor
618 %defattr(644,root,root,755)
619 %{_appdir}/misc/monitor.php
620 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
621
622 %files route-emails
623 %defattr(644,root,root,755)
624 %{_appdir}/misc/route_emails.php
625
626 %files route-notes
627 %defattr(644,root,root,755)
628 %{_appdir}/misc/route_drafts.php
629 %{_appdir}/misc/route_notes.php
630
631 %files irc
632 %defattr(644,root,root,755)
633 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
634 %{_appdir}/misc/irc
635 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
636
637 %files cli
638 %defattr(644,root,root,755)
639 %doc eventumrc
640 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cli.php
641 %attr(755,root,root) %{_bindir}/%{name}
642 %dir %{_appdir}/misc/cli
643 %{_appdir}/misc/cli/include
644
645 %files scm
646 %defattr(644,root,root,755)
647 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
648 # FIXME: not sure about this naming.
649 %attr(755,root,root) %{_bindir}/%{name}-scm
This page took 0.087729 seconds and 3 git commands to generate.