]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
5ae0dde9bfaffd061c0898661e4006d9c17d5427
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - system pear is incompatible, at least pear DB class seems broke Eventum
3 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
4 # - discard bundled packages (from INSTALL):
5 #  - JpGraph 1.5.3 (last GPL version)
6 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
7 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
8 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
9 #  - A few other small javascript libraries
10 # - create eventum-router-qmail, eventum-router-postfix for -route-mails and -route-notes
11 # - need start-stop-daemon (from dpkg for now)
12 # - use eventum user for irc bot?
13
14 %bcond_with     pear    # build with system PEAR packages (or use bundled ones)
15
16 # snapshot: DATE
17 #define _snap 20050124
18
19 %if 0%{?_snap}
20 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
21 %else
22 %define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
23 %endif
24
25 %define _rel 1.136
26
27 Summary:        Eventum Issue - a bug tracking system
28 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
29 Name:           eventum
30 Version:        1.4
31 Release:        %{?_snap:0.%{_snap}.}%{_rel}
32 License:        GPL
33 Group:          Applications/WWW
34 Source0:        %{_source}
35 # Source0-md5:  361c1355e46a6bbfa54e420964ec92cf
36 Source1:        %{name}-apache.conf
37 Source2:        %{name}-mail-queue.cron
38 Source3:        %{name}-mail-download.cron
39 Source4:        %{name}-reminder.cron
40 Source5:        %{name}-monitor.cron
41 Source6:        %{name}-cvs.php
42 Source7:        %{name}-irc.php
43 Source8:        %{name}-irc.init
44 Patch0:         %{name}-paths.patch
45 Patch1:         %{name}-scm-encode.patch
46 Patch2:         %{name}-cvs-config.patch
47 Patch3:         %{name}-irc-config.patch
48 Patch4:         %{name}-PEAR.patch
49 Patch10:                %{name}-clock-status.patch
50 Patch11:                %{name}-scm_checkin_associated.patch
51 Patch12:                %{name}-mail-queue.tpl.patch
52 URL:            http://dev.mysql.com/downloads/other/eventum/index.html
53 BuildRequires:  rpmbuild(macros) >= 1.177
54 BuildRequires:  sed >= 4.0
55 Requires:       php >= 4.1.0
56 Requires:       php-gd
57 Requires:       php-imap
58 Requires:       php-mysql
59 Requires:       php-pcre
60 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
61 %if %{with pear}
62 Requires:       Smarty >= 2.6.2
63 Requires:       php-pear-Benchmark
64 Requires:       php-pear-DB
65 Requires:       php-pear-Date
66 Requires:       php-pear-HTTP_Request
67 Requires:       php-pear-Mail
68 Requires:       php-pear-Math_Stats
69 Requires:       php-pear-Net_DIME
70 Requires:       php-pear-Net_POP3
71 Requires:       php-pear-Net_SMTP
72 Requires:       php-pear-Net_SmartIRC
73 Requires:       php-pear-Net_Socket
74 Requires:       php-pear-Net_URL
75 Requires:       php-pear-Net_UserAgent_Detect
76 Requires:       php-pear-PEAR
77 Requires:       php-pear-Text_Diff
78 Requires:       php-pear-XML_RPC
79 %endif
80 #Requires:      apache-mod_dir
81 # conflict with non-confdir apache
82 Conflicts:      apache1 < 1.3.33-1.1
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %define         _sysconfdir     /etc/%{name}
86 %define         _appdir %{_datadir}/%{name}
87 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
88
89 %define         _apache1dir     /etc/apache
90 %define         _apache2dir     /etc/httpd
91
92 %description
93 Eventum is a user-friendly and flexible issue tracking system that can
94 be used by a support department to track incoming technical support
95 requests, or by a software development team to quickly organize tasks
96 and bugs. Eventum is used by the MySQL AB Technical Support team, and
97 has allowed us to dramatically improve our response times.
98
99 %description -l pl
100 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
101 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
102 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
103 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
104 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
105 reakcji.
106
107 %package base
108 Summary:        Eventum base package
109 Summary(pl):    Podstawowy pakiet Eventum
110 Group:          Applications/WWW
111
112 %description base
113 This package contains base directory structure for Eventum.
114
115 %description base -l pl
116 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
117
118 %package setup
119 Summary:        Eventum setup package
120 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
121 Group:          Applications/WWW
122 PreReq:         %{name} = %{epoch}:%{version}-%{release}
123
124 %description setup
125 Install this package to configure initial Eventum installation. You
126 should uninstall this package when you're done, as it considered
127 insecure to keep the setup files in place.
128
129 %description setup -l pl
130 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
131 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
132 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
133
134 %package mail-queue
135 Summary:        Eventum mail queue process
136 Summary(pl):    Przetwarzanie kolejki poczty Eventum
137 Group:          Applications/WWW
138 Requires:       %{name} = %{epoch}:%{version}-%{release}
139 Requires:       crondaemon
140 Requires:       php4 >= 4.1.0
141
142 %description mail-queue
143 Beginning with the first release of Eventum, emails are not directly
144 sent out from the various scripts, but rather added to a mail queue
145 table that is processed by a cron job. If an email cannot be sent, it
146 will be marked as such in the mail queue log, and the cron job script
147 will re-try to send it again the next time it runs.
148
149 This package contains the cron job.
150
151 %description mail-queue -l pl
152 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
153 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
154 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
155 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
156 nastêpnym razem.
157
158 Ten pakiet zawiera zadanie dla crona.
159
160 %package mail-download
161 Summary:        Eventum email download
162 Summary(pl):    ¦ci±ganie poczty Eventum
163 Group:          Applications/WWW
164 Requires:       %{name} = %{epoch}:%{version}-%{release}
165 Requires:       crondaemon
166 Requires:       php4 >= 4.1.0
167
168 %description mail-download
169 In order for Eventum's email integration feature to work, you need to
170 setup a cron job to run the script every so often.
171
172 This package contains the cron job.
173
174 %description mail-download -l pl
175 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
176 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
177 czêsto.
178
179 Ten pakiet zawiera zadanie dla crona.
180
181 %package reminder
182 Summary:        Eventum Reminder System
183 Summary(pl):    System przypominania dla Eventum
184 Group:          Applications/WWW
185 Requires:       %{name} = %{epoch}:%{version}-%{release}
186 Requires:       php4 >= 4.1.0
187 Requires:       crondaemon
188
189 %description reminder
190 The reminder system was designed with the objective as serving as a
191 safe net for issues that need attention. Depending on what
192 configuration you create, you may have several reminders (or alerts)
193 be sent out whenever an issue needs attention, for whatever parameter
194 you may deem necessary.
195
196 This package contains the cron job.
197
198 %description reminder -l pl
199 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
200 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
201 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
202 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
203 uwa¿aæ za potrzebny.
204
205 Ten pakiet zawiera zadanie dla crona.
206
207 %package monitor
208 Summary:        Eventum Heartbeat Monitor
209 Summary(pl):    Monitor ¿ycia dla Eventum
210 Group:          Applications/WWW
211 Requires:       %{name} = %{epoch}:%{version}-%{release}
212 Requires:       php4 >= 4.1.0
213 Requires:       crondaemon
214
215 %description monitor
216 The heartbeat monitor is a feature designed for the administrator that
217 wants to be alerted whenever a common problem in Eventum is detected,
218 like the database server not being available anymore, or maybe when
219 the recommended permissions for certain configuration files are
220 changed.
221
222 Please note that before running the heartbeat monitor, you may need to
223 customize some of the checks to be appropriate for your own system,
224 particularly the permission and file checks on
225 Monitor::checkConfiguration().
226
227 This package contains the cron job.
228
229 %description monitor -l pl
230 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
231 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
232 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
233 do plików konfiguracyjnych.
234
235 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
236 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
237 testów uprawnieñ i plików w Monitor::checkConfiguration().
238
239 Ten pakiet zawiera zadanie dla crona.
240
241 %package route-emails
242 Summary:        Eventum Email Routing
243 Summary(pl):    Przekazywanie poczty dla Eventum
244 Group:          Applications/WWW
245 Requires:       %{name} = %{epoch}:%{version}-%{release}
246 Requires:       php4 >= 4.1.0
247 #Requires:      eventum-router
248
249 %description route-emails
250 The email routing feature is used to automatically associate a thread
251 of emails into an Eventum issue. By setting up qmail (or even postfix)
252 to deliver emails sent to a specific address (usually
253 issue-<number>@<domain>) to the above script, users are able to use
254 their email clients to reply to emails coming from Eventum, and those
255 replies will be automatically associated with the issue and
256 broadcasted to the entire notification list.
257
258 %description route-emails -l pl
259 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
260 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
261 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
262 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
263 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
264 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
265 rozprowadzane do ca³ej listy og³oszeniowej.
266
267 %package route-notes
268 Summary:        Eventum Note Routing
269 Summary(pl):    Przekazywanie notatek dla Eventum
270 Group:          Applications/WWW
271 Requires:       %{name} = %{epoch}:%{version}-%{release}
272 Requires:       php4 >= 4.1.0
273 #Requires:      eventum-router
274
275 %description route-notes
276 The note routing feature is used to automatically associate a thread
277 of notes into an Eventum issue. By setting up qmail (or even postfix)
278 to deliver emails sent to a specific address (usually
279 note-<number>@<domain>) to the above script, users are able to use
280 their email clients to reply to internal notes coming from Eventum,
281 and those replies will be automatically associated with the issue and
282 broadcasted to the notification list staff members.
283
284 %description route-notes -l pl
285 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
286 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
287 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
288 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
289 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
290 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
291 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
292
293 %package irc
294 Summary:        Eventum IRC Notification Bot
295 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
296 Group:          Applications/WWW
297 Requires:       %{name} = %{epoch}:%{version}-%{release}
298 Requires:       php >= 4.1.0
299 Requires:       php-sockets
300 # FIXME just need start-stop-daemon
301 Requires:       dpkg
302
303 %description irc
304 The IRC notification bot is a nice feature for remote teams that want
305 to handle issues and want to have a quick and easy way to get simple
306 notifications. Right now the bot notifies of the following actions:
307 - New Issues
308 - Blocked emails
309 - Issues that got their assignment list changed
310
311 NOTE: You will need to manually edit the bot.php script to set your
312 appropriate preferences, like IRC server and channel that the bot
313 should join.
314
315 %description irc -l pl
316 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
317 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
318 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
319 nastêpuj±cych zdarzeniach:
320 - nowych sprawach
321 - zablokowanych listach
322 - sprawach, dla których zmieni³a siê lista powi±zañ
323
324 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
325 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
326
327 %package cli
328 Summary:        Eventum command-line interface
329 Summary(pl):    Interfejs linii poleceñ dla Eventum
330 Group:          Applications/WWW
331 Requires:       %{name} = %{epoch}:%{version}-%{release}
332 Requires:       php4 >= 4.1.0
333 Requires:       php4-cli
334 Requires:       php4-curl
335 Requires:       php4-xml
336 Requires:       php-pear-XML_RPC
337
338 %description cli
339 The Eventum command-line interface allows you to access most of the
340 features of the web interface straight from your command shell.
341
342 %description cli -l pl
343 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
344 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
345
346 %package scm
347 Summary:        Eventum SCM integration
348 Summary(pl):    Integracja SCM dla Eventum
349 Group:          Applications/WWW
350 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
351 Requires:       php4 >= 4.1.0
352
353 %description scm
354 This feature allows your software development teams to integrate your
355 Source Control Management system with your Issue Tracking System.
356
357 The integration is implemented in such a way that it will be forward
358 compatible with pretty much any SCM system, such as CVS.
359
360 For installation see
361 /eventum/help.php?topic=scm_integration_installation .
362
363 %description scm -l pl
364 Ten pakiet pozwala zespo³om programistów na integracjê systemu
365 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
366 ¶ledzenia spraw.
367
368 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
369 prawie ka¿dym systemem SCM, jak np. CVS.
370
371 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
372 /eventum/help.php?topic=scm_integration_installation .
373
374 %prep
375 %setup -q %{?_snap:-n %{name}-%{_snap}}
376 # undos the source
377 find . -type f -print0 | xargs -0 sed -i -e 's,
378 $,,'
379
380 # packaging
381 %patch0 -p1 -b .paths
382 %patch1 -p1
383 %patch2 -p1
384 %patch3 -p1
385 %{?with_pear:%patch4 -p1 -b .PEAR}
386
387 # bug fixes
388 %patch10 -p1
389 %patch11 -p1
390 %patch12 -p1
391
392 rm -f */*~ */*/*~
393
394 %install
395 rm -rf $RPM_BUILD_ROOT
396 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_appdir}} \
397         $RPM_BUILD_ROOT{/etc/{rc.d/init.d,cron.d},/var/log/%{name}} \
398         $RPM_BUILD_ROOT{/var/run/eventum,/var/cache/eventum}
399
400 cp -a *.php {css,customer,images,include,js} \
401         {manage,misc,reports,rpc,setup,templates} $RPM_BUILD_ROOT%{_appdir}
402 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
403
404 > $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
405
406 sed -i -e 's,/usr/local/bin/php,/usr/bin/php4,' $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum
407 echo '#!/usr/bin/php4 -q' > %{name}-scm
408 cat $RPM_BUILD_ROOT%{_appdir}/misc/scm/process_cvs_commits.php >> %{name}-scm
409
410 # change private key, so we can easily grep
411 sed -i -e '
412 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
413 ' $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
414
415 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
416 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
417 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
418 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
419 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
420 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
421 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
422 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
423
424 # in conf
425 mv $RPM_BUILD_ROOT%{_appdir}/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/config.php
426 mv $RPM_BUILD_ROOT%{_appdir}/setup.conf.php $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
427 mv $RPM_BUILD_ROOT%{_appdir}/include/private_key.php $RPM_BUILD_ROOT%{_sysconfdir}
428 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
429 ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
430 ln -s %{_sysconfdir}/setup.php $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
431 ln -s %{_sysconfdir}/private_key.php $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
432
433 # in doc
434 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/upgrade
435 # sample, not used in eventum
436 rm -rf $RPM_BUILD_ROOT%{_appdir}/rpc/xmlrpc_client.php
437
438 # in bindir
439 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum $RPM_BUILD_ROOT%{_bindir}
440 rm -f $RPM_BUILD_ROOT%{_appdir}/misc/{cli/eventumrc_example,scm/process_cvs_commits.php}
441 cp misc/cli/eventumrc_example eventumrc
442 install %{name}-scm $RPM_BUILD_ROOT%{_bindir}/%{name}-scm
443
444 %if %{with pear}
445 # provided by PEAR
446 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/cli/include/pear
447 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
448
449 # use system Smarty
450 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
451 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
452 # These plugins are not in Smarty package (Smarty-2.6.2-3)
453 cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php $RPM_BUILD_ROOT%{_smartyplugindir}
454 %endif
455
456 %clean
457 rm -rf $RPM_BUILD_ROOT
458
459 %post
460 # apache1
461 if [ -f %{_apache1dir}/apache.conf ]; then
462         ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
463         if [ -f /var/lock/subsys/apache ]; then
464                 /etc/rc.d/init.d/apache restart 1>&2
465         fi
466 fi
467 # apache2
468 if [ -d %{_apache2dir}/httpd.conf ]; then
469         ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
470         if [ -f /var/lock/subsys/httpd ]; then
471                 /etc/rc.d/init.d/httpd restart 1>&2
472         fi
473 fi
474
475 # check if the package is configured.
476 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
477 %banner %{name} -e <<EOF
478
479 You haven't yet configured Eventum!
480
481 Install %{name}-setup and open up http://yourserver/eventum/
482 -- that will help you setup initial config.
483
484 when have configured Eventum, please uninstall the setup package,
485 so that %{name}-setup is able to secure your Eventum installation.
486
487 EOF
488 #' vim stupidity.
489
490 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
491 %banner %{name} -e <<EOF
492
493 You have default private key installed!
494
495 Install %{name}-setup and open up http://yourserver/eventum/setup/
496 -- that will help you setup initial config.
497
498 when have configured Eventum, please uninstall the setup package,
499 so that %{name}-setup is able to secure your Eventum installation.
500
501 EOF
502         elif [ -d %{_appdir}/setup ]; then
503 %banner %{name} -e <<EOF
504
505 If you have have configured Eventum, please uninstall the setup package,
506 so that %{name}-setup is able to secure your Eventum installation.
507
508 EOF
509 fi
510
511
512 %preun
513 if [ "$1" = "0" ]; then
514         # apache1
515         if [ -f %{_apache1dir}/apache.conf ]; then
516                 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
517                 if [ -f /var/lock/subsys/apache ]; then
518                         /etc/rc.d/init.d/apache restart 1>&2
519                 fi
520         fi
521         # apache2
522         if [ -d %{_apache2dir}/httpd.conf ]; then
523                 rm -f %{_apache1dir}/httpd.conf/99_%{name}.conf
524                 if [ -f /var/lock/subsys/httpd ]; then
525                         /etc/rc.d/init.d/httpd restart 1>&2
526                 fi
527         fi
528 fi
529
530 %post setup
531 chmod 660 %{_sysconfdir}/{config,private_key}.php
532 chown root:http %{_sysconfdir}/{config,private_key}.php
533
534 %postun setup
535 if [ "$1" = "0" ]; then
536         chmod 640 %{_sysconfdir}/{config,private_key}.php
537         chown root:http %{_sysconfdir}/{config,private_key}.php
538 fi
539
540 %files
541 %defattr(644,root,root,755)
542 %doc ChangeLog FAQ INSTALL README UPGRADE misc/upgrade docs/* rpc/xmlrpc_client.php
543 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
544 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
545 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
546 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
547
548 %dir %{_appdir}
549 %dir %{_appdir}/misc
550
551 %dir %attr(731,root,http) /var/log/%{name}
552 %attr(620,root,http) %ghost /var/log/%{name}/*
553
554 %{_appdir}/*.php
555 %{_appdir}/css
556 %{_appdir}/customer
557 %{_appdir}/images
558 %{_appdir}/js
559 %{_appdir}/manage
560 %{_appdir}/reports
561 %{_appdir}/rpc
562 %{_appdir}/templates
563
564 %if %{with pear}
565 %{_smartyplugindir}/*
566 %else
567 %{_appdir}/include/pear
568 %{_appdir}/include/Smarty
569 %endif
570
571 %dir %{_appdir}/include
572 %{_appdir}/include/customer
573 %{_appdir}/include/jpgraph
574 %{_appdir}/include/workflow
575 %{_appdir}/include/*.php
576
577 %dir %attr(730,root,http) /var/run/%{name}
578 %dir %attr(730,root,http) /var/cache/%{name}
579
580 %{_appdir}/misc/blank.html
581
582 %files base
583 %defattr(644,root,root,755)
584 %attr(751,root,root) %dir %{_sysconfdir}
585
586 %files setup
587 %defattr(644,root,root,755)
588 %{_appdir}/setup
589
590 %files mail-queue
591 %defattr(644,root,root,755)
592 %{_appdir}/misc/process_mail_queue.php
593 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
594
595 %files mail-download
596 %defattr(644,root,root,755)
597 %{_appdir}/misc/download_emails.php
598 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
599
600 %files reminder
601 %defattr(644,root,root,755)
602 %{_appdir}/misc/check_reminders.php
603 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
604
605 %files monitor
606 %defattr(644,root,root,755)
607 %{_appdir}/misc/monitor.php
608 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
609
610 %files route-emails
611 %defattr(644,root,root,755)
612 %{_appdir}/misc/route_emails.php
613
614 %files route-notes
615 %defattr(644,root,root,755)
616 %{_appdir}/misc/route_drafts.php
617 %{_appdir}/misc/route_notes.php
618
619 %files irc
620 %defattr(644,root,root,755)
621 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
622 %{_appdir}/misc/irc
623 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
624
625 %files cli
626 %defattr(644,root,root,755)
627 %doc eventumrc
628 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cli.php
629 %attr(755,root,root) %{_bindir}/%{name}
630 %dir %{_appdir}/misc/cli
631 %{_appdir}/misc/cli/include
632
633 %files scm
634 %defattr(644,root,root,755)
635 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
636 # FIXME: not sure about this naming.
637 %attr(755,root,root) %{_bindir}/%{name}-scm
This page took 0.295355 seconds and 3 git commands to generate.