]> git.pld-linux.org Git - packages/eventum.git/blob - eventum.spec
564a2850a9b305720a866a8b054809448d1a7441
[packages/eventum.git] / eventum.spec
1 # TODO
2 # - system pear is incompatible, at least pear DB class seems broke Eventum
3 # - php5 is not tested, but not placing hard conflict on it, as it prevents php4 & php coinstallation
4 # - discard bundled packages (from INSTALL):
5 #  - JpGraph 1.5.3 (last GPL version)
6 #  - dTree 2.0.5 (http://www.destroydrop.com/javascript/tree/)
7 #  - dynCalendar.js (http://www.phpguru.org/dyncalendar.html)
8 #  - overLIB 3.5.1 (http://www.bosrup.com/web/overlib/)
9 #  - A few other small javascript libraries
10 # - create eventum-router-qmail, eventum-router-postfix for -route-mails and -route-notes
11 # - need start-stop-daemon (from dpkg for now)
12 # - use eventum user for irc bot?
13
14 %bcond_with     pear    # build with system PEAR packages (or use bundled ones)
15
16 # snapshot: DATE
17 #define _snap 20050217
18
19 %if 0%{?_snap}
20 %define _source http://downloads.mysql.com/snapshots/%{name}/%{name}-nightly-%{_snap}.tar.gz
21 %else
22 %define _source http://mysql.wildyou.net/Downloads/%{name}/%{name}-%{version}.tar.gz
23 %endif
24
25 %define _rel 1.151
26
27 Summary:        Eventum Issue - a bug tracking system
28 Summary(pl):    Eventum - system ¶ledzenia spraw/b³êdów
29 Name:           eventum
30 Version:        1.4
31 Release:        %{?_snap:0.%{_snap}.}%{_rel}
32 License:        GPL
33 Group:          Applications/WWW
34 Source0:        %{_source}
35 # Source0-md5:  361c1355e46a6bbfa54e420964ec92cf
36 Source1:        %{name}-apache.conf
37 Source2:        %{name}-mail-queue.cron
38 Source3:        %{name}-mail-download.cron
39 Source4:        %{name}-reminder.cron
40 Source5:        %{name}-monitor.cron
41 Source6:        %{name}-cvs.php
42 Source7:        %{name}-irc.php
43 Source8:        %{name}-irc.init
44 Patch0:         %{name}-paths.patch
45 Patch1:         %{name}-scm-encode.patch
46 Patch2:         %{name}-cvs-config.patch
47 Patch3:         %{name}-irc-config.patch
48 Patch4:         %{name}-PEAR.patch
49 Patch11:                %{name}-scm_checkin_associated.patch
50 Patch12:                %{name}-mail-queue.tpl.patch
51 Patch13:                %{name}-maildecode.patch
52 Patch14:                %{name}-send-typo.patch
53 Patch15:                %{name}-fixes.patch
54 Patch16:                %{name}-rss-charset.patch
55 Patch17:                %{name}-scm-silence-add.patch
56 Patch18:                %{name}-default-TZ.patch
57 Patch19:                %{name}-charset-mailsubj.patch
58 URL:            http://dev.mysql.com/downloads/other/eventum/index.html
59 BuildRequires:  rpmbuild(macros) >= 1.177
60 BuildRequires:  sed >= 4.0
61 Requires:       php >= 4.1.0
62 Requires:       php-gd
63 Requires:       php-imap
64 Requires:       php-mysql
65 Requires:       php-pcre
66 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
67 %if %{with pear}
68 Requires:       Smarty >= 2.6.2
69 Requires:       php-pear-Benchmark
70 Requires:       php-pear-DB
71 Requires:       php-pear-Date
72 Requires:       php-pear-HTTP_Request
73 Requires:       php-pear-Mail
74 Requires:       php-pear-Math_Stats
75 Requires:       php-pear-Net_DIME
76 Requires:       php-pear-Net_POP3
77 Requires:       php-pear-Net_SMTP
78 Requires:       php-pear-Net_SmartIRC
79 Requires:       php-pear-Net_Socket
80 Requires:       php-pear-Net_URL
81 Requires:       php-pear-Net_UserAgent_Detect
82 Requires:       php-pear-PEAR
83 Requires:       php-pear-Text_Diff
84 Requires:       php-pear-XML_RPC
85 %endif
86 Requires:       apache-mod_dir
87 # conflict with non-confdir apache
88 Conflicts:      apache1 < 1.3.33-1.1
89 BuildArch:      noarch
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define         _sysconfdir     /etc/%{name}
93 %define         _libdir         %{_prefix}/%{_lib}/%{name}
94 %define         _appdir %{_datadir}/%{name}
95 %define         _smartyplugindir        %{php_pear_dir}/Smarty/plugins
96
97 %define         _apache1dir     /etc/apache
98 %define         _apache2dir     /etc/httpd
99
100 %description
101 Eventum is a user-friendly and flexible issue tracking system that can
102 be used by a support department to track incoming technical support
103 requests, or by a software development team to quickly organize tasks
104 and bugs. Eventum is used by the MySQL AB Technical Support team, and
105 has allowed us to dramatically improve our response times.
106
107 %description -l pl
108 Eventum to przyjazny dla u¿ytkownika system ¶ledzenia spraw, który
109 mo¿e byæ u¿ywany przez dzia³ obs³ugi do ¶ledzenia przychodz±cych ¿±dañ
110 obs³ugi technicznej albo przez zespó³ tworz±cy oprogramowanie do
111 szybkiej organizacji zadañ i b³êdów. Eventum jest u¿ywany przez zespó³
112 Technical Support MySQL AB i umo¿liwi³ im znacz±co poprawiæ czasy
113 reakcji.
114
115 %package base
116 Summary:        Eventum base package
117 Summary(pl):    Podstawowy pakiet Eventum
118 Group:          Applications/WWW
119
120 %description base
121 This package contains base directory structure for Eventum.
122
123 %description base -l pl
124 Ten pakiet zawiera podstawow± strukturê katalogów dla Eventum.
125
126 %package setup
127 Summary:        Eventum setup package
128 Summary(pl):    Pakiet do wstêpnej konfiguracji Eventum
129 Group:          Applications/WWW
130 PreReq:         %{name} = %{epoch}:%{version}-%{release}
131
132 %description setup
133 Install this package to configure initial Eventum installation. You
134 should uninstall this package when you're done, as it considered
135 insecure to keep the setup files in place.
136
137 %description setup -l pl
138 Ten pakiet nale¿y zainstalowaæ w celu wstêpnej konfiguracji Eventum po
139 pierwszej instalacji. Potem nale¿y go odinstalowaæ, jako ¿e
140 pozostawienie plików instalacyjnych mog³oby byæ niebezpieczne.
141
142 %package mail-queue
143 Summary:        Eventum mail queue process
144 Summary(pl):    Przetwarzanie kolejki poczty Eventum
145 Group:          Applications/WWW
146 Requires:       %{name} = %{epoch}:%{version}-%{release}
147 Requires:       crondaemon
148 Requires:       php4 >= 4.1.0
149
150 %description mail-queue
151 Beginning with the first release of Eventum, emails are not directly
152 sent out from the various scripts, but rather added to a mail queue
153 table that is processed by a cron job. If an email cannot be sent, it
154 will be marked as such in the mail queue log, and the cron job script
155 will re-try to send it again the next time it runs.
156
157 This package contains the cron job.
158
159 %description mail-queue -l pl
160 Od pierwszego wydania Eventum poczta nie jest wysy³ana bezpo¶rednio z
161 ró¿nych skryptów, lecz dodawana do kolejki przetwarzanej z crona.
162 Je¶li poczta nie mo¿e byæ wys³ana, bêdzie odpowiednio oznaczona w logu
163 kolejki poczty, a skrypt z crona bêdzie próbowa³ wys³aæ j± ponownie
164 nastêpnym razem.
165
166 Ten pakiet zawiera zadanie dla crona.
167
168 %package mail-download
169 Summary:        Eventum email download
170 Summary(pl):    ¦ci±ganie poczty Eventum
171 Group:          Applications/WWW
172 Requires:       %{name} = %{epoch}:%{version}-%{release}
173 Requires:       crondaemon
174 Requires:       php >= 4.1.0
175
176 %description mail-download
177 In order for Eventum's email integration feature to work, you need to
178 setup a cron job to run the script every so often.
179
180 This package contains the cron job.
181
182 %description mail-download -l pl
183 Aby integracja poczty elektronicznej w Eventum dzia³a³a, trzeba
184 ustawiæ zadanie crona, aby uruchamia³ odpowiedni skrypt wystarczaj±co
185 czêsto.
186
187 Ten pakiet zawiera zadanie dla crona.
188
189 %package reminder
190 Summary:        Eventum Reminder System
191 Summary(pl):    System przypominania dla Eventum
192 Group:          Applications/WWW
193 Requires:       %{name} = %{epoch}:%{version}-%{release}
194 Requires:       php4 >= 4.1.0
195 Requires:       crondaemon
196
197 %description reminder
198 The reminder system was designed with the objective as serving as a
199 safe net for issues that need attention. Depending on what
200 configuration you create, you may have several reminders (or alerts)
201 be sent out whenever an issue needs attention, for whatever parameter
202 you may deem necessary.
203
204 This package contains the cron job.
205
206 %description reminder -l pl
207 System przypominania zosta³ zaprojektowany tak, aby s³u¿y³ jako
208 bezpieczna sieæ dla spraw wymagaj±cych uwagi. W zale¿no¶ci od
209 konfiguracji mo¿na ustawiæ ró¿ne przypominajki (lub alarmy) wysy³ane
210 przy ka¿dej sprawie wymagaj±cej uwagi lub przy parametrze, który mo¿na
211 uwa¿aæ za potrzebny.
212
213 Ten pakiet zawiera zadanie dla crona.
214
215 %package monitor
216 Summary:        Eventum Heartbeat Monitor
217 Summary(pl):    Monitor ¿ycia dla Eventum
218 Group:          Applications/WWW
219 Requires:       %{name} = %{epoch}:%{version}-%{release}
220 Requires:       php4 >= 4.1.0
221 Requires:       crondaemon
222
223 %description monitor
224 The heartbeat monitor is a feature designed for the administrator that
225 wants to be alerted whenever a common problem in Eventum is detected,
226 like the database server not being available anymore, or maybe when
227 the recommended permissions for certain configuration files are
228 changed.
229
230 Please note that before running the heartbeat monitor, you may need to
231 customize some of the checks to be appropriate for your own system,
232 particularly the permission and file checks on
233 Monitor::checkConfiguration().
234
235 This package contains the cron job.
236
237 %description monitor -l pl
238 Monitor ¿ycia to funkcjonalno¶æ zaprojektowana dla administratora
239 chc±cego byæ alarmowanym przy ka¿dym wykryciu popularnego problemu z
240 Eventum, jak nie dzia³anie serwera bazy danych albo zmiana uprawnieñ
241 do plików konfiguracyjnych.
242
243 Nale¿y zauwa¿yæ, ¿e przed uruchomieniem tego monitora mo¿e byæ
244 konieczne dostosowanie niektórych testów do systemu, w szczególno¶ci
245 testów uprawnieñ i plików w Monitor::checkConfiguration().
246
247 Ten pakiet zawiera zadanie dla crona.
248
249 %package route-emails
250 Summary:        Eventum Email Routing
251 Summary(pl):    Przekazywanie poczty dla Eventum
252 Group:          Applications/WWW
253 Requires:       %{name} = %{epoch}:%{version}-%{release}
254 Requires:       php4 >= 4.1.0
255 #Requires:      eventum-router
256
257 %description route-emails
258 The email routing feature is used to automatically associate a thread
259 of emails into an Eventum issue. By setting up qmail (or even postfix)
260 to deliver emails sent to a specific address (usually
261 issue-<number>@<domain>) to the above script, users are able to use
262 their email clients to reply to emails coming from Eventum, and those
263 replies will be automatically associated with the issue and
264 broadcasted to the entire notification list.
265
266 %description route-emails -l pl
267 Funkcjonalno¶æ przekazywania poczty s³u¿y do automatycznego wi±zania
268 w±tku listów ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
269 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
270 issue-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
271 u¿ywaæ klientów pocztowych do odpowiadania na listy przychodz±ce z
272 Eventum, a odpowiedzi te bêd± automatycznie wi±zane ze spraw± i
273 rozprowadzane do ca³ej listy og³oszeniowej.
274
275 %package route-notes
276 Summary:        Eventum Note Routing
277 Summary(pl):    Przekazywanie notatek dla Eventum
278 Group:          Applications/WWW
279 Requires:       %{name} = %{epoch}:%{version}-%{release}
280 Requires:       php4 >= 4.1.0
281 #Requires:      eventum-router
282
283 %description route-notes
284 The note routing feature is used to automatically associate a thread
285 of notes into an Eventum issue. By setting up qmail (or even postfix)
286 to deliver emails sent to a specific address (usually
287 note-<number>@<domain>) to the above script, users are able to use
288 their email clients to reply to internal notes coming from Eventum,
289 and those replies will be automatically associated with the issue and
290 broadcasted to the notification list staff members.
291
292 %description route-notes -l pl
293 Funkcjonalno¶æ przekazywania notatek s³u¿y do automatycznego wi±zania
294 w±tku notatek ze spraw± w Eventum. Po ustawieniu qmaila (czy nawet
295 postfiksa), aby dostarcza³ listy wysy³ane na pewien adres (zwykle
296 note-<numer>@<domena>) na powy¿szy skrypt, u¿ytkownicy bêd± mogli
297 u¿ywaæ klientów pocztowych do odpowiadania na wewnêtrzne notatki
298 pochodz±ce od Eventu, a odpowiedzi te bêd± automatycznie wi±zane ze
299 spraw± i rozprowadzane do cz³onków personelu listy og³oszeniowej.
300
301 %package irc
302 Summary:        Eventum IRC Notification Bot
303 Summary(pl):    IRC-owy bot powiadamiaj±cy dla Eventum
304 Group:          Applications/WWW
305 Requires:       %{name} = %{epoch}:%{version}-%{release}
306 Requires:       php >= 4.1.0
307 Requires:       php-sockets
308 # FIXME just need start-stop-daemon
309 Requires:       dpkg
310
311 %description irc
312 The IRC notification bot is a nice feature for remote teams that want
313 to handle issues and want to have a quick and easy way to get simple
314 notifications. Right now the bot notifies of the following actions:
315 - New Issues
316 - Blocked emails
317 - Issues that got their assignment list changed
318
319 NOTE: You will need to manually edit the bot.php script to set your
320 appropriate preferences, like IRC server and channel that the bot
321 should join.
322
323 %description irc -l pl
324 IRC-owy bot powiadamiaj±cy to mi³a funkcjonalno¶æ dla zdalnych
325 zespo³ów chc±cych obs³ugiwaæ sprawy i mieæ szybki i ³atwy sposób na
326 uzyskiwanie prostych powiadomieñ. Aktualnie bot powiadamia o
327 nastêpuj±cych zdarzeniach:
328 - nowych sprawach
329 - zablokowanych listach
330 - sprawach, dla których zmieni³a siê lista powi±zañ
331
332 UWAGA: w celu wprowadzenia w³asnych ustawieñ, takich jak serwer IRC i
333 kana³ u¿ywany przez bota, trzeba rêcznie zmodyfikowaæ skrypt bot.php .
334
335 %package cli
336 Summary:        Eventum command-line interface
337 Summary(pl):    Interfejs linii poleceñ dla Eventum
338 Group:          Applications/WWW
339 Requires:       %{name} = %{epoch}:%{version}-%{release}
340 Requires:       php4 >= 4.1.0
341 Requires:       php4-cli
342 Requires:       php4-curl
343 Requires:       php4-xml
344 Requires:       php-pear-XML_RPC
345
346 %description cli
347 The Eventum command-line interface allows you to access most of the
348 features of the web interface straight from your command shell.
349
350 %description cli -l pl
351 Interfejs linii poleceñ Eventum pozwala na dostêp do wiêkszo¶ci
352 funkcji interfejsu WWW prosto z linii poleceñ pow³oki.
353
354 %package scm
355 Summary:        Eventum SCM integration
356 Summary(pl):    Integracja SCM dla Eventum
357 Group:          Applications/WWW
358 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
359 Requires:       php4 >= 4.1.0
360
361 %description scm
362 This feature allows your software development teams to integrate your
363 Source Control Management system with your Issue Tracking System.
364
365 The integration is implemented in such a way that it will be forward
366 compatible with pretty much any SCM system, such as CVS.
367
368 For installation see
369 </eventum/help.php?topic=scm_integration_installation>.
370
371 %description scm -l pl
372 Ten pakiet pozwala zespo³om programistów na integracjê systemu
373 zarz±dzania ¼ród³ami (SCM - Source Control Management) z systemem
374 ¶ledzenia spraw.
375
376 Integracja jest zaimplementowana tak, aby byæ kompatybilna w przód z
377 prawie ka¿dym systemem SCM, jak np. CVS.
378
379 Szczegó³y na temat instalacji mo¿na przeczytaæ pod
380 </eventum/help.php?topic=scm_integration_installation>.
381
382 %prep
383 %setup -q %{?_snap:-n %{name}-%{_snap}}
384 # undos the source
385 find . -type f -print0 | xargs -0 sed -i -e 's,
386 $,,'
387
388 # packaging
389 %patch0 -p1 -b .paths
390 %patch1 -p1
391 %patch2 -p1
392 %patch3 -p1
393 %{?with_pear:%patch4 -p1 -b .PEAR}
394
395 # bug fixes.
396 %patch11 -p1
397 %patch12 -p1
398 %patch13 -p1
399 %patch14 -p1
400 %patch15 -p1
401 %patch16 -p1
402 %patch17 -p1
403 %patch18 -p1
404 %patch19 -p1
405
406 rm -f */*~ */*/*~
407
408 %install
409 rm -rf $RPM_BUILD_ROOT
410 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_bindir},%{_libdir},%{_appdir}} \
411         $RPM_BUILD_ROOT{/etc/{rc.d/init.d,cron.d},/var/log/%{name}} \
412         $RPM_BUILD_ROOT{/var/run/eventum,/var/cache/eventum}
413
414 cp -a *.php {css,customer,images,include,js} \
415         {manage,misc,reports,rpc,setup,templates} $RPM_BUILD_ROOT%{_appdir}
416 cp -a logs/* $RPM_BUILD_ROOT/var/log/%{name}
417
418 > $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
419
420 sed -i -e 's,/usr/local/bin/php,/usr/bin/php4,' $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum
421 echo '#!/usr/bin/php4 -q' > %{name}-scm
422 cat $RPM_BUILD_ROOT%{_appdir}/misc/scm/process_cvs_commits.php >> %{name}-scm
423
424 # change private key, so we can easily grep
425 sed -i -e '
426 s,$private_key\s*=\s*".*";,$private_key = "DEFAULTPRIVATEKEYPLEASERUNSETUP!";,
427 ' $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
428
429 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
430 install %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-queue
431 install %{SOURCE3} $RPM_BUILD_ROOT/etc/cron.d/%{name}-mail-download
432 install %{SOURCE4} $RPM_BUILD_ROOT/etc/cron.d/%{name}-reminder
433 install %{SOURCE5} $RPM_BUILD_ROOT/etc/cron.d/%{name}-monitor
434 install %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cvs.php
435 install %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/irc.php
436 install %{SOURCE8} $RPM_BUILD_ROOT/etc/rc.d/init.d/eventum-irc
437
438 # in conf
439 mv $RPM_BUILD_ROOT%{_appdir}/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/config.php
440 mv $RPM_BUILD_ROOT%{_appdir}/setup.conf.php $RPM_BUILD_ROOT%{_sysconfdir}/setup.php
441 mv $RPM_BUILD_ROOT%{_appdir}/include/private_key.php $RPM_BUILD_ROOT%{_sysconfdir}
442 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/config.inc.php $RPM_BUILD_ROOT%{_sysconfdir}/cli.php
443 ln -s %{_sysconfdir}/config.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
444 ln -s %{_sysconfdir}/setup.php $RPM_BUILD_ROOT%{_appdir}/setup.conf.php
445 ln -s %{_sysconfdir}/private_key.php $RPM_BUILD_ROOT%{_appdir}/include/private_key.php
446
447 # in doc
448 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/upgrade
449 # sample, not used in eventum
450 rm -rf $RPM_BUILD_ROOT%{_appdir}/rpc/xmlrpc_client.php
451
452 # in bindir
453 mv $RPM_BUILD_ROOT%{_appdir}/misc/cli/eventum $RPM_BUILD_ROOT%{_bindir}
454 rm -f $RPM_BUILD_ROOT%{_appdir}/misc/{cli/eventumrc_example,scm/process_cvs_commits.php}
455 cp -f misc/cli/eventumrc_example eventumrc
456 install %{name}-scm $RPM_BUILD_ROOT%{_libdir}/scm
457
458 %if %{with pear}
459 # provided by PEAR
460 rm -rf $RPM_BUILD_ROOT%{_appdir}/misc/cli/include/pear
461 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/pear
462
463 # use system Smarty
464 rm -rf $RPM_BUILD_ROOT%{_appdir}/include/Smarty
465 install -d $RPM_BUILD_ROOT%{_smartyplugindir}
466 # These plugins are not in Smarty package (Smarty-2.6.2-3)
467 cp -a include/Smarty/plugins/function.{calendar,get_{display_style,innerhtml,textarea_size}}.php $RPM_BUILD_ROOT%{_smartyplugindir}
468 %endif
469
470 %clean
471 rm -rf $RPM_BUILD_ROOT
472
473 %post
474 # apache1
475 if [ -d %{_apache1dir}/conf.d ]; then
476         ln -sf %{_sysconfdir}/apache.conf %{_apache1dir}/conf.d/99_%{name}.conf
477         if [ -f /var/lock/subsys/apache ]; then
478                 /etc/rc.d/init.d/apache restart 1>&2
479         fi
480 fi
481 # apache2
482 if [ -d %{_apache2dir}/httpd.conf ]; then
483         ln -sf %{_sysconfdir}/apache.conf %{_apache2dir}/httpd.conf/99_%{name}.conf
484         if [ -f /var/lock/subsys/httpd ]; then
485                 /etc/rc.d/init.d/httpd restart 1>&2
486         fi
487 fi
488
489 # check if the package is configured.
490 if grep -q 'header("Location: setup/")' %{_sysconfdir}/config.php; then
491 %banner %{name} -e <<EOF
492
493 You haven't yet configured Eventum!
494
495 Install %{name}-setup and open up http://yourserver/eventum/
496 -- that will help you setup initial config.
497
498 when have configured Eventum, please uninstall the setup package,
499 so that %{name}-setup is able to secure your Eventum installation.
500
501 EOF
502 #' vim stupidity.
503
504 elif grep -q 'DEFAULTPRIVATEKEY' %{_sysconfdir}/private_key.php; then
505 %banner %{name} -e <<EOF
506
507 You have default private key installed!
508
509 Install %{name}-setup and open up http://yourserver/eventum/setup/
510 -- that will help you setup initial config.
511
512 when have configured Eventum, please uninstall the setup package,
513 so that %{name}-setup is able to secure your Eventum installation.
514
515 EOF
516         elif [ -d %{_appdir}/setup ]; then
517 %banner %{name} -e <<EOF
518
519 If you have have configured Eventum, please uninstall the setup package,
520 so that %{name}-setup is able to secure your Eventum installation.
521
522 EOF
523 fi
524
525
526 %preun
527 if [ "$1" = "0" ]; then
528         # apache1
529         if [ -f %{_apache1dir}/apache.conf ]; then
530                 rm -f %{_apache1dir}/conf.d/99_%{name}.conf
531                 if [ -f /var/lock/subsys/apache ]; then
532                         /etc/rc.d/init.d/apache restart 1>&2
533                 fi
534         fi
535         # apache2
536         if [ -d %{_apache2dir}/httpd.conf ]; then
537                 rm -f %{_apache2dir}/httpd.conf/99_%{name}.conf
538                 if [ -f /var/lock/subsys/httpd ]; then
539                         /etc/rc.d/init.d/httpd restart 1>&2
540                 fi
541         fi
542 fi
543
544 %post setup
545 chmod 660 %{_sysconfdir}/{config,private_key}.php
546 chown root:http %{_sysconfdir}/{config,private_key}.php
547
548 %postun setup
549 if [ "$1" = "0" ]; then
550         chmod 640 %{_sysconfdir}/{config,private_key}.php
551         chown root:http %{_sysconfdir}/{config,private_key}.php
552 fi
553
554 %files
555 %defattr(644,root,root,755)
556 %doc ChangeLog FAQ INSTALL README UPGRADE
557 %doc misc/upgrade docs/* rpc/xmlrpc_client.php setup/schema.sql 
558 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
559 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.php
560 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/private_key.php
561 %attr(660,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/setup.php
562
563 %dir %{_appdir}
564 %dir %{_appdir}/misc
565
566 %dir %attr(731,root,http) /var/log/%{name}
567 %attr(620,root,http) %ghost /var/log/%{name}/*
568
569 %{_appdir}/*.php
570 %{_appdir}/css
571 %{_appdir}/customer
572 %{_appdir}/images
573 %{_appdir}/js
574 %{_appdir}/manage
575 %{_appdir}/reports
576 %{_appdir}/rpc
577 %{_appdir}/templates
578
579 %if %{with pear}
580 %{_smartyplugindir}/*
581 %else
582 %{_appdir}/include/pear
583 %{_appdir}/include/Smarty
584 %endif
585
586 %dir %{_appdir}/include
587 %{_appdir}/include/customer
588 %{_appdir}/include/jpgraph
589 %{_appdir}/include/workflow
590 %{_appdir}/include/*.php
591
592 %dir %attr(730,root,http) /var/run/%{name}
593 %dir %attr(730,root,http) /var/cache/%{name}
594
595 %{_appdir}/misc/blank.html
596
597 %files base
598 %defattr(644,root,root,755)
599 %attr(751,root,root) %dir %{_sysconfdir}
600 %dir %{_libdir}
601
602 %files setup
603 %defattr(644,root,root,755)
604 %{_appdir}/setup
605
606 %files mail-queue
607 %defattr(644,root,root,755)
608 %{_appdir}/misc/process_mail_queue.php
609 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-queue
610
611 %files mail-download
612 %defattr(644,root,root,755)
613 %{_appdir}/misc/download_emails.php
614 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-mail-download
615
616 %files reminder
617 %defattr(644,root,root,755)
618 %{_appdir}/misc/check_reminders.php
619 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-reminder
620
621 %files monitor
622 %defattr(644,root,root,755)
623 %{_appdir}/misc/monitor.php
624 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/%{name}-monitor
625
626 %files route-emails
627 %defattr(644,root,root,755)
628 %{_appdir}/misc/route_emails.php
629
630 %files route-notes
631 %defattr(644,root,root,755)
632 %{_appdir}/misc/route_drafts.php
633 %{_appdir}/misc/route_notes.php
634
635 %files irc
636 %defattr(644,root,root,755)
637 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/irc.php
638 %{_appdir}/misc/irc
639 %attr(754,root,root) /etc/rc.d/init.d/%{name}-irc
640
641 %files cli
642 %defattr(644,root,root,755)
643 %doc eventumrc
644 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cli.php
645 %attr(755,root,root) %{_bindir}/%{name}
646 %dir %{_appdir}/misc/cli
647 %{_appdir}/misc/cli/include
648
649 %files scm
650 %defattr(644,root,root,755)
651 %attr(644,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cvs.php
652 %attr(755,root,root) %{_libdir}/scm
This page took 0.108232 seconds and 3 git commands to generate.