]> git.pld-linux.org Git - packages/et.git/blob - et.spec
pl, short Name
[packages/et.git] / et.spec
1 #
2 # Conditional build:
3 #
4 %bcond_with     data    # build data subpackage (huge and resource consuming)
5 #
6 Summary:        Enemy Territory
7 Summary(pl):    Enemy Territory - Terytorium wroga
8 Name:           et
9 Version:        2.56
10 Release:        0.11
11 Epoch:          0
12 License:        RTCW-ETEULA
13 Group:          Applications/Games
14 Source0:        http://3dgamers.planetmirror.com/pub/3dgamers/games/wolfensteinet/et-linux-%{version}-2.x86.run
15 # NoSource0-md5:        4dddf1612b9ed5b3fe9d3348ec78c28f
16 Source1:        %{name}.desktop
17 NoSource:       0
18 URL:            http://www.idsoftware.com/
19 # loose dependancy is intentional
20 Requires:       %{name}-data = %{version}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         no_install_post_strip   1
24 %define         no_install_post_chrpath 1
25 %define         _gamelibdir     %{_libdir}/games/et
26 %define         _gamedatadir    %{_datadir}/games/et
27
28 %description
29 Return to Castle Wolfenstein: Enemy Territory - standalone
30 multi-player game based on Return to Castle Wolfenstein.
31
32 %description -l pl
33 Powrót do zamku Wolfenstein: Terytorium wroga (Return to Castle
34 Wolfenstein: Enemy Territory) jest to samodzielna gra dla wielu graczy
35 oparta na Powrocie do zamku Wolfenstein (Return to Castle
36 Wolfenstein).
37
38 %package data
39 Summary:        Enemy Territory data files
40 Summary(pl):    Pliki z danymi dla Enemy Territory
41 Group:          Applications/Games
42
43 %description data
44 This package contains the data files for Enemy Territory.
45
46 %description data -l pl
47 Pakiet ten zawiera pliki z danymi dla gry Enemy Territory.
48
49 %prep
50 %setup -qcT
51 sh %{SOURCE0} --tar xf
52
53 %build
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_desktopdir}} \
58         $RPM_BUILD_ROOT{%{_gamelibdir},%{_gamedatadir}}
59
60 install bin/Linux/x86/et.x86 $RPM_BUILD_ROOT%{_gamelibdir}/%{name}
61
62 cat << EOF > $RPM_BUILD_ROOT%{_bindir}/%{name}
63 #!/bin/sh
64 # Needed to make symlinks/shortcuts work.
65 # the binaries must run with correct working directory
66 cd %{_gamelibdir}
67 export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
68 exec ./%{name} "\$@"
69 EOF
70
71 install ET.xpm $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.xpm
72 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
73 ln -s ../../../share/games/et/etmain $RPM_BUILD_ROOT%{_gamelibdir}
74
75 cp -a pb $RPM_BUILD_ROOT%{_gamelibdir}
76 # in DOCS
77 rm -f $RPM_BUILD_ROOT%{_gamelibdir}/pb/PB_EULA.txt
78
79 %if %{with data}
80 cp -a etmain $RPM_BUILD_ROOT%{_gamedatadir}
81 %endif
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc CHANGES v1.02_Readme.htm Docs pb/PB_EULA.txt
89 %attr(755,root,root) %{_bindir}/*
90
91 %dir %{_gamelibdir}
92 %attr(755,root,root) %{_gamelibdir}/et
93 %{_gamelibdir}/etmain
94
95 %dir %{_gamelibdir}/pb
96 %{_gamelibdir}/pb/htm
97 %attr(755,root,root) %{_gamelibdir}/pb/*.x86
98 %attr(755,root,root) %{_gamelibdir}/pb/*.so
99 %{_gamelibdir}/pb/*.db
100
101 %{_desktopdir}/%{name}.desktop
102 %{_pixmapsdir}/%{name}.xpm
103
104 %if %{with data}
105 %files data
106 %{_gamedatadir}
107 %endif
This page took 0.059256 seconds and 4 git commands to generate.