]> git.pld-linux.org Git - packages/et.git/blob - et.spec
84383713b642a6a1f20ce1468fe128904dd862a9
[packages/et.git] / et.spec
1 # TODO
2 # - create dedicated server subpackage
3 #
4 # Conditional build:
5 %bcond_without  data    # skip build of data subpackage (huge and resource consuming)
6 #
7 Summary:        Enemy Territory
8 Summary(pl):    Enemy Territory - Terytorium wroga
9 Name:           et
10 Version:        2.56
11 Release:        0.13
12 Epoch:          0
13 License:        RTCW-ETEULA
14 Group:          Applications/Games
15 Source0:        http://3dgamers.planetmirror.com/pub/3dgamers/games/wolfensteinet/et-linux-%{version}-2.x86.run
16 # NoSource0-md5:        4dddf1612b9ed5b3fe9d3348ec78c28f
17 Source1:        %{name}.desktop
18 NoSource:       0
19 URL:            http://www.idsoftware.com/
20 # loose dependancy is intentional
21 Requires:       %{name}-data = %{version}
22 ExclusiveArch:  %{ix86}
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         no_install_post_strip   1
26 %define         no_install_post_chrpath 1
27 %define         _gamelibdir     %{_libdir}/games/et
28 %define         _gamedatadir    %{_datadir}/games/et
29
30 %description
31 Return to Castle Wolfenstein: Enemy Territory - standalone
32 multi-player game based on Return to Castle Wolfenstein.
33
34 %description -l pl
35 Powrót do zamku Wolfenstein: Terytorium wroga (Return to Castle
36 Wolfenstein: Enemy Territory) jest to samodzielna gra dla wielu graczy
37 oparta na Powrocie do zamku Wolfenstein (Return to Castle
38 Wolfenstein).
39
40 %package data
41 Summary:        Enemy Territory data files
42 Summary(pl):    Pliki z danymi dla Enemy Territory
43 Group:          Applications/Games
44
45 %description data
46 This package contains the data files for Enemy Territory.
47
48 %description data -l pl
49 Pakiet ten zawiera pliki z danymi dla gry Enemy Territory.
50
51 %prep
52 %setup -qcT
53 sh %{SOURCE0} --tar xf
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{_desktopdir}} \
58         $RPM_BUILD_ROOT{%{_gamelibdir},%{_gamedatadir}}
59
60 install bin/Linux/x86/et.x86 $RPM_BUILD_ROOT%{_gamelibdir}/%{name}
61
62 cat << EOF > $RPM_BUILD_ROOT%{_bindir}/%{name}
63 #!/bin/sh
64 # Needed to make symlinks/shortcuts work.
65 # the binaries must run with correct working directory
66 cd %{_gamelibdir}
67 export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:.
68 exec ./%{name} "\$@"
69 EOF
70
71 install ET.xpm $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.xpm
72 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
73 ln -s ../../../share/games/et/etmain $RPM_BUILD_ROOT%{_gamelibdir}
74
75 cp -a pb $RPM_BUILD_ROOT%{_gamelibdir}
76 # in DOCS
77 rm -f $RPM_BUILD_ROOT%{_gamelibdir}/pb/PB_EULA.txt
78
79 %if %{with data}
80 cp -a etmain $RPM_BUILD_ROOT%{_gamedatadir}
81 %endif
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc CHANGES v1.02_Readme.htm Docs pb/PB_EULA.txt
89 %attr(755,root,root) %{_bindir}/*
90
91 %dir %{_gamelibdir}
92 %attr(755,root,root) %{_gamelibdir}/et
93 %{_gamelibdir}/etmain
94
95 %dir %{_gamelibdir}/pb
96 %{_gamelibdir}/pb/htm
97 %attr(755,root,root) %{_gamelibdir}/pb/*.x86
98 %attr(755,root,root) %{_gamelibdir}/pb/*.so
99 %{_gamelibdir}/pb/*.db
100
101 %dir %{_gamedatadir}
102 %{_desktopdir}/%{name}.desktop
103 %{_pixmapsdir}/%{name}.xpm
104
105 %if %{with data}
106 %files data
107 %defattr(644,root,root,755)
108 %{_gamedatadir}/*
109 %endif
This page took 0.125982 seconds and 3 git commands to generate.