]> git.pld-linux.org Git - packages/eric6.git/blob - eric6.spec
Version 17.03.1. Rel 1.
[packages/eric6.git] / eric6.spec
1 %bcond_with     python2 # Use python2 (NOTE: as for 17.03.1 it has issuses in PLD)
2
3 %define         module  eric6
4 Summary:        Eric6 - a full featured Python IDE
5 Summary(pl.UTF-8):      Eric6 - pełnowartościowe IDE dla Pythona
6 # Name must match the python module/package name (as on pypi or in 'import' statement)
7 Name:           eric6
8 Version:        17.03.1
9 Release:        1
10 License:        GPL v3
11 Group:          Libraries/Python
12 Source0:        https://sourceforge.net/projects/eric-ide/files/eric6/stable/%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  4e56a985387cceed981db1ba2579183b
14 URL:            http://eric-ide.python-projects.org/index.html
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.714
17 %if %{with python2}
18 BuildRequires:  python-modules
19 BuildRequires:  python-setuptools
20 # NOTE: As for 6.1.8  eric6 still tries to import PyQt5 while having PyQt4 leading to crash
21 #       http://die-offenbachs.homelinux.org:48888/issues/issue204
22 # for --pyqt=4
23 # BuildRequires:        python-PyQt4-qscintilla2
24 # BuildRequires:        python-PyQt4-uic
25 # for --pyqt=5
26 BuildRequires:  python-PyQt5-qscintilla2
27 BuildRequires:  python-PyQt5-uic
28 Requires:       python-PyQt5-qscintilla2
29 Requires:       python-modules
30 Suggests:       python-pylint
31 %else
32 BuildRequires:  python3-PyQt5-qscintilla2
33 BuildRequires:  python3-PyQt5-uic
34 BuildRequires:  python3-modules
35 BuildRequires:  python3-setuptools
36 Requires:       python3-PyQt5-qscintilla2
37 Requires:       python3-modules
38 Suggests:       python3-pylint
39 %endif
40
41 BuildArch:      noarch
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Eric is a Python IDE written using PyQt and QScintilla. It provides
46 various features such as any number of open editors, an integrated
47 (remote) debugger, project management facilities, unit test,
48 refactoring and much more.
49
50 %description -l pl.UTF-8
51 Eric jest pythonowym graficznym środowiskiem programistycznym
52 używającym PyQt i QScintilla.
53
54 %prep
55 %setup -q
56
57 %build
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 %if %{with python2}
62 python install.py -z -c -b %{_bindir} -d %{py_sitescriptdir} -i $RPM_BUILD_ROOT  --pyqt=5
63 %else
64 python3 install.py -z -c -b %{_bindir} -d %{py3_sitescriptdir} -i $RPM_BUILD_ROOT  --pyqt=5
65 %endif
66 mkdir $RPM_BUILD_ROOT%{_datadir}/appdata
67 mv $RPM_BUILD_ROOT%{_datadir}/metainfo/eric6.appdata.xml $RPM_BUILD_ROOT%{_datadir}/appdata
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc README.rst
75 %if %{with python2}
76 %{py_sitescriptdir}/%{module}
77 %else
78 %{py3_sitescriptdir}/%{module}
79 %endif
80
81 %attr(755,root,root) %{_bindir}/eric6
82 %attr(755,root,root) %{_bindir}/eric6_*
83 # for --pyqt=4
84 # %{_datadir}/qt4/qsci/api/qss/
85 # %{_datadir}/qt4/qsci/api/ruby/
86 # NOTE: file %{_datadir}/qt4/qsci/api/ruby/Ruby-1.8.7.api from install of eric6-6.1.8-0.1.noarch conflicts with file from package eric4-4.5.24-3.noarch
87 # %{_datadir}/qt4/qsci/api/python/eric6.*
88 # %{_datadir}/qt4/qsci/api/python/zope-*.api
89
90 # for --pyqt=5
91 %{_datadir}/qt5/qsci/api/qss/
92 %{_datadir}/qt5/qsci/api/ruby/
93 %{_datadir}/qt5/qsci/api/python/eric6.*
94 %{_datadir}/qt5/qsci/api/python/zope-*.api
95
96 %{_pixmapsdir}/eric*.png
97 %{_desktopdir}/eric6.desktop
98 %{_desktopdir}/eric6_webbrowser.desktop
99 %{_desktopdir}/eric6_browser.desktop
100 %{_datadir}/appdata/eric6.appdata.xml
101 %if %{with python2}
102 %{py_sitescriptdir}/eric6config.py
103 %{py_sitescriptdir}/eric6plugins
104 %else
105 %{py3_sitescriptdir}/eric6config.py
106 %{py3_sitescriptdir}/eric6plugins
107 %endif
This page took 0.078579 seconds and 4 git commands to generate.