]> git.pld-linux.org Git - packages/eric6.git/blob - eric6.spec
Rel. 2
[packages/eric6.git] / eric6.spec
1 %bcond_with     python2 # Use python2 (NOTE: as for 17.03.1 it has issuses in PLD)
2
3 %define         module  eric6
4 Summary:        Eric6 - a full featured Python IDE
5 Summary(pl.UTF-8):      Eric6 - pełnowartościowe IDE dla Pythona
6 # Name must match the python module/package name (as on pypi or in 'import' statement)
7 Name:           eric6
8 Version:        17.03.1
9 Release:        2
10 License:        GPL v3
11 Group:          Libraries/Python
12 Source0:        https://sourceforge.net/projects/eric-ide/files/eric6/stable/%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  4e56a985387cceed981db1ba2579183b
14 URL:            http://eric-ide.python-projects.org/index.html
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.714
17 %if %{with python2}
18 BuildRequires:  python-modules
19 BuildRequires:  python-setuptools
20 # NOTE: As for 6.1.8  eric6 still tries to import PyQt5 while having PyQt4 leading to crash
21 #       http://die-offenbachs.homelinux.org:48888/issues/issue204
22 # for --pyqt=4
23 # BuildRequires:        python-PyQt4-qscintilla2
24 # BuildRequires:        python-PyQt4-uic
25 # for --pyqt=5
26 BuildRequires:  python-PyQt5-qscintilla2
27 BuildRequires:  python-PyQt5-uic
28 Requires:       python-PyQt5-qscintilla2
29 Requires:       python-modules
30 Suggests:       python-pylint
31 %else
32 BuildRequires:  python3-PyQt5-qscintilla2
33 BuildRequires:  python3-PyQt5-uic
34 BuildRequires:  python3-modules
35 BuildRequires:  python3-setuptools
36 # NOTE: Not sure if Qt5Svg should be listed here or be R by other BRs.
37 BuildRequires:  Qt5Svg
38 Requires:       python3-PyQt5-qscintilla2
39 Requires:       python3-modules
40 Suggests:       python3-pylint
41 %endif
42
43 BuildArch:      noarch
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Eric is a Python IDE written using PyQt and QScintilla. It provides
48 various features such as any number of open editors, an integrated
49 (remote) debugger, project management facilities, unit test,
50 refactoring and much more.
51
52 %description -l pl.UTF-8
53 Eric jest pythonowym graficznym środowiskiem programistycznym
54 używającym PyQt i QScintilla.
55
56 %prep
57 %setup -q
58
59 %build
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 %if %{with python2}
64 python install.py -z -c -b %{_bindir} -d %{py_sitescriptdir} -i $RPM_BUILD_ROOT  --pyqt=5
65 %else
66 python3 install.py -z -c -b %{_bindir} -d %{py3_sitescriptdir} -i $RPM_BUILD_ROOT  --pyqt=5
67 %endif
68 mkdir $RPM_BUILD_ROOT%{_datadir}/appdata
69 mv $RPM_BUILD_ROOT%{_datadir}/metainfo/eric6.appdata.xml $RPM_BUILD_ROOT%{_datadir}/appdata
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc README.rst
77 %if %{with python2}
78 %{py_sitescriptdir}/%{module}
79 %else
80 %{py3_sitescriptdir}/%{module}
81 %endif
82
83 %attr(755,root,root) %{_bindir}/eric6
84 %attr(755,root,root) %{_bindir}/eric6_*
85 # for --pyqt=4
86 # %{_datadir}/qt4/qsci/api/qss/
87 # %{_datadir}/qt4/qsci/api/ruby/
88 # NOTE: file %{_datadir}/qt4/qsci/api/ruby/Ruby-1.8.7.api from install of eric6-6.1.8-0.1.noarch conflicts with file from package eric4-4.5.24-3.noarch
89 # %{_datadir}/qt4/qsci/api/python/eric6.*
90 # %{_datadir}/qt4/qsci/api/python/zope-*.api
91
92 # for --pyqt=5
93 %{_datadir}/qt5/qsci/api/qss/
94 %{_datadir}/qt5/qsci/api/ruby/
95 %{_datadir}/qt5/qsci/api/python/eric6.*
96 %{_datadir}/qt5/qsci/api/python/zope-*.api
97
98 %{_pixmapsdir}/eric*.png
99 %{_desktopdir}/eric6.desktop
100 %{_desktopdir}/eric6_webbrowser.desktop
101 %{_desktopdir}/eric6_browser.desktop
102 %{_datadir}/appdata/eric6.appdata.xml
103 %if %{with python2}
104 %{py_sitescriptdir}/eric6config.py
105 %{py_sitescriptdir}/eric6plugins
106 %else
107 %{py3_sitescriptdir}/eric6config.py
108 %{py3_sitescriptdir}/eric6plugins
109 %endif
This page took 0.035945 seconds and 4 git commands to generate.