]> git.pld-linux.org Git - packages/eric6.git/blob - eric6.spec
f4477c578cf4dd664934df188204b257330b85c8
[packages/eric6.git] / eric6.spec
1 %bcond_with     python2 # Use python2 (NOTE: as for 17.03.1 it has issuses in PLD)
2
3 # NOTE: Detlev Offenbach <detlev@die-offenbachs.de> (author) 2017/04/13 wrote:
4 # "eric6 can be used with  Python2 or Python3 and with PyQt5 or PyQt4. 
5 # However, the recommended combination is PyQt5 on Python3.
6
7 %define         module  eric6
8 Summary:        Eric6 - a full featured Python IDE
9 Summary(pl.UTF-8):      Eric6 - pełnowartościowe IDE dla Pythona
10 Name:           eric6
11 Version:        17.07
12 Release:        7
13 License:        GPL v3
14 Group:          Libraries/Python
15 Source0:        https://sourceforge.net/projects/eric-ide/files/eric6/stable/%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  c21c097bf36259ff61187e2698b7c50d
17 Patch0:         python3.patch
18 URL:            http://eric-ide.python-projects.org/index.html
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.714
21 %if %{with python2}
22 BuildRequires:  python-modules
23 BuildRequires:  python-setuptools
24 # NOTE: As for 6.1.8  eric6 still tries to import PyQt5 while having PyQt4 leading to crash
25 #       http://die-offenbachs.homelinux.org:48888/issues/issue204
26 # for --pyqt=4
27 # BuildRequires:        python-PyQt4-qscintilla2
28 # BuildRequires:        python-PyQt4-uic
29 # for --pyqt=5
30 BuildRequires:  python-PyQt5-qscintilla2
31 BuildRequires:  python-PyQt5-uic
32 Requires:       python-PyQt5-qscintilla2
33 Requires:       python-modules
34 Suggests:       python-pylint
35 %else
36 BuildRequires:  python3-PyQt5-qscintilla2
37 BuildRequires:  python3-PyQt5-uic
38 BuildRequires:  python3-modules
39 BuildRequires:  python3-setuptools
40 # NOTE: Not sure if Qt5Svg should be listed here or be R by other BRs.
41 BuildRequires:  Qt5Svg
42 Requires:       python3-PyQt5-qscintilla2
43 Requires:       python3-modules
44 Suggests:       python3-pylint
45 %endif
46
47 BuildArch:      noarch
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Eric is a Python IDE written using PyQt and QScintilla. It provides
52 various features such as any number of open editors, an integrated
53 (remote) debugger, project management facilities, unit test,
54 refactoring and much more.
55
56 %description -l pl.UTF-8
57 Eric jest pythonowym graficznym środowiskiem programistycznym
58 używającym PyQt i QScintilla.
59
60 %prep
61 %setup -q
62 %patch0 -p1
63
64 %build
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %if %{with python2}
69 python install.py -z -c -b %{_bindir} -d %{py_sitescriptdir} -i $RPM_BUILD_ROOT  --pyqt=5
70 %else
71 python3 install.py -z -c -b %{_bindir} -d %{py3_sitescriptdir} -i $RPM_BUILD_ROOT  --pyqt=5
72 %endif
73 mkdir $RPM_BUILD_ROOT%{_datadir}/appdata
74 mv $RPM_BUILD_ROOT%{_datadir}/metainfo/eric6.appdata.xml $RPM_BUILD_ROOT%{_datadir}/appdata
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc README.rst
82 %if %{with python2}
83 %{py_sitescriptdir}/%{module}
84 %else
85 %{py3_sitescriptdir}/%{module}
86 %endif
87
88 %attr(755,root,root) %{_bindir}/eric6
89 %attr(755,root,root) %{_bindir}/eric6_*
90 # for --pyqt=4
91 # %{_datadir}/qt4/qsci/api/qss/
92 # %{_datadir}/qt4/qsci/api/ruby/
93 # NOTE: file %{_datadir}/qt4/qsci/api/ruby/Ruby-1.8.7.api from install of eric6-6.1.8-0.1.noarch conflicts with file from package eric4-4.5.24-3.noarch
94 # %{_datadir}/qt4/qsci/api/python/eric6.*
95 # %{_datadir}/qt4/qsci/api/python/zope-*.api
96
97 # for --pyqt=5
98 %{_datadir}/qt5/qsci/api/qss/
99 %{_datadir}/qt5/qsci/api/ruby/
100 %{_datadir}/qt5/qsci/api/python/eric6.*
101 %{_datadir}/qt5/qsci/api/python/zope-*.api
102
103 %{_pixmapsdir}/eric*.png
104 %{_desktopdir}/eric6.desktop
105 %{_desktopdir}/eric6_webbrowser.desktop
106 %{_desktopdir}/eric6_browser.desktop
107 %{_datadir}/appdata/eric6.appdata.xml
108 %if %{with python2}
109 %{py_sitescriptdir}/eric6config.py
110 %{py_sitescriptdir}/eric6plugins
111 %else
112 %{py3_sitescriptdir}/eric6config.py
113 %{py3_sitescriptdir}/eric6plugins
114 %endif
This page took 0.072261 seconds and 3 git commands to generate.