]> git.pld-linux.org Git - packages/epiphany.git/blob - epiphany.spec
ff509db59790e78bb81de00a97926c85d6b85c4e
[packages/epiphany.git] / epiphany.spec
1 # Conditinal build:
2 %bcond_with     mozilla_firefox # build with mozilla-firefox-devel
3 #
4 Summary:        Epiphany - gecko-based GNOME web browser
5 Summary(es):    Epiphany - navigador Web de GNOME basado en gecko
6 Summary(pl):    Epiphany - przegl±darka WWW dla GNOME
7 Name:           epiphany
8 Version:        1.8.0
9 Release:        1
10 License:        GPL v2
11 Group:          X11/Applications/Networking
12 Source0:        http://ftp.gnome.org/pub/gnome/sources/epiphany/1.8/%{name}-%{version}.tar.bz2
13 # Source0-md5:  297ca64ce700e90db596a50d58b68a80
14 Patch0:         %{name}-first-tab.patch
15 Patch1:         %{name}-desktop.patch
16 Patch2:         %{name}-mozilla_includes.patch
17 Patch3:         %{name}-mozilla.patch
18 Patch4:         %{name}-pld-homepage.patch
19 URL:            http://www.gnome.org/projects/epiphany/
20 BuildRequires:  GConf2-devel >= 2.10.0
21 BuildRequires:  ORBit2-devel >= 1:2.12.1
22 BuildRequires:  autoconf >= 2.59
23 BuildRequires:  automake >= 1.8
24 BuildRequires:  dbus-glib-devel >= 0.34
25 BuildRequires:  gnome-common >= 2.8.0
26 BuildRequires:  gnome-desktop-devel >= 2.10.0-2
27 BuildRequires:  gnome-doc-utils >= 0.3.2-1
28 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
29 BuildRequires:  gtk+2-devel >= 2:2.8.3
30 BuildRequires:  gtk-doc >= 1.3
31 BuildRequires:  intltool >= 0.33
32 BuildRequires:  iso-codes >= 0.35
33 BuildRequires:  libglade2-devel >= 1:2.5.1
34 BuildRequires:  libgnomeprintui-devel >= 2.11.0-3
35 BuildRequires:  libgnomeui-devel >= 2.10.0-2
36 BuildRequires:  startup-notification-devel >= 0.5
37 BuildRequires:  libtool
38 BuildRequires:  libxslt-devel >= 1.1.15
39 %if %{with mozilla_firefox}
40 BuildRequires:  mozilla-firefox-devel
41 %else
42 BuildRequires:  mozilla-devel >= 5:1.7
43 %endif
44 BuildRequires:  pkgconfig
45 # Requries but python package not present?
46 BuildRequires:  python-gnome-devel >= 2.6.0
47 BuildRequires:  python-pygtk-devel >= 2.6.0
48 BuildRequires:  rpmbuild(macros) >= 1.197
49 BuildRequires:  scrollkeeper
50 Requires(post,preun):   GConf2
51 Requires(post,postun):  desktop-file-utils
52 Requires(post,postun):  scrollkeeper
53 Requires:       gnome-icon-theme >= 2.10.0
54 Requires:       gtk+2 >= 2:2.8.3
55 %if %{with mozilla_firefox}
56 %requires_eq    mozilla-firefox
57 %else
58 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
59 %endif
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 # can be provided by mozilla or mozilla-embedded
63 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
64
65 %description
66 GNOME browser based on Gecko (Mozilla rendering engine).
67
68 %description -l es
69 Navigador Web de GNOME basado en Gecko (el engine plasmante de Mozilla).
70
71 %description -l pl
72 Epiphany jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
73 interpretacji stron Mozilli).
74
75 %package devel
76 Summary:        Epiphany header files
77 Summary(es):    Ficheros de cabecera de Epiphany
78 Summary(pl):    Pliki nag³ówkowe Epiphany
79 Group:          X11/Applications/Networking
80 # doesn't require base
81 Requires:       gtk+2-devel >= 2:2.8.3
82 Requires:       libxslt-devel >= 1.1.15
83
84 %description devel
85 Epiphany header files for plugin development.
86
87 %description devel -l es
88 Ficheros de cabecera de Epiphany para desarrollar plug-ins.
89
90 %description devel -l pl
91 Pliki nag³ówkowe Epiphany do tworzenia wtyczek.
92
93 %prep
94 %setup -q
95 %patch0 -p1
96 %patch1 -p1
97 %patch2 -p1
98 %patch3 -p1
99 %patch4 -p1
100
101 %build
102 gnome-doc-prepare --copy --force
103 %{__gnome_doc_common}
104 %{__glib_gettextize}
105 %{__intltoolize}
106 %{__libtoolize}
107 %{__aclocal} -I m4
108 %{__autoheader}
109 %{__automake}
110 %{__autoconf}
111
112 %configure \
113         --disable-schemas-install \
114         --enable-dbus \
115         --enable-gtk-doc \
116         --enable-python \
117         --with-html-dir=%{_gtkdocdir}
118 # CFLAGS is a hack for gcc 3.3
119 %{__make} \
120         CFLAGS="%{rpmcflags} -fno-strict-aliasing"
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/1.8/extensions
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT \
128         HTML_DIR=%{_gtkdocdir}
129
130 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
131 rm -r $RPM_BUILD_ROOT%{_datadir}/application-registry/*
132
133 # epiphany-2.0.mo, but gnome/help/epiphany
134 %find_lang %{name}-2.0 --with-gnome --all-name
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post
140 %gconf_schema_install epiphany-lockdown.schemas
141 %gconf_schema_install epiphany.schemas
142 %scrollkeeper_update_post
143 %update_desktop_database_post
144
145 %preun
146 %gconf_schema_uninstall epiphany-lockdown.schemas
147 %gconf_schema_uninstall epiphany.schemas
148
149 %postun
150 %scrollkeeper_update_postun
151 %update_desktop_database_postun
152
153 %files -f %{name}-2.0.lang
154 %defattr(644,root,root,755)
155 %doc AUTHORS ChangeLog NEWS README
156 %attr(755,root,root) %{_bindir}/*
157 %{_libdir}/bonobo/servers/*
158 %{_datadir}/%{name}
159 %{_desktopdir}/*
160 %{_pixmapsdir}/*
161 %{_sysconfdir}/gconf/schemas/epiphany-lockdown.schemas
162 %{_sysconfdir}/gconf/schemas/epiphany.schemas
163 %{_omf_dest_dir}/*
164 %dir %{_libdir}/%{name}
165 %dir %{_libdir}/%{name}/1.8
166 %dir %{_libdir}/%{name}/1.8/extensions
167 %{_mandir}/man1/*
168
169 %files devel
170 %defattr(644,root,root,755)
171 %{_includedir}/epiphany
172 %{_pkgconfigdir}/*.pc
173 %{_datadir}/pygtk/*/defs/epiphany.defs
174 %{_gtkdocdir}/*
This page took 0.102771 seconds and 3 git commands to generate.