]> git.pld-linux.org Git - packages/epiphany.git/blob - epiphany.spec
a67094293e1649a07569d45a0a58ba25d7718748
[packages/epiphany.git] / epiphany.spec
1 %define         minmozver       5:1.7
2 Summary:        Epiphany - gecko-based GNOME web browser
3 Summary(es):    Epiphany - navigador Web de GNOME basado en gecko
4 Summary(pl):    Epiphany - przegl±darka WWW dla GNOME
5 Name:           epiphany
6 Version:        1.6.1
7 Release:        1
8 License:        GPL v2
9 Group:          X11/Applications/Networking
10 Source0:        http://ftp.gnome.org/pub/gnome/sources/epiphany/1.6/%{name}-%{version}.tar.bz2
11 # Source0-md5:  945545f33714736154725ed2a3b8c8b8
12 Patch0:         %{name}-first-tab.patch
13 Patch1:         %{name}-desktop.patch
14 Patch2:         %{name}-mozilla_includes.patch
15 Patch3:         %{name}-mozilla.patch
16 URL:            http://www.gnome.org/projects/epiphany/
17 BuildRequires:  GConf2-devel >= 2.10.0
18 BuildRequires:  ORBit2-devel >= 1:2.12.1
19 BuildRequires:  autoconf >= 2.59
20 BuildRequires:  automake
21 BuildRequires:  gnome-common >= 2.8.0
22 BuildRequires:  gnome-desktop >= 2.10.0-2
23 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
24 BuildRequires:  gtk+2-devel >= 2:2.6.4
25 BuildRequires:  gtk-doc >= 1.3
26 BuildRequires:  intltool >= 0.33
27 BuildRequires:  libglade2-devel >= 1:2.5.1
28 BuildRequires:  libgnomeui-devel >= 2.10.0-2
29 BuildRequires:  libtool
30 BuildRequires:  libxml2-devel >= 2.6.19
31 BuildRequires:  mozilla-devel >= %{minmozver}
32 BuildRequires:  nautilus-devel >= 2.10.0-3
33 BuildRequires:  pango-devel >= 1:1.8.1
34 BuildRequires:  pkgconfig
35 BuildRequires:  rpm-build >= 4.1-10
36 BuildRequires:  rpmbuild(macros) >= 1.196
37 BuildRequires:  scrollkeeper
38 Requires(post,preun):   GConf2
39 Requires(post,postun):  desktop-file-utils
40 Requires(post,postun):  scrollkeeper
41 Requires:       gnome-icon-theme >= 2.10.0
42 Requires:       gtk+2 >= 2:2.6.4
43 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 # can be provided by mozilla or mozilla-embedded
47 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
48
49 %description
50 GNOME browser based on Gecko (Mozilla rendering engine).
51
52 %description -l es
53 Navigador Web de GNOME basado en Gecko (el engine plasmante de Mozilla).
54
55 %description -l pl
56 Epiphany jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
57 interpretacji stron Mozilli).
58
59 %package devel
60 Summary:        Epiphany header files
61 Summary(es):    Ficheros de cabecera de Epiphany
62 Summary(pl):    Pliki nag³ówkowe Epiphany
63 Group:          X11/Applications/Networking
64 # doesn't require base
65 Requires:       gtk+2-devel >= 2:2.6.4
66 Requires:       libxml2-devel >= 2.6.19
67
68 %description devel
69 Epiphany header files for plugin development.
70
71 %description devel -l es
72 Ficheros de cabecera de Epiphany para desarrollar plug-ins.
73
74 %description devel -l pl
75 Pliki nag³ówkowe Epiphany do tworzenia wtyczek.
76
77 %prep
78 %setup -q
79 %patch0 -p1
80 %patch1 -p1
81 %patch2 -p1
82 %patch3 -p1
83
84 %build
85 rm -f acconfig.h
86 cp /usr/share/automake/mkinstalldirs .
87 glib-gettextize --copy --force
88 intltoolize --copy --force
89 gnome-doc-common --copy
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoheader}
93 %{__automake}
94 %{__autoconf}
95
96 %configure \
97         --disable-schemas-install \
98         --enable-nautilus-view=yes \
99         --enable-gtk-doc \
100         --with-html-dir=%{_gtkdocdir}
101 # CFLAGS is a hack for gcc 3.3
102 %{__make} \
103         CFLAGS="%{rpmcflags} -fno-strict-aliasing"
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}-1.6/extensions
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT \
111         HTML_DIR=%{_gtkdocdir}
112
113 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
114 rm -r $RPM_BUILD_ROOT%{_datadir}/application-registry/*
115
116 # epiphany-2.0.mo, but gnome/help/epiphany
117 %find_lang %{name}-2.0 --with-gnome --all-name
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post
123 %gconf_schema_install /etc/gconf/schemas/epiphany-lockdown.schemas
124 %gconf_schema_install /etc/gconf/schemas/epiphany.schemas
125 /usr/bin/scrollkeeper-update -q
126 /usr/bin/update-desktop-database
127
128 %preun
129 if [ $1 = 0 ]; then
130 %gconf_schema_uninstall /etc/gconf/schemas/epiphany-lockdown.schemas
131 %gconf_schema_uninstall /etc/gconf/schemas/epiphany.schemas
132 fi
133
134 %postun
135 if [ $1 = 0 ]; then
136 /usr/bin/scrollkeeper-update -q
137 /usr/bin/update-desktop-database
138 fi
139
140 %files -f %{name}-2.0.lang
141 %defattr(644,root,root,755)
142 %doc AUTHORS ChangeLog NEWS README
143 %attr(755,root,root) %{_bindir}/*
144 %{_libdir}/bonobo/servers/*
145 %{_datadir}/%{name}
146 %{_desktopdir}/*
147 %{_pixmapsdir}/*
148 %{_sysconfdir}/gconf/schemas/*
149 %{_omf_dest_dir}/*
150 %dir %{_libdir}/%{name}-1.6
151 %dir %{_libdir}/%{name}-1.6/extensions
152 %{_mandir}/man1/*
153
154 %files devel
155 %defattr(644,root,root,755)
156 %{_includedir}/epiphany-1.6
157 %{_pkgconfigdir}/*.pc
158 %{_gtkdocdir}/*
This page took 0.069236 seconds and 3 git commands to generate.