]> git.pld-linux.org Git - packages/epiphany.git/blob - epiphany.spec
8d86127e6093c531dd19fceb8f62f5ca3d322c05
[packages/epiphany.git] / epiphany.spec
1 # Conditinal build:
2 %bcond_with     mozilla_firefox # build with mozilla-firefox-devel
3 #
4 Summary:        Epiphany - gecko-based GNOME web browser
5 Summary(es):    Epiphany - navigador Web de GNOME basado en gecko
6 Summary(pl):    Epiphany - przegl±darka WWW dla GNOME
7 Name:           epiphany
8 Version:        1.8.0
9 Release:        1
10 License:        GPL v2
11 Group:          X11/Applications/Networking
12 Source0:        http://ftp.gnome.org/pub/gnome/sources/epiphany/1.8/%{name}-%{version}.tar.bz2
13 # Source0-md5:  297ca64ce700e90db596a50d58b68a80
14 Patch0:         %{name}-first-tab.patch
15 Patch1:         %{name}-desktop.patch
16 Patch2:         %{name}-mozilla_includes.patch
17 Patch3:         %{name}-mozilla.patch
18 Patch4:         %{name}-pld-homepage.patch
19 URL:            http://www.gnome.org/projects/epiphany/
20 BuildRequires:  GConf2-devel >= 2.10.0
21 BuildRequires:  ORBit2-devel >= 1:2.12.1
22 BuildRequires:  autoconf >= 2.59
23 BuildRequires:  automake >= 1.8
24 BuildRequires:  dbus-glib-devel >= 0.34
25 BuildRequires:  gnome-common >= 2.8.0
26 BuildRequires:  gnome-desktop-devel >= 2.10.0-2
27 BuildRequires:  gnome-doc-utils >= 0.3.2-1
28 BuildRequires:  gnome-vfs2-devel >= 2.10.0-2
29 BuildRequires:  gtk+2-devel >= 2:2.8.3
30 BuildRequires:  gtk-doc >= 1.3
31 BuildRequires:  intltool >= 0.33
32 BuildRequires:  iso-codes >= 0.35
33 BuildRequires:  libglade2-devel >= 1:2.5.1
34 BuildRequires:  libgnomeprintui-devel >= 2.11.0-3
35 BuildRequires:  libgnomeui-devel >= 2.10.0-2
36 BuildRequires:  startup-notification-devel >= 0.5
37 BuildRequires:  libtool
38 BuildRequires:  libxslt-devel >= 1.1.15
39 %if %{with mozilla_firefox}
40 BuildRequires:  mozilla-firefox-devel
41 %else
42 BuildRequires:  mozilla-devel >= 5:1.7
43 %endif
44 BuildRequires:  pkgconfig
45 # Requries but python package not present?
46 BuildRequires:  python-gnome-devel >= 2.6.0
47 BuildRequires:  python-pygtk-devel >= 2.6.0
48 BuildRequires:  rpmbuild(macros) >= 1.197
49 BuildRequires:  scrollkeeper
50 Requires(post,preun):   GConf2
51 Requires(post,postun):  desktop-file-utils
52 Requires(post,postun):  scrollkeeper
53 Requires:       gnome-icon-theme >= 2.10.0
54 Requires:       gtk+2 >= 2:2.8.3
55 %if %{with mozilla_firefox}
56 %requires_eq    mozilla-firefox
57 %else
58 Requires:       mozilla-embedded = %(rpm -q --qf '%{EPOCH}:%{VERSION}' --whatprovides mozilla-embedded)
59 %endif
60 Obsoletes:      python-epiphany
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 # can be provided by mozilla or mozilla-embedded
64 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
65
66 %description
67 GNOME browser based on Gecko (Mozilla rendering engine).
68
69 %description -l es
70 Navigador Web de GNOME basado en Gecko (el engine plasmante de Mozilla).
71
72 %description -l pl
73 Epiphany jest przegl±dark± WWW bazuj±c± na Gecko (mechanizmie
74 interpretacji stron Mozilli).
75
76 %package devel
77 Summary:        Epiphany header files
78 Summary(es):    Ficheros de cabecera de Epiphany
79 Summary(pl):    Pliki nag³ówkowe Epiphany
80 Group:          X11/Applications/Networking
81 # doesn't require base
82 Requires:       gtk+2-devel >= 2:2.8.3
83 Requires:       libxslt-devel >= 1.1.15
84
85 %description devel
86 Epiphany header files for plugin development.
87
88 %description devel -l es
89 Ficheros de cabecera de Epiphany para desarrollar plug-ins.
90
91 %description devel -l pl
92 Pliki nag³ówkowe Epiphany do tworzenia wtyczek.
93
94 %prep
95 %setup -q
96 %patch0 -p1
97 %patch1 -p1
98 %patch2 -p1
99 %patch3 -p1
100 %patch4 -p1
101
102 %build
103 gnome-doc-prepare --copy --force
104 %{__gnome_doc_common}
105 %{__glib_gettextize}
106 %{__intltoolize}
107 %{__libtoolize}
108 %{__aclocal} -I m4
109 %{__autoheader}
110 %{__automake}
111 %{__autoconf}
112
113 %configure \
114         --disable-schemas-install \
115         --enable-dbus \
116         --enable-gtk-doc \
117         --enable-python \
118         --with-html-dir=%{_gtkdocdir}
119 # CFLAGS is a hack for gcc 3.3
120 %{__make} \
121         CFLAGS="%{rpmcflags} -fno-strict-aliasing"
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/1.8/extensions
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT \
129         HTML_DIR=%{_gtkdocdir}
130
131 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
132 rm -r $RPM_BUILD_ROOT%{_datadir}/application-registry/*
133
134 # epiphany-2.0.mo, but gnome/help/epiphany
135 %find_lang %{name}-2.0 --with-gnome --all-name
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post
141 %gconf_schema_install epiphany-lockdown.schemas
142 %gconf_schema_install epiphany.schemas
143 %scrollkeeper_update_post
144 %update_desktop_database_post
145
146 %preun
147 %gconf_schema_uninstall epiphany-lockdown.schemas
148 %gconf_schema_uninstall epiphany.schemas
149
150 %postun
151 %scrollkeeper_update_postun
152 %update_desktop_database_postun
153
154 %files -f %{name}-2.0.lang
155 %defattr(644,root,root,755)
156 %doc AUTHORS ChangeLog NEWS README
157 %attr(755,root,root) %{_bindir}/*
158 %{_libdir}/bonobo/servers/*
159 %{_datadir}/%{name}
160 %{_desktopdir}/*
161 %{_pixmapsdir}/*
162 %{_sysconfdir}/gconf/schemas/epiphany-lockdown.schemas
163 %{_sysconfdir}/gconf/schemas/epiphany.schemas
164 %{_omf_dest_dir}/*
165 %dir %{_libdir}/%{name}
166 %dir %{_libdir}/%{name}/1.8
167 %dir %{_libdir}/%{name}/1.8/extensions
168 %{_mandir}/man1/*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %{_includedir}/epiphany
173 %{_pkgconfigdir}/*.pc
174 %{_datadir}/pygtk/*/defs/epiphany.defs
175 %{_gtkdocdir}/*
This page took 0.048953 seconds and 3 git commands to generate.