]> git.pld-linux.org Git - packages/epiphany.git/blob - epiphany.spec
767418d4b5303f84a82503b14dcecd831d58fb29
[packages/epiphany.git] / epiphany.spec
1 #
2 #Conditional build:
3 %bcond_with     webkit          # Build with experimental webkit suppor instead of xulrunner
4 #
5 %define         basever         2.20
6 Summary:        Epiphany - gecko-based GNOME web browser
7 Summary(es.UTF-8):      Epiphany - navigador Web de GNOME basado en gecko
8 Summary(pl.UTF-8):      Epiphany - przeglądarka WWW dla GNOME
9 Name:           epiphany
10 Version:        2.20.1
11 Release:        2
12 License:        GPL v2
13 Group:          X11/Applications/Networking
14 Source0:        http://ftp.gnome.org/pub/gnome/sources/epiphany/2.20/%{name}-%{version}.tar.bz2
15 # Source0-md5:  bacb5c7f1a421f6d5adbec35d4cab3ea
16 Patch0:         %{name}-pld-homepage.patch
17 Patch1:         %{name}-configure.patch
18 Patch2:         %{name}-agent.patch
19 URL:            http://www.gnome.org/projects/epiphany/
20 BuildRequires:  GConf2-devel >= 2.20.0
21 BuildRequires:  ORBit2-devel >= 1:2.14.9
22 BuildRequires:  autoconf >= 2.59
23 BuildRequires:  automake >= 1:1.9
24 BuildRequires:  dbus-glib-devel >= 0.73
25 BuildRequires:  gnome-common >= 2.20.0
26 BuildRequires:  gnome-desktop-devel >= 2.20.0
27 BuildRequires:  gnome-doc-utils >= 0.12.0
28 BuildRequires:  gnome-vfs2-devel >= 2.20.0
29 BuildRequires:  gtk+2-devel >= 2:2.12.0
30 BuildRequires:  gtk-doc >= 1.8
31 %if %{with webkit}
32 BuildRequires:  gtk-webkit-devel
33 BuildRequires:  libssh2-devel
34 %endif
35 BuildRequires:  intltool >= 0.36.2
36 BuildRequires:  iso-codes >= 0.53
37 BuildRequires:  libglade2-devel >= 1:2.6.2
38 BuildRequires:  libgnomeprintui-devel >= 2.18.0
39 BuildRequires:  libgnomeui-devel >= 2.20.0
40 BuildRequires:  libtool
41 BuildRequires:  libxml2-devel >= 1:2.6.28
42 BuildRequires:  libxslt-devel >= 1.1.20
43 BuildRequires:  pkgconfig
44 BuildRequires:  python-gnome-devel >= 2.20.0
45 BuildRequires:  python-pygtk-devel >= 2:2.12.0
46 BuildRequires:  rpmbuild(macros) >= 1.311
47 BuildRequires:  scrollkeeper
48 BuildRequires:  startup-notification-devel >= 0.8
49 %if %{without webkit}
50 BuildRequires:  xulrunner
51 BuildRequires:  xulrunner-devel >= 1.8.1.6-1.20070731.2
52 %endif
53 Requires(post,postun):  desktop-file-utils
54 Requires(post,postun):  gtk+2
55 Requires(post,postun):  hicolor-icon-theme
56 Requires(post,postun):  scrollkeeper
57 Requires(post,preun):   GConf2
58 Requires:       dbus >= 1.0.2
59 Requires:       gnome-icon-theme >= 2.20.0
60 Requires:       libgnomeui >= 2.20.0
61 %if %{without webkit}
62 %requires_eq    xulrunner
63 %endif
64 Obsoletes:      python-epiphany
65 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
66
67 %if %{without webkit}
68 # can be provided by mozilla or mozilla-embedded
69 %define         _noautoreqdep   libgtkembedmoz.so libgtksuperwin.so libxpcom.so
70 # we have strict deps for it
71 %define         _noautoreq      libxpcom.so
72 %endif
73
74 %description
75 GNOME browser based on Gecko (Mozilla rendering engine).
76
77 %description -l es.UTF-8
78 Navigador Web de GNOME basado en Gecko (el engine plasmante de
79 Mozilla).
80
81 %description -l pl.UTF-8
82 Epiphany jest przeglądarką WWW bazującą na Gecko (mechanizmie
83 interpretacji stron Mozilli).
84
85 %package devel
86 Summary:        Epiphany header files
87 Summary(es.UTF-8):      Ficheros de cabecera de Epiphany
88 Summary(pl.UTF-8):      Pliki nagłówkowe Epiphany
89 Group:          X11/Applications/Networking
90 # doesn't require base
91 Requires:       gtk+2-devel >= 2:2.12.0
92 Requires:       libxslt-devel >= 1.1.20
93
94 %description devel
95 Epiphany header files for plugin development.
96
97 %description devel -l es.UTF-8
98 Ficheros de cabecera de Epiphany para desarrollar plug-ins.
99
100 %description devel -l pl.UTF-8
101 Pliki nagłówkowe Epiphany do tworzenia wtyczek.
102
103 %package apidocs
104 Summary:        Epiphany API documentation
105 Summary(pl.UTF-8):      Dokumentacja API Epiphany
106 Group:          Documentation
107 Requires:       gtk-doc-common
108
109 %description apidocs
110 Epiphany API documentation.
111
112 %description apidocs -l pl.UTF-8
113 Dokumentacja API Epiphany.
114
115 %prep
116 %setup -q
117 %patch0 -p1
118 %patch1 -p1
119 %patch2 -p1
120
121 %build
122 %{__gnome_doc_prepare}
123 %{__gnome_doc_common}
124 %{__glib_gettextize}
125 %{__intltoolize}
126 %{__libtoolize}
127 %{__aclocal} -I m4
128 %{__autoheader}
129 %{__automake}
130 %{__autoconf}
131 %configure \
132         --disable-schemas-install \
133         --enable-dbus \
134         %{?!with_webkit:--enable-gtk-doc} \
135         --enable-network-manager \
136         --enable-python\
137         --enable-spell-checker \
138         %{?with_webkit:--with-engine=webkit} \
139         --with-html-dir=%{_gtkdocdir}
140 %{__make}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/%{basever}/extensions
145
146 %{__make} install \
147         DESTDIR=$RPM_BUILD_ROOT \
148         HTML_DIR=%{_gtkdocdir}
149
150 rm -f $RPM_BUILD_ROOT%{_libdir}/epiphany/%{basever}/plugins/*.la
151
152 %find_lang %{name} --with-gnome
153
154 %clean
155 rm -rf $RPM_BUILD_ROOT
156
157 %post
158 %gconf_schema_install epiphany-fonts.schemas
159 %gconf_schema_install epiphany-lockdown.schemas
160 %gconf_schema_install epiphany-pango.schemas
161 %gconf_schema_install epiphany.schemas
162 %scrollkeeper_update_post
163 %update_desktop_database_post
164 %update_icon_cache hicolor
165
166 %preun
167 %gconf_schema_uninstall epiphany-fonts.schemas
168 %gconf_schema_uninstall epiphany-lockdown.schemas
169 %gconf_schema_uninstall epiphany-pango.schemas
170 %gconf_schema_uninstall epiphany.schemas
171
172 %postun
173 %scrollkeeper_update_postun
174 %update_desktop_database_postun
175 %update_icon_cache hicolor
176
177 %files -f %{name}.lang
178 %defattr(644,root,root,755)
179 %doc AUTHORS ChangeLog NEWS README
180 %attr(755,root,root) %{_bindir}/*
181 %{_datadir}/dbus-1/services/*.service
182 %{_datadir}/%{name}
183 %{_desktopdir}/*.desktop
184 %{_iconsdir}/*/*/apps/*.*
185 %{_sysconfdir}/gconf/schemas/epiphany-fonts.schemas
186 %{_sysconfdir}/gconf/schemas/epiphany-lockdown.schemas
187 %{_sysconfdir}/gconf/schemas/epiphany-pango.schemas
188 %{_sysconfdir}/gconf/schemas/epiphany.schemas
189 %{_omf_dest_dir}/*
190 %dir %{_libdir}/%{name}
191 %dir %{_libdir}/%{name}/%{basever}
192 %dir %{_libdir}/%{name}/%{basever}/extensions
193 %if %{without webkit}
194 %dir %{_libdir}/%{name}/%{basever}/plugins
195 %attr(755,root,root) %{_libdir}/epiphany/%{basever}/plugins/*.so*
196 %endif
197 %{_mandir}/man1/*
198
199 %files devel
200 %defattr(644,root,root,755)
201 %{_aclocaldir}/*
202 %{_includedir}/epiphany
203 %{_pkgconfigdir}/*.pc
204 %{_datadir}/pygtk/*/defs/epiphany.defs
205
206 %files apidocs
207 %defattr(644,root,root,755)
208 %{_gtkdocdir}/*
This page took 0.166816 seconds and 3 git commands to generate.