]> git.pld-linux.org Git - packages/empy.git/blob - empy.spec
- removed %%include /usr/lib/rpm/macros.python
[packages/empy.git] / empy.spec
1
2
3 Summary:        System for embedding Python expressions and statements in template text
4 Summary(pl):    System wbudowywania wyra¿eñ jêzyka Python w pliki tekstowe
5 Name:           empy
6 Version:        3.3
7 Release:        1
8 License:        LGPL
9 Group:          Applications/Text
10 Source0:        http://www.alcyone.com/software/empy/%{name}-%{version}.tar.gz
11 # Source0-md5:  e7b518a6fc4fd28fef87726cdb003118
12 URL:            http://www.alcyone.com/software/empy/
13 BuildRequires:  rpm-pythonprov
14 %pyrequires_eq  python-modules
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 System for embedding Python expressions and statements in template
20 text.
21
22 %description -l pl
23 System wbudowywania wyra¿eñ jêzyka Python w pliki tekstowe.
24
25 %prep
26 %setup -q
27
28 %build
29 python setup.py build
30
31 %install
32 rm -rf $RPM_BUILD_ROOT
33 install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{_bindir}}
34
35 python setup.py install \
36         --optimize=2 \
37         --root=$RPM_BUILD_ROOT
38
39 cat > $RPM_BUILD_ROOT%{_bindir}/em.py <<"EOF"
40 #!/usr/bin/python
41 import em
42 em.invoke(sys.argv[1:])
43 EOF
44
45 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.py
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc README *.em doc
53 %attr(755,root,root) %{_bindir}/*
54 %{py_sitedir}/*.py[co]
This page took 0.071552 seconds and 4 git commands to generate.