]> git.pld-linux.org Git - packages/empy.git/blob - empy.spec
- release 2 to rebuild with Python 2.4
[packages/empy.git] / empy.spec
1 Summary:        System for embedding Python expressions and statements in template text
2 Summary(pl):    System wbudowywania wyra¿eñ jêzyka Python w pliki tekstowe
3 Name:           empy
4 Version:        3.3
5 Release:        2
6 License:        LGPL
7 Group:          Applications/Text
8 Source0:        http://www.alcyone.com/software/empy/%{name}-%{version}.tar.gz
9 # Source0-md5:  e7b518a6fc4fd28fef87726cdb003118
10 URL:            http://www.alcyone.com/software/empy/
11 BuildRequires:  rpm-pythonprov
12 %pyrequires_eq  python-modules
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 System for embedding Python expressions and statements in template
18 text.
19
20 %description -l pl
21 System wbudowywania wyra¿eñ jêzyka Python w pliki tekstowe.
22
23 %prep
24 %setup -q
25
26 %build
27 python setup.py build
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 install -d $RPM_BUILD_ROOT{%{_examplesdir}/%{name}-%{version},%{_bindir}}
32
33 python setup.py install \
34         --optimize=2 \
35         --root=$RPM_BUILD_ROOT
36
37 cat > $RPM_BUILD_ROOT%{_bindir}/em.py <<"EOF"
38 #!/usr/bin/python
39 import em
40 em.invoke(sys.argv[1:])
41 EOF
42
43 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.py
44
45 %clean
46 rm -rf $RPM_BUILD_ROOT
47
48 %files
49 %defattr(644,root,root,755)
50 %doc README *.em doc
51 %attr(755,root,root) %{_bindir}/*
52 %{py_sitescriptdir}/*.py[co]
This page took 0.13329 seconds and 4 git commands to generate.