]> git.pld-linux.org Git - packages/emotion.git/blob - emotion.spec
54b5552283cbff6e21f8adc366c3e21567a5cadd
[packages/emotion.git] / emotion.spec
1 #
2 # Conditional build:
3 %bcond_without  gstreamer       # don't build gstreamer decoder
4 %bcond_without  vlc             # don't build vlc generic decoder
5 %bcond_without  xine            # don't build xine decoder
6 %bcond_without  static_libs     # don't build static library
7 #
8 %define         ecore_ver       1.0.0
9 %define         edje_ver        1.0.0
10 %define         eet_ver         1.4.0
11 %define         eeze_ver        1.1.0
12 %define         eina_ver        1.0.0
13 %define         evas_ver        1.0.0
14
15 Summary:        Emotion - EFL media playback library
16 Summary(pl.UTF-8):      Emotion - biblioteka EFL do odtwarzania multimediów
17 Name:           emotion
18 Version:        0.2.0.65643
19 Release:        1
20 License:        BSD-like
21 Group:          Libraries
22 Source0:        http://download.enlightenment.org/snapshots/LATEST/%{name}-%{version}.tar.bz2
23 # Source0-md5:  1c4fb7c26f4324f4fcc343d6baa21e42
24 URL:            http://trac.enlightenment.org/e/wiki/Emotion
25 BuildRequires:  autoconf >= 2.60
26 BuildRequires:  automake >= 1.6
27 BuildRequires:  ecore-devel >= %{ecore_ver}
28 BuildRequires:  ecore-evas-devel >= %{ecore_ver}
29 BuildRequires:  ecore-fb-devel >= %{ecore_ver}
30 BuildRequires:  ecore-x-devel >= %{ecore_ver}
31 BuildRequires:  edje >= %{edje_ver}
32 BuildRequires:  edje-devel >= %{edje_ver}
33 BuildRequires:  eet-devel >= %{eet_ver}
34 BuildRequires:  eeze-devel >= %{eeze_ver}
35 BuildRequires:  eio-devel
36 BuildRequires:  eina-devel >= %{eina_ver}
37 BuildRequires:  evas-devel >= %{evas_ver}
38 %if %{with gstreamer}
39 BuildRequires:  gstreamer-devel >= 0.10.2
40 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.34
41 %endif
42 BuildRequires:  libtool
43 BuildRequires:  pkgconfig >= 1:0.22
44 %{?with_vlc:BuildRequires:      vlc-devel >= 0.9}
45 %{?with_xine:BuildRequires:     xine-lib-devel >= 2:1.1.1}
46 Requires:       ecore >= %{ecore_ver}
47 Requires:       ecore-evas >= %{ecore_ver}
48 Requires:       ecore-fb >= %{ecore_ver}
49 Requires:       ecore-x >= %{ecore_ver}
50 Requires:       edje-libs >= %{edje_ver}
51 Requires:       eet >= %{eet_ver}
52 Requires:       eeze >= %{eeze_ver}
53 Requires:       eina >= %{eina_ver}
54 Requires:       evas >= %{evas_ver}
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 Emotion is a library to easily integrate media playback into EFL
59 applications, it will take care of using Ecore's main loop and video
60 display is done using Evas.
61
62 %description -l pl.UTF-8
63 Emotion to biblioteka pozwalająca na łatwą integrację odtwarzania
64 multimediów w aplikacjach EFL. Współpracuje z główną pętlą Ecore, a do
65 wyświetlania wykorzystuje bibliotekę Evas.
66
67 %package devel
68 Summary:        Emotion header files
69 Summary(pl.UTF-8):      Pliki nagłówkowe Emotion
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72 Requires:       ecore-devel >= %{ecore_ver}
73 Requires:       eio-devel
74 Requires:       eet-devel >= %{eet_ver}
75 Requires:       eeze-devel >= %{eeze_ver}
76 Requires:       eina-devel >= %{eina_ver}
77 Requires:       evas-devel >= %{evas_ver}
78
79 %description devel
80 Header files for Emotion.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe Emotion.
84
85 %package static
86 Summary:        Static Emotion library
87 Summary(pl.UTF-8):      Statyczna biblioteka Emotion
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static Emotion library.
93
94 %description static -l pl.UTF-8
95 Statyczna biblioteka Emotion.
96
97 %package decoder-gstreamer
98 Summary:        Emotion decoder using gstreamer
99 Summary(pl.UTF-8):      Dekoder Emotion używający gstreamera
100 Group:          Development/Libraries
101 Requires:       %{name} = %{version}-%{release}
102 Requires:       gstreamer >= 0.10.2
103 Requires:       gstreamer-plugins-base >= 0.10.34
104
105 %description decoder-gstreamer
106 Emotion decoder using gstreamer.
107
108 %description decoder-gstreamer -l pl.UTF-8
109 Dekoder Emotion używający gstreamera.
110
111 %package decoder-xine
112 Summary:        Emotion decoder using xine
113 Summary(pl.UTF-8):      Dekoder Emotion używający xine
114 Group:          Development/Libraries
115 Requires:       %{name} = %{version}-%{release}
116 Requires:       xine-lib >= 2:1.1.1
117
118 %description decoder-xine
119 Emotion decoder using xine.
120
121 %description decoder-xine -l pl.UTF-8
122 Dekoder Emotion używający xine.
123
124 %package decoder-vlc
125 Summary:        Emotion decoder using vlc
126 Summary(pl.UTF-8):      Dekoder Emotion używający vlc
127 Group:          Development/Libraries
128 Requires:       %{name} = %{version}-%{release}
129 Requires:       vlc >= 0.9
130
131 %description decoder-vlc
132 Emotion decoder using vlc and Emotion generic plugin.
133
134 %description decoder-vlc -l pl.UTF-8
135 Dekoder Emotion używający vlc i wtyczkę generic biblioteki Emotion.
136
137 %prep
138 %setup -q
139
140 %build
141 %{__libtoolize}
142 %{__aclocal} -I m4
143 %{__autoconf}
144 %{__autoheader}
145 %{__automake}
146 %configure \
147         --disable-silent-rules \
148         %{!?with_static_libs:--disable-static} \
149         %{!?with_vlc:--disable-generic-vlc} \
150         %{!?with_gstreamer:--disable-gstreamer} \
151         %{!?with_xine:--disable-xine}
152 %{__make}
153
154 %install
155 rm -rf $RPM_BUILD_ROOT
156
157 %{__make} install \
158         DESTDIR=$RPM_BUILD_ROOT
159
160 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la \
161         $RPM_BUILD_ROOT%{_libdir}/edje/modules/emotion/linux-gnu-*/*.la
162
163 %if %{without vlc}
164 # dir not installed if vlc module not installed
165 install -d $RPM_BUILD_ROOT%{_libdir}/%{name}/utils
166 %endif
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post   -p /sbin/ldconfig
172 %postun -p /sbin/ldconfig
173
174 %files
175 %defattr(644,root,root,755)
176 %doc AUTHORS COPYING COPYING-PLAIN ChangeLog README TODO
177 %attr(755,root,root) %{_bindir}/emotion_test
178 %attr(755,root,root) %{_libdir}/libemotion.so.*.*.*
179 %attr(755,root,root) %ghost %{_libdir}/libemotion.so.0
180 %dir %{_libdir}/%{name}
181 %attr(755,root,root) %{_libdir}/%{name}/em_generic.so
182 %dir %{_libdir}/%{name}/utils
183 %dir %{_libdir}/edje/modules/emotion
184 %dir %{_libdir}/edje/modules/emotion/linux-gnu-*
185 %attr(755,root,root) %{_libdir}/edje/modules/emotion/linux-gnu-*/module.so
186 %{_datadir}/%{name}
187
188 %files devel
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/libemotion.so
191 %{_libdir}/libemotion.la
192 %{_includedir}/emotion-0
193 %{_pkgconfigdir}/emotion.pc
194
195 %if %{with static_libs}
196 %files static
197 %defattr(644,root,root,755)
198 %{_libdir}/libemotion.a
199 %endif
200
201 %if %{with gstreamer}
202 %files decoder-gstreamer
203 %defattr(644,root,root,755)
204 %attr(755,root,root) %{_libdir}/%{name}/gstreamer.so
205 %endif
206
207 %if %{with xine}
208 %files decoder-xine
209 %defattr(644,root,root,755)
210 %attr(755,root,root) %{_libdir}/%{name}/xine.so
211 %endif
212
213 %if %{with vlc}
214 %files decoder-vlc
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_libdir}/%{name}/utils/em_generic_vlc
217 %endif
This page took 0.130369 seconds and 3 git commands to generate.