]> git.pld-linux.org Git - packages/em8300.git/blob - em8300.spec
reversed bogus change
[packages/em8300.git] / em8300.spec
1 #
2 # Conditional build:
3 # _without_dist_kernel  - without distribution kernel
4 #
5 # TODO: UP/SMP modules
6 Summary:        dxr3 and h+ driver
7 Summary(pl):    sterowniki dla dxr3 i h+
8 Name:           em8300
9 Version:        0.13.0
10 Release:        1
11 License:        GPL
12 Group:          Libraries
13 Source0:        http://dxr3.sourceforge.net/download/%{name}-%{version}.tar.gz
14 # Source0-md5:  306984dfd4f0f29538179cbbf391f5a8
15 Source1:        %{name}.init
16 Source2:        %{name}.sysconf
17 Patch0:         %{name}-automake.patch
18 URL:            http://dxr3.sourceforge.net/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  libtool
22 BuildRequires:  gtk+-devel >= 1.2.0
23 %{!?_without_dist_kernel:BuildRequires: kernel-headers}
24 BuildRequires:  rpmbuild(macros) >= 1.118
25 Requires(post,postun):  /sbin/ldconfig
26 Requires(post,preun):   /sbin/chkconfig
27 Provides:       dxr3
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 em8300 is a Linux driver for Creative DXR3 and Sigma Designs
32 Hollywood+ cards. Both cards are hardware MPEG1, MPEG2, AC3 decoders.
33 Additionaly Xine and MPlayer with help of this driver allow you to
34 play all the video formats that they recognise through the tv-out of
35 these cards.
36
37 %description -l pl
38 em8300 pozwala na uruchomienie pod Linuksem kart Creative DXR3 i Sigma
39 Designs Hollywood+. Obie karty, o prawie identycznej konstrukcji s±
40 sprzêtowymi dekoderami MPEG1, MPEG2 i AC3. Programy Xine i MPlayer
41 pozwalaj± przy u¿yciu tego sterownika na odtwarzanie przez wyj¶cie
42 telewizyjne tych kart nie tylko w/w formatów, ale tak¿e wszystkich
43 formatów video, które te programy rozpoznaj±.
44
45 %package devel
46 Summary:        Files required to develop programs using em8300
47 Summary(pl):    Pliki potrzebne do tworzenia programów korzystaj±cych z em8300
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}
50
51 %description devel
52 Header files and additional scripts useful for developers of em8300
53 apps.
54
55 %description devel -l pl
56 Pliki nag³ówkowe i skrypty przydatne dla autorów aplikacji
57 korzystaj±cych z em8300.
58
59 %package static
60 Summary:        Static libraries for em8300
61 Summary(pl):    Statyczne biblioteki dla em8300
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}
64
65 %description static
66 Static libraries for em8300.
67
68 %description static -l pl
69 Statyczne biblioteki dla em8300.
70
71 %package gtk
72 Summary:        Utility programs for em8300 using gtk+
73 Summary(pl):    Programy u¿ytkowe em8300 u¿ywaj±ce bibliteki gtk+
74 Group:          X11/Applications
75 Requires:       %{name} = %{version}
76
77 %description gtk
78 Utility programs for em8300 using gtk+ toolkit.
79
80 %description gtk -l pl
81 Programy u¿ytkowe em8300 u¿ywaj±ce biblioteki gtk+.
82
83 %package -n kernel-video-em8300
84 Summary:        em8300 Linux kernel modules
85 Summary(pl):    Modu³y j±dra Linuksa em8300
86 Group:          Base/Kernel
87 %{!?_without_dist_kernel:%requires_releq_kernel_up}
88 Requires(post,postun):  /sbin/depmod
89
90 %description -n kernel-video-em8300
91 em8300 Linux kernel modules.
92
93 %description -n kernel-video-em8300 -l pl
94 Modu³y j±dra Linuksa em8300.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99
100 %build
101 rm -f missing
102 %{__libtoolize}
103 %{__aclocal} -I autotools
104 %{__autoconf}
105 %{__autoheader}
106 %{__automake}
107 %configure
108 %{__make}
109
110 %{__make} -C modules \
111         KERNEL_LOCATION="%{_kernelsrcdir}" \
112         EM8300_DEBUG="%{rpmcflags}"
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %{__make} -C modules install-newkern \
121         KERNVER=%{_kernel_ver} \
122         prefix=$RPM_BUILD_ROOT
123
124 mv -f modules/{INSTALL,INSTALL.modules}
125
126 install -D modules/em8300.uc $RPM_BUILD_ROOT%{_datadir}/misc/em8300.uc
127
128 install scripts/microcode_upload.pl $RPM_BUILD_ROOT%{_bindir}/em8300_microcode_upload
129
130 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
131 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post
137 /sbin/ldconfig
138 /sbin/chkconfig --add %{name}
139 if [ -f /var/lock/subsys/%{name} ]; then
140         /etc/rc.d/init.d/%{name} restart 1>&2
141 else
142         echo "Run \"/etc/rc.d/init.d/%{name} start\" to load %{name} modules."
143 fi
144
145 %preun
146 if [ "$1" = "0" ]; then
147         if [ -f /var/lock/subsys/%{name} ]; then
148                 /etc/rc.d/init.d/%{name} stop 1>&2
149         fi
150         /sbin/chkconfig --del %{name}
151 fi
152
153 %postun -p /sbin/ldconfig
154
155 %post   -n kernel-video-em8300
156 %depmod %{_kernel_ver}
157  
158 %postun -n kernel-video-em8300
159 %depmod %{_kernel_ver}
160
161 %files
162 %defattr(644,root,root,755)
163 %doc AUTHORS ChangeLog README modules/{README*,INSTALL*,devices.sh,devfs_symlinks}
164 %attr(755,root,root) %{_bindir}/em8300_microcode_upload
165 %{_datadir}/misc/em8300.uc
166 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
167 %attr(754,root,root) /etc/rc.d/init.d/%{name}
168 %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/%{name}
169
170 %files devel
171 %defattr(644,root,root,755)
172 %{_includedir}/libdxr3
173 %{_includedir}/linux/*.h
174 %attr(755,root,root) %{_libdir}/lib*.so
175 %{_libdir}/lib*.la
176 %attr(755,root,root) %dir %{_datadir}/em8300
177 %attr(755,root,root) %{_datadir}/em8300/*
178
179 %files static
180 %defattr(644,root,root,755)
181 %{_libdir}/lib*.a
182
183 %files gtk
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_bindir}/autocal
186 %attr(755,root,root) %{_bindir}/dhc
187 %attr(755,root,root) %{_bindir}/dxr3view
188 %attr(755,root,root) %{_bindir}/em8300setup
189
190 %files -n kernel-video-em8300
191 %defattr(644,root,root,755)
192 /lib/modules/%{_kernel_ver}/kernel/drivers/video/*.o*
This page took 0.616478 seconds and 3 git commands to generate.