]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- gzip encoded chunked data was not always properly decoded.
[packages/elinks.git] / elinks.spec
1 # TODO: consider lua51
2 #
3 # Conditional build:
4 %bcond_with     x               # Use the X Windows System
5 %bcond_with     gnutls          # Enable GNUTLS SSL support (disables openssl)
6 %bcond_with     ruby            # Enable (experimental) Ruby scripting support
7 %bcond_without  256             # Disable 256 colors support
8 %bcond_without  bittorrent      # Disable BitTorrent support
9 %bcond_without  cgi             # Disable Local CGI support
10 %bcond_without  fsp             # Disable FSP support
11 %bcond_without  guile           # Disable Guile scripting
12 %bcond_without  idn             # Disable Internation Domain Names support
13 %bcond_without  ipv6            # Disable IPv6 support
14 %bcond_without  js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
15 %bcond_without  led             # Disable LEDs
16 %bcond_without  lua             # Disable Lua scripting
17 %bcond_without  openssl         # Disable OpenSSL support
18 %bcond_without  perl            # Disable Perl scripting
19
20 %if %{with gnutls}
21 %undefine       with_openssl
22 %endif
23 #
24 Summary:        Experimantal Links (text WWW browser)
25 Summary(es.UTF-8):      El links es un browser para modo texto, similar a lynx
26 Summary(pl.UTF-8):      Eksperymentalny Links (tekstowa przeglądarka WWW)
27 Summary(pt_BR.UTF-8):   O links é um browser para modo texto, similar ao lynx
28 Name:           elinks
29 Version:        0.11.3
30 Release:        6
31 Epoch:          1
32 License:        GPL
33 Group:          Applications/Networking
34 Source0:        http://www.elinks.cz/download/%{name}-%{version}.tar.bz2
35 # Source0-md5:  a0eb50e18a2ac8e77d6b0df8f94bb5a6
36 Source1:        %{name}.desktop
37 Source2:        links.png
38 Patch0:         %{name}-home_etc.patch
39 Patch1:         %{name}-lua40.patch
40 Patch2:         %{name}-bug517.patch
41 Patch3:         %{name}-cgi.patch
42 Patch4:         %{name}-date-format.patch
43 Patch5:         %{name}-pl.po.patch
44 URL:            http://www.elinks.cz/
45 BuildRequires:  autoconf
46 BuildRequires:  automake
47 BuildRequires:  bzip2-devel
48 BuildRequires:  expat-devel
49 %{?with_fsp:BuildRequires:      fsplib-devel}
50 BuildRequires:  gettext-devel
51 BuildRequires:  gpm-devel
52 %{?with_guile:BuildRequires: guile-devel}
53 %{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
54 %{?with_js:BuildRequires:       js-devel >= 1.5-0.rc6a.1}
55 %{?with_idn:BuildRequires:      libidn-devel}
56 %{?with_lua:BuildRequires:      lua50-devel}
57 BuildRequires:  ncurses-devel >= 5.1
58 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
59 %{?with_perl:BuildRequires:     perl-devel}
60 %{?with_ruby:BuildRequires:     ruby-devel}
61 BuildRequires:  zlib-devel
62 Provides:       webclient
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %define         _sysconfdir     /etc/elinks
66 %define         specflags_ia32  -fomit-frame-pointer 
67
68 %description
69 This is the elinks tree - intended to provide feature-rich version of
70 links, however not rock-stable and dedicated mainly for testing. Its
71 purpose is to make alternative to links, until Mikulas will have some
72 time to maintain it, and to test and tune various patches for Mikulas
73 to be able to include them in the official links releases.
74
75 %description -l es.UTF-8
76 Links es un browser WWW modo texto, similar al Lynx. El links muestra
77 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
78 keepalive.
79
80 %description -l pl.UTF-8
81 Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
82 elinks jednak jest dedykowana głównie do testowania.
83
84 %description -l pt_BR.UTF-8
85 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
86 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
87 keepalive.
88
89 %prep
90 %setup -q
91 %patch0 -p1
92 %patch1 -p1
93 %patch2 -p1
94 %patch3 -p1
95 %patch4 -p1
96 %patch5 -p1
97
98 %build
99 %{__aclocal}
100 %{__autoconf}
101 %{__autoheader}
102 %configure \
103         HAVE_SMBCLIENT=yes \
104         --disable-no-root \
105         %{!?debug:--enable-fastmem} \
106         %{?debug:--enable-debug} \
107         %{!?with_ipv6:--disable-ipv6} \
108         %{?with_bittorrent:--enable-bittorrent} \
109         %{?with_cgi:--enable-cgi} \
110         --enable-finger \
111         --enable-gopher \
112         --enable-nntp \
113         %{?with_256:--enable-256-colors} \
114         --enable-exmode \
115         %{?with_fsp:--enable-fsp} \
116         %{?with_leds:--enable-leds} \
117         --enable-marks \
118         --enable-html-highlight \
119         %{!?with_idn:--without-idn} \
120         %{?with_guile:--with-guile} \
121         %{?with_perl:--with-perl} \
122         %{!?with_lua:--without-lua} \
123         %{?with_ruby:--with-ruby} \
124         %{!?with_js:--without-spidermonkey} \
125         %{?with_gnutls:--with-gnutls} \
126         %{!?with_openssl:--without-openssl} \
127         --with%{!?with_x:out}-x
128 # xterm -e is default, one might want to change it to
129 # something else
130 #       --with-xterm="xterm -e"
131
132 %{__make} V=1
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT%{_desktopdir} \
137         $RPM_BUILD_ROOT%{_datadir}/%{name} \
138         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
139
140 %{__make} install V=1 \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
144 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
145
146 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
147
148 %find_lang %{name}
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files -f %{name}.lang
154 %defattr(644,root,root,755)
155 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
156 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
157 %doc contrib/conv/{*awk,*.pl,*.sh}
158 %doc doc/html/*.html
159 %attr(755,root,root) %{_bindir}/*
160 %{_mandir}/man*/*
161 %{_desktopdir}/*.desktop
162 %{_pixmapsdir}/*
163 %{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.476757 seconds and 4 git commands to generate.