]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- updated to 0.10.1
[packages/elinks.git] / elinks.spec
1 # Conditional build:
2 %bcond_with     x       # Use the X Windows System
3 %bcond_with     gnutls  # Enable GNUTLS SSL support (disables openssl)
4 %bcond_with     js      # Enable experimental JavaScript support (using SpiderMonkey)
5 %bcond_without  256     # Disable 256 colors support
6 %bcond_without  cgi     # Disable Local CGI support
7 %bcond_without  guile   # Disable Guile scripting
8 %bcond_without  idn     # Disable Internation Domain Names support
9 %bcond_without  ipv6    # Disable IPv6 support
10 %bcond_without  led     # Disable LEDs
11 %bcond_without  lua     # Disable Lua scripting
12 %bcond_without  openssl # Disable OpenSSL support
13 %bcond_without  perl    # Disable Perl scripting
14
15 %if %{with gnutls}
16 %undefine       with_openssl
17 %endif
18 #
19 Summary:        Experimantal Links (text WWW browser)
20 Summary(es):    El links es un browser para modo texto, similar a lynx
21 Summary(pl):    Eksperymentalny Links (tekstowa przegl±darka WWW)
22 Summary(pt_BR): O links é um browser para modo texto, similar ao lynx
23 Name:           elinks
24 Version:        0.10.1
25 Release:        1
26 Epoch:          1
27 License:        GPL
28 Group:          Applications/Networking
29 #Source0Download:       http://elinks.or.cz/download.html
30 Source0:        http://elinks.or.cz/download/%{name}-%{version}.tar.bz2
31 # Source0-md5:  ff730be29416dabdbbf2a2fa6ac8b298
32 Source1:        %{name}.desktop
33 Source2:        links.png
34 Patch0:         %{name}-home_etc.patch
35 Patch1:         %{name}-lua40.patch
36 Patch2:         %{name}-locale_names.patch
37 URL:            http://elinks.or.cz/
38 BuildRequires:  autoconf
39 BuildRequires:  automake
40 BuildRequires:  bzip2-devel
41 BuildRequires:  expat-devel
42 BuildRequires:  gettext-devel
43 BuildRequires:  gpm-devel
44 %{?with_guile:BuildRequires: guile-devel}
45 %{?with_gnutls:BuildRequires: gnutls-devel}
46 %{?with_js:BuildRequires:       js-devel >= 1.5-0.rc6a.1}
47 %{?with_idn:BuildRequires:      libidn-devel}
48 %{?with_lua:BuildRequires:      lua40-devel >= 4.0.1-9}
49 BuildRequires:  ncurses-devel => 5.1
50 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
51 %{?with_perl:BuildRequires:     perl-devel}
52 BuildRequires:  zlib-devel
53 BuildRequires:  tetex
54 Provides:       webclient
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %define         _sysconfdir     /etc/elinks
58 %define         specflags_ia32  -fomit-frame-pointer 
59
60 %description
61 This is the elinks tree - intended to provide feature-rich version of
62 links, however not rock-stable and dedicated mainly for testing. Its
63 purpose is to make alternative to links, until Mikulas will have some
64 time to maintain it, and to test and tune various patches for Mikulas
65 to be able to include them in the official links releases.
66
67 %description -l es
68 Links es un browser WWW modo texto, similar al Lynx. El links muestra
69 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
70 keepalive.
71
72 %description -l pl
73 Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki WWW - links.
74 elinks jednak jest dedykowana g³ównie do testowania.
75
76 %description -l pt_BR
77 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
78 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
79 keepalive.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85 %patch2 -p1
86
87 mv -f po/{no,nb}.po
88
89 %build
90 %{__aclocal}
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         %{!?debug:--enable-fastmem} \
96         %{?debug:--enable-debug} \
97         %{!?with_ipv6:--disable-ipv6} \
98         %{?with_cgi:--enable-cgi} \
99         --enable-finger \
100         --enable-gopher \
101         --enable-nntp \
102         %{?with_256:--enable-256-colors} \
103         --enable-exmode \
104         %{?with_leds:--enable-leds} \
105         --enable-html-highlight \
106         --enable-no-root \
107         %{!?with_idn:--without-idn} \
108         %{?with_guile:--with-guile} \
109         %{?with_perl:--with-perl} \
110         %{!?with_lua:--without-lua} \
111         %{!?with_js:--without-spidermonkey} \
112         %{?with_gnutls:--with-gnutls} \
113         %{!?with_openssl:--without-openssl} \
114         %{?with_x:--with-x} 
115
116 %{__make}
117
118 cd doc
119 texi2html elinks-lua.texi
120 cd ..
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 install -d $RPM_BUILD_ROOT%{_desktopdir} \
125         $RPM_BUILD_ROOT%{_datadir}/%{name} \
126         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
132 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
133
134 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
135
136 %find_lang %{name}
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %files -f %{name}.lang
142 %defattr(644,root,root,755)
143 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
144 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
145 %doc contrib/conv/{*awk,*.pl,*.sh}
146 %doc doc/{*.txt,*.html}
147 %attr(755,root,root) %{_bindir}/*
148 %{_mandir}/man*/*
149 %{_desktopdir}/*
150 %{_pixmapsdir}/*
151 %{?with_lua:%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}}
This page took 0.033654 seconds and 4 git commands to generate.