]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
add sixel support
[packages/elinks.git] / elinks.spec
1 #
2 # Conditional build:
3 # - protocols
4 %bcond_without  bittorrent      # BitTorrent protocol support
5 %bcond_without  curl            # FTPes, SFTP, HTTP/2, etc.
6 %bcond_without  fsp             # FSP support
7 %bcond_without  idn             # Internation Domain Names support
8 %bcond_without  ipv6            # IPv6 support
9 %bcond_with     smb             # smb protocol support (non-distib: recent libsmbclient is GPL v3)
10 %bcond_with     gnutls          # GNUTLS-based SSL support (instead of openssl)
11 %bcond_without  openssl         # OpenSSL-based SSL support
12 # - content
13 %bcond_without  cgi             # Local CGI support
14 %bcond_without  brotli          # Brotli compression support
15 %bcond_without  js              # experimental (yet quite usable) JavaScript support (using quickjs)
16 %bcond_without  libcss          # libcss support
17 %bcond_with     lzma            # LZMA support (old API, incompatible with xz-libs)
18 %bcond_without  zstd    # zstd compression support
19 # - scripting
20 %bcond_with     guile           # Guile scripting support (non-distrib: guile 2 is LGPL v3+)
21 %bcond_without  lua             # Lua scripting
22 %bcond_with     perl            # Perl scripting
23 %bcond_with     python          # Python scripting support
24 %bcond_with     ruby            # (experimental) Ruby scripting support
25 # - display and UI
26 %bcond_without  256             # 256 colors support
27 %bcond_without  led             # LEDs
28 %bcond_without  sixel           # image display support in SIXEL capable terminals
29 %bcond_without  truecolor       # true color
30 %bcond_with     x               # Use the X Window System
31 # - misc
32 %bcond_without  verbose         # verbose build (V=1)
33 %bcond_without  libevent        # build without libevent
34
35 %if %{with gnutls}
36 %undefine       with_openssl
37 %endif
38
39 %if %{without libcss}
40 %undefine       with_js
41 %endif
42
43 Summary:        Experimantal Links (text WWW browser)
44 Summary(es.UTF-8):      El links es un browser para modo texto, similar a lynx
45 Summary(pl.UTF-8):      Eksperymentalny Links (tekstowa przeglądarka WWW)
46 Summary(pt_BR.UTF-8):   O links é um browser para modo texto, similar ao lynx
47 Name:           elinks
48 Version:        0.17.0
49 Release:        1
50 Epoch:          1
51 License:        GPL v2
52 Group:          Applications/Networking
53 Source0:        https://github.com/rkd77/elinks/releases/download/v%{version}/%{name}-%{version}.tar.xz
54 # Source0-md5:  6bb43cd9037ad83cded1df85d95dbd73
55 Source1:        %{name}.desktop
56 Source2:        links.png
57 URL:            http://www.elinks.cz/
58 BuildRequires:  bzip2-devel
59 %{?with_curl:BuildRequires:     curl-devel}
60 BuildRequires:  expat-devel
61 %{?with_fsp:BuildRequires:      fsplib-devel}
62 BuildRequires:  gettext-tools
63 BuildRequires:  git-core
64 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
65 BuildRequires:  gpm-devel
66 %{?with_guile:BuildRequires: guile-devel}
67 %{?with_libcss:BuildRequires:   libCSS-devel >= 0.9.1}
68 BuildRequires:  libstdc++-devel
69 BuildRequires:  rpmbuild(macros) >= 1.736
70 %{?with_js:BuildRequires:       sqlite3-devel}
71 %{?with_brotli:BuildRequires:   libbrotli-devel}
72 %if %{with js} || %{with libcss}
73 BuildRequires:  libdom-devel >= 0.4.1
74 %endif
75 %{?with_libevent:BuildRequires: libevent-devel}
76 %{?with_idn:BuildRequires:      libidn2-devel}
77 %{?with_sixel:BuildRequires:    libsixel-devel}
78 %{?with_smb:BuildRequires:      libsmbclient-devel}
79 %{?with_lua:BuildRequires:      lua53-devel}
80 %{?with_lzma:BuildRequires:     lzma-devel}
81 BuildRequires:  meson
82 BuildRequires:  ncurses-devel >= 5.1
83 BuildRequires:  ninja >= 1.5
84 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
85 %{?with_perl:BuildRequires:     perl-devel}
86 BuildRequires:  pkgconfig
87 %{?with_python:BuildRequires:   python3-devel}
88 %{?with_js:BuildRequires:       quickjs-devel >= 20210327-4}
89 %{?with_ruby:BuildRequires:     ruby-devel}
90 BuildRequires:  sed
91 BuildRequires:  tar >= 1:1.22
92 BuildRequires:  tre-devel
93 BuildRequires:  which
94 BuildRequires:  xmlto
95 BuildRequires:  xz
96 BuildRequires:  zlib-devel
97 %{?with_zstd:BuildRequires:     zstd-devel}
98 %{?with_gnutls:Requires:        gnutls-libs >= 1.2.5}
99 %{?with_libcss:Requires:        libCSS >= 0.9.1}
100 %if %{with js} || %{with libcss}
101 Requires:       libdom >= 0.4.1
102 %endif
103 Requires:       ncurses >= 5.1
104 %{?with_openssl:Requires:       openssl >= 0.9.7d}
105 %{?with_js:Requires:    quickjs >= 20210327-4}
106 Suggests:       mailcap
107 Provides:       webclient
108 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
109
110 %define         _sysconfdir     /etc/elinks
111 %define         specflags_ia32  -fomit-frame-pointer
112
113 %description
114 This is the elinks tree - intended to provide feature-rich version of
115 links, however not rock-stable and dedicated mainly for testing. Its
116 purpose is to make alternative to links, until Mikulas will have some
117 time to maintain it, and to test and tune various patches for Mikulas
118 to be able to include them in the official links releases.
119
120 %description -l es.UTF-8
121 Links es un browser WWW modo texto, similar al Lynx. El links muestra
122 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
123 keepalive.
124
125 %description -l pl.UTF-8
126 Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
127 elinks jednak jest dedykowana głównie do testowania.
128
129 %description -l pt_BR.UTF-8
130 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
131 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
132 keepalive.
133
134 %prep
135 %setup -q
136
137 %build
138 %meson build \
139         -Dapidoc=false \
140         -Dhtmldoc=true \
141         -Dpdfdoc=false \
142         -Ddocdir=%{_docdir}/%{name}-%{version} \
143         %{?with_bittorrent:-Dbittorrent=true} \
144         %{?with_cgi:-Dcgi=true} \
145         -D88-colors=true \
146         %{?with_256:-D256-colors=true} \
147         %{?with_truecolor:-Dtrue-color=true} \
148         -Dexmode=true \
149         %{?debug:-Ddebug=true} \
150         %{!?debug:-Dfastmem=true} \
151         -Dfinger=true \
152         -Dfsp=%{__true_false fsp} \
153         -Dgemini=true \
154         -Dgettext=true \
155         -Dgopher=true \
156         -Dhtml-highlight=true \
157         %{!?with_ipv6:-Dipv6=false} \
158         %{?with_leds:-Dleds=true} \
159         -Dlibsixel=%{__true_false sixel} \
160         -Dmarks=true \
161         -Dnntp=true \
162         -Dno-root=false \
163         %{?with_smb:-Dsmb=true} \
164         %{?with_brotli:-Dbrotli=true} \
165         %{?with_zstd:-Dzstd=true} \
166         %{?with_gnutls:-Dgnutls=true} \
167         %{?with_guile:-Dguile=true} \
168         %{!?with_idn:-Didn=false} \
169         %{?with_lua:-Dluapkg=lua5.3} \
170         %{?with_lzma:-Dlzma=true} \
171         %{?with_openssl:-Dopenssl=true} \
172         %{?with_perl:-Dperl=true} \
173         %{?with_python:-Dpython=true} \
174         %{?with_ruby:-Druby=true} \
175         %{?with_js:-Dquickjs=true} \
176         %{?with_x:-Dx=true} \
177         %{?with_libevent:-Dlibevent=true} \
178         %{!?with_curl:-Dlibcurl=false} \
179         %{!?with_libcss:-Dlibcss=false}
180
181 %ninja_build -C build
182
183 %install
184 rm -rf $RPM_BUILD_ROOT
185 %ninja_install -C build
186
187 install -d $RPM_BUILD_ROOT%{_desktopdir} \
188         $RPM_BUILD_ROOT%{_datadir}/%{name} \
189         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
190
191 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
192 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
193
194 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
195 sed -i -e 's|bin/lua|bin/lua5.3|g' $RPM_BUILD_ROOT%{_sysconfdir}/*lua
196
197 install AUTHORS BUGS ChangeLog NEWS README.md SITES TODO $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
198 install contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote} contrib/conv/{*awk,*.pl,*.sh} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
199
200 %find_lang %{name}
201
202 %clean
203 rm -rf $RPM_BUILD_ROOT
204
205 %files -f %{name}.lang
206 %defattr(644,root,root,755)
207 %{_docdir}/%{name}-%{version}
208 %attr(755,root,root) %{_bindir}/elinks
209 %{_mandir}/man1/elinks.1*
210 %{_mandir}/man5/elinks.conf.5*
211 %{_mandir}/man5/elinkskeys.5*
212 %{_desktopdir}/elinks.desktop
213 %{_pixmapsdir}/elinks.png
214 %if %{with lua}
215 %dir %{_sysconfdir}
216 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.lua
217 %endif
This page took 0.119242 seconds and 4 git commands to generate.