]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- added pl.po-update patch
[packages/elinks.git] / elinks.spec
1 #
2 # Conditional build:
3 %bcond_with     x       # Use the X Windows System
4 %bcond_with     gnutls  # Enable GNUTLS SSL support (disables openssl)
5 %bcond_with     js      # Enable experimental JavaScript support (using SpiderMonkey)
6 %bcond_without  256     # Disable 256 colors support
7 %bcond_without  cgi     # Disable Local CGI support
8 %bcond_without  guile   # Disable Guile scripting
9 %bcond_without  idn     # Disable Internation Domain Names support
10 %bcond_without  ipv6    # Disable IPv6 support
11 %bcond_without  led     # Disable LEDs
12 %bcond_without  lua     # Disable Lua scripting
13 %bcond_without  openssl # Disable OpenSSL support
14 %bcond_without  perl    # Disable Perl scripting
15
16 %if %{with gnutls}
17 %undefine       with_openssl
18 %endif
19 #
20 Summary:        Experimantal Links (text WWW browser)
21 Summary(es):    El links es un browser para modo texto, similar a lynx
22 Summary(pl):    Eksperymentalny Links (tekstowa przegl±darka WWW)
23 Summary(pt_BR): O links é um browser para modo texto, similar ao lynx
24 Name:           elinks
25 Version:        0.10.4
26 Release:        1
27 Epoch:          1
28 License:        GPL
29 Group:          Applications/Networking
30 #Source0Download:       http://elinks.or.cz/download.html
31 Source0:        http://elinks.or.cz/download/%{name}-%{version}.tar.bz2
32 # Source0-md5:  0bcc8324f70dba46503af15023c8ee0f
33 Source1:        %{name}.desktop
34 Source2:        links.png
35 Patch0:         %{name}-home_etc.patch
36 Patch1:         %{name}-lua40.patch
37 Patch2:         %{name}-locale_names.patch
38 Patch3:         %{name}-lua40-fix.patch
39 Patch4:         %{name}-pl.po-update.patch
40 URL:            http://elinks.or.cz/
41 BuildRequires:  autoconf
42 BuildRequires:  automake
43 BuildRequires:  bzip2-devel
44 BuildRequires:  expat-devel
45 BuildRequires:  gettext-devel
46 BuildRequires:  gpm-devel
47 %{?with_guile:BuildRequires: guile-devel}
48 %{?with_gnutls:BuildRequires: gnutls-devel}
49 %{?with_js:BuildRequires:       js-devel >= 1.5-0.rc6a.1}
50 %{?with_idn:BuildRequires:      libidn-devel}
51 %{?with_lua:BuildRequires:      lua40-devel >= 4.0.1-9}
52 BuildRequires:  ncurses-devel >= 5.1
53 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
54 %{?with_perl:BuildRequires:     perl-devel}
55 BuildRequires:  zlib-devel
56 BuildRequires:  tetex
57 Provides:       webclient
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %define         _sysconfdir     /etc/elinks
61 %define         specflags_ia32  -fomit-frame-pointer 
62
63 %description
64 This is the elinks tree - intended to provide feature-rich version of
65 links, however not rock-stable and dedicated mainly for testing. Its
66 purpose is to make alternative to links, until Mikulas will have some
67 time to maintain it, and to test and tune various patches for Mikulas
68 to be able to include them in the official links releases.
69
70 %description -l es
71 Links es un browser WWW modo texto, similar al Lynx. El links muestra
72 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
73 keepalive.
74
75 %description -l pl
76 Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki WWW - links.
77 elinks jednak jest dedykowana g³ównie do testowania.
78
79 %description -l pt_BR
80 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
81 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
82 keepalive.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89 %patch3 -p0
90 %patch4 -p1
91
92 mv -f po/{no,nb}.po
93
94 %build
95 %{__aclocal}
96 %{__autoconf}
97 %{__autoheader}
98 %{__automake}
99 %configure \
100         --disable-no-root \
101         HAVE_SMBCLIENT=yes \
102         %{!?debug:--enable-fastmem} \
103         %{?debug:--enable-debug} \
104         %{!?with_ipv6:--disable-ipv6} \
105         %{?with_cgi:--enable-cgi} \
106         --enable-finger \
107         --enable-gopher \
108         --enable-nntp \
109         %{?with_256:--enable-256-colors} \
110         --enable-exmode \
111         %{?with_leds:--enable-leds} \
112         --enable-html-highlight \
113         %{!?with_idn:--without-idn} \
114         %{?with_guile:--with-guile} \
115         %{?with_perl:--with-perl} \
116         %{!?with_lua:--without-lua} \
117         %{!?with_js:--without-spidermonkey} \
118         %{?with_gnutls:--with-gnutls} \
119         %{!?with_openssl:--without-openssl} \
120         --with%{!?with_x:out}-x 
121
122 %{__make}
123
124 cd doc
125 texi2html elinks-lua.texi
126 cd ..
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 install -d $RPM_BUILD_ROOT%{_desktopdir} \
131         $RPM_BUILD_ROOT%{_datadir}/%{name} \
132         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
138 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
139
140 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
141
142 %find_lang %{name}
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %files -f %{name}.lang
148 %defattr(644,root,root,755)
149 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
150 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
151 %doc contrib/conv/{*awk,*.pl,*.sh}
152 %doc doc/{*.txt,*.html}
153 %attr(755,root,root) %{_bindir}/*
154 %{_mandir}/man*/*
155 %{_desktopdir}/*
156 %{_pixmapsdir}/*
157 %{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.131073 seconds and 4 git commands to generate.