]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- BR: python-devel
[packages/elinks.git] / elinks.spec
1 # TODO: consider lua51
2 #
3 # Conditional build:
4 %bcond_with     x               # Use the X Windows System
5 %bcond_with     gnutls          # Enable GNUTLS SSL support (disables openssl)
6 %bcond_with     python          # Enable Python scripting support
7 %bcond_with     ruby            # Enable (experimental) Ruby scripting support
8 %bcond_with     verbose         # verbose build (V=1)
9 %bcond_without  256             # Disable 256 colors support
10 %bcond_without  bittorrent      # Disable BitTorrent support
11 %bcond_without  cgi             # Disable Local CGI support
12 %bcond_without  fsp             # Disable FSP support
13 %bcond_without  guile           # Disable Guile scripting
14 %bcond_without  idn             # Disable Internation Domain Names support
15 %bcond_without  ipv6            # Disable IPv6 support
16 %bcond_without  js              # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
17 %bcond_without  led             # Disable LEDs
18 %bcond_without  lua             # Disable Lua scripting
19 %bcond_without  openssl         # Disable OpenSSL support
20 %bcond_without  perl            # Disable Perl scripting
21
22 %if %{with gnutls}
23 %undefine       with_openssl
24 %endif
25 #
26 Summary:        Experimantal Links (text WWW browser)
27 Summary(es.UTF-8):      El links es un browser para modo texto, similar a lynx
28 Summary(pl.UTF-8):      Eksperymentalny Links (tekstowa przeglądarka WWW)
29 Summary(pt_BR.UTF-8):   O links é um browser para modo texto, similar ao lynx
30 Name:           elinks
31 Version:        0.11.4
32 Release:        1
33 Epoch:          1
34 License:        GPL
35 Group:          Applications/Networking
36 Source0:        http://www.elinks.cz/download/%{name}-%{version}.tar.bz2
37 # Source0-md5:  88036a518ebc4f1150a7e14b29f9d8db
38 Source1:        %{name}.desktop
39 Source2:        links.png
40 Patch0:         %{name}-home_etc.patch
41 Patch1:         %{name}-lua40.patch
42 Patch2:         %{name}-bug517.patch
43 Patch3:         %{name}-date-format.patch
44 Patch4:         %{name}-chunked.patch
45 Patch5:         %{name}-mailcap_DISPLAY.patch
46 URL:            http://www.elinks.cz/
47 BuildRequires:  autoconf
48 BuildRequires:  automake
49 BuildRequires:  bzip2-devel
50 BuildRequires:  expat-devel
51 %{?with_fsp:BuildRequires:      fsplib-devel}
52 BuildRequires:  gettext-devel
53 BuildRequires:  gpm-devel
54 %{?with_guile:BuildRequires: guile-devel}
55 %{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
56 %{?with_js:BuildRequires:       js-devel >= 1.5-0.rc6a.1}
57 %{?with_idn:BuildRequires:      libidn-devel}
58 %{?with_lua:BuildRequires:      lua50-devel}
59 BuildRequires:  ncurses-devel >= 5.1
60 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
61 %{?with_perl:BuildRequires:     perl-devel}
62 %{?with_python:BuildRequires:   python-devel}
63 %{?with_ruby:BuildRequires:     ruby-devel}
64 BuildRequires:  zlib-devel
65 Suggests:       mailcap
66 Provides:       webclient
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %define         _sysconfdir     /etc/elinks
70 %define         specflags_ia32  -fomit-frame-pointer 
71
72 %description
73 This is the elinks tree - intended to provide feature-rich version of
74 links, however not rock-stable and dedicated mainly for testing. Its
75 purpose is to make alternative to links, until Mikulas will have some
76 time to maintain it, and to test and tune various patches for Mikulas
77 to be able to include them in the official links releases.
78
79 %description -l es.UTF-8
80 Links es un browser WWW modo texto, similar al Lynx. El links muestra
81 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
82 keepalive.
83
84 %description -l pl.UTF-8
85 Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
86 elinks jednak jest dedykowana głównie do testowania.
87
88 %description -l pt_BR.UTF-8
89 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
90 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
91 keepalive.
92
93 %prep
94 %setup -q
95 %patch0 -p1
96 %patch1 -p1
97 %patch2 -p1
98 %patch3 -p1
99 %patch4 -p1
100 %patch5 -p1
101
102 %build
103 %{__aclocal}
104 %{__autoconf}
105 %{__autoheader}
106 %configure \
107         HAVE_SMBCLIENT=yes \
108         --disable-no-root \
109         %{!?debug:--enable-fastmem} \
110         %{?debug:--enable-debug} \
111         %{!?with_ipv6:--disable-ipv6} \
112         %{?with_bittorrent:--enable-bittorrent} \
113         %{?with_cgi:--enable-cgi} \
114         --enable-finger \
115         --enable-gopher \
116         --enable-nntp \
117         %{?with_256:--enable-256-colors} \
118         --enable-exmode \
119         %{?with_fsp:--enable-fsp} \
120         %{?with_leds:--enable-leds} \
121         --enable-marks \
122         --enable-html-highlight \
123         %{!?with_idn:--without-idn} \
124         %{?with_guile:--with-guile} \
125         %{?with_perl:--with-perl} \
126         %{!?with_lua:--without-lua} \
127         %{?with_python:--with-python} \
128         %{?with_ruby:--with-ruby} \
129         %{!?with_js:--without-spidermonkey} \
130         %{?with_gnutls:--with-gnutls} \
131         %{!?with_openssl:--without-openssl} \
132         --with%{!?with_x:out}-x
133 # xterm -e is default, one might want to change it to
134 # something else
135 #       --with-xterm="xterm -e"
136
137 %{__make} %{?with_verbose:V=1}
138
139 %install
140 rm -rf $RPM_BUILD_ROOT
141 install -d $RPM_BUILD_ROOT%{_desktopdir} \
142         $RPM_BUILD_ROOT%{_datadir}/%{name} \
143         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
144
145 %{__make} install %{?with_verbose:V=1} \
146         DESTDIR=$RPM_BUILD_ROOT
147
148 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
149 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
150
151 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
152
153 %find_lang %{name}
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %files -f %{name}.lang
159 %defattr(644,root,root,755)
160 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
161 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
162 %doc contrib/conv/{*awk,*.pl,*.sh}
163 %doc doc/html/*.html
164 %attr(755,root,root) %{_bindir}/*
165 %{_mandir}/man*/*
166 %{_desktopdir}/*.desktop
167 %{_pixmapsdir}/*
168 %{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.511681 seconds and 4 git commands to generate.