]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- release 0.1 due to unfinished upgrade (more done on DEVEL)
[packages/elinks.git] / elinks.spec
1 #
2 # TODO: review/merge DEVEL branch
3 #
4 # Conditional build:
5 %bcond_with     x       # Use the X Windows System
6 %bcond_without  cgi     # Disable Local CGI support
7 %bcond_without  ipv6    # Disable IPv6 Support
8 %bcond_without  led     # Disable LEDs
9 %bcond_without  256     # Disable 256 colors support
10 %bcond_without  lua     # Disable Lua scripting
11 #
12 Summary:        Experimantal Links (text WWW browser)
13 Summary(es):    El links es un browser para modo texto, similar a lynx
14 Summary(pl):    Eksperymentalny Links (tekstowa przegl±darka WWW)
15 Summary(pt_BR): O links é um browser para modo texto, similar ao lynx
16 Name:           elinks
17 Version:        0.10.0
18 Release:        0.1
19 Epoch:          1
20 License:        GPL
21 Group:          Applications/Networking
22 #Source0Download:       http://elinks.or.cz/download.html
23 Source0:        http://elinks.or.cz/download/%{name}-%{version}.tar.bz2
24 # Source0-md5:  09a199b496bcdaf54791f2010a8351b8
25 Source1:        %{name}.desktop
26 Source2:        links.png
27 #Patch0:                %{name}-pl.po.patch
28 Patch1:         %{name}-home_etc.patch
29 Patch2:         %{name}-lua40.patch
30 Patch3:         %{name}-content-type.patch
31 URL:            http://elinks.or.cz/
32 BuildRequires:  autoconf
33 BuildRequires:  automake
34 BuildRequires:  bzip2-devel
35 BuildRequires:  expat-devel
36 BuildRequires:  gettext-devel
37 BuildRequires:  gpm-devel
38 %{?with_lua:BuildRequires:      lua40-devel >= 4.0.1-9}
39 BuildRequires:  ncurses-devel >= 5.1
40 BuildRequires:  openssl-devel >= 0.9.7d
41 BuildRequires:  sed >= 4.0
42 BuildRequires:  tetex
43 BuildRequires:  zlib-devel
44 Provides:       webclient
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _sysconfdir     /etc/elinks
48 %define         specflags_ia32  -fomit-frame-pointer
49
50 %description
51 This is the elinks tree - intended to provide feature-rich version of
52 links, however not rock-stable and dedicated mainly for testing. Its
53 purpose is to make alternative to links, until Mikulas will have some
54 time to maintain it, and to test and tune various patches for Mikulas
55 to be able to include them in the official links releases.
56
57 %description -l es
58 Links es un browser WWW modo texto, similar al Lynx. El links muestra
59 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
60 keepalive.
61
62 %description -l pl
63 Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki WWW - links.
64 elinks jednak jest dedykowana g³ównie do testowania.
65
66 %description -l pt_BR
67 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
68 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
69 keepalive.
70
71 %prep
72 %setup -q
73 #%patch0 -p1
74 %patch1 -p1
75 %patch2 -p1
76 %patch3 -p1
77
78 mv -f po/{no,nb}.po
79
80 %build
81 %{__sed} -i 's,\(^ALL_LINGUAS=.*\)\(no\),\1nb,' configure.in
82 %{__aclocal}
83 %{__autoconf}
84 %{__autoheader}
85 %{__automake}
86 %configure \
87 %{!?debug:      --enable-fastmem} \
88 %{?debug:       --enable-debug} \
89         %{!?with_ipv6:--disable-ipv6} \
90         %{!?with_lua:--without-lua} \
91         --with%{!?with_x:out}-x
92 %{?with_led:echo    '#define CONFIG_LEDS' >> feature.h}
93 %{?with_256:echo    '#define CONFIG_256_COLORS' >> feature.h}
94 %{?with_cgi:echo -e "#ifdef HAVE_SETENV\n\t#define CONFIG_CGI\n#endif" >> feature.h}
95 %{__make}
96
97 cd doc
98 texi2html elinks-lua.texi
99 cd ..
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 install -d $RPM_BUILD_ROOT%{_desktopdir} \
104         $RPM_BUILD_ROOT%{_datadir}/%{name} \
105         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
111 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
112
113 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
114
115 %find_lang %{name}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %files -f %{name}.lang
121 %defattr(644,root,root,755)
122 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
123 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
124 %doc contrib/conv/{*awk,*.pl,*.sh}
125 %doc doc/{*.txt,*.html}
126 %attr(755,root,root) %{_bindir}/*
127 %{_mandir}/man*/*
128 %{_desktopdir}/*
129 %{_pixmapsdir}/*
130 %{?with_lua:%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}}
This page took 0.071895 seconds and 4 git commands to generate.