]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
BR gnutls >= 1.2.5
[packages/elinks.git] / elinks.spec
1 #
2 # Conditional build:
3 %bcond_with     x       # Use the X Windows System
4 %bcond_with     gnutls  # Enable GNUTLS SSL support (disables openssl)
5 %bcond_without  256     # Disable 256 colors support
6 %bcond_without  cgi     # Disable Local CGI support
7 %bcond_without  guile   # Disable Guile scripting
8 %bcond_without  idn     # Disable Internation Domain Names support
9 %bcond_without  ipv6    # Disable IPv6 support
10 %bcond_without  js      # Disable experimental (yet quite usable) JavaScript support (using SpiderMonkey)
11 %bcond_without  led     # Disable LEDs
12 %bcond_without  lua     # Disable Lua scripting
13 %bcond_without  openssl # Disable OpenSSL support
14 %bcond_without  perl    # Disable Perl scripting
15
16 %if %{with gnutls}
17 %undefine       with_openssl
18 %endif
19 #
20 Summary:        Experimantal Links (text WWW browser)
21 Summary(es):    El links es un browser para modo texto, similar a lynx
22 Summary(pl):    Eksperymentalny Links (tekstowa przegl±darka WWW)
23 Summary(pt_BR): O links é um browser para modo texto, similar ao lynx
24 Name:           elinks
25 Version:        0.10.5
26 Release:        3
27 Epoch:          1
28 License:        GPL
29 Group:          Applications/Networking
30 #Source0Download:       http://elinks.or.cz/download.html
31 Source0:        http://elinks.or.cz/download/%{name}-%{version}.tar.bz2
32 # Source0-md5:  d19fea8cddd1c64ae890319650dce1ff
33 Source1:        %{name}.desktop
34 Source2:        links.png
35 Patch0:         %{name}-home_etc.patch
36 Patch1:         %{name}-lua40.patch
37 Patch2:         %{name}-locale_names.patch
38 #Patch3:                %{name}-pl.po-update.patch
39 URL:            http://elinks.or.cz/
40 BuildRequires:  autoconf
41 BuildRequires:  automake
42 BuildRequires:  bzip2-devel
43 BuildRequires:  expat-devel
44 BuildRequires:  gettext-devel
45 BuildRequires:  gpm-devel
46 %{?with_guile:BuildRequires: guile-devel}
47 %{?with_gnutls:BuildRequires: gnutls-devel >= 1.2.5}
48 %{?with_js:BuildRequires:       js-devel >= 1.5-0.rc6a.1}
49 %{?with_idn:BuildRequires:      libidn-devel}
50 %{?with_lua:BuildRequires:      lua50-devel}
51 BuildRequires:  ncurses-devel >= 5.1
52 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
53 %{?with_perl:BuildRequires:     perl-devel}
54 BuildRequires:  zlib-devel
55 BuildRequires:  tetex
56 Provides:       webclient
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %define         _sysconfdir     /etc/elinks
60 %define         specflags_ia32  -fomit-frame-pointer 
61
62 %description
63 This is the elinks tree - intended to provide feature-rich version of
64 links, however not rock-stable and dedicated mainly for testing. Its
65 purpose is to make alternative to links, until Mikulas will have some
66 time to maintain it, and to test and tune various patches for Mikulas
67 to be able to include them in the official links releases.
68
69 %description -l es
70 Links es un browser WWW modo texto, similar al Lynx. El links muestra
71 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
72 keepalive.
73
74 %description -l pl
75 Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki WWW - links.
76 elinks jednak jest dedykowana g³ównie do testowania.
77
78 %description -l pt_BR
79 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
80 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
81 keepalive.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87 %patch2 -p1
88
89 mv -f po/{no,nb}.po
90
91 %build
92 %{__aclocal}
93 %{__autoconf}
94 %{__autoheader}
95 %{__automake}
96 %configure \
97         --disable-no-root \
98         HAVE_SMBCLIENT=yes \
99         %{!?debug:--enable-fastmem} \
100         %{?debug:--enable-debug} \
101         %{!?with_ipv6:--disable-ipv6} \
102         %{?with_cgi:--enable-cgi} \
103         --enable-finger \
104         --enable-gopher \
105         --enable-nntp \
106         %{?with_256:--enable-256-colors} \
107         --enable-exmode \
108         %{?with_leds:--enable-leds} \
109         --enable-html-highlight \
110         %{!?with_idn:--without-idn} \
111         %{?with_guile:--with-guile} \
112         %{?with_perl:--with-perl} \
113         %{!?with_lua:--without-lua} \
114         %{!?with_js:--without-spidermonkey} \
115         %{?with_gnutls:--with-gnutls} \
116         %{!?with_openssl:--without-openssl} \
117         --with%{!?with_x:out}-x 
118
119 %{__make}
120
121 cd doc
122 texi2html elinks-lua.texi
123 cd ..
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127 install -d $RPM_BUILD_ROOT%{_desktopdir} \
128         $RPM_BUILD_ROOT%{_datadir}/%{name} \
129         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
135 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
136
137 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
138
139 %find_lang %{name}
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %files -f %{name}.lang
145 %defattr(644,root,root,755)
146 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
147 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
148 %doc contrib/conv/{*awk,*.pl,*.sh}
149 %doc doc/{*.txt,*.html}
150 %attr(755,root,root) %{_bindir}/*
151 %{_mandir}/man*/*
152 %{_desktopdir}/*
153 %{_pixmapsdir}/*
154 %{?with_lua:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}}
This page took 0.054869 seconds and 4 git commands to generate.