]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
uses libidn2 now
[packages/elinks.git] / elinks.spec
1 #
2 # Conditional build:
3 # - protocols
4 %bcond_without  bittorrent      # BitTorrent protocol support
5 %bcond_without  curl            # FTPes, SFTP, HTTP/2, etc.
6 %bcond_without  fsp             # FSP support
7 %bcond_without  idn             # Internation Domain Names support
8 %bcond_without  ipv6            # IPv6 support
9 %bcond_with     smb             # smb protocol support (non-distib: recent libsmbclient is GPL v3)
10 %bcond_with     gnutls          # GNUTLS-based SSL support (instead of openssl)
11 %bcond_without  openssl         # OpenSSL-based SSL support
12 # - content
13 %bcond_without  cgi             # Local CGI support
14 %bcond_without  brotli          # Brotli compression support
15 %bcond_without  js              # experimental (yet quite usable) JavaScript support (using quickjs)
16 %bcond_without  libcss          # libcss support
17 %bcond_with     lzma            # LZMA support (old API, incompatible with xz-libs)
18 %bcond_without  zstd    # zstd compression support
19 # - scripting
20 %bcond_with     guile           # Guile scripting support (non-distrib: guile 2 is LGPL v3+)
21 %bcond_without  lua             # Lua scripting
22 %bcond_with     perl            # Perl scripting
23 %bcond_with     python          # Python scripting support
24 %bcond_with     ruby            # (experimental) Ruby scripting support
25 # - display and UI
26 %bcond_without  256             # 256 colors support
27 %bcond_without  led             # LEDs
28 %bcond_without  truecolor       # true color
29 %bcond_with     x               # Use the X Window System
30 # - misc
31 %bcond_without  verbose         # verbose build (V=1)
32 %bcond_without  libevent        # build without libevent
33
34 %if %{with gnutls}
35 %undefine       with_openssl
36 %endif
37
38 %if %{with js}
39 %define         with_libcss     1
40 %endif
41
42 Summary:        Experimantal Links (text WWW browser)
43 Summary(es.UTF-8):      El links es un browser para modo texto, similar a lynx
44 Summary(pl.UTF-8):      Eksperymentalny Links (tekstowa przeglądarka WWW)
45 Summary(pt_BR.UTF-8):   O links é um browser para modo texto, similar ao lynx
46 Name:           elinks
47 Version:        0.17.0
48 Release:        1
49 Epoch:          1
50 License:        GPL v2
51 Group:          Applications/Networking
52 Source0:        https://github.com/rkd77/elinks/releases/download/v%{version}/%{name}-%{version}.tar.xz
53 # Source0-md5:  6bb43cd9037ad83cded1df85d95dbd73
54 Source1:        %{name}.desktop
55 Source2:        links.png
56 URL:            http://www.elinks.cz/
57 BuildRequires:  bzip2-devel
58 %{?with_curl:BuildRequires:     curl-devel}
59 BuildRequires:  expat-devel
60 %{?with_fsp:BuildRequires:      fsplib-devel}
61 BuildRequires:  gettext-tools
62 BuildRequires:  git-core
63 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
64 BuildRequires:  gpm-devel
65 %{?with_guile:BuildRequires: guile-devel}
66 %{?with_libcss:BuildRequires:   libCSS-devel >= 0.9.1}
67 BuildRequires:  libstdc++-devel
68 BuildRequires:  rpmbuild(macros) >= 1.736
69 %{?with_js:BuildRequires:       sqlite3-devel}
70 %{?with_brotli:BuildRequires:   libbrotli-devel}
71 %{?with_js:BuildRequires:       libdom-devel >= 0.4.1}
72 %{?with_libevent:BuildRequires: libevent-devel}
73 %{?with_idn:BuildRequires:      libidn2-devel}
74 %{?with_smb:BuildRequires:      libsmbclient-devel}
75 %{?with_lua:BuildRequires:      lua53-devel}
76 %{?with_lzma:BuildRequires:     lzma-devel}
77 BuildRequires:  meson
78 BuildRequires:  ncurses-devel >= 5.1
79 BuildRequires:  ninja >= 1.5
80 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
81 %{?with_perl:BuildRequires:     perl-devel}
82 BuildRequires:  pkgconfig
83 %{?with_python:BuildRequires:   python3-devel}
84 %{?with_js:BuildRequires:       quickjs-devel >= 20210327-4}
85 %{?with_ruby:BuildRequires:     ruby-devel}
86 BuildRequires:  sed
87 BuildRequires:  tar >= 1:1.22
88 BuildRequires:  tre-devel
89 BuildRequires:  which
90 BuildRequires:  xmlto
91 BuildRequires:  xz
92 BuildRequires:  zlib-devel
93 %{?with_zstd:BuildRequires:     zstd-devel}
94 Suggests:       mailcap
95 Provides:       webclient
96 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
97
98 %define         _sysconfdir     /etc/elinks
99 %define         specflags_ia32  -fomit-frame-pointer
100
101 %description
102 This is the elinks tree - intended to provide feature-rich version of
103 links, however not rock-stable and dedicated mainly for testing. Its
104 purpose is to make alternative to links, until Mikulas will have some
105 time to maintain it, and to test and tune various patches for Mikulas
106 to be able to include them in the official links releases.
107
108 %description -l es.UTF-8
109 Links es un browser WWW modo texto, similar al Lynx. El links muestra
110 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
111 keepalive.
112
113 %description -l pl.UTF-8
114 Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
115 elinks jednak jest dedykowana głównie do testowania.
116
117 %description -l pt_BR.UTF-8
118 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
119 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
120 keepalive.
121
122 %prep
123 %setup -q
124
125 %build
126 %meson build \
127         -Dapidoc=false \
128         -Dhtmldoc=true \
129         -Dpdfdoc=false \
130         -Ddocdir=%{_docdir}/%{name}-%{version} \
131         %{?with_bittorrent:-Dbittorrent=true} \
132         %{?with_cgi:-Dcgi=true} \
133         -D88-colors=true \
134         %{?with_256:-D256-colors=true} \
135         %{?with_truecolor:-Dtrue-color=true} \
136         -Dexmode=true \
137         %{?debug:-Ddebug=true} \
138         %{!?debug:-Dfastmem=true} \
139         -Dfinger=true \
140         -Dfsp=%{__true_false fsp} \
141         -Dgemini=true \
142         -Dgettext=true \
143         -Dgopher=true \
144         -Dhtml-highlight=true \
145         %{!?with_ipv6:-Dipv6=false} \
146         %{?with_leds:-Dleds=true} \
147         -Dmarks=true \
148         -Dnntp=true \
149         -Dno-root=false \
150         %{?with_smb:-Dsmb=true} \
151         %{?with_brotli:-Dbrotli=true} \
152         %{?with_zstd:-Dzstd=true} \
153         %{?with_gnutls:-Dgnutls=true} \
154         %{?with_guile:-Dguile=true} \
155         %{!?with_idn:-Didn=false} \
156         %{?with_lua:-Dluapkg=lua5.3} \
157         %{?with_lzma:-Dlzma=true} \
158         %{?with_openssl:-Dopenssl=true} \
159         %{?with_perl:-Dperl=true} \
160         %{?with_python:-Dpython=true} \
161         %{?with_ruby:-Druby=true} \
162         %{?with_js:-Dquickjs=true} \
163         %{?with_x:-Dx=true} \
164         %{?with_libevent:-Dlibevent=true} \
165         %{!?with_curl:-Dlibcurl=false} \
166         %{!?with_libcss:-Dlibcss=false}
167
168 %ninja_build -C build
169
170 %install
171 rm -rf $RPM_BUILD_ROOT
172 %ninja_install -C build
173
174 install -d $RPM_BUILD_ROOT%{_desktopdir} \
175         $RPM_BUILD_ROOT%{_datadir}/%{name} \
176         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
177
178 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
179 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
180
181 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
182 sed -i -e 's|bin/lua|bin/lua5.3|g' $RPM_BUILD_ROOT%{_sysconfdir}/*lua
183
184 install AUTHORS BUGS ChangeLog NEWS README.md SITES TODO $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
185 install contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote} contrib/conv/{*awk,*.pl,*.sh} $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}
186
187 %find_lang %{name}
188
189 %clean
190 rm -rf $RPM_BUILD_ROOT
191
192 %files -f %{name}.lang
193 %defattr(644,root,root,755)
194 %{_docdir}/%{name}-%{version}
195 %attr(755,root,root) %{_bindir}/elinks
196 %{_mandir}/man1/elinks.1*
197 %{_mandir}/man5/elinks.conf.5*
198 %{_mandir}/man5/elinkskeys.5*
199 %{_desktopdir}/elinks.desktop
200 %{_pixmapsdir}/elinks.png
201 %if %{with lua}
202 %dir %{_sysconfdir}
203 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.lua
204 %endif
This page took 0.157088 seconds and 4 git commands to generate.