]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- fix without x
[packages/elinks.git] / elinks.spec
1 #
2 # Conditional build:
3 %bcond_with     x       # Use the X Windows System
4 %bcond_with     gnutls  # Enable GNUTLS SSL support (disables openssl)
5 %bcond_with     js      # Enable experimental JavaScript support (using SpiderMonkey)
6 %bcond_without  256     # Disable 256 colors support
7 %bcond_without  cgi     # Disable Local CGI support
8 %bcond_without  guile   # Disable Guile scripting
9 %bcond_without  idn     # Disable Internation Domain Names support
10 %bcond_without  ipv6    # Disable IPv6 support
11 %bcond_without  led     # Disable LEDs
12 %bcond_without  lua     # Disable Lua scripting
13 %bcond_without  openssl # Disable OpenSSL support
14 %bcond_without  perl    # Disable Perl scripting
15
16 %if %{with gnutls}
17 %undefine       with_openssl
18 %endif
19 #
20 Summary:        Experimantal Links (text WWW browser)
21 Summary(es):    El links es un browser para modo texto, similar a lynx
22 Summary(pl):    Eksperymentalny Links (tekstowa przegl±darka WWW)
23 Summary(pt_BR): O links é um browser para modo texto, similar ao lynx
24 Name:           elinks
25 Version:        0.10.1
26 Release:        1
27 Epoch:          1
28 License:        GPL
29 Group:          Applications/Networking
30 #Source0Download:       http://elinks.or.cz/download.html
31 Source0:        http://elinks.or.cz/download/%{name}-%{version}.tar.bz2
32 # Source0-md5:  ff730be29416dabdbbf2a2fa6ac8b298
33 Source1:        %{name}.desktop
34 Source2:        links.png
35 Patch0:         %{name}-home_etc.patch
36 Patch1:         %{name}-lua40.patch
37 Patch2:         %{name}-locale_names.patch
38 URL:            http://elinks.or.cz/
39 BuildRequires:  autoconf
40 BuildRequires:  automake
41 BuildRequires:  bzip2-devel
42 BuildRequires:  expat-devel
43 BuildRequires:  gettext-devel
44 BuildRequires:  gpm-devel
45 %{?with_guile:BuildRequires: guile-devel}
46 %{?with_gnutls:BuildRequires: gnutls-devel}
47 %{?with_js:BuildRequires:       js-devel >= 1.5-0.rc6a.1}
48 %{?with_idn:BuildRequires:      libidn-devel}
49 %{?with_lua:BuildRequires:      lua40-devel >= 4.0.1-9}
50 BuildRequires:  ncurses-devel >= 5.1
51 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
52 %{?with_perl:BuildRequires:     perl-devel}
53 BuildRequires:  zlib-devel
54 BuildRequires:  tetex
55 Provides:       webclient
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %define         _sysconfdir     /etc/elinks
59 %define         specflags_ia32  -fomit-frame-pointer 
60
61 %description
62 This is the elinks tree - intended to provide feature-rich version of
63 links, however not rock-stable and dedicated mainly for testing. Its
64 purpose is to make alternative to links, until Mikulas will have some
65 time to maintain it, and to test and tune various patches for Mikulas
66 to be able to include them in the official links releases.
67
68 %description -l es
69 Links es un browser WWW modo texto, similar al Lynx. El links muestra
70 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
71 keepalive.
72
73 %description -l pl
74 Bogata w opcje i mo¿liwo¶ci wersja tekstowej przegl±darki WWW - links.
75 elinks jednak jest dedykowana g³ównie do testowania.
76
77 %description -l pt_BR
78 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
79 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
80 keepalive.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85 %patch1 -p1
86 %patch2 -p1
87
88 mv -f po/{no,nb}.po
89
90 %build
91 %{__aclocal}
92 %{__autoconf}
93 %{__autoheader}
94 %{__automake}
95 %configure \
96         %{!?debug:--enable-fastmem} \
97         %{?debug:--enable-debug} \
98         %{!?with_ipv6:--disable-ipv6} \
99         %{?with_cgi:--enable-cgi} \
100         --enable-finger \
101         --enable-gopher \
102         --enable-nntp \
103         %{?with_256:--enable-256-colors} \
104         --enable-exmode \
105         %{?with_leds:--enable-leds} \
106         --enable-html-highlight \
107         --disable-no-root \
108         %{!?with_idn:--without-idn} \
109         %{?with_guile:--with-guile} \
110         %{?with_perl:--with-perl} \
111         %{!?with_lua:--without-lua} \
112         %{!?with_js:--without-spidermonkey} \
113         %{?with_gnutls:--with-gnutls} \
114         %{!?with_openssl:--without-openssl} \
115         --with%{!?with_x:out}-x 
116
117 %{__make}
118
119 cd doc
120 texi2html elinks-lua.texi
121 cd ..
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT%{_desktopdir} \
126         $RPM_BUILD_ROOT%{_datadir}/%{name} \
127         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
128
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
133 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
134
135 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
136
137 %find_lang %{name}
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %files -f %{name}.lang
143 %defattr(644,root,root,755)
144 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO
145 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote}
146 %doc contrib/conv/{*awk,*.pl,*.sh}
147 %doc doc/{*.txt,*.html}
148 %attr(755,root,root) %{_bindir}/*
149 %{_mandir}/man*/*
150 %{_desktopdir}/*
151 %{_pixmapsdir}/*
152 %{?with_lua:%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}}
This page took 0.105164 seconds and 4 git commands to generate.