]> git.pld-linux.org Git - packages/elinks.git/blob - elinks.spec
- cosmetics
[packages/elinks.git] / elinks.spec
1 # TODO: consider lua51
2
3 # Conditional build:
4 # - protocols
5 %bcond_without  bittorrent      # BitTorrent protocol support
6 %bcond_without  fsp             # FSP support
7 %bcond_without  idn             # Internation Domain Names support
8 %bcond_without  ipv6            # IPv6 support
9 %bcond_with     smb             # smb protocol support (non-distib: recent libsmbclient is GPL v3)
10 %bcond_with     gnutls          # GNUTLS-based SSL support (instead of openssl)
11 %bcond_without  openssl         # OpenSSL-based SSL support
12 # - content
13 %bcond_without  cgi             # Local CGI support
14 %bcond_without  js              # experimental (yet quite usable) JavaScript support (using SpiderMonkey)
15 %bcond_with     lzma            # LZMA support (old API, incompatible with xz-libs)
16 # - scripting
17 %bcond_with     guile           # Guile scripting support (non-distrib: guile 2 is LGPL v3+)
18 %bcond_without  lua             # Lua scripting
19 %bcond_without  perl            # Perl scripting
20 %bcond_with     python          # Python scripting support
21 %bcond_with     ruby            # (experimental) Ruby scripting support
22 # - display and UI
23 %bcond_without  256             # 256 colors support
24 %bcond_without  led             # LEDs
25 %bcond_with     olderisbetter   # variuos pre-0.10.0 behaviour rules (typeahead and esc-esc)
26 %bcond_with     x               # Use the X Window System
27 # - misc
28 %bcond_without  verbose         # verbose build (V=1)
29
30 %if %{with gnutls}
31 %undefine       with_openssl
32 %endif
33
34 %define         subver  pre6
35 %define         rel     2
36 Summary:        Experimantal Links (text WWW browser)
37 Summary(es.UTF-8):      El links es un browser para modo texto, similar a lynx
38 Summary(pl.UTF-8):      Eksperymentalny Links (tekstowa przeglądarka WWW)
39 Summary(pt_BR.UTF-8):   O links é um browser para modo texto, similar ao lynx
40 Name:           elinks
41 Version:        0.12
42 Release:        0.%{subver}.%{rel}
43 Epoch:          1
44 License:        GPL v2
45 Group:          Applications/Networking
46 Source0:        http://www.elinks.cz/download/%{name}-%{version}%{subver}.tar.bz2
47 # Source0-md5:  3d0962f4b65fb039342fefd3ada050a9
48 Source1:        %{name}.desktop
49 Source2:        links.png
50 Patch0:         %{name}-home_etc.patch
51 Patch1:         %{name}-lua40.patch
52 Patch2:         %{name}-date-format.patch
53 Patch3:         %{name}-fbterm.patch
54 Patch4:         %{name}-old_incremental.patch
55 Patch5:         %{name}-0.10.0-0.9.3-typeahead-beginning.patch
56 Patch6:         %{name}-double-esc.patch
57 URL:            http://www.elinks.cz/
58 BuildRequires:  autoconf >= 2.61
59 BuildRequires:  automake
60 BuildRequires:  bzip2-devel
61 BuildRequires:  expat-devel
62 %{?with_fsp:BuildRequires:      fsplib-devel}
63 BuildRequires:  gettext-devel
64 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
65 BuildRequires:  gpm-devel
66 %{?with_guile:BuildRequires: guile-devel}
67 #BuildRequires: heimdal-devel
68 %{?with_js:BuildRequires:       js-devel >= 1.5-0.rc6a.1}
69 %{?with_js:BuildRequires:       js-devel < 2:1.8.5}
70 %{?with_idn:BuildRequires:      libidn-devel}
71 %{?with_smb:BuildRequires:      libsmbclient-devel}
72 %{?with_lua:BuildRequires:      lua50-devel}
73 %{?with_lzma:BuildRequires:     lzma-devel}
74 BuildRequires:  ncurses-devel >= 5.1
75 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
76 %{?with_perl:BuildRequires:     perl-devel}
77 BuildRequires:  pkgconfig
78 %{?with_python:BuildRequires:   python-devel}
79 %{?with_ruby:BuildRequires:     ruby-devel}
80 BuildRequires:  tre-devel
81 BuildRequires:  which
82 BuildRequires:  zlib-devel
83 Suggests:       mailcap
84 Provides:       webclient
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %define         _sysconfdir     /etc/elinks
88 %define         specflags_ia32  -fomit-frame-pointer
89
90 %description
91 This is the elinks tree - intended to provide feature-rich version of
92 links, however not rock-stable and dedicated mainly for testing. Its
93 purpose is to make alternative to links, until Mikulas will have some
94 time to maintain it, and to test and tune various patches for Mikulas
95 to be able to include them in the official links releases.
96
97 %description -l es.UTF-8
98 Links es un browser WWW modo texto, similar al Lynx. El links muestra
99 tablas, hace baja archivos en segundo plano, y usa conexiones HTTP/1.1
100 keepalive.
101
102 %description -l pl.UTF-8
103 Bogata w opcje i możliwości wersja tekstowej przeglądarki WWW - links.
104 elinks jednak jest dedykowana głównie do testowania.
105
106 %description -l pt_BR.UTF-8
107 Links é um browser WWW modo texto, similar ao Lynx. O Links exibe
108 tabelas, baixa arquivos em segundo plano, e usa as conexões HTTP/1.1
109 keepalive.
110
111 %prep
112 %setup -q -n %{name}-%{version}%{subver}
113 %patch0 -p1
114 %patch1 -p1
115 %patch2 -p1
116 %patch3 -p1
117 %if %{with olderisbetter}
118 %patch4 -p1
119 %patch5 -p1
120 %patch6 -p1
121 %endif
122
123 %build
124 %{__aclocal}
125 %{__autoconf}
126 %{__autoheader}
127 %configure \
128         %{?with_bittorrent:--enable-bittorrent} \
129         %{?with_cgi:--enable-cgi} \
130         --enable-88-colors \
131         %{?with_256:--enable-256-colors} \
132         --enable-true-color \
133         --enable-exmode \
134         %{?debug:--enable-debug} \
135         %{!?debug:--enable-fastmem} \
136         --enable-finger \
137         %{?with_fsp:--enable-fsp} \
138         --enable-gopher \
139         --enable-html-highlight \
140         %{!?with_ipv6:--disable-ipv6} \
141         %{?with_leds:--enable-leds} \
142         --enable-marks \
143         --enable-nntp \
144         --disable-no-root \
145         %{?with_smb:--enable-smb} \
146         --without-gc \
147         %{?with_gnutls:--with-gnutls} \
148         %{?with_guile:--with-guile} \
149         %{!?with_idn:--without-idn} \
150         %{!?with_lua:--without-lua} \
151         %{?with_lzma:--with-lzma} \
152         %{!?with_openssl:--without-openssl} \
153         %{?with_perl:--with-perl} \
154         %{?with_python:--with-python} \
155         %{?with_ruby:--with-ruby} \
156         %{!?with_js:--without-spidermonkey} \
157         --with-x%{!?with_x:=no}
158 # xterm -e is default, one might want to change it to something else:
159 #       --with-xterm="xterm -e"
160
161 %{__make} %{?with_verbose:V=1}
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165 install -d $RPM_BUILD_ROOT%{_desktopdir} \
166         $RPM_BUILD_ROOT%{_datadir}/%{name} \
167         $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir}}
168
169 %{__make} install %{?with_verbose:V=1} \
170         DESTDIR=$RPM_BUILD_ROOT
171
172 %{__rm} $RPM_BUILD_ROOT%{_datadir}/locale/locale.alias
173
174 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
175 cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
176
177 %{?with_lua:install contrib/lua/*.lua $RPM_BUILD_ROOT%{_sysconfdir}}
178
179 %find_lang %{name}
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %files -f %{name}.lang
185 %defattr(644,root,root,755)
186 %doc AUTHORS BUGS ChangeLog NEWS README SITES TODO doc/html/*.html
187 %doc contrib/{keybind*,wipe-out-ssl*,lua/elinks-remote} contrib/conv/{*awk,*.pl,*.sh}
188 %attr(755,root,root) %{_bindir}/elinks
189 %{_mandir}/man1/elinks.1*
190 %{_mandir}/man5/elinks.conf.5*
191 %{_mandir}/man5/elinkskeys.5*
192 %{_desktopdir}/elinks.desktop
193 %{_pixmapsdir}/elinks.png
194 %if %{with lua}
195 %dir %{_sysconfdir}
196 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.lua
197 %endif
This page took 0.052678 seconds and 3 git commands to generate.